Screen Resolution too small

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this

Screen Resolution too small

Postby Pian0Play0r on Tue Nov 20, 2012 2:30 pm

Hello!
I've got a problem. My screen resolution from Linux Mint is too small.
Does anyone had the same problem? My PC is an Acer Aspire 5734z-4836.
Grettings Alex
Pian0Play0r
Level 1
Level 1
 
Posts: 3
Joined: Tue Nov 20, 2012 1:50 pm

Linux Mint is funded by ads and donations.
 

Re: Screen Resolution too small

Postby cwsnyder on Tue Nov 20, 2012 6:41 pm

Are you using the 1024x768 resolution, or other setting? Your maximum resolution on the screen, according to a Cnet review is 1366x768.
LMDE Mate 64-bit, LM16 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 13.10 64-bit, Xubuntu Trusty Tahr 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1039
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Screen Resolution too small

Postby Pian0Play0r on Wed Nov 21, 2012 8:31 am

Yes, the current Resolution is 1024x768. And I meant 1366x768 pixels.
Greetings Alex
Pian0Play0r
Level 1
Level 1
 
Posts: 3
Joined: Tue Nov 20, 2012 1:50 pm

Re: Screen Resolution too small

Postby cwsnyder on Wed Nov 21, 2012 1:31 pm

Open a terminal and see if you can enter the command xrandr. If this is an unknown command or filename, install the x11-xserver-utils package, which will install xrandr. Now that you have xrandr loaded, open the terminal and type xrandr again on a line by itself. The output will look something like:
Code: Select all
xrandr
Screen 0: minimum 64 x 64, current 1280 x 1024, maximum 32000 x 32000
VGA-0 connected 1280x1024+0+0 0mm x 0mm
   1280x1024      60.0*+
   1600x1200      60.0 
   1440x1050      60.0 
   1280x960       60.0 
   1024x768       60.0 
   800x600        60.0 
   640x480        60.0
See if your desired 1366x768 resolution is available. If it is, simply choose it from your menu display settings.

If 1366x768 is not available, enter the following in your terminal window:
Code: Select all
cvt 1366 768
# 1368x768 59.88 Hz (CVT) hsync: 47.79 kHz; pclk: 85.25 MHz
Modeline "1368x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync
The second and third lines are the output from the cvt command.
Code: Select all
xrandr --newmode 1366x768 85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync
xrandr --addmode VGA-0 1366x768
xrandr --output VGA-0 --mode 1366x768
When you are entering the 3 lines, the first line numbers, except for the mode name, are simply copied from the previous box's Modeline, VGA-0 is replaced by whatever is in that position of the output of the xrandr command on a line by itself, and the final line should kick you over into the higher resolution mode.

EXCEPTIONS: If you get a message about being unable to read gamma from your display, and the line for the display starts with "default connected" this doesn't work. I have reported the bug to launchpad.
LMDE Mate 64-bit, LM16 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 13.10 64-bit, Xubuntu Trusty Tahr 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1039
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Screen Resolution too small

Postby Pian0Play0r on Wed Nov 21, 2012 6:06 pm

Thanks! I'll try it.
Greetings Alex
Pian0Play0r
Level 1
Level 1
 
Posts: 3
Joined: Tue Nov 20, 2012 1:50 pm

Re: Screen Resolution too small

Postby Gloomshroud on Sun Dec 02, 2012 4:23 am

Semi-Necro:

I was told this may resolve an issue I have in which I can't see anything on my HDTV. I posted separately, but this is directly implied as a possible solve. Does anyone concur?
Gloomshroud
Level 1
Level 1
 
Posts: 7
Joined: Sat Dec 01, 2012 4:58 am

Re: Screen Resolution too small

Postby cwsnyder on Sat Dec 08, 2012 9:10 pm

Addendum: If you get the message about 'unable to read gamma' from your display, if you can change to a different video driver, that may fix the problem. For example, on LM 14 Cinnamon 64-bit Live DVD on my system, I first go the 'unable to read gamma' message, but was able to install the nvidia-current driver on the Live machine, then I was able to re-size the display. This doesn't always work, as a VM I have installed under VirtualBox of Bodhi Linux seems to have the correct video driver for VirtualBox, but still can't read the gamma.
LMDE Mate 64-bit, LM16 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 13.10 64-bit, Xubuntu Trusty Tahr 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1039
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Screen Resolution too small

Postby cwsnyder on Mon Dec 31, 2012 8:40 am

In case someone is still following this thread, I have found a fix for the case where the gamma of the display is not being read properly. What you do is change the third xrandr line from xrandr --output VGA-0 --mode 1366x768 to xrandr --output VGA-0 --gamma 1:1:1 --mode 1366x768.
LMDE Mate 64-bit, LM16 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 13.10 64-bit, Xubuntu Trusty Tahr 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1039
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Screen Resolution too small

Postby pampidou on Thu Feb 06, 2014 2:49 am

Hello , i am a complete linux noob, as in i havnt sleep because i had the great idea of trying out some linux :P.
I know this question has to have been answered but i am such a noob that even the slightest change in the answer of some1 else compared to mine loses me.
I have just installed the newest Linux mint OS 64 bit,
i installed correctly (following this youtube guide: http://www.youtube.com/watch?v=AkKkuzWlaGo) the Nvidia propriatary Driver.
but i am still restricted to a low resolution and not the 1920x1080 that my screen and card can handle,
do i need to provide more information?\
can some1 help?
thank you in advance and again sorry for bad english and M$ office user :P
UPDATE of my efforts
tried the Xrandr method posted on the forums(viewtopic.php?f=59&t=117398&p=650290) but i am Having trouble with it here is my command lines :
oula@oula-desktop ~ $ cvt 1920 1080
# 1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz
Modeline "1920x1080_60.00" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
oula@oula-desktop ~ $ xrandr --newmode 1920x1080 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
X Error of failed request: BadName (named color or font does not exist)
Major opcode of failed request: 140 (RANDR)
Minor opcode of failed request: 16 (RRCreateMode)
Serial number of failed request: 33
Current serial number in output stream: 33
// tried same thing again same output(idk why i did that :P)

oula@oula-desktop ~ $ xrandr --newmode 1920x1080 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
X Error of failed request: BadName (named color or font does not exist)
Major opcode of failed request: 140 (RANDR)
Minor opcode of failed request: 16 (RRCreateMode)
Serial number of failed request: 33
Current serial number in output stream: 33

/tried it now with 1920x1080"_60" no error in newmode this time but errors in the next line
oula@oula-desktop ~ $ xrandr --newmode 1920x1080_60 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
oula@oula-desktop ~ $ xrandr --addmode VGA-0 1920x1080
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 140 (RANDR)
Minor opcode of failed request: 18 (RRAddOutputMode)
Serial number of failed request: 33
Current serial number in output stream: 34
oula@oula-desktop ~ $
pampidou
Level 1
Level 1
 
Posts: 2
Joined: Sat Feb 01, 2014 3:46 am

Re: Screen Resolution too small

Postby cwsnyder on Sat Feb 08, 2014 8:47 pm

@pampidou,
What is the output of the terminal command xrandr on a line by itself? Your actual display is probably NOT VGA-0, that is just what I used as an example.

The error messages indicate that either a) the resolution which you wish to apply is already set up and available, probably under Menu >> Preferences >> Monitors, or b) the proprietary driver you installed does not work properly with your monitor/card combination, or c) you simply are specifying a monitor selection which does not match your installation.
LMDE Mate 64-bit, LM16 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 13.10 64-bit, Xubuntu Trusty Tahr 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1039
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Linux Mint is funded by ads and donations.
 

Return to Graphic Cards & Monitors

Who is online

Users browsing this forum: No registered users and 11 guests