How to install the Nvidia proprietary drivers in LinuxMint

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby McLovin on Mon Sep 16, 2013 10:23 pm

georgepbrown wrote:I am New to linux thank you for this post my only problem is im running cinnamon not mate or kde what would the " code" be for this to type into cli ?

All versions of LinuxMint use the same DM, (desktop manager)
so the commands would be the same.
Good luck and welcome to computing bliss, if you need any more help don't hesitate to ask
User avatar
McLovin
Level 5
Level 5
 
Posts: 788
Joined: Thu Aug 23, 2007 6:53 pm

Linux Mint is funded by ads and donations.
 

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby thedroidbuilder on Tue Oct 01, 2013 7:24 pm

I read through most of this thread trying to figure out how to install a driver for my GeForce MX4000 AGP card on an older system. I've used linux years ago and thought I'd throw something together out of the scrape pile downstairs and let my family use this one upstairs. Anyways, I tried Mint 15 [Olivia] and didn't have much luck with that. Kept having too include nomodeset xforcevesa on the bootup to get it to come up where I could read everything. Someone in the chat room suggested I try Mint 13 [Maya]. So I have that on the machine currently and have downloaded the driver from Nvidia for my card and it would not install at all. Kept complaining about the x server running. I finally got my machine to boot into the tty terminal. So I started to install the driver and got this:

ERROR: The Nouveau kernal driver is currently in use by your system.
This driver is incompatible with the NVIDIA driver, and must be disabled before proceeding. Please consult the NVIDIA driver README and your linux distribution's documentation for details on how to correctly disable the Nouveau kernal driver.


Then after hitting okay!

For some distributions, Nouveau can be disabled by adding a file in the modprobe configuration directory. Would you like nvidia-installer to attempt to create this modprobe file for you?

I hit Yes! and got this.


The modprobe configuration file to disable Nouveau, /ect/modprobe.d/nvidia-installer-disable-nouveau.conf, has been written.
For some distributions, this may be sufficient to disable Nouveau; other distributions may require modification of the initial ramdisk.
Please reboot your system and attempt NVIDIA driver installation again.
Note if you later wish to reenable Nouveau, you will need to delete the file /etc/modprobe.d/nvidia-installer-disable-nouveau.conf.


And after all that I pressed 'Okay' and this shows up.

ERROR: Installation has failed. Please see the file '/var/log/nvidia-installer.log'. For details. You may find suggestions on fixing installation problems in the README available on the Linux driver download page at http://www.nvidia.com.

Now my system boots up and the backdrop looks okay but I have no icons and no menu to click on. Just the cursor. Did I forget to startup mdm? Or is there something else missing?

Thanks
Thomas
thedroidbuilder
Level 1
Level 1
 
Posts: 1
Joined: Sun Sep 29, 2013 11:29 am

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby themonkeymixer on Wed Oct 09, 2013 12:00 am

you have to unload the nouveau driver I had to blacklist it and reboot, look for how to blacklist and that should get you started. After you have sucessfully prevented it from loading you have to retry the nvidia install.
themonkeymixer
Level 1
Level 1
 
Posts: 17
Joined: Thu Jun 23, 2011 11:37 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby jlane01 on Thu Oct 10, 2013 1:59 pm

I have an HP tower that has the NVIDIA 6150 SE graphics card. When I tried running linix mint 15 from usb my screen kept going all wonky (as soon as the desktop would load) and I would not have enough time to install the proprietary driver. I currently have linux mint 13 installed and have no problems or complaints, but I'm curious as to how I would solve that problem. Is there an ISO available that has the proprietary drivers already installed? I know that would fix the problem, but I am unsure how to go about doing that.
jlane01
Level 1
Level 1
 
Posts: 9
Joined: Sun Aug 05, 2012 10:40 am

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby mbemboom on Thu Oct 10, 2013 3:37 pm

The easiest way to get Nvidia drivers installed is to use SGFXI.

http://smxi.org/

I have used this in Ubuntu, Mint, Mepis, Bodhi, and Crunchbang to successfully install an Nvidia driver to various computers.
mbemboom
Level 1
Level 1
 
Posts: 9
Joined: Thu Mar 24, 2011 10:02 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby jlane01 on Thu Oct 10, 2013 5:02 pm

Usually I don't have a problem installing the proprietary drivers. I know it's an issue with the 3.10 kernels & later as I've had this issue with other distros. As long as mint 13 keeps working I'll be happy! :D
jlane01
Level 1
Level 1
 
Posts: 9
Joined: Sun Aug 05, 2012 10:40 am

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby RushKing on Sat Nov 23, 2013 7:17 pm

I get this "you apeer to be running an x server" error message. I have tried the following comands to shut it down and none of them worked.

Code: Select all
telinit 3


Code: Select all
sudo service lightdm stop


Code: Select all
stopx


Edit:

Gave up and installed bumblebee.
RushKing
Level 1
Level 1
 
Posts: 1
Joined: Sat Nov 23, 2013 7:08 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby iamphil on Wed Nov 27, 2013 8:57 pm

So, after reading 6 pages of posts, I come down to 1 question. Has anyone come up with a foolproof method of installing the proprietary nvidia drivers? I have tried most of the steps I could folow in this thread, but with no success. My vid card is

inxi -Gx
Graphics: Card: NVIDIA GK106 [GeForce GTX 650 Ti] bus-ID: 01:00.0
X.Org: 1.14.3 drivers: nvidia (unloaded: fbdev,vesa,nouveau) Resolution: 1024x768@60.0hz
GLX Renderer: GeForce GTX 650 Ti/PCIe/SSE2 GLX Version: 4.4.0 NVIDIA 331.20 Direct Rendering: Yes

When I run xrandr I get this.

xrandr
Screen 0: minimum 8 x 8, current 1024 x 768, maximum 16384 x 16384
DVI-I-0 connected primary 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
1024x768 60.0*+
1360x768 60.0 59.8
1152x864 60.0
800x600 72.2 60.3 56.2
680x384 60.0 59.8
640x480 59.9
512x384 60.0
400x300 72.2
320x240 60.1
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 disconnected (normal left inverted right x axis y axis)


When I try to force a mod to use 1600x900 resolution it tells me that it can't find DVI-I-0, but right above it says it is using it. This has ben one of my most frustrating experiences I have had. Almost makes me want to go back to windows.

My thread since my first forey into Linux

viewtopic.php?f=46&t=149878
iamphil
Level 1
Level 1
 
Posts: 46
Joined: Mon Nov 11, 2013 9:18 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby SZahara on Fri Dec 27, 2013 12:53 pm

So i've got a new to Mint Lenovo W530 with the hybrid videocards but I'm not planning on using the switching functions (I do a lot of graphic deisgn work, but its a dual-boot and I'll be using all my graphics programs in windows). I would like to connect HMDI through Mint though and I've been having issues with the generic drivers. Would this method help for me or do I need to try something else? I also should mention I'm pretty damn new to Linux so I may well be missing something obvious.
SZahara
Level 1
Level 1
 
Posts: 4
Joined: Sun Dec 22, 2013 1:28 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby Liberatee on Sat Dec 28, 2013 2:18 am

Thank you, McLovin for this very helpful tutorial! It seems to have solved my problems, and I am most grateful.

Also, thanks to Enkidu, as I needed this advice as well:

Enkidu wrote:When you get this error message

WARNING: The modprobe configuration file to disable Nouveau, /etc/modprobe.d/nvidia-installer-disable-nouveau.conf, is already
present. Please be sure you have rebooted your system since that file was written. If you have rebooted, then
Nouveau may be enabled for other reasons, such as being included in the system initial ramdisk or in your X
configuration file. Please consult the NVIDIA driver README and your Linux distribution's documentation for details
on how to correctly disable the Nouveau kernel driver.

after you have rebooted your system, do the following steps:

Code: Select all
sudo apt-get purge xserver-xorg-video-nouveau libdrm-nouveau1a nvidia*
sudo update-initramfs -u -k all

and reboot again.

Enkidu


Just to clarify for others, I entered the above commands in the tty1. Maybe you could do it in the bash shell, I don't know, but I figured I'd stick with the text interface I'd already been using. (Newbie, I certainly am, so I don't even know if it matters that much) So then I could get nVidia going after that.

If you're going to follow this tutorial, I highly recommend you print out the instructions or copy them out very clearly (if you're a n00b like me, that is) so that you can keep referring to them as you go, as you won't be able to see anything but the text interface when in tty1.

I hope this is the end of my graphics card issues. Thanks much!
Liberatee
Level 1
Level 1
 
Posts: 4
Joined: Thu Dec 19, 2013 9:57 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby inflatablemouse on Tue Dec 31, 2013 8:28 am

I just installed Mint 16 (64-bit Cinnamon) alongside Debian.

I've installed the latest Nvidia drivers plenty of times before on Debian so I'm familiar with how that goes.

On Debian I used to do what is described here in post # 16 before installing the Nvidia drivers.

When I received the installers' question about the 32-bit libs on Mint, I cancelled the install and I went searching for the /usr/lib32 folder but couldn't find it. I posted a question about that here and were advised to ask here.

So, long story short. When I install the latest Nvidia drivers on a fresh 64-bit install, what am I supposed to do with that 32-bit library question?

Thanks!

Ps. system is a i7 2600k with GTX580. Nouveau disabled.
inflatablemouse
Level 2
Level 2
 
Posts: 72
Joined: Mon Jan 09, 2012 6:07 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby inflatablemouse on Tue Dec 31, 2013 9:51 am

I think I fixed it although I'm unsure why this isn't in any of the guides here or elsewhere on the internet (maybe this can be added for the people that run into this as well?).

First I created the directory structure for Nvidia Libraries: mkdir -p /emul/ia32-linux/usr/lib

I added this directory to /etc/ld.so.conf.d/libc.conf and ran sudo ldconfig.

Installing the Nvidia drivers installed the 32-bit libraries without complaining and Steam/Games seem to like it as well.
inflatablemouse
Level 2
Level 2
 
Posts: 72
Joined: Mon Jan 09, 2012 6:07 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby kk5000 on Thu Jan 02, 2014 11:51 pm

The info in this thread is no longer current. I have started a new thread with an end to end tutorial that works. See :

viewtopic.php?f=59&t=154932
kk5000
Level 1
Level 1
 
Posts: 5
Joined: Thu Jan 02, 2014 10:15 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby inflatablemouse on Fri Jan 03, 2014 4:43 pm

kk5000 wrote:The info in this thread is no longer current. I have started a new thread with an end to end tutorial that works. See :

viewtopic.php?f=59&t=154932


Thanks for the effort.


Your post does not deal with the issue I posted about though.

On a 64-bit system, when you install the Nvidia driver, what do you answer when asked about the 32-bit libraries? If you say yes, do you get a message that the location does not exist?

I posted a possible solution (another option is to move /emul/ia32-linux/usr/lib to where your current 32-bit libraries are and create a link to it from /emul/ia32-linux/usr/lib, but I honestly think my solution is more elegant and less prone to problems).
inflatablemouse
Level 2
Level 2
 
Posts: 72
Joined: Mon Jan 09, 2012 6:07 pm

SOLVED/I think/ more info/Nvidia proprietary drivers

Postby rn1 on Sat Jan 04, 2014 2:20 pm

finally, I can offer some help here (I am learning<g>)..and I hope this note is not premature:

i followed the excellent directions written by mclovin using a Dell m6800 and nvidia 331, something or other (64bit; from Nvidia site).

i got various messages during the process ..none discussed in these instructions.......they amounted to Mint 16 (cinnamon) offering to "overcome" (my word) certain requirements during the installation of the driver. These included something to do with "building"...I apologize I cannot recall...I was intent on using my intuition to say "yes" or "no" to various steps, as,as new to Linux as I am, I am a vet on PCs......but was able to OK my way to what appeared to be a successful install.

upon reinvoking display manager, my external mouse and keyboard would not work (this machine is docked).

as what I hope will be a helpful aside, when playing around prior to understanding how to do this install, i found that using the "display" utility that auto installed with mint, that if I unselected the checkbox for "mirror", i also lost my mouse and keyboard uniless I let that setting revert..while never getting display on both my monitors (I want an extended desktop).

anyway, when I could not enter my password after reinvoking display manager after what appeared to have been a successful install (i had to do a hard reboot a number of times and still got nothing), I selected "recovery" from the GRUB menu.

I could see during the screen echo of the process, that it indicated that the nvidia driver had "tainted" the kernel.

that said, the process went thru to a console prompt....i entered my log in information...and before I could reinvoke display manager again, the GUI appeared and voila, I was able to enter my log in information.

right now I am looking at desktop mirrors...and am almost afraid to try to create the extended desktop I need<g>...but of course I must.

assuming that works, and I am not able to actually use my screen real estate as I need to, I am hoping to finally drop windows as my manin OS.

in closing, and with thanks, again, to mclovin....i think I could have figured this out, but it would have taken much longer........I also hope that, given the ubuiquity of these nvidia cards, that some kind soul on the mint team will develop a utility specifically for this arcane process, taking into account, especially, the "what can go wrong with this" nature of the additional steps I had to take to make this work.

that is a helpful suggestion and not a criticism....mint 16 is beautiful.

anyway, hope this has been helpful......i will try to get this the way I need it now.

robert
rn1
Level 1
Level 1
 
Posts: 41
Joined: Sun Oct 27, 2013 10:38 am

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby kk5000 on Sun Jan 05, 2014 4:33 am

inflatablemouse wrote:
kk5000 wrote:The info in this thread is no longer current. I have started a new thread with an end to end tutorial that works. See :

viewtopic.php?f=59&t=154932


On a 64-bit system, when you install the Nvidia driver, what do you answer when asked about the 32-bit libraries? If you say yes, do you get a message that the location does not exist?


I say yes, it proceeds without issues. The posted tutorial has been tried on 4 separate machines. Works end-to-end. No issues. These were all fresh installations though. If you have old stuff installed, there is no telling how it would conflict with things.
kk5000
Level 1
Level 1
 
Posts: 5
Joined: Thu Jan 02, 2014 10:15 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby rn1 on Mon Jan 06, 2014 10:31 pm

re my previous post "solution", sad to say, it turned out not to be one.

upon rebooting, while I could use my mouse to make a grub selection, I never could get it or my <external> keyboard to work to actually log on...at the log in screen, neither works, so I cannot log in.

I suspect this may be related to the dell m6800 docking station, although my external USB items are plugged right into my machine directly, even as it is docked (upon reflection at the moment, maybe that is the problem?)

either way, I am not there yet...and have run out of time, for now, to try to make it work.

back to windows until.......
rn1
Level 1
Level 1
 
Posts: 41
Joined: Sun Oct 27, 2013 10:38 am

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby rn1 on Mon Jan 06, 2014 10:32 pm

re my previous post "solution", sad to say, it turned out not to be one.

upon rebooting, while I could use my mouse to make a grub selection, I never could get it or my <external> keyboard to work to actually log on...at the log in screen, neither works, so I cannot log in.

I suspect this may be related to the dell m6800 docking station, although my external USB items are plugged right into my machine directly, even as it is docked (upon reflection at the moment, maybe that is the problem?)

either way, I am not there yet...and have run out of time, for now, to try to make it work.

back to windows until.......

ps.... I am on a 64 bit system and downloaded a 64 bit driver, and therefore...for those folks asking about a 32 bit prompt...I never saw one.
rn1
Level 1
Level 1
 
Posts: 41
Joined: Sun Oct 27, 2013 10:38 am

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby ridobe on Sun Jan 19, 2014 5:52 pm

Hello, fellow strugglers.

I, like you guys have been struggling to get this figured out. After reading the several topics on this board regarding the Nvidia drivers, I finally fell upon the one set of instructions that not only got me working again, but got me to the most updated point I had hoped to achieve.

First of all, the many attempts by me were a mirror image of pretty much all that I have read on here. That stupid "Driver manager" was useless. It seemed that every time I tried installing anything be it Nouveau, Nvidia 331, 318, nvidia-current or nvidia-319-updates there was something stepping on something elses toes. There were always remnants of other crap I tried. Now, mind you, I never once reinstalled the operating system. I have been trying to avoid this even though this is essentially a brand new install on a computer I just built.

So here is what fixed it for me. **All credit goes to RNGd_in_the_womb** from, of all places, Reddit in the /linuxquestions sub. Feel free to look for it on there to see his initial struggle and his search for a fix. This is his "code" section from his post. I didn't have to do all of this so you may have to adjust to your needs.

sudo ppa-purge ppa:ubuntu-x-swat/x-updates
sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo rm /etc/modprobe.d/bumblebee.conf (I removed current nvidia.conf)
sudo apt-get install nvidia-331
sudo modprobe nvidia (Returned with: ERROR: could not insert 'nvidia_331': No such device)
sudo nvidia-xconfig (Returned with: WARNING: Unable to locate/open X configuration file. New X configuration file written to '/etc/X11/xorg.conf')

By letting the installer do all of the work, all files were correctly written/rewritten/blacklisted, etc. It seems like I have tried most of this at one point or another but not in order like this. I think the key for me was removing the /etc/modprobe.d/nvidia* as I didn't have a bumblebee.conf file. I also didn't have to purge the x-swat ppa.

Thanks to this guide, I am now running with the 3.13rc8 kernel with the 331.38 drivers. As an aside, if you are going to update your kernel too, do that first.

Hope this helps somebody.
ridobe
Level 1
Level 1
 
Posts: 9
Joined: Fri May 31, 2013 7:09 pm

Re: How to install the Nvidia proprietary drivers in LinuxMi

Postby ScottyD on Sun Jan 19, 2014 7:09 pm

Didn't work for me...
Scott

ridobe wrote:Hello, fellow strugglers.

Hope this helps somebody.
ScottyD
Level 1
Level 1
 
Posts: 40
Joined: Thu Oct 20, 2011 5:16 pm

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Graphic Cards & Monitors

Who is online

Users browsing this forum: No registered users and 5 guests