Opengl/3D/... not working on Intel Graphic Card

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this

Opengl/3D/... not working on Intel Graphic Card

Postby Bouelge on Thu Dec 20, 2012 7:02 am

Hi there,

I've been searching for days, but without success.

I cannot use any 3D/opengl/...-function (e.g. compiz-effect; cairo (with opengl); etc...) and I'm wondering why? It used to work before (linux mint 9 was my former OS).

Hereby as much as details of which I think can help you give some idea of my laptop-specifications :

inxi -Gx :
roelof@roelof-HP-Compaq-nc6120-EJ101EC-UUG ~ $ inxi -Gx
Graphics: Card: Intel Mobile 915GM/GMS/910GML Express Graphics Controller bus-ID: 00:02.0
X.Org: 1.13.0.902 drivers: (unloaded: fbdev) FAILED: intel Resolution: 1024x768@60.0hz
GLX Renderer: N/A GLX Version: N/A Direct Rendering: N/A

glxinfo :
roelof@roelof-HP-Compaq-nc6120-EJ101EC-UUG ~ $ glxinfo
name of display: :0
X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 153 (GLX)
Minor opcode of failed request: 19 (X_GLXQueryServerString)
Serial number of failed request: 12
Current serial number in output stream: 12

System Info :
-Computer-
Processor : Intel(R) Pentium(R) M processor 1.73GHz
Memory : 499MB (362MB used)
Operating System : Linux Mint 13 Maya
User Name : roelof (roelof)
Date/Time : Thu 20 Dec 2012 11:51:07 AM CET
-Display-
Resolution : 1024x768 pixels
OpenGL Renderer : Unknown
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : ICH4 - Intel ICH6
-Input Devices-
Sleep Button
Lid Switch
Power Button
AT Translated Set 2 keyboard
Video Bus
HP WMI hotkeys
SynPS/2 Synaptics TouchPad
-Printers-
No printers found
-SCSI Disks-
ATA FUJITSU MHV2060A
SONY CD-RW CRX835E

Kernel Info :
-Version-
Kernel : Linux 3.7.0-7-generic (i686)
Compiled : #15-Ubuntu SMP Sat Dec 15 16:34:21 UTC 2012
C Library : Unknown
Default C Compiler : GNU C Compiler version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5)
Distribution : Linux Mint 13 Maya
-Current Session-
Computer Name : roelof-HP-Compaq-nc6120-EJ101EC-UUG
User Name : roelof (roelof)
Home Directory : /home/roelof
Desktop Environment : MATE
-Misc-
Uptime : 25 minutes
Load Average : 0.27, 0.31, 0.39

Display Info :
-Display-
Resolution : 1024x768 pixels
Vendor : The X.Org Foundation
Version : 1.13.0.902
-Monitors-
Monitor 0 : 1024x768 pixels
-Extensions-
BIG-REQUESTS
Composite
DAMAGE
DOUBLE-BUFFER
DPMS
DRI2
GLX
Generic Event Extension
MIT-SCREEN-SAVER
MIT-SHM
RANDR
RECORD
RENDER
SECURITY
SGI-GLX
SHAPE
SYNC
X-Resource
XC-MISC
XFIXES
XFree86-DGA
XFree86-VidModeExtension
XINERAMA
XInputExtension
XKEYBOARD
XTEST
XVideo
-OpenGL-
Vendor : Unknown
Renderer : Unknown
Version : Unknown
Direct Rendering : No


If anyone can help I will be very grateful :-)

tx.
Bouelge
Level 1
Level 1
 
Posts: 9
Joined: Tue Aug 17, 2010 12:34 am

Linux Mint is funded by ads and donations.
 

Re: Opengl/3D/... not working on Intel Graphic Card

Postby ddaniel on Thu Dec 20, 2012 7:15 am

Bouelge wrote:Hi there,

I've been searching for days, but without success.

I cannot use any 3D/opengl/...-function (e.g. compiz-effect; cairo (with opengl); etc...) and I'm wondering why? It used to work before (linux mint 9 was my former OS).
...


You can't use it because your 3d acceleration doesn't work.
ddaniel
Level 2
Level 2
 
Posts: 58
Joined: Sun Jun 03, 2012 12:17 pm

Re: Opengl/3D/... not working on Intel Graphic Card

Postby Bouelge on Thu Dec 20, 2012 8:26 am

Ok, but can I do something about it? Something wrong with my installation of Linux Mint 13? I ask because on my former OS (Linux Mint 9) I was able to use all those functions (3D/Opengl/...).

FYI : I downloaded and installed the most recent dirvers from http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu but still it won't work.

grtz
Bouelge
Level 1
Level 1
 
Posts: 9
Joined: Tue Aug 17, 2010 12:34 am

Re: Opengl/3D/... not working on Intel Graphic Card

Postby ddaniel on Thu Dec 20, 2012 8:57 am

Bouelge wrote:FYI : I downloaded and installed the most recent dirvers from http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu but still it won't work.


From all you posted I will say that you have a bit old comp and you are using the most recent kernel and optimized display drivers from ppa. This can cause problem on your system which is a bit old and you are using software for most recent hardware. I'm not sure, but if this was working in the past with prior version of display drivers and older kernel and doesn't work now on a newer version of display drivers and newer kernel there is a problem somewhere in a software you are using. You can simply try to downgrade your display drivers and kernel, but be aware that you can break your system.
ddaniel
Level 2
Level 2
 
Posts: 58
Joined: Sun Jun 03, 2012 12:17 pm

Re: Opengl/3D/... not working on Intel Graphic Card

Postby mank_in on Thu Dec 20, 2012 10:43 am

Do you using nomodeset or acpi=off on boot parameter :?:
If you are using that, remove it.

Hmmm, i found interesting command on ubuntu forum to check kernel module in use for your graphic driver :
Code: Select all
lspci -v | perl -ne '/VGA/../^$/ and /VGA|Kern/ and print'
Image
Sorry for my bad English , I am Indonesian.
User avatar
mank_in
Level 6
Level 6
 
Posts: 1346
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: Opengl/3D/... not working on Intel Graphic Card

Postby rkmugen on Sat Dec 22, 2012 3:41 am

I also have an intel graphics chipset and have the same issue.

Compaq Presario V2000 notebook (from 2005/2006)
*intel 852gm integrated graphics

I tried the following terminal command:
Code: Select all
lspci -v | perl -ne '/VGA/../^$/ and /VGA|Kern/ and print'


...and my output is:
Code: Select all
00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02) (prog-if 00 [VGA controller])
   Kernel driver in use: i915
   Kernel modules: intelfb, i915


So..... i'm looking at it.... and I'm not sure if there's a mismatch here.... why did the Linux Mint 14 installer configure my system to use the i915 driver when I clearly have the Intel 852GM device? Or, is this an unresolved bug as of late (22-Dec.2012)?

I just got rid of Linux Mint 13 XFCE (wiped the hard drive clean... though I still have the burned 13 XFCE on DVD from earlier this year) and wanted to move on up to Linux Mint 14 Cinnamon....... also because Mint 13 was (or still is) having problems with the update servers... like... for the past 2 weeks!!!! My plan is that, if there won't be any support for the 852/855 chipset for subsequent Mint releases, i may as well just go back to 13 and squeeze as many useful years as I can get out of this trusty old notebook... but hopefully someone here has had better luck...
My setup:
    *Linux Mint 13 XFCE 32-bit (Until the next LTS release)
    *Linux Mint 15 XFCE (RC) 32-bit (Tried...Failed)
    *Compaq Presario V2000 (from 2006) - Intel 1.5GHz (Pentium M) - 2 GB RAM - Intel 82852/855GM integrated video (i915)- WiFi
User avatar
rkmugen
Level 2
Level 2
 
Posts: 70
Joined: Sat Jan 08, 2011 3:01 pm

Re: Opengl/3D/... not working on Intel Graphic Card

Postby mank_in on Sat Dec 22, 2012 5:46 am

@rkmugen, i think intel 852/855G cannot capable running cinnamon. ( and cinnamon 2D required intensive CPU process ).
I think the oldest intel graphic capable to running cinnamon is i945G.

i915 module driver is for the Intel i8xx and i9xx family of chipsets, including i810, i815, i830, i845, i855, i865, i915, i945
and i965 series chips.

my G41 chipset show output like this ( show only i915 module is in use ):
Code: Select all
VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03) (prog-if 00 [VGA controller])
   Kernel driver in use: i915
   Kernel modules: i915


my inxi -Gx output is ( what about your output ? ):
Code: Select all
Graphics:  Card: Intel 4 Series Chipset Integrated Graphics Controller bus-ID: 00:02.0
           X.Org: 1.13.0 drivers: intel (unloaded: fbdev,vesa) Resolution: 1024x768@85.0hz
           GLX Renderer: Mesa DRI Intel G41 x86/MMX/SSE2 GLX Version: 2.1 Mesa 9.0 Direct Rendering: Yes
Image
Sorry for my bad English , I am Indonesian.
User avatar
mank_in
Level 6
Level 6
 
Posts: 1346
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: Opengl/3D/... not working on Intel Graphic Card

Postby rkmugen on Sat Dec 22, 2012 7:48 am

mank_in wrote:@rkmugen, i think intel 852/855G cannot capable running cinnamon. ( and cinnamon 2D required intensive CPU process ).
I think the oldest intel graphic capable to running cinnamon is i945G.

i915 module driver is for the Intel i8xx and i9xx family of chipsets, including i810, i815, i830, i845, i855, i865, i915, i945
and i965 series chips.


I'm not so sure that's entirely true, according to this user... He seemed to have Cinnamon running at one point or another...
http://forums.linuxmint.com/viewtopic.php?f=208&t=118726

Granted, he is using LMDE while I'm just using the regular Linux Mint 14 Cinnamon.... I'm wondering if I'd have better results (OpenGL/3d acceleration/GLXgears) with Linux Mint 14 XFCE... but I want to see what I can do w/ Cinnamon first before I jump ship.

I'll have to get back to you with my "inxi -Gx" output as I'm on a different computer as I'm typing this reply.
My setup:
    *Linux Mint 13 XFCE 32-bit (Until the next LTS release)
    *Linux Mint 15 XFCE (RC) 32-bit (Tried...Failed)
    *Compaq Presario V2000 (from 2006) - Intel 1.5GHz (Pentium M) - 2 GB RAM - Intel 82852/855GM integrated video (i915)- WiFi
User avatar
rkmugen
Level 2
Level 2
 
Posts: 70
Joined: Sat Jan 08, 2011 3:01 pm

Re: Opengl/3D/... not working on Intel Graphic Card

Postby rkmugen on Sun Dec 23, 2012 12:19 am

Alright, my output for
Code: Select all
inxi -Gx


...is as follows:
Code: Select all
Graphics:  Card: Intel 82852/855GM Integrated Graphics Device bus-ID: 00:02.0
           X.Org: 1.13.0 drivers: intel (unloaded: fbdev,vesa) Resolution: 1280x768@60.0hz
           GLX Renderer: N/A GLX Version: N/A Direct Rendering: N/A


No GLX... no direct rendering... this has me a bit nervous... :?
My setup:
    *Linux Mint 13 XFCE 32-bit (Until the next LTS release)
    *Linux Mint 15 XFCE (RC) 32-bit (Tried...Failed)
    *Compaq Presario V2000 (from 2006) - Intel 1.5GHz (Pentium M) - 2 GB RAM - Intel 82852/855GM integrated video (i915)- WiFi
User avatar
rkmugen
Level 2
Level 2
 
Posts: 70
Joined: Sat Jan 08, 2011 3:01 pm

Re: Opengl/3D/... not working on Intel Graphic Card

Postby Bouelge on Sun Dec 23, 2012 11:48 am

After trying to install / de-install, testing, downgrading, etc... kernels and/or drivers; in the end, I complete messed up my system :roll:
I did a new fresh install of LM Maya Mate version, and now my renderer etc... is back again

inxi -Gx :
Graphics: Card: Intel Mobile 915GM/GMS/910GML Express Graphics Controller bus-ID: 00:02.0
X.Org: 1.11.3 drivers: intel (unloaded: fbdev,vesa) Resolution: 1024x768@60.0hz
GLX Renderer: Mesa DRI Intel 915GM x86/MMX/SSE2 GLX Version: 1.4 Mesa 8.0.4 Direct Rendering: Yes

As you can read my X.Org is older now. Thus downgrading is apparently the only solution. Don't know how to downgrade in a correct way, sorry. Me, I needed to install LM Maya again.

Still, compiz does not work, but I believe this is a main issue for most users of LM Maya Mate version.

grtz, and good luck.
Bouelge
Level 1
Level 1
 
Posts: 9
Joined: Tue Aug 17, 2010 12:34 am

Re: Opengl/3D/... not working on Intel Graphic Card

Postby rkmugen on Sun Dec 23, 2012 5:12 pm

:\ I didn't want to have to deal with downgrading packages, then only finding out down the line that it breaks something else i'd need. I'll just sit tight and wait for the next LTS release (Linux Mint 17 XFCE?)... hopefully they'd still have some level of support for this old machine...
My setup:
    *Linux Mint 13 XFCE 32-bit (Until the next LTS release)
    *Linux Mint 15 XFCE (RC) 32-bit (Tried...Failed)
    *Compaq Presario V2000 (from 2006) - Intel 1.5GHz (Pentium M) - 2 GB RAM - Intel 82852/855GM integrated video (i915)- WiFi
User avatar
rkmugen
Level 2
Level 2
 
Posts: 70
Joined: Sat Jan 08, 2011 3:01 pm

Re: Opengl/3D/... not working on Intel Graphic Card

Postby AlbertP on Sun Dec 23, 2012 5:31 pm

If you are on Mint 14 then please make sure you have installed all updates including mdm 1.0.8.

Also you should not need any tweaks to have Cinnamon running on any Intel card (from 915 on, not sure about older hardware). If it doesn't work at you then you probably messed it up somehow, or you haven't installed the update to mdm 1.0.8 yet (in case you're on the original Mint 14 and not 14.1).
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6504
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Opengl/3D/... not working on Intel Graphic Card

Postby rkmugen on Sun Dec 23, 2012 6:58 pm

AlbertP wrote:If you are on Mint 14 then please make sure you have installed all updates including mdm 1.0.8.

Also you should not need any tweaks to have Cinnamon running on any Intel card (from 915 on, not sure about older hardware). If it doesn't work at you then you probably messed it up somehow, or you haven't installed the update to mdm 1.0.8 yet (in case you're on the original Mint 14 and not 14.1).


I was pretty sure I had installed all the updates (including "mdm 1.0.8"), following the fresh install of Mint 14. My goal was not just to have Cinnamon running, but to also have hardware video acceleration through my integrated Intel graphics (it's not a card... it's actually part of the mobo).

1.5Ghz isn't exactly stellar (on top of being a 32-bit Centrino.... ouch!). So being able to delegate as many things as I can to the on-board graphics hardware to free up CPU cycles is rather appealing to me.
My setup:
    *Linux Mint 13 XFCE 32-bit (Until the next LTS release)
    *Linux Mint 15 XFCE (RC) 32-bit (Tried...Failed)
    *Compaq Presario V2000 (from 2006) - Intel 1.5GHz (Pentium M) - 2 GB RAM - Intel 82852/855GM integrated video (i915)- WiFi
User avatar
rkmugen
Level 2
Level 2
 
Posts: 70
Joined: Sat Jan 08, 2011 3:01 pm

Re: Opengl/3D/... not working on Intel Graphic Card

Postby AlbertP on Mon Dec 24, 2012 11:54 am

I'm wondering why it is not working at all. Probably you tried to install a driver or something like that? Maybe it will work on a fresh Mint system. Even though I'm not sure if it's capable enough for Cinnamon, there should be 3D acceleration on this chip.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6504
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Opengl/3D/... not working on Intel Graphic Card

Postby rkmugen on Thu Dec 27, 2012 6:54 pm

Linux Mint 13 XFCE 32-bit
Kernel: 3.2.0-23-generic (i686)
Graphics chipset: Intel 80852 (integrated; notebook)

Well, I went back to LM 13 XFCE and after performing all the updates, I found that I had NO OpenGL or graphics hardware acceleration/support whatsoever. Even glxgears nor glxinfo would run!

So, I did some digging and found that MESA 9.x was the culprit. (i'm mostly following this Ubuntu bug report: #1061073)


I then manually downgraded 4 files related to MESA and brought them all down to MESA 8.0.4...

I downloaded these to a folder...

Opened up a terminal in the directory containing the 4 downloaded files then installed all of them using:
Code: Select all
dpkg -i *.deb


I reloaded the apt update to find the updates needed to get to MESA 9.x... and when the updater found them, I simply right-clicked each entry in the window to ignore updates for those files. Then I went into Synaptic and "pinned" the 4 files I manually installed to stick to the 8.0.4 version.

I rebooted and double-checked that my compositor in the XFCE's Window Manager Teaks control panel was turned on, and BOOM.... she works again; glxgears, glxinfo, and even cairo-dock! I now have graphics acceleration! I don't know if I'm gonna bother trying this in LM 14 XFCE, now that I have XFCE 13 working perfectly again.

Btw, as the beginning of my post indicates, I chose NOT to do an apt upgrade, which would've given me the 3.5.x kernel, which I don't want right now.
My setup:
    *Linux Mint 13 XFCE 32-bit (Until the next LTS release)
    *Linux Mint 15 XFCE (RC) 32-bit (Tried...Failed)
    *Compaq Presario V2000 (from 2006) - Intel 1.5GHz (Pentium M) - 2 GB RAM - Intel 82852/855GM integrated video (i915)- WiFi
User avatar
rkmugen
Level 2
Level 2
 
Posts: 70
Joined: Sat Jan 08, 2011 3:01 pm

Re: Opengl/3D/... not working on Intel Graphic Card

Postby paulgault on Sat May 04, 2013 7:47 pm

I had the exact same problem on an old frankenstein machine that is mainly used by the kids for streaming tv programmes (and me experimenting with new distros!).

doing what rkmugen describes worked for me

I then manually downgraded 4 files related to MESA and brought them all down to MESA 8.0.4...

I downloaded these to a folder...

libgl1-mesa-dri_8.0.4-1ubuntu1_i386.deb
libgl1-mesa-glx_8.0.4-1ubuntu1_i386.deb
libglapi-mesa_8.0.4-1ubuntu1_i386.deb
libglu1-mesa

Opened up a terminal in the directory containing the 4 downloaded files then installed all of them using:

Code: Select all
dpkg -i *.deb

I reloaded the apt update to find the updates needed to get to MESA 9.x... and when the updater found them, I simply right-clicked each entry in the window to ignore updates for those files. Then I went into Synaptic and "pinned" the 4 files I manually installed to stick to the 8.0.4 version.


THANKS!!!!!
paulgault
Level 1
Level 1
 
Posts: 1
Joined: Sat May 04, 2013 7:38 pm

Re: Opengl/3D/... not working on Intel Graphic Card

Postby rkmugen on Tue May 14, 2013 11:41 am

paulgault wrote:I had the exact same problem on an old frankenstein machine that is mainly used by the kids for streaming tv programmes (and me experimenting with new distros!).

doing what rkmugen describes worked for me

THANKS!!!!!


You're welcomd! :)

As a side note, i recently tried Linux Mint Debian 201303 (May 2013) with Cinnamoin, and I found that Cinnamon actually works! The problem is that the performance was incredibly slow because it was running off of the Gallium drivers instead of the Intel ones, so i had NO 3d accreleration. So, as I'm typing this on my other computer, i'm re-installing Mint 13 XFCE.... but experimenting with using the new Ubuntu 13.04 (Raring Ringtail) repositories. Why? I've got the time and patience to fool around with it. :P And if it doesn't work, I'll just revert back to 12.04's (Precise Pangolin) repos or just do another fresh reinstall from scratch.

One other thing I've noticed with 3d acceleration under Mint 13 on the Intel 82852/855GM chipset is when I try to run any Windows games under WINE that require 3d support. Like when i try to run 3d games from 2000-2002, "No One Lives Forever" and "Star Trek Armada 2" respectively, I get the error:
Code: Select all
intel_do_flush_locked failed


....yadda-yadda. < :?

It's really dumb though because I know for a fact that those games worked fine under Windows XP.... ON THE SAME MACHINE! What also sucks is that each time support gets added in Linux for newer graphics cards, 3d acceleration (MESA/OpenGL) support for older cards gets thrown out, forcing you to stick with an older Linux distro or forcing you to rely on software rendering.

A gentleman by the name of Paul Drain came up with one possible workaround, though i've yet to try it.

I should probably make a new topic/thread for this, but as I'm typing this last paragraph, I just finished installing my custom Mint 13 XFCE with Ubuntu 13.04 repos. And when I did:
Code: Select all
glxinfo | grep -i opengl


I get:
Code: Select all
OpenGL vendor string:  Intel Open Source Technology Center
OpenGL renderer string:  Mesa DRI Intel(R) 852GM/855GM x86/MMX/SSE2
OpenGL version string:  1.3 Mesa 9.1.1
OpenGL Extensions:


So, I guess my custom installation worked and I retained the very basic level of 3d acceleration on my Intel chipset. Not bad.... not stellar.... but not bad.
My setup:
    *Linux Mint 13 XFCE 32-bit (Until the next LTS release)
    *Linux Mint 15 XFCE (RC) 32-bit (Tried...Failed)
    *Compaq Presario V2000 (from 2006) - Intel 1.5GHz (Pentium M) - 2 GB RAM - Intel 82852/855GM integrated video (i915)- WiFi
User avatar
rkmugen
Level 2
Level 2
 
Posts: 70
Joined: Sat Jan 08, 2011 3:01 pm

Re: Opengl/3D/... not working on Intel Graphic Card

Postby rkmugen on Tue May 14, 2013 11:52 am

scratch that.... I rebooted, and now, I don't even get a GUI. :(

So, i'm going back to plain Mint 13 XFCE.
My setup:
    *Linux Mint 13 XFCE 32-bit (Until the next LTS release)
    *Linux Mint 15 XFCE (RC) 32-bit (Tried...Failed)
    *Compaq Presario V2000 (from 2006) - Intel 1.5GHz (Pentium M) - 2 GB RAM - Intel 82852/855GM integrated video (i915)- WiFi
User avatar
rkmugen
Level 2
Level 2
 
Posts: 70
Joined: Sat Jan 08, 2011 3:01 pm

Linux Mint is funded by ads and donations.
 

Return to Graphic Cards & Monitors

Who is online

Users browsing this forum: No registered users and 5 guests