NVidia X Server Settings - Making Permanent

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this

NVidia X Server Settings - Making Permanent

Postby rtX on Wed Dec 26, 2012 11:56 am

I have two screens attached to a 9500GT. When I make changes in the NVidia X-Server Settings dialogue (under X Server Display Configuration) - specifically, when I change the primary display, the change only has effect (after pressing "Apply") for the session and does not survive a re-boot. I have tried "Save to X Configuration File", but that did not work. I even renamed the existing etc/X11/xorg.conf file and then saved a new version from the NVidia X Server Settings program. This did not work either but I did see a new file was created.

Please could someone advise?
rtX
Level 1
Level 1
 
Posts: 28
Joined: Sun Oct 14, 2012 6:05 am

Linux Mint is funded by ads and donations.
 

Re: NVidia X Server Settings - Making Permanent

Postby cwsnyder on Wed Dec 26, 2012 1:41 pm

Questions: Have you checked the nVidia 9500GT specifications? Perhaps one connector is hardware pre-selected as the primary display during the boot process, in which case you should be able to swap connectors to get the display primary to swap.
LMDE Mate 64-bit, LM16 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 13.10 64-bit, Xubuntu Trusty Tahr 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1039
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: NVidia X Server Settings - Making Permanent

Postby kwisher on Wed Dec 26, 2012 7:55 pm

When I select the "Save to X Configuration File", a dialog opens with the path /etc/X11/xorg.conf. When I select "Save" from this dialog, I am prompted for my password and the file is saved.

Is this not working for you?
The instructions suggested Windows XP or better, so I installed Linux :)
User avatar
kwisher
Level 5
Level 5
 
Posts: 624
Joined: Wed Mar 05, 2008 12:54 pm
Location: Greentown, Indiana USA

Re: NVidia X Server Settings - Making Permanent

Postby rtX on Mon Dec 31, 2012 3:42 pm

cwsnyder: Using LM13, the other screen was the primary, so I think the primary display is not 'hard-wired'. I have only had this issue since I performed a fresh install upgrade to LM14. Also, I can make the change to the primary display, but it does not survive a re-boot despite chnaging the X configuration file.

kwisher: I think the file is being saved, but next time I boot the displays have switched back...
rtX
Level 1
Level 1
 
Posts: 28
Joined: Sun Oct 14, 2012 6:05 am

Re: NVidia X Server Settings - Making Permanent

Postby kwisher on Mon Dec 31, 2012 4:07 pm

rtX wrote:cwsnyder: Using LM13, the other screen was the primary, so I think the primary display is not 'hard-wired'. I have only had this issue since I performed a fresh install upgrade to LM14. Also, I can make the change to the primary display, but it does not survive a re-boot despite chnaging the X configuration file.

kwisher: I think the file is being saved, but next time I boot the displays have switched back...

Try starting nvidia settings as root using "gksu nvidia-settings" and then save the file. I had to do that on older versions of ubuntu/mint in the past.
The instructions suggested Windows XP or better, so I installed Linux :)
User avatar
kwisher
Level 5
Level 5
 
Posts: 624
Joined: Wed Mar 05, 2008 12:54 pm
Location: Greentown, Indiana USA

Re: NVidia X Server Settings - Making Permanent

Postby rtX on Tue Jan 01, 2013 10:06 am

Interesting...

When I start nvidia-settings as a superuser, I get an error/warning message when I try to save the X configuration file (which I did not get previously). The message asks if I want to truncate the MetaMode list, warning that MetaMode strings greater than 900 characters are not supported. I am given the option of truncating so that only the first 38 MetaModes are written or risk the X server failing to start if I do not truncate.

This is the content of the untruncated version (which I have not saved):

Code: Select all
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 304.51  (buildd@batsu)  Fri Oct 12 12:53:54 UTC 2012


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Bit 3 LE22A3"
    HorizSync       31.0 - 83.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 9500 GT"
EndSection

Section "Screen"

# Removed Option "metamodes" "DFP: nvidia-auto-select +1680+0, CRT: nvidia-auto-select +0+0; CRT: nvidia-auto-select +0+0; CRT: 1680x1050 +0+0; CRT: 1680x1050_60 +0+0; CRT: 1680x1050_60_0 +0+0; CRT: 1440x900 +0+0; CRT: 1440x900_75 +0+0; CRT: 1440x900_60 +0+0; CRT: 1400x1050 +0+0; CRT: 1400x1050_75 +0+0; CRT: 1280x1024 +0+0; CRT: 1280x1024_75 +0+0; CRT: 1152x864 +0+0; CRT: 1152x864_75 +0+0; CRT: 1024x768 +0+0; CRT: 1024x768_75 +0+0; CRT: 1024x768_70 +0+0; CRT: 1024x768_60 +0+0; CRT: 800x600 +0+0; CRT: 800x600_75 +0+0; CRT: 800x600_72 +0+0; CRT: 800x600_60 +0+0; CRT: 800x600_56 +0+0; CRT: 640x480 +0+0; CRT: 640x480_75 +0+0; CRT: 640x480_72 +0+0; CRT: 640x480_60 +0+0; CRT: nvidia-auto-select +0+0; CRT: nvidia-auto-select +0+0"
# Removed Option "metamodes" "CRT: nvidia-auto-select +0+0; CRT: 1680x1050 +0+0; CRT: 1680x1050_60 +0+0; CRT: 1680x1050_60_0 +0+0; CRT: 1440x900 +0+0; CRT: 1440x900_75 +0+0; CRT: 1440x900_60 +0+0; CRT: 1400x1050 +0+0; CRT: 1400x1050_75 +0+0; CRT: 1280x1024 +0+0; CRT: 1280x1024_75 +0+0; CRT: 1152x864 +0+0; CRT: 1152x864_75 +0+0; CRT: 1024x768 +0+0; CRT: 1024x768_75 +0+0; CRT: 1024x768_70 +0+0; CRT: 1024x768_60 +0+0; CRT: 800x600 +0+0; CRT: 800x600_75 +0+0; CRT: 800x600_72 +0+0; CRT: 800x600_60 +0+0; CRT: 800x600_56 +0+0; CRT: 640x480 +0+0; CRT: 640x480_75 +0+0; CRT: 640x480_72 +0+0; CRT: 640x480_60 +0+0; CRT: nvidia-auto-select +0+0; CRT: nvidia-auto-select +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DFP: nvidia-auto-select +1680+0, CRT: nvidia-auto-select +0+0; CRT: nvidia-auto-select +0+0; CRT: 1680x1050 +0+0; CRT: 1680x1050_60 +0+0; CRT: nvidia-auto-select +0+0; CRT: 1680x1050_60_0 +0+0; CRT: 1680x1050 +0+0; CRT: 1440x900 +0+0; CRT: 1680x1050_60 +0+0; CRT: 1440x900_75 +0+0; CRT: 1680x1050_60_0 +0+0; CRT: 1440x900_60 +0+0; CRT: 1440x900 +0+0; CRT: 1400x1050 +0+0; CRT: 1440x900_75 +0+0; CRT: 1400x1050_75 +0+0; CRT: 1440x900_60 +0+0; CRT: 1280x1024 +0+0; CRT: 1400x1050 +0+0; CRT: 1280x1024_75 +0+0; CRT: 1400x1050_75 +0+0; CRT: 1152x864 +0+0; CRT: 1280x1024 +0+0; CRT: 1152x864_75 +0+0; CRT: 1280x1024_75 +0+0; CRT: 1024x768 +0+0; CRT: 1152x864 +0+0; CRT: 1024x768_75 +0+0; CRT: 1152x864_75 +0+0; CRT: 1024x768_70 +0+0; CRT: 1024x768 +0+0; CRT: 1024x768_60 +0+0; CRT: 1024x768_75 +0+0; CRT: 800x600 +0+0; CRT: 1024x768_70 +0+0; CRT: 800x600_75 +0+0; CRT: 1024x768_60 +0+0; CRT: 800x600_72 +0+0; CRT: 800x600 +0+0; CRT: 800x600_60 +0+0; CRT: 800x600_75 +0+0; CRT: 800x600_56 +0+0; CRT: 800x600_72 +0+0; CRT: 640x480 +0+0; CRT: 800x600_60 +0+0; CRT: 640x480_75 +0+0; CRT: 800x600_56 +0+0; CRT: 640x480_72 +0+0; CRT: 640x480 +0+0; CRT: 640x480_60 +0+0; CRT: 640x480_75 +0+0; CRT: nvidia-auto-select +0+0; CRT: 640x480_72 +0+0; CRT: nvidia-auto-select +0+0; CRT: 640x480_60 +0+0; CRT: nvidia-auto-select +0+0; CRT: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection



Does anyone have any suggestions as to how I might work around this? Many thanks.
rtX
Level 1
Level 1
 
Posts: 28
Joined: Sun Oct 14, 2012 6:05 am

Re: NVidia X Server Settings - Making Permanent

Postby McLovin on Wed Jan 02, 2013 8:49 pm

You have to run the nvidia-settings as root to get it to work properly, the easiest way to do it is to hit alt+f2, and enter
Code: Select all
gksu nvidia-settings
this will allow to save the configuration properly.
User avatar
McLovin
Level 5
Level 5
 
Posts: 788
Joined: Thu Aug 23, 2007 6:53 pm

Re: NVidia X Server Settings - Making Permanent

Postby rtX on Sat Jan 05, 2013 3:00 pm

McLovin wrote:You have to run the nvidia-settings as root to get it to work properly, the easiest way to do it is to hit alt+f2, and enter
Code: Select all
gksu nvidia-settings
this will allow to save the configuration properly.


Thanks but as I said in my earlier post I already ran it as root. It was then that the error message in my immediately prior post arose. The issue is more likely the size of the file?
rtX
Level 1
Level 1
 
Posts: 28
Joined: Sun Oct 14, 2012 6:05 am

Re: NVidia X Server Settings - Making Permanent

Postby DrHu on Sat Jan 05, 2013 3:12 pm

Well, save your xorg.conf file first as your user or as root (using a different filename, eg xorgconf.sav), and then you can mess with the nvidia setup for the X-server file (xorg.conf) as much as you like, since you will be able to restore (cp, copy or via a file manager) you saved xorg.conf filename as /etc/X11/xorg.conf

Usually the nvidia GUI tool nvidia-settings is A-OK for that file, it edits it correctly for meta-modes
--try it and check..
    if it (nvidia-settings) removes meta-modes, they are either somewhat duplicating other entries or are necessary for the full potential of your graphics card via nvidia driver file..
User avatar
DrHu
Level 16
Level 16
 
Posts: 6292
Joined: Wed Jun 17, 2009 8:20 pm

Re: NVidia X Server Settings - Making Permanent

Postby McLovin on Tue Jan 22, 2013 9:42 pm

rtX wrote:
McLovin wrote:You have to run the nvidia-settings as root to get it to work properly, the easiest way to do it is to hit alt+f2, and enter
Code: Select all
gksu nvidia-settings
this will allow to save the configuration properly.


Thanks but as I said in my earlier post I already ran it as root. It was then that the error message in my immediately prior post arose. The issue is more likely the size of the file?

You could also try backing up your /etc/X11/xorg,conf and then open a terminal and run this
Code: Select all
sudo nvidia-xconfig
and see if that helps at all
User avatar
McLovin
Level 5
Level 5
 
Posts: 788
Joined: Thu Aug 23, 2007 6:53 pm

Linux Mint is funded by ads and donations.
 

Return to Graphic Cards & Monitors

Who is online

Users browsing this forum: Bing [Bot] and 5 guests