New to Linux. Display corruption issue. AMD 6770HD.

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this

New to Linux. Display corruption issue. AMD 6770HD.

Postby Wintersbane on Tue Mar 12, 2013 8:20 pm

I will start off with the basics here.

1st time Linux user running Mint 14 Cinnamon 64 bit on a dual boot. I dedicated 50G of the drive to Mint as its own partition.
I am looking to eventually go full Mint and do away with Windows period. I am an avid gamer.

System specs:
Ga-970-UD3 Mobo
FX-6100 CPU
AMD 6770 HD Video card
8G 1600 GSkill Ram

Info from inxi:
inxi
CPU~Hexa core AMD FX-6100 Six-Core (-MCP-) clocked at 3999.839 Mhz Kernel~3.5.0-17-generic x86_64 Up~35 min Mem~703.6/7984.2MB HDD~1000.2GB(3.2% used) Procs~174 Client~Shell inxi~1.8.4


After install i downloaded and ran http://support.amd.com/us/gpudownload/l ... ng=English 13.1 set of drivers via Terminal after unpacking the .zip and setting execute permissions via the right click properties menu.

Now to the issues.
1. On occasion the first time i open Chromium it is a very tiny well detailed window but refuses to get larger. After i exit it and re open Chromium it works fine after that.
2. Anytime i try to use the auto hide option in Cinnamon i get a full screen static style corruption during the transitions. This also happens with window transfers at times.
3. I run World of Warcraft via W.I.N.E. I can not run it in true full screen if i do the display is black but still have audio.

So my questions are: Is this normal? Did i miss something? Is there a fix for this issue?

Thank you in advance for any help.
Wintersbane
Level 1
Level 1
 
Posts: 2
Joined: Tue Mar 12, 2013 12:58 am

Linux Mint is funded by ads and donations.
 

Re: New to Linux. Display corruption issue. AMD 6770HD.

Postby Wintersbane on Thu Mar 14, 2013 3:03 pm

Did a fresh install of Mint 14 again.
Just used the drivers that came with it and the issues went away. I get lower fps in Warcraft running Mint instead of Windows 7 but at least it runs i guess.
2 days, 35 views, zero responses >.<
Wintersbane
Level 1
Level 1
 
Posts: 2
Joined: Tue Mar 12, 2013 12:58 am

Re: New to Linux. Display corruption issue. AMD 6770HD.

Postby eanfrid on Thu Mar 14, 2013 3:26 pm

I have an AMD HD 6770 on my main desktop (a non-dedicated server indeed) running very well with O/S drivers under Cinnamon. No need for any AMD proprietary drivers.
Main desktop: Debian GNU/Linux Wheezy 64bit w/custom 3.14 longterm kernel - MATE 1.8.1
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
User avatar
eanfrid
Level 7
Level 7
 
Posts: 1607
Joined: Mon Apr 30, 2012 2:49 am
Location: there is no place like ~


Return to Graphic Cards & Monitors

Who is online

Users browsing this forum: No registered users and 3 guests