Nvidia 310.14 - Direct Rendering: No ???

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this

Nvidia 310.14 - Direct Rendering: No ???

Postby josealb77 on Sun Mar 24, 2013 8:32 pm

Hello,
I'm using kernel 3.5.0-26 64 bits, with a NVIDIA GeForce GTX 460.
When I launch glxgears I got this:
Code: Select all
~/$ LIBGL_DEBUG=verbose glxgears
libGL: screen 0 does not appear to be DRI2 capable
libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so
libGL error: failed to load driver: swrast
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
423 frames in 5.0 seconds = 83.833 FPS
380 frames in 5.1 seconds = 74.983 FPS
380 frames in 5.1 seconds = 74.985 FPS
380 frames in 5.1 seconds = 74.984 FPS
380 frames in 5.1 seconds = 74.984 FPS
380 frames in 5.1 seconds = 74.982 FPS
~/POL/playonlinux $

And the gears moves too slowly (I never saw them to move so slowly)
In the NVIDIA X Server Settings > OpenGL/GLX Information the first information that appears is
Code: Select all
GLX Information
Direct Rendering: No
GLX Extensions: GLX_ARB_create_context
etc.


Another strange thing is that being in a x64 system when I launch Play On Linux 4.2 (with 4.1.9 also happened), downloaded as tar.gz and extracted, it appears a message that says "PlayOnLinux is unable to find 64bit OpenGL libraries. You may encounter problems with your games". Since I'm in a 64 bits system I would see normal that playonlinux couldn't find the 32 bits libraries, but... the 64 bits???
But when I launch playonlinux from the linuxmint repositories I don't get any kind of message about libraries. Since this version is so old (4.1.1) I'm not sure if the lack of library messages at the beginning is caused by its better integration with the system, as it is the oficial one, or it is because this older version does not check libraries.

Launching playonlinux 4.2 from the official web downloaded tar.gz:
Code: Select all
~/POL/playonlinux $ ./playonlinux
[main] Message: PlayOnLinux (4.2) is starting
[clean_tmp] Message: Cleaning temp directory
[Check_OpenGL] Message: 32bits direct rendering is enabled
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
[Check_OpenGL] Warning: 64bits direct rendering is not enabled
[POL_System_CheckFS] Message: Checking filesystem for /home/user/.PlayOnLinux/
[main] Message: Filesystem is compatible
[install_plugins] Message: Comprobando extensión: Capture...
[install_plugins] Message: Comprobando extensión: ScreenCap...
[install_plugins] Message: Comprobando extensión: PlayOnLinux Vault...
[maj_check] Message: List is up to date


Launching playonlinux from the Linux Mint software manager package (4.1.1):
Code: Select all
~/POL/playonlinux $ playonlinux
[install_plugins] Message: Comprobando extensión: Offline PlayOnLinux...
[install_plugins] Message: Comprobando extensión: Transgaming Cedega...
[install_plugins] Message: Comprobando extensión: WineImport...
[install_plugins] Message: Comprobando extensión: Wine Look...
[main] Message: Filesystem is compatible
[install_plugins] Message: Comprobando extensión: ScreenCap...
[install_plugins] Message: Comprobando extensión: PlayOnLinux Vault...
[maj_check] Message: List is up to date
~/POL/playonlinux $


What's going on? Do I have Direct Rendering or not? Do I have the 64bits OpenGL libraries? Why glxgears plays so slowly and says "libGL: screen 0 does not appear to be DRI2 capable"? And, Why one version of POL says that can't find 64bits libraries while the another one does not complain about that?
josealb77
Level 1
Level 1
 
Posts: 40
Joined: Sun Nov 27, 2011 9:50 am

Linux Mint is funded by ads and donations.
 

Re: Nvidia 310.14 - Direct Rendering: No ???

Postby Jamesc359 on Sun Mar 24, 2013 8:55 pm

Did you manually install the NVidia drivers? If so you need to blacklist nouveau, otherwise your system will update it and break NVidia's drivers.

If you did a manual install try creating a file /etc/modprobe.d/nvidia-installer-disable-nouveau.conf with the following in it and then reinstalling your NVidia drivers.
Code: Select all
blacklist nouveau
options nouveau modeset=0
“Gosh, you've... really got some nice toys here.”
User avatar
Jamesc359
Level 3
Level 3
 
Posts: 110
Joined: Sun May 06, 2012 1:42 pm

Re: Nvidia 310.14 - Direct Rendering: No ???

Postby anandrkris on Mon Mar 25, 2013 2:07 am

Post results of below from terminal.
Code: Select all
inxi -Gx
Cheers,
If there is a drive, there will be a path
User avatar
anandrkris
Level 5
Level 5
 
Posts: 850
Joined: Fri Nov 16, 2012 1:13 am
Location: Chennai

Re: Nvidia 310.14 - Direct Rendering: No ???

Postby josealb77 on Mon Mar 25, 2013 1:52 pm

/etc/modprobe.d/nvidia-installer-disable-nouveau.conf already was that way. Some time ago I tried to install nvidia drivers manually.

inxi -Gx output:
Code: Select all
user@PCLinuxMint14 ~ $ sudo inxi -Gx
[sudo] password for user:
Graphics:  Card: NVIDIA GF104 [GeForce GTX 460] bus-ID: 01:00.0
           X.org: 1.13.0 drivers: (unloaded: fbdev,vesa,nouveau) FAILED: nvidia tty size: 148x21 Advanced Data: N/A for root
user@PCLinuxMint14 ~ $
josealb77
Level 1
Level 1
 
Posts: 40
Joined: Sun Nov 27, 2011 9:50 am

Re: Nvidia 310.14 - Direct Rendering: No ???

Postby kabads on Thu Mar 28, 2013 6:16 pm

I'm having the same problem - with nouveau blacklisted. Did you find a fix for this?
Image
kabads
Level 3
Level 3
 
Posts: 121
Joined: Thu Dec 01, 2011 2:01 pm

Re: Nvidia 310.14 - Direct Rendering: No ???

Postby josealb77 on Thu Mar 28, 2013 6:23 pm

No, I haven't. Sorry.
josealb77
Level 1
Level 1
 
Posts: 40
Joined: Sun Nov 27, 2011 9:50 am

Re: Nvidia 310.14 - Direct Rendering: No ???

Postby catweazel on Thu Mar 28, 2013 6:35 pm

Both the drivers and the installation process work fine here. Try this:

Code: Select all
sudo apt-get install nvidia-settings-experimental-310 nvidia-experimental-310
Mint Testing Team & Mint Donor #3606
KDE 4.12.0, custom preemptive kernel 3.12.5,
Intel i7 4770K @ 4.7GHz, 16GB 2666MHz XMP,
4 Samsung 840 PRO 512GB SSDs in RAID0,
6TB HW RAID10, dual 24" Acer X243H,
Gigabyte nVidia GTX 680 Super Overclock
User avatar
catweazel
Level 7
Level 7
 
Posts: 1656
Joined: Fri Oct 12, 2012 9:44 pm

Re: Nvidia 310.14 - Direct Rendering: No ???

Postby josealb77 on Thu Mar 28, 2013 7:26 pm

catweazel wrote:Both the drivers and the installation process work fine here. Try this:

Code: Select all
sudo apt-get install nvidia-settings-experimental-310 nvidia-experimental-310

Thank you, but as you can read in the header of the thread, the NVIDIA 310 drivers are which I'm already using and having troubles.
josealb77
Level 1
Level 1
 
Posts: 40
Joined: Sun Nov 27, 2011 9:50 am

Re: Nvidia 310.14 - Direct Rendering: No ???

Postby catweazel on Thu Mar 28, 2013 7:32 pm

josealb77 wrote:
catweazel wrote:Both the drivers and the installation process work fine here. Try this:

Code: Select all
sudo apt-get install nvidia-settings-experimental-310 nvidia-experimental-310

Thank you, but as you can read in the header of the thread, the NVIDIA 310 drivers are which I'm already using and having troubles.

Yes, I know that full well. I'll leave you to sort it out yourself.
Mint Testing Team & Mint Donor #3606
KDE 4.12.0, custom preemptive kernel 3.12.5,
Intel i7 4770K @ 4.7GHz, 16GB 2666MHz XMP,
4 Samsung 840 PRO 512GB SSDs in RAID0,
6TB HW RAID10, dual 24" Acer X243H,
Gigabyte nVidia GTX 680 Super Overclock
User avatar
catweazel
Level 7
Level 7
 
Posts: 1656
Joined: Fri Oct 12, 2012 9:44 pm

Re: Nvidia 310.14 - Direct Rendering: No ???

Postby josealb77 on Fri Mar 29, 2013 9:09 am

ALMOST SOLVED COMPLETELY:
I've solved it uninstalling 310.14 drivers and installing manually the 310.40 nvidia drivers, but I still have a minor problem. This is how I've done:

1- Uninstall completely the 310.14 drivers:
Code: Select all
- Go to nvidia.com and download the latest drivers (310.40)
- Go to Menu > Software Manager > Edit > Software Origins > Additional Drivers (Sorry if these aren't the exact words in the english version, I've got the spanish one) and install the Nouveau option.
- Don't erase the /etc/modprobe.d/nvidia-installer-disable-nouveau.conf file. This way when you reboot it won't be loaded neither the nvidia kernel module nor the nouveau one.
- Reboot
(If you don't uninstall completely the 310.14 drivers you will get a missmatch error with the kernel modules when reboot. I tried to unload and remove the 310.14 kernel module but I didn't succeed. The only way I was able to do it was the way I'm explaining)

2- Install the NVIDIA-Linux-x86_64-310.40 drivers
Code: Select all
- When you are in the login screen press Ctrl+Alt+F1 and login as root in the tty1
- Execute # init 3 (I think it is not necessary but thi is the way I've done)
- /etc/init.d/# mdm stop
- # service mdm stop
- Go where you downloaded NVIDIA-Linux-x86_64-310.40.run
- Change its permissions in order to make it executable with #chmod +x NVIDIA-Linux-x86_64-310.40.run and launch it with ./NVIDIA-Linux-x86_64-310.40.run
- Respond yes to every question.
- Start X Sever with #service mdm start and login.


Now it's suppose to be solved, but launching some applications these failed to find the 32-libs libraries, despite I choosed yes in its corresponding question in the nvidia-installer (NVIDIA-Linux-x86_64-310.40.run). So, now I have to solve this another problem:

3- Solving the 32 bits libraries issue:
Code: Select all
- Since I want this to be solved for any user in my machine I'm going to add
export LD_LIBRARY_PATH="/usr/lib32:$LD_LIBRARY_PATH"
to my /etc/bash.bashrc
- If you want this to be solved just for your user you just have to create the file .bashrc in your home directory and add the line above.
(I must say that editing the files .profile, /etc/profle, and similars didn't work at all. Just worked editing /etc/bash.bashrc for all users or home/user/.bashrc for a single user)


But now, this is the minor issue that I think must be a silly one with a silly solution but I don't know how to solve it:
It is solved for applications launched from the terminal, but when I try to lauch them from the desktop icons or from the Menu they don't find the 32 bits libraries.

How do I do in order to launch applications from the desktop and not having the 32 bits problems? (Better if it is a global solution, not an "edit each application one by one in order to add just one line" or something like that) (just adding /usr/lib32 to the PATH didn't work)
josealb77
Level 1
Level 1
 
Posts: 40
Joined: Sun Nov 27, 2011 9:50 am

Linux Mint is funded by ads and donations.
 

Return to Graphic Cards & Monitors

Who is online

Users browsing this forum: nomko and 6 guests