A throny problem of ATI graphic card

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this

A throny problem of ATI graphic card

Postby songcheng0628 on Thu Mar 28, 2013 5:06 am

Hi everybody,

I am trying to use Linux recently. And my computer is a 5-year-old one. Here are the main components:
CPU: Intel Core 2 6500
Graphic Card: ATI Randon 2600XT HD
Motherboard: MSI P35


I installed the Linux Mint 13 64bit MATE(for LTS), and tried a lot of approaches to install the proprietary driver from ATI. But they all performanced badly on my computer. Every time, when I transfered into the Cinnamon Desktop Environment, the computer responded slowly. I guess there must be something wrong with the installation of drivers. But the system tells me that the proprietary driver functions well.

fgl_glxgears
Using GLX_SGIX_pbuffer
5971 frames in 5.0 seconds = 1194.200 FPS
6158 frames in 5.0 seconds = 1231.600 FPS


fglrxinfo
display: :0 screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Radeon HD 2600 XT
OpenGL version string: 3.3.11631 Compatibility Profile Context


So my questions are:
1. Does the driver function properly, according to the result?
2. It seems that I can't install the latest the driver (13.1) of ATI, since the kernel is not so up-to-date. Am I right?
3. Does anybody succesfully install the proprietary driver of ATI 2600XT HD on Linux Mint 13 64bit?
4. Is there a big difference between the proprietary driver and open source driver?
songcheng0628
Level 1
Level 1
 
Posts: 15
Joined: Tue Aug 21, 2012 2:25 pm

Linux Mint is funded by ads and donations.
 

Re: A throny problem of ATI graphic card

Postby songcheng0628 on Thu Mar 28, 2013 5:50 am

Another problem:
I uninstalled the official driver of ATI, and my computer can't roll back! I mean the open source driver doesn't function at all!

System: Host: PowerStation Kernel: 3.2.0-23-generic x86_64 (64 bit) Desktop: N/A Distro: Linux Mint 13 Maya
Machine: Mobo: MICRO-STAR model: P35 Platinum(MS-7345) version: 1.0
Bios: American Megatrends version: V1.12 date: 12/30/2009
CPU: Dual core Intel Core2 Duo CPU E6550 (-MCP-) cache: 4096 KB flags: (lm nx sse sse2 sse3 ssse3 vmx)
Clock Speeds: 1: 2337.763 MHz 2: 2337.763 MHz
Graphics: Card: Advanced Micro Devices [AMD] nee ATI RV630 [Radeon HD 2600XT]
X.Org: 1.11.3 drivers: vesa (unloaded: fbdev,fglrx) Resolution: 1152x864@0.0hz
GLX Renderer: N/A GLX Version: N/A
Audio: Card-1: Advanced Micro Devices [AMD] nee ATI RV630 audio device [Radeon HD 2600 Series] driver: snd_hda_intel
Card-2: Intel 82801I (ICH9 Family) HD Audio Controller driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture ver: 1.0.24
Network: Card-1: Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller driver: r8169
IF: eth0 state: down mac: 00:19:db:f6:b6:b7
Card-2: Atheros TP-Link TL-WN821N v3 802.11n [Atheros AR7010+AR9287]
IF: N/A state: N/A mac: N/A
Drives: HDD Total Size: 2320.5GB (0.6% used) 1: /dev/sda WDC_WD20EURS 2000.4GB
2: /dev/sdb WDC_WD3200YS 320.1GB
Partition: ID: / size: 42G used: 7.9G (20%) fs: ext4 ID: /boot size: 93M used: 33M (38%) fs: ext4
ID: /home size: 13G used: 4.5G (37%) fs: ext4 ID: swap-1 size: 4.00GB used: 0.00GB (0%) fs: swap
Sensors: Error: You do not have the sensors app installed.
Info: Processes: 156 Uptime: 28 min Memory: 844.6/3954.5MB Client: Shell inxi: 1.7.33


How can I reinstall the open source driver?
songcheng0628
Level 1
Level 1
 
Posts: 15
Joined: Tue Aug 21, 2012 2:25 pm

Re: A throny problem of ATI graphic card

Postby wayne128 on Thu Mar 28, 2013 9:11 am

1. Does the driver function properly, according to the result?

it seems OK
2. It seems that I can't install the latest the driver (13.1) of ATI, since the kernel is not so up-to-date. Am I right?

Your ATI is legacy.
13.1 will not support legacy card.
13.1 support HD5xxx series or later.
Not really a kernel problem, more like the xorg.
Read the Mint14 announcement, it mentioned all these legacy driver support issue
3. Does anybody succesfully install the proprietary driver of ATI 2600XT HD on Linux Mint 13 64bit?

not me, since I have two other legacy cards and one HD5xxx series.
HD 5xxx series can take all version of ATI driver, including 13.2 beta and on kernel upto 3.6 level. I have not yet tested kernel 3.7 and 3.8
4. Is there a big difference between the proprietary driver and open source driver?

Just me only
two advantages
1. 3D
2. GPU temp is 10 degC lower than the free Radeon driver
wayne128
Level 9
Level 9
 
Posts: 2808
Joined: Tue Jul 13, 2010 12:15 am

Re: A throny problem of ATI graphic card

Postby songcheng0628 on Thu Mar 28, 2013 11:26 am

wayne128 wrote:
1. Does the driver function properly, according to the result?

it seems OK
2. It seems that I can't install the latest the driver (13.1) of ATI, since the kernel is not so up-to-date. Am I right?

Your ATI is legacy.
13.1 will not support legacy card.
13.1 support HD5xxx series or later.
Not really a kernel problem, more like the xorg.
Read the Mint14 announcement, it mentioned all these legacy driver support issue
3. Does anybody succesfully install the proprietary driver of ATI 2600XT HD on Linux Mint 13 64bit?

not me, since I have two other legacy cards and one HD5xxx series.
HD 5xxx series can take all version of ATI driver, including 13.2 beta and on kernel upto 3.6 level. I have not yet tested kernel 3.7 and 3.8
4. Is there a big difference between the proprietary driver and open source driver?

Just me only
two advantages
1. 3D
2. GPU temp is 10 degC lower than the free Radeon driver


Thank you very much, mate!

Is there any usable driver for the so-called 'legacy' drivers? I have installed the catalyst 12.4. It functioned wrosen than the 13.1 version in my eyes.

What is your final solution for your two legacy cards? Open source driver?

Apologise for so many questions, coz I am really a rookie in Linux and my English is not good as well.
songcheng0628
Level 1
Level 1
 
Posts: 15
Joined: Tue Aug 21, 2012 2:25 pm

Re: A throny problem of ATI graphic card

Postby wayne128 on Thu Mar 28, 2013 9:46 pm

go to amd website to check

here is a link to start
http://wiki.cchtml.com/index.php/Hardware

you may need to change kernel version (lower version) to match the driver version.

just copy out from their website to show you
Older RadeonHD (Catalyst Legacy 13.1 & Open Source)

ATI/AMD initially dropped Catalyst support for these cards in the regular Catalyst 12-6. These cards are now supported with the later released Catalyst 13-1 legacy, but you MUST use a kernel <= 3.4 and Xserver <= 1.12. For example, you can use Catalyst 13-1 legacy if you're running Ubuntu 12.04 or Debian Squeeze/6.0. Open source support is good and 3D is still improving.

* R600 Radeon HD 2900
* RV610/RV630 Radeon HD 2400/2600, 3000/3100/3200/3300, M71, M72, M74, M76
* RV620 Radeon HD 3450/3470, M82
* RV635 Radeon HD 3650/3670, M86
* RV670 Radeon HD 3850/3870, M88
* RS780 Radeon HD 3100/3200/3300
* RS880 Radeon HD 4100/4200/4290
* RV710 Radeon HD 4350/4550/5145/530v/545v, M92
* RV730 Radeon HD 4650/4670/5165/550v/560v/565v, M96, M96-XT
* RV770 Radeon HD 4850/4870, M97, M98







For me, I simply stay with free radeon for the legacy card, I do not use them too much for heavy graphic... because I have HD5450 which works in many driver versions and kernel versions.. :mrgreen:
wayne128
Level 9
Level 9
 
Posts: 2808
Joined: Tue Jul 13, 2010 12:15 am

Re: A throny problem of ATI graphic card

Postby songcheng0628 on Fri Mar 29, 2013 1:30 am

wayne128 wrote:go to amd website to check

here is a link to start
http://wiki.cchtml.com/index.php/Hardware

you may need to change kernel version (lower version) to match the driver version.

just copy out from their website to show you
Older RadeonHD (Catalyst Legacy 13.1 & Open Source)

ATI/AMD initially dropped Catalyst support for these cards in the regular Catalyst 12-6. These cards are now supported with the later released Catalyst 13-1 legacy, but you MUST use a kernel <= 3.4 and Xserver <= 1.12. For example, you can use Catalyst 13-1 legacy if you're running Ubuntu 12.04 or Debian Squeeze/6.0. Open source support is good and 3D is still improving.

* R600 Radeon HD 2900
* RV610/RV630 Radeon HD 2400/2600, 3000/3100/3200/3300, M71, M72, M74, M76
* RV620 Radeon HD 3450/3470, M82
* RV635 Radeon HD 3650/3670, M86
* RV670 Radeon HD 3850/3870, M88
* RS780 Radeon HD 3100/3200/3300
* RS880 Radeon HD 4100/4200/4290
* RV710 Radeon HD 4350/4550/5145/530v/545v, M92
* RV730 Radeon HD 4650/4670/5165/550v/560v/565v, M96, M96-XT
* RV770 Radeon HD 4850/4870, M97, M98







For me, I simply stay with free radeon for the legacy card, I do not use them too much for heavy graphic... because I have HD5450 which works in many driver versions and kernel versions.. :mrgreen:


Ok, thank you very much. I think I got the answer - The only solution for me right now is using the the open source driver. Thanks again!
songcheng0628
Level 1
Level 1
 
Posts: 15
Joined: Tue Aug 21, 2012 2:25 pm


Return to Graphic Cards & Monitors

Who is online

Users browsing this forum: No registered users and 5 guests