Help installing mint 14 on toshiba U940 (gt 630m)

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this

Help installing mint 14 on toshiba U940 (gt 630m)

Postby kryptos on Mon Apr 29, 2013 10:17 am

Hey everyone,

I've been using mint 13 and 14 for 1 year, but now I've encountered a problem that i couldn't solve, my last laptop gone dead (compaq cq61) and I've purchased a Toshiba ultra-book U940-112 and i can not make mint14 to work properly, everything works fine except the graphic card, I've tried the latest nvidia's drivers and the repository ones, nothing works, the installation runs fine but the xorg configuration isn't done right. So, that said, i really need help to make everything works and go back to using linux mint as my primary OS.

thanks!

laptop setup:
nvidia gt 630m
intel core i5
mSata cache drive 32gb
seagate 750gb 7200 16mb
4gb ram ddr3 1600 -(8 gb hyperX coming soon)
kryptos
Level 1
Level 1
 
Posts: 7
Joined: Tue Jan 08, 2013 10:45 am

Linux Mint is funded by ads and donations.
 

Re: Help installing mint 14 on toshiba U940 (gt 630m)

Postby zerozero on Mon Apr 29, 2013 10:50 am

Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6488
Joined: Tue Jul 07, 2009 2:29 pm

Re: Help installing mint 14 on toshiba U940 (gt 630m)

Postby kryptos on Mon Apr 29, 2013 11:24 am

zerozero, i've installed bumblebee but didn't helped...
kryptos
Level 1
Level 1
 
Posts: 7
Joined: Tue Jan 08, 2013 10:45 am

Re: Help installing mint 14 on toshiba U940 (gt 630m)

Postby zerozero on Mon Apr 29, 2013 11:42 am

kryptos,
sorry, i looked closer and there's an issue opened with that card in the bumblebee bug track
https://github.com/Bumblebee-Project/bbswitch/issues/40
in the meantime bumblebee had several updates (and i expected that this issue was already solved, apparently not)
if you still have problems with the installation i advise to open an issue directly against bumblebee.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6488
Joined: Tue Jul 07, 2009 2:29 pm

Re: Help installing mint 14 on toshiba U940 (gt 630m)

Postby kryptos on Mon Apr 29, 2013 11:59 am

thanks for the help.

i'll do a clean install cause it seems that mint isn't finding the drivers, even bumblebee don't find the nvidia drivers. Maybe is something messed up with xorg or xorg folder.
kryptos
Level 1
Level 1
 
Posts: 7
Joined: Tue Jan 08, 2013 10:45 am

Re: Help installing mint 14 on toshiba U940 (gt 630m)

Postby zerozero on Mon Apr 29, 2013 12:00 pm

open a terminal and post the output of the following command
Code: Select all
inxi -Gx
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6488
Joined: Tue Jul 07, 2009 2:29 pm

Re: Help installing mint 14 on toshiba U940 (gt 630m)

Postby kryptos on Mon Apr 29, 2013 12:42 pm

Got this after inxi -Gx

Code: Select all
tiago@TCLinux-U940 ~ $ inxi -Gx
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0
           Card-2: NVIDIA GF108 [GeForce GT 630M] bus-ID: 01:00.0
           X.Org: 1.13.0 drivers: intel (unloaded: fbdev,vesa) Resolution: 640x480@59.9hz
           GLX Renderer: N/A GLX Version: N/A Direct Rendering: N/A
kryptos
Level 1
Level 1
 
Posts: 7
Joined: Tue Jan 08, 2013 10:45 am

Re: Help installing mint 14 on toshiba U940 (gt 630m)

Postby zerozero on Mon Apr 29, 2013 5:43 pm

that output shows that mint is not recognizing neither of the gpus
you have this
Code: Select all
GLX Renderer: N/A GLX Version: N/A Direct Rendering: N/A

and should have something similar to this
Code: Select all
GLX Renderer: Mesa DRI Intel Ivybridge Desktop GLX Version: 3.0 Mesa 8.0.5 Direct Rendering: Yes
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6488
Joined: Tue Jul 07, 2009 2:29 pm

Re: Help installing mint 14 on toshiba U940 (gt 630m)

Postby kryptos on Tue Apr 30, 2013 10:20 am

any idea on what i should do?
kryptos
Level 1
Level 1
 
Posts: 7
Joined: Tue Jan 08, 2013 10:45 am

Re: Help installing mint 14 on toshiba U940 (gt 630m)

Postby kryptos on Tue Apr 30, 2013 1:35 pm

after:
- a clean install
- installing nvidia 310 drivers from repos
- installing bumblebee
- installing ubuntu's repos intel drivers
- upgrading all system

got this
Code: Select all
tiago@TCLinux-U940 ~ $ inxi -Gx
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0
           Card-2: NVIDIA GF108 [GeForce GT 630M] bus-ID: 01:00.0
           X.Org: 1.13.0 drivers: intel (unloaded: fbdev,vesa) Resolution: 640x480@59.9hz
           GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 9.0.3 Direct Rendering: Yes


and cinnamon is loading in a 600x800 resulotion.

i really don't know what's happening and i can not solve it, anyone have an idea?

if i can not solve this i'll stop using linux cause is impossible to work like this.


thanks!
kryptos
Level 1
Level 1
 
Posts: 7
Joined: Tue Jan 08, 2013 10:45 am

Re: Help installing mint 14 on toshiba U940 (gt 630m)

Postby kryptos on Thu May 02, 2013 6:51 am

anyone got an ideia?
kryptos
Level 1
Level 1
 
Posts: 7
Joined: Tue Jan 08, 2013 10:45 am

Linux Mint is funded by ads and donations.
 

Return to Graphic Cards & Monitors

Who is online

Users browsing this forum: Shankaraya and 8 guests