[Solved] NVIDIA Driver Does Not Work on Dell Latitude E6520

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this

[Solved] NVIDIA Driver Does Not Work on Dell Latitude E6520

Postby piuforte on Wed Dec 14, 2011 9:49 pm

Greetings! I'm new to Linux and liking it very much. My problem is that the NVIDIA driver on my Dell laptop does not work. Compiz and 3D effects don't work. Neither does the HDMI port (VGA is OK).

The following information appears for Menu>Additional Drivers:
"No proprietary drivers are in use on this system.
NVIDIA accelerated graphics driver (version current) [Recomended]
* This driver is activated but not currently in use."

NVIDIA X Server Settings returns the following error:
"You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server."

I ran nvidia-xconfig as root in the terminal. However, after restart only a dark screen appeared, and, without a command line, I was unable to do anything. Fortunately, I figured out how to reboot in safe graphics mode and return to the previous graphics settings.

I've been trying different solutions in Linux and Ubuntu forums, but none seem to work. For instance, one source recommended disabling Optimus in BIOS (http://ubuntuforums.org/showthread.php?t=1726575), but this makes the graphics very crude. Another source suggested to navigate to /etc/X11/xorg.conf and edit the driver line to read Driver "nvidia"...and then restart/kill/restart the X server. However, there is *no* "xorg.config" file in the x11 folder, only "xorg.config.backup" and "xorg.config.failsafe." (In xorg.config.backup the driver is listed as Nvidia)

Any help you could provide would be greatly appreciated. Thus far, I've been able to recover from my missteps, but I'm in way over my head. Below is the relevant info for my computer:

jf@jf-Latitude-E6520 ~ $ inxi -v 4 G
System: Host jf-Latitude-E6520 Kernel 2.6.38-13-generic x86_64 (64 bit) Distro Linux Mint 11 Katya
CPU: Dual core Intel Core i5-2520M (-HT-MCP-) cache 3072 KB flags (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) clocked at 800.00 MHz
Graphics: Card-1 Intel 2nd Generation Core Processor Family Integrated Graphics Controller Card-2 nVidia Device 1056 X.Org 1.10.1 Res: 1360x768@59.8hz
GLX Renderer N/A GLX Version N/A
Last edited by piuforte on Mon Dec 19, 2011 12:12 pm, edited 1 time in total.
piuforte
Level 1
Level 1
 
Posts: 2
Joined: Wed Dec 14, 2011 9:43 pm

Linux Mint is funded by ads and donations.
 

Re: NVIDIA Driver Does Not Work on Dell Latitude E6520

Postby piuforte on Mon Dec 19, 2011 10:12 am

Driver problem solved! I'm replying to my own post. Perhaps it will prove uselful for someone. My solution for getting the Nvidia driver to work on Dell Latitude E6520 is as follows.
1 - Upgrade to Linx Mint 12 Lisa and install all of the updates:
_ a - Back up files using the Backup Tool. Also back up your software selection.
_ b - Download Linux Mint 12 - 32-bit desktop image. Burn the iso file to a DVD disk. It's important to the select 32-bit version, even though Dell Latitude E6520 is a 64-bit machine. Dell Latitude E6520 is certified only for 11.10 Ubuntu 32-bit, which is the basis for Mint 12 (see http://www.ubuntu.com/certification/har ... 01101-6956).
_ c - Boot Mint 12 from the live DVD. Connect to the Internet in case you need to research questions.
_ d - Open a terminal window and type in the following: sudo lshw -short
_ e - Check the output to make sure all your hardware is recognized. The "display" line should read "/0/100/1/0 display GF108 [Quadro NVS 4200M]" if you're doing this on a Latitude E6520.
_ f - If everything seems OK, click the install icon on the desktop and follow the steps. (for dual boot, select "Something else" when the Installation type window appears).
_ g - Reinstall your files and software selection.
2 - Restart the computer. Wait for the BIOS screen to appear and press the F12 key to enter BIOS (you have to be quick!). Using the down-arrow key, select BIOS Setup and hit enter. Open Video under Settings. Select Optimus and uncheck the "Enable Optimus" box. (OPTIMUS is only applicable to Windows operating systems.) Click the Exit button and wait for restart.
3 - Go to System Tools->System Settings->Additional Drivers. After the search in complete, select and install "Nvidia accelerated graphics driver (version current) [Recommended]." After it's installed, the message at the bottom should read "This driver is activated and currently in use."
4 - Open Applications->Other->NVIDIA X Server Settings. Check the information. If everything is OK, there should be *no* error message. The full information about your monitor and graphics card can be viewed under the various links on the left.
5 - The following is for how to get Compiz to work.
_ a - When you login to Mint 12, click the cog in the upper right corner of the small login screen and select "Gnome Classic" desktop (Gnome Classic is Gnome 2; Compiz is not supported on Gnome 3).
_ b - Open the package manager (Applications->Other->Synaptic Package Manager) and search for "compiz-check" Mark for installation and apply.
_ c - Open a terminal and type in "compiz-check" (not as root). Verify that all the responses are marked "[ OK ]"
_ d - Everything should work now. Open Applications->Other->CompizConfig Settings Manager and configure as desired. If the Compiz Settings Manager is not installed, open the package manager, search for "compizconfig-settings-manager", mark for installation and apply.
piuforte
Level 1
Level 1
 
Posts: 2
Joined: Wed Dec 14, 2011 9:43 pm


Return to Graphic Cards & Monitors

Who is online

Users browsing this forum: No registered users and 7 guests