To use the latest version or stick with the old vesion?

Chat about anything related to Linux Mint

To use the latest version or stick with the old vesion?

Postby glas on Wed Oct 03, 2012 5:33 am

I've been using Linux Mint as my main desktop operating system since version 2.1 (Bea). I have upgrqaded my version to the latest offerings from Mint experiencing many improvements (like wireless networking and compiz-fusion) and some losses (the decent and stable version of Kompozer will no longer functioned after Mint 5).

I have discovered some versions just seem to work better than others on specific hardware. 9 and 10 work great for me on a variety of hardware. I found 11 buggy and there were some issues with 12 too but I can't remember the details right now. I have tried the Debian editions, and Mint 13 Mate (which works great apart from compiz-fusion).

So I'm always torn, should I upgrade to then latest version or should I stick with a version that works best for me and I have configured just as I like it - even though it is labelled as 'obsolete' and its support, short-term or long-term, has run out?

I currently using Mint 10 to write about this post (Obsolete since April 2012). Is this going to cause me problems in the future? Should I disable the update manager and 'freeze' the system in its current state? Or should I accept a more recent version that still has support (even if it means loosing some features and capability)?

Pentium Dual Core E5800 @ 3.20 GHz
RAM 4022 MB
Linux Mint 10
Gnome 2.32.0
User avatar
glas
Level 2
Level 2
 
Posts: 54
Joined: Tue Jan 09, 2007 8:13 am
Location: Cymru/Pays de Galles/Wales

Linux Mint is funded by ads and donations.
 

Re: To use the latest version or stick with the old vesion?

Postby nunol on Thu Oct 04, 2012 5:24 am

Issues with obsolete editions:
- security bugs that are common knowledge are not fixed and could be exploited, sometimes with only a few clicks.
- no programs updates (bug fix, new features, new standards support, etc).
- no more new hardware support.
- the repos may close.

If you are happy with the obsolete Mint edition despite the above mentioned issues, then it's OK to use it. I would advise you to stick with LTS releases because they last longer, Mint 9 LTS is supported until April 2013 and Mint 13 LTS until 2017.

I would not use obsolete editions to to home banking or other activities where security is important but you could use a second more secure OS to do that (LiveCD/DVD/USB, dualboot, etc).
User avatar
nunol
Level 9
Level 9
 
Posts: 2664
Joined: Sun Mar 06, 2011 9:25 pm
Location: Portugal

Re: To use the latest version or stick with the old vesion?

Postby xenopeek on Thu Oct 04, 2012 9:56 am

nunol's answer sums it up I think. Adding one detail to that, "the repos may close"; this will actually happen. Meaning there will come a time where you won't be able to install any new programs from the repositories (with Software Manager, Synaptic, apt-get, aptitude, or other package management program).

I'd recommend making an effort to upgrade to Linux Mint 13, and you can stay with that for 5 years without worry. Often recommended to dual-boot. So keep your current installation of Linux Mint 10, and install the new version of Linux Mint alongside it in dual-boot. That way, you can always go back to your old installation to check on how you configured something in the past and you can also use it as a rescue installation for when you run into problems with your new version of Linux Mint.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14524
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands


Return to Chat about Linux Mint

Who is online

Users browsing this forum: Bing [Bot] and 4 guests