Marvell controller: installer can't see attached HDDs

Chat about Linux in general

Marvell controller: installer can't see attached HDDs

Postby Dragget on Thu Sep 20, 2012 3:41 am

I have a Gigabyte GA-790FXTA-UD5 motherboard that I want to use in an HTPC I'm building. To that end, I'm trying to install Mythbuntu 12.04.1 (64 bit) on it. The HDD is connected to the onboard Marvell 9128 SATA controller (in AHCI mode) as this controller supports SATA 6Gbps, whereas the AMD 750 southbridge chipset only supports up to 3 Gbps. Unfortunately, the install utility seems to be unable to detect drives attached to the Marvell controller. I also tried a Linux Mint install CD (64 bit, "Maya" 13 MATE) with the same results. When I plug a drive into one of the SATA ports connected to the AMD controller--also in AHCI mode--the installer picks it right up. I have tried two different drives with the same result. I even tried setting the controller to IDE "compatibility" mode in the BIOS before booting the install CD, but that didn't make the HDD visible to the installer either. The weird thing is that when I boot into the LiveCD mode and download GParted, it has no trouble recognizing the drive on the Marvell controller... I was able to view and edit partitions with no issues.

NOTE: I have successfully installed Windows XP (32 bit) and Windows 7 (64 bit) on this system with the HDD attached to the Marvell controller with no issues of any kind, So I'm certain the controller itself is OK.
Level 1
Level 1
Posts: 1
Joined: Tue Jul 24, 2012 4:41 pm

Linux Mint is funded by ads and donations.

Return to Chat about Linux

Who is online

Users browsing this forum: Fragezeichen, M0em, mike acker and 5 guests