X Window System error with ATI card

Chat about Linux in general

X Window System error with ATI card

Postby caerolle on Fri Sep 28, 2012 11:01 pm

This is a problem I have been trying to solve for months now. A viewer I run for an online game consistently crashes in every single distro but Mint (YAY, Mint!) The viewer will sometimes somewhat run, then finally crash before I load the ATI driver. After I load the driver, I get the following sort of error:

The program 'do-not-directly-run-firestorm-bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such operation)'.
(Details: serial 14 error_code 1 request_code 139 minor_code 66)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)
*** Bad shutdown ($LL_RUN_ERR). ***

I have researched this to death and posted requesting help on this on several of the viewer developers' sites , and tried several different distros, to no avail. I am pretty much at my wit's end. :?

I have a Mint set-up I love, and it works fine with the viewer, and everything else, but it's driving me crazy that nothing else seems to work with it, and I can't figure out how to fix it. I am hoping someone here has some ideas.

There are a couple of questions, in my mind. First, the direct approach. Any ideas about what could cause this error, in general? The second is, what is it that is different with the Mint setup that makes it works straight off with the viewer? Ubuntu doesn't work, nor any of the other derivatives I've tried but Mint, yet I used the same 'Additional Drivers' in Mint that I used in the other 'buntus'. I have even considered springing for a Nvidia video card if that would make things work...

I appreciate any help anyone can give me!

Thanks so much!

caerolle :)


i5, Raedon 5700, 8GB 1333 DDR3 RAM
main setup Mint13 Xfce
caerolle
Level 3
Level 3
 
Posts: 143
Joined: Sun Aug 26, 2012 3:50 pm

Linux Mint is funded by ads and donations.
 

Re: X Window System error with ATI card

Postby xenopeek on Sun Sep 30, 2012 7:48 am

Can you name the game and the viewer you use?
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14807
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands


Return to Chat about Linux

Who is online

Users browsing this forum: No registered users and 4 guests