driver intel pour utiliser compiz

French Forum

driver intel pour utiliser compiz

Postby Elhy on Fri May 09, 2008 6:41 am

Bonjour tout le monde. Je suis nouveau sur linux et j'ai quelques problèmes pour les drivers de ma carte vidéo.
Je ne peux pas utiliser les effets visuels de Daryna malheureusement.

A savoir que j'ai : Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)

Si quelqu'un a eu le même problème et pouvait me filer un coup de pattes ce serait sympa :D
Elhy
 

Linux Mint is funded by ads and donations.
 

Re: driver intel pour utiliser compiz

Postby Dupo on Fri May 09, 2008 9:10 am

Salut Elhy,

le problème pourrait provenir du fait que ta carte soit blacklistée dans compiz (c'est-à-dire incorporée dans la blacklist de compiz).

Mais tout d'abord, as tu installé le pilote propriétaire de ta carte graphique (cfr. synaptic + dépôts) ?
Et as tu vérifié que celui-ci était activé dans Système->Administration=>gestionnaire pilote prioritaire.

Sinon,

1er chose à vérifier : tapez dans le terminal la commande :

~$ glxinfo | grep "direct rendering"

La commande doit renvoyé : direct rendering: Yes (si correct).

2 ème chose : lancer la commande : compiz --replace (vérifier si messages d'erreurs).

3 ème et dernière chose : Dans un terminal tu fais: sudo gedit /etc/xdg/compiz/compiz-manager

Dans ton fichier /etc/xdg/compiz/compiz-manager, tu dois avoir ça :

COMPIZ_BIN_PATH="/usr/bin/"
PLUGIN_PATH="/usr/lib/compiz/"
COMPIZ_NAME="compiz.real"
SKIP_CHECKS=yes

Sauvegarde, puis redémarre le serveur X (sortir de ta session par ex.).

Voilà, en attendant ta réponse.

A+.

P.S: Petite remarque en passant.
Last edited by Dupo on Fri May 09, 2008 9:26 am, edited 1 time in total.
Dupo
Level 4
Level 4
 
Posts: 286
Joined: Thu Jan 31, 2008 9:42 pm

Re: driver intel pour utiliser compiz

Postby Elhy on Fri May 09, 2008 9:24 am

voila, d'abord merci de ta réponse,

J'ai ce que tu m'a indiqué :

1) la commande: glxinfo | grep "direct rendering" m'a renvoyé:

Code: Select all
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".



2) ensuite : pour compiz --replace

Code: Select all
Checking for Xgl: not present.
No whitelisted driver found
aborting and using fallback: /usr/bin/metacity

3) enfin, dans le fichier /etc/xdg/compiz/compiz-manager j'ai :

# Ubuntu specifc compiz-manager configuration file
# goes into /etc/xdg/compiz/compiz-manager
# works with git://anongit.compiz-fusion.org/fusion/ ... iz-manager
COMPIZ_BIN_PATH="/usr/bin/"
PLUGIN_PATH="/usr/lib/compiz/"
COMPIZ_NAME="compiz.real"


Je comprend pas tout, mais je pense qu'il me manque 2 ou 3 trucs :?

Merci de m'aider en tout cas, la communauté linux est très sympatique :D
Elhy
 

Re: driver intel pour utiliser compiz

Postby Dupo on Fri May 09, 2008 9:30 am

Ok, nous allons commencer par étape.

Première étape :

as tu installé le pilote propriétaire de ta carte graphique intel (cfr. synaptic + dépôts) ?
Et as tu vérifié que celui-ci était activé dans Système->Administration=>gestionnaire pilote prioritaire ?
Dupo
Level 4
Level 4
 
Posts: 286
Joined: Thu Jan 31, 2008 9:42 pm

Re: driver intel pour utiliser compiz

Postby Elhy on Fri May 09, 2008 9:39 am

euh il n'y ait pas dans la gestionnaire, j'ai que celui pour la carte réseaux, mais j'utilise un pilote génrérique intel (celui qui est par default)

J'ai pas trouvé de pilotes sur le site intel

ou alors j'ai rien compris :roll:
Elhy
 

Re: driver intel pour utiliser compiz

Postby Dupo on Fri May 09, 2008 9:52 am

Tu lances le programme Synaptic. Puis appuye sur recherche, et tape intel.

installer pilote graphique intel : http://doc.ubuntu-fr.org:81//intel_graphics?redirect=1

Sinon, il faudra installer le paquet : xserver-xgl (via synaptic).

Si ça rame avec Xgl, il faudra utiliser AIGLX pour compiz : http://wiki.compiz-fusion.org/Intel%20with%20AiGLX
Dupo
Level 4
Level 4
 
Posts: 286
Joined: Thu Jan 31, 2008 9:42 pm

Re: driver intel pour utiliser compiz

Postby Elhy on Fri May 09, 2008 10:39 am

voilou ou j'en suis : j'ai remplacé la ligne Driver "i810" par Driver "intel" dans le fichier /etc/X11/xorg.conf comme indiqué sur le lien que tu m'a donné

ça n'a rien changé,

J'ai installé le paquet xserver-xgl via synaptic mais je ne peux toujours pas afficher les effets visuels, le même message d'erreur apparait :
"Desktop effects could not be enabled"

Au passage, ça rame pas depuis que j'ai installé xgl. ( j'ai bien pensé a reboot )
Elhy
Level 1
Level 1
 
Posts: 14
Joined: Fri May 09, 2008 10:33 am

Re: driver intel pour utiliser compiz

Postby Dupo on Fri May 09, 2008 10:41 am

Que donne la commande : glxinfo | grep "direct rendering"

et la commande : compiz --replace

Vérifier Système / Administration / Gestionnaire de pilotes proprietaires
Last edited by Dupo on Fri May 09, 2008 10:50 am, edited 2 times in total.
Dupo
Level 4
Level 4
 
Posts: 286
Joined: Thu Jan 31, 2008 9:42 pm

Re: driver intel pour utiliser compiz

Postby Elhy on Fri May 09, 2008 10:47 am

La commande : glxinfo | grep "direct rendering"

donne toujours :
Code: Select all
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":


et compiz --replace

Code: Select all
Checking for Xgl: not present.
No whitelisted driver found
aborting and using fallback: /usr/bin/metacity


je comprend pas trop car d'après ça Xgl n'est pas present alors que je viens de l'installé, quand je vais dans synaptic il est coché comme installé pourtant
Ou alors j'ai mal fait quelque chose?
(toujours rien dans le gestionnaire de pilotes proprio)

Merci de ton coup de main car je galère pas mal là
Elhy
Level 1
Level 1
 
Posts: 14
Joined: Fri May 09, 2008 10:33 am

Re: driver intel pour utiliser compiz

Postby Dupo on Fri May 09, 2008 10:50 am

essaye ceci :

Dans un terminal tu fais: sudo gedit /etc/xdg/compiz/compiz-manager

Dans ton fichier /etc/xdg/compiz/compiz-manager, tu dois avoir ça :

COMPIZ_BIN_PATH="/usr/bin/"
PLUGIN_PATH="/usr/lib/compiz/"
COMPIZ_NAME="compiz.real"
SKIP_CHECKS=yes

Sauvegarde, puis redémarre le serveur X (sortir de ta session par ex.).
Dupo
Level 4
Level 4
 
Posts: 286
Joined: Thu Jan 31, 2008 9:42 pm

Re: driver intel pour utiliser compiz

Postby Elhy on Fri May 09, 2008 10:54 am

Voila c'est fait, mais toujours pas de changement :?
Elhy
Level 1
Level 1
 
Posts: 14
Joined: Fri May 09, 2008 10:33 am

Re: driver intel pour utiliser compiz

Postby Dupo on Fri May 09, 2008 11:02 am

Je vais devoir partir, mais je te donne l'adresse suivante :

http://doc.ubuntu-fr.org/compiz_fusion# ... _de_compiz

Si tu as encore des problèmes, je chercherai de mon côté pour trouver une solution. :wink:

A+.
Dupo
Level 4
Level 4
 
Posts: 286
Joined: Thu Jan 31, 2008 9:42 pm

Re: driver intel pour utiliser compiz

Postby Elhy on Fri May 09, 2008 11:03 am

Pas de problème je vais bientot y aller aussi, je vais voir sur ton lien puis je te tiens au courant ;)

Merci encore et bonne fin de journée
Elhy
Level 1
Level 1
 
Posts: 14
Joined: Fri May 09, 2008 10:33 am

Re: driver intel pour utiliser compiz

Postby Dupo on Fri May 09, 2008 6:34 pm

Elhy, vérifie dans ton fichier xorg.conf si dans la Section "module", tu as les deux lignes suivantes :

Load "glx" # 3D layer
Load "dri" # direct rendering

Sinon, rajoutes les.

Puis revérifie la commande : glxinfo | grep "direct rendering" pour savoir si les messages d'erreurs ont disparus.

A+.
Dupo
Level 4
Level 4
 
Posts: 286
Joined: Thu Jan 31, 2008 9:42 pm

Re: driver intel pour utiliser compiz

Postby Elhy on Sat May 10, 2008 5:53 am

Re, alors j'ai rajouté #3D layer et # direct rendering car j'avais déjà les deux lignes,

mais la commande glxinfo | grep "direct rendering" me renvoi toujours la même chose :

Code: Select all
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0


Ca veut vraiment pas marcher avec moi ^^

PS : j'ai egalement fait cette manip :

Repérer la ligne :

WHITELIST="nvidia intel etc ..."

et rajouter fglrx avant nvidia en laissant un espace entre les deux, puis redémarrer.

WHITELIST="fglrx nvidia intel etc ..."

Qui était expliquée dans ton lien d'hier pour mon message d'erreur ( cas 2 ) mais ça n'a pas marché non plus
Elhy
Level 1
Level 1
 
Posts: 14
Joined: Fri May 09, 2008 10:33 am

Re: driver intel pour utiliser compiz

Postby Dupo on Sat May 10, 2008 8:19 pm

Salut Elhy,

le problème c'est que tant que tu n'as pas activé l'accélération 3D, et bien compiz ne fonctionnera pas.
Il faut que la commande : glxinfo | grep "direct rendering" renvoie "direct rendering : yes", ce qui n'est pas encore le cas.

Je tente de trouver une solution concernant ton problème, mais c'est pas évident. :(

Bon, nous allons tenter plusieurs choses :

Phase 1 : Retirer ta carte de la blacklist de compiz (attention si ça fonctionne, tu pourrais rencontrer des problèmes avec certains effets et certains logiciels). Voici les étapes à faire :

gksudo gedit /usr/bin/compiz

Il faut remplacer la ligne :

T="$T 8086:2982 8086:2992 8086:29a2 8086:2a02 8086:2a12" # intel 965

par

#T="$T 8086:2982 8086:2992 8086:29a2 8086:2a02 8086:2a12" # intel 965

Donc tu commentes la ligne se rapportant à intel 965 (mettre un # devant la ligne).

Si pas OK, nous passons à la phase 2.

Phase 2 : : Vérifier si les paquets suivants ont été installés :

- fglrx
- linux-restricted-modules

relancer session puis taper commande glxinfo .... , ainsi que la commande fglrxinfo pour savoir si cela renvoie des messages.

Si pas OK, enlève ces 2 fichiers dans synaptic et passe à la phase 3.

Phase 3 : Il se peut qu'il manque simplement un lien avec la librairie GL. Donc tout d'abord, tu vas recréer le lien par la commande suivante :

sudo ln -s /usr/lib/libGL.so.1.2 /usr/lib/libGL.so.1

exit (2x) pour sortir du terminal.

Ensuite, tu redémarres l'interface graphique à l'aide du raccourci ctrl+alt+backspace (le backspace, c'est la touche <- ).
Relancer la commande glxinfo....

Si pas OK, nous aviserons à ce moment là.

Voilà.

A+.
Dupo
Level 4
Level 4
 
Posts: 286
Joined: Thu Jan 31, 2008 9:42 pm

Re: driver intel pour utiliser compiz

Postby Elhy on Mon May 12, 2008 5:02 am

Voila j'ai essayé tout ça, rien a marché malheureusement. Au reboot de mon ordi la résolution était passé à 640x480 et là j'ai pus activé les effets visuels. Bon une fois repassé en résolution normale ça ne marchait plus et pas moyen de les réactiver.

Au passage l'accélération 3D n'est toujours pas reconnue et les commandes répondent comme avant.

(j'ai un amis qui m'a dit que j'avais pas de tty de F1 à F6, mais je pense pas quil y est de rapport)

Merci encore
Elhy
Level 1
Level 1
 
Posts: 14
Joined: Fri May 09, 2008 10:33 am

Re: driver intel pour utiliser compiz

Postby Dupo on Mon May 12, 2008 6:28 am

Elhy wrote:Au reboot de mon ordi la résolution était passé à 640x480 et là j'ai pus activé les effets visuels. Bon une fois repassé en résolution normale ça ne marchait plus et pas moyen de les réactiver.


Si tu as pu activer les effets visuels sous 640x480, c'est que l'accélération 3D était activée sous cette résolution.

Pourrais tu mettre une copie de ton xorg.conf ici ?

P.S : Je pense pour un problème avec les pilotes graphiques, mais c'est une supposition.

Merci.
Dupo
Level 4
Level 4
 
Posts: 286
Joined: Thu Jan 31, 2008 9:42 pm

Re: driver intel pour utiliser compiz

Postby Elhy on Mon May 12, 2008 9:49 am

Voici la copie de mon xorg.conf :
Code: Select all
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
#   sudo dpkg-reconfigure -phigh xserver-xorg
Section "Files"
EndSection

Section "Module"
   Load      "glx"
   Load      "GLcore"
   Load      "v4l"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "fr"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"   "/dev/input/mice"
   Option      "Protocol"   "ImPS/2"
   Option      "ZAxisMapping"   "4 5"
   Option      "Emulate3Buttons"   "true"
EndSection


Section "InputDevice"
   Identifier   "Synaptics Touchpad"
   Driver      "synaptics"
   Option      "SendCoreEvents"   "true"
   Option      "Device"   "/dev/psaux"
   Option      "Protocol"   "auto-dev"
   Option      "HorizScrollDelta"   "0"
EndSection

Section "Device"
   Identifier   "Failsafe Device"
   Boardname   "vesa"
   Busid      "PCI:0:2:0"
   Driver      "vesa"
   Screen   0
EndSection

Section "Monitor"
   Identifier   "Failsafe Monitor"
   Vendorname   "Plug 'n' Play"
   Modelname   "Plug 'n' Play"
  modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
   Gamma   1.0
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "Failsafe Device"
   Monitor      "Failsafe Monitor"
   Defaultdepth   24
   SubSection "Display"
      Depth   24
      Virtual   640   480
      Modes      "640x480@60"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
  screen 0 "Default Screen" 0 0
   Inputdevice   "Generic Keyboard"
   Inputdevice   "Configured Mouse"
   Inputdevice   "Synaptics Touchpad"
EndSection
Section "device" #
   Identifier   "device1"
   Boardname   "vesa"
   Busid      "PCI:0:2:0"
   Driver      "vesa"
   Screen   1
EndSection
Section "screen" #
   Identifier   "screen1"
   Device      "device1"
   Defaultdepth   24
   Monitor      "monitor1"
EndSection
Section "monitor" #
   Identifier   "monitor1"
   Gamma   1.0
EndSection
Section "device" #
   Identifier   "device2"
   Boardname   "VESA driver (generic)"
   Busid      "PCI:0:2:1"
   Driver      "vesa"
   Screen   0
EndSection
Section "screen" #
   Identifier   "screen2"
   Device      "device2"
   Defaultdepth   24
   Monitor      "monitor2"
EndSection
Section "monitor" #
   Identifier   "monitor2"
   Gamma   1.0
EndSection
Section "ServerFlags"
EndSection


Je pense que ça doit être un problème de pilotes aussi mais je comprend vraiment pas pourquoi ça ne veux pas marcher.

Encore un grand merci pour ton aide et dsl de te prendre autant de temps pour m'aider à trouver une solution.
Elhy
Level 1
Level 1
 
Posts: 14
Joined: Fri May 09, 2008 10:33 am

Re: driver intel pour utiliser compiz

Postby Dupo on Mon May 12, 2008 5:57 pm

C'est le xorg.conf en mode normal qu'il me faut (avec pilote intel activé). Le xorg.conf que tu me présentes est celui du mode failsafe.

N'oublie pas une chose, si ta carte est blacklistée (tu as dû t'en rendre compte en éditant le fichier compiz), compiz peut ne pas fonctionner correctement. Et cette affirmation a été confirmée sur plusieurs forums (car elle n'est pas supportée à 100% par ce logiciel).
Dupo
Level 4
Level 4
 
Posts: 286
Joined: Thu Jan 31, 2008 9:42 pm

Linux Mint is funded by ads and donations.
 
Next

Return to Français (French)

Who is online

Users browsing this forum: No registered users and 6 guests