En vue d'un passage en 6.0

French Forum

En vue d'un passage en 6.0

Postby hugo29er on Mon Sep 08, 2008 3:13 pm

Bonjour,
J'envisage d'installer Mint sur mon ordinateur portable en dual-boot avec vista suite à un crash avec ubuntu.
Seulement si je souhaite par la suite passer en 6.0, faut t'il que je crée une partition spéciale pour /home, ou bien / et swap suffisent ?

Sinon j'aimerai savoir si mint est traduit en français sur la distribution classique.

Merci

Hugo.
hugo29er
Level 1
Level 1
 
Posts: 3
Joined: Mon Sep 08, 2008 3:07 pm

Linux Mint is funded by ads and donations.
 

Re: En vue d'un passage en 6.0

Postby saouleur on Tue Sep 09, 2008 11:23 am

Bonjour !

Personnellement, je ne sais pas (encore) comment marchent les mises à jours de mint, si elles sont simplifiées ou pas, mais par expérience il vaut nettement mieux créer à l'installation une partition réservée à /home, et ce pour toutes les ditributions. Ca coute rien, et en plus en cas de crash/mise à jour foireuse/indisponible, on perd rien, on s'embete pas à transférer des Go de fichiers, etc ... Donc quoi qu'il en soit je te conseille de créer une partition /home indépendante.

Pour ce qui est de la version française, moi j'utilise mint 5 Elyssa en français, mais je crois que j'ai eu à installer un package (pas sûr). Quoi qu'il en soit elle existe bel et bien.
saouleur
 

Re: En vue d'un passage en 6.0

Postby Logos2.0 on Sat Sep 20, 2008 8:53 pm

Stop le psychotage mes amis!

Vous voulez passer version 6 lorsqu'elle sera dispo? Qu'à celà ne tienne :

sudo gedit /etc/apt/sources.list

#Modifiez vos dépôts pour ceux de la version 6.

sudo apt-get update

sudo apt-get upgrade

sudo apt-get update

#Et on redémarre!


Ma procédure peut faire parano mais pour être franc je me suis déjà planté en fesant l'upgrade d'une Mandriva (ce qui est beaucoup plus dur), et aucune de mes données n'a jamais été effacée, alors avec la commande upgrade, aucun risque (ou alors vous avez THE malchnace).
:D


Edit : dual boot avec Vista, voilà qui risque de poser problème par contre. Vista est comme qui dirait, xénophobe... Pas étnnant qu'Ubuntu est craché, tu n'es pas le premier hélas...
Logos2.0
Level 1
Level 1
 
Posts: 11
Joined: Sun Aug 24, 2008 11:03 am

Re: En vue d'un passage en 6.0

Postby linuxviolin on Sun Sep 21, 2008 11:51 am

Logos2.0 wrote:Stop le psychotage mes amis!

Vous voulez passer version 6 lorsqu'elle sera dispo? Qu'à celà ne tienne :

sudo gedit /etc/apt/sources.list

#Modifiez vos dépôts pour ceux de la version 6.

sudo apt-get update

sudo apt-get upgrade

sudo apt-get update

#Et on redémarre!


Je suis désolé mais cette procédure est la chose à éviter et ne pas faire! Que ce soit pour Ubuntu ou Mint. Et d'ailleurs elle n'est pas exacte, pour essayer d'upgrader à une version supérieure lisez toujours les Release Notes (voir par exemple ci-dessous pour le passage à Elyssa)

http://www.linuxmint.com/forum/viewtopic.php?f=18&t=9146 ou http://www.linuxmint.com/rel_elyssa.php#upgradeInstructions

Warning

We strongly recommend fresh installs (downloading the CD and installing from it), for the following reasons:

* Upgrading your system to Elyssa won't make your system the same as Elyssa. Your system is your system. Artwork, configuration changes and a lot of other things will not be changed on your system.
* Upgrading your system will trigger conflicts on files maintained by both Mint and Ubuntu. You will be asked questions on whether to overwrite these files. Also, some settings will be reverted to their Ubuntu default (so you might see some orange here and there :)). It takes time to reapply these settings and it isn't the scope of these notes.
* Downloading the CD is faster than upgrading the entire system. The reason for this is that the bare system (not including all the packages you might have installed) is 2.5GB. On the CD it's compressed to a size of 700MB.
* Releases are well tested. Upgrade paths aren't. By upgrading and reporting errors you will act as the Guinea pig. By installing from the CD you will benefit from the hard work of all the community members who helped us test and debug prior to the final release.
* You might just break something you're not able to fix. Unless you're experienced with APT and until an upgrade tool is developed (planned for Mint 6), you should perform only fresh installs.

Note: If you're using a proprietary nVidia or ATI driver you may experience problems while upgrading xorg and the linux kernel. Unless you know what you're doing we strongly recommend you do a fresh install.



Créez toujours une partition /home et faîtes une installation "fraîche"... :!:

Voici pour information la bonne procédure pour passer (upgrader) à Elyssa (Mint 5)

Upgrade path
Change your APT sources

Edit the sources.list as root (sudo gedit /etc/apt/sources.list) to make it look like this:

## -----------------------
## LINUX MINT REPOSITORIES
## -----------------------

## +++ Linux Mint 5 Elyssa (stable) +++
deb http://packages.linuxmint.com elyssa main upstream import

## +++ Backports (not as stable) +++
## deb http://packages.linuxmint.com elyssa backport

## +++ Community (not as stable) +++
## deb http://packages.linuxmint.com elyssa community

## +++ Romeo (unstable) +++
## deb http://packages.linuxmint.com elyssa romeo

## +++ Source Repositories +++
## deb-src http://packages.linuxmint.com elyssa main upstream import
## deb-src http://packages.linuxmint.com elyssa community
## deb-src http://packages.linuxmint.com elyssa backport
## deb-src http://packages.linuxmint.com elyssa romeo

## -------------------
## UBUNTU REPOSITORIES
## -------------------

## +++ Ubuntu 8.04 Hardy (stable) +++
deb http://archive.ubuntu.com/ubuntu hardy main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu hardy-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu hardy-security main restricted universe multiverse

## +++ Backports & Proposed (not as stable) +++
## deb http://archive.ubuntu.com/ubuntu hardy-backports main restricted universe multiverse
## deb http://archive.ubuntu.com/ubuntu hardy-proposed main restricted universe multiverse

## +++ Source Repositories +++
## deb-src http://archive.ubuntu.com/ubuntu hardy main restricted universe multiverse
## deb-src http://archive.ubuntu.com/ubuntu hardy-updates main restricted universe multiverse
## deb-src http://security.ubuntu.com/ubuntu hardy-security main restricted universe multiverse
## deb-src http://archive.ubuntu.com/ubuntu hardy-backports main restricted universe multiverse
## deb-src http://archive.ubuntu.com/ubuntu hardy-proposed main restricted universe multiverse

## ------------------
## OTHER REPOSITORIES
## ------------------

## +++ Canonical (stable) +++
deb http://archive.canonical.com/ubuntu hardy partner

## +++ Medibuntu (stable) +++
deb http://packages.medibuntu.org/ hardy free non-free
Upgrade your packages

Open a terminal and type the following commands:

* apt update
* apt upgrade
* apt dist-upgrade

Repeat the three commands above until the output says for both upgrade and dist-upgrade that there is nothing to upgrade to.
Install additional software

Open a terminal and type the following command:

* apt install nautilus-wallpaper gstreamer0.10-plugins-ugly-multiverse gstreamer0.10-plugins-bad-multiverse gnome-do nspluginwrapper gtk2-engines-aurora gtk2-engines-pixbuf gtk2-engines-candido mintbackup gnome-do-plugin-rhythmbox gnome-do-plugins padevchooser gtkhtml3.14 libgtkhtml3.14-19 libgtkhtml3.16-cil libgtk-vnc-1.0-0 transmission-common transmission-gtk gstreamer0.10-pitfdll jockey-gtk jockey-common libwpg-0.1-1 libwps-0.1-1 openoffice.org-base openoffice.org-base-core openoffice.org-calc openoffice.org-draw openoffice.org-impress openoffice.org-java-common openoffice.org-writer python-uno openoffice.org-gnome openoffice.org-hyphenation openoffice.org-l10n-common openoffice.org-thesaurus-en-us nautilus-share nautilus-sendto pidgin-otr obex-data-server bluez-gnome gimp-gnomevfs gvfs-fuse hal-cups-utils ghostscript-x dcraw libnss-mdns samba libpam-smbpass seahorse language-support-en gnome-spell bogofilter evolution-data-server openprinting-ppds pxljr splix mousetweaks libpt-1.10.10 libpt-1.10.10-plugins-alsa libpt-1.10.10-plugins-v4l libpt-1.10.10-plugins-v4l2

Run the following commands:

* apt-get remove --purge flashplugin-nonfree libflashsupport
* apt-get install nspluginwrapper
* apt-get install libflashsupport
* apt-get install flashplugin-nonfree

(Extrait des Release notes de Elyssa: http://www.linuxmint.com/rel_elyssa.php ... structions )

Maintenant si vous êtes un utilisateur avancé et savez vous débrouiller si quelque chose ne va pas, vous pouvez essayez d'upgrader vers la nouvelle version, certains ont réussi, mais si vous êtes 'moins avancé' préférez toujours une nouvelle install. :) (avec Mint 6 il est planifié de développer un "upgrade tool" qui permettra enfin de passer à la nouvelle version sans faire une nouvelle install :D Affaire à suivre mais pour l'instant ===> nouvelle install :!: )
K.I.S.S. ===> "Keep It Simple, Stupid"
"Simplicity is the ultimate sophistication." (Leonardo da Vinci)
"Everything should be made as simple as possible, but no simpler." (Albert Einstein)
User avatar
linuxviolin
Level 8
Level 8
 
Posts: 2055
Joined: Tue Feb 27, 2007 6:55 pm
Location: France

Re: En vue d'un passage en 6.0

Postby hugo29er on Mon Sep 29, 2008 12:53 pm

Ok ben merci des infos.

J'ai installé mint il y a quelques semaines déjà, j'aime bien, même beaucoup.

Seulement j'ai toujours le même problème qu'avec unbuntu:

Au démarrage grub reste planté à stage 1.5, je n'ai pas de message d'erreur, je reboot manuellement et il se lance...
Donc je n'ai toujours pas trouvé la solution, c'est quand même embêtant de démarrer en deux temps donc si quelqu'un à la solution ce serait sympa de m'aider.

Hugo.
hugo29er
Level 1
Level 1
 
Posts: 3
Joined: Mon Sep 08, 2008 3:07 pm

Re: En vue d'un passage en 6.0

Postby linuxviolin on Tue Sep 30, 2008 8:58 am

Essayer de réparer Grub en suivant la procédure de cette page
K.I.S.S. ===> "Keep It Simple, Stupid"
"Simplicity is the ultimate sophistication." (Leonardo da Vinci)
"Everything should be made as simple as possible, but no simpler." (Albert Einstein)
User avatar
linuxviolin
Level 8
Level 8
 
Posts: 2055
Joined: Tue Feb 27, 2007 6:55 pm
Location: France

Re: En vue d'un passage en 6.0

Postby hugo29er on Thu Oct 02, 2008 1:04 pm

Ha merci pour l'info.

Je vais suivre la procédure mais je ne pense pas que ce soit un bug du fichier, car sous ubuntu ca me faisait la même chose.
En fait j'ai un Zepto comme portable, on ma dit au sav qu'il n'est pas tatoué, mais c'est peut être le cas finalement... Donc je me demande si c'est pour cela que j'ai ce problème, faut-il que j'installe grub sur le mbr ou pbr ?

Hugo.
hugo29er
Level 1
Level 1
 
Posts: 3
Joined: Mon Sep 08, 2008 3:07 pm

Re: En vue d'un passage en 6.0

Postby Goonize on Sat Oct 04, 2008 9:01 am

C'est plus ou moins ce que l'autre avait dit sauf qu'il avait oublié sudo apt-get dist-upgrade et les commandes qui suivent. :lol: :lol: :lol:
Goonize
 

Linux Mint is funded by ads and donations.
 

Return to Français (French)

Who is online

Users browsing this forum: No registered users and 3 guests