Pas de son

French Forum

Pas de son

Postby jeantout on Mon Nov 01, 2010 9:29 am

Bonjour,
Nouveau venu parmi vous, je viens d'installer la version 10 de Linux Mint après être passé passé par mandriva et dernièrement par Ubuntu la 10.10.
C'est vrai que c'est tout de mème un peu plus agréable.
Mais, il y a toujours un mai, si le son fonctionne sur Ubuntu, il ne fonctionne pas sur la Mint, même après avoir décoché tout ce qui est sourdine ou muet.

Ma Config;
CM Asus M3N78, avec carte son intégrée , chipset, Nvidia 8300, avec drivers Realteck.
Y aurait-il une petite différence entre les deux versions, Ubuntu et la Mint?
Par contre lorsque je vais sur la partie Matériel, et l'option son, il est bien reconnu, la BT878, La Quickam pro 4000,
mais pour la carte son de la Carte mère, il y simplement d'affiché: Audio interne 1 sortie. sans autre détails.

Merci de vos avis si c'est possible.

A+ G R
jeantout
Level 1
Level 1
 
Posts: 11
Joined: Mon Nov 01, 2010 9:12 am

Linux Mint is funded by ads and donations.
 

Re: Pas de son

Postby dmonix66 on Mon Nov 08, 2010 9:50 pm

salut jeantout ,j'ai eu le meme probleme avec d'autres distris linux,OUVRE UN TERMINAL et tape "alsamixer" en esperant qu'il soit installe,si c'est le cas
tu devrais voir plus ou moins ca

pour te deplacer utilise les fleches G ou D / H et B pour le volume

M pour allume ou eteindre le canal

n'oublie pas f6 pour choisir ta carte son , il se peut que le systeme a choisi la 0,alors que ta carte est en 1 ou 2
je te souhaite bonne chance
Attachments
'écran2.png
'écran2.png (34.51 KiB) Viewed 3957 times
dmonix66
Level 1
Level 1
 
Posts: 4
Joined: Mon Nov 08, 2010 9:00 pm

Re: Pas de son

Postby benjabox on Wed Nov 10, 2010 9:15 am

Bonjour,

Ce que je viens de lire m'a déjà aidé, merci! Mais mon pb n'est pas réglé...

J'ai 2 cartes son : une interne dans la tour sous la table et une USB posée devant moi (Soundblaster).
Je voudrais que Mint envoie le signal vers la carte externe USB. Il semble en reconnaître l'existence autant dans les Préférences son que dans alsamixer, mais je ne vois pas comment la désigner comme carte principale.

screenshot4.png
Carte Sounblaster USB reconnue dans Préférences son.
screenshot4.png (31.32 KiB) Viewed 3944 times


screenshot6.png
Carte Sounblaster USB reconnue par alsamixer.
screenshot6.png (45.87 KiB) Viewed 3944 times


Mais au moment de choisir :

screenshot5.png
Impossible de choisir le périphérique Soundblaster USB pour la sortie son!
screenshot5.png (11.16 KiB) Viewed 3944 times


Je suis assez démuni! Merci de vos conseils!
benjabox
Level 1
Level 1
 
Posts: 3
Joined: Wed Nov 10, 2010 8:45 am

Re: Pas de son

Postby dmonix66 on Thu Nov 11, 2010 4:12 pm

Salut benja,
As tu essaye sur materiel,pour voir si tu as le choix des 2 cartes
sinon dans alsamixer' une fois ton choix fait as tu au moins le son???
si oui ton probleme est regle tant que tu ne reeboote pas
car a chaque reeboot la config se remet d'origine
pour eviter cela soit 1: ta carte son est une PCI alors tu l'enleves et tu recommence tes reglages plus haut
soit 2; c'est soude sur ta carte mere et la tu devras edite certains fichiers en ligne de commandes pour q'ua chaque boot ta carte usb soit choisi
en premier
je suis desole de ne pas te fournir ces codes ,je crois les avoir vu sur ubuntu.fr je crois
dmonix66
Level 1
Level 1
 
Posts: 4
Joined: Mon Nov 08, 2010 9:00 pm

Re: Pas de son

Postby benjabox on Fri Nov 12, 2010 6:09 am

Salut!

Ce que je voulais montrer avec mes captures d'écran c'est que :
...dans l'onglet Matériel justement il affiche la carte USB, ce qui me donnait de l'espoir ;
...dans AlsaMixer aussi, il affichait la carte USB, et ça me donnait encore plus d'espoir ;
...dans l'onglet Sortie, par contre, il n'y a que la carte interne. (Je crois qu'elle est intégrée à la carte mère.)

Donc au final, le son ne sort que par la carte interne. C'est déjà ça, tu me diras, mais ce n'est pas ce que je veux!
dmonix66 wrote: sinon dans alsamixer' une fois ton choix fait as tu au moins le son???
R : non! Il me permet de régler les niveaux de la SoundBlaster USB mais dans un silence religieux.

Quant aux lignes de commande, je suis sûr que c'est une bonne façon de contrôler la machine mais je suis tout à fait ignorant, je suis un enfant de l'interface graphique! :mrgreen: Mais il n'est jamais trop tard pour s'y mettre...

De toute façon j'ai d'autres problèmes avec Linux, donc la migration sans retour n'est pas pour aujourd'hui - je continue à booter en Windows pour scanner (Canon lide80 pas supporté par debian), et pour mes bébés chéris les très propriétaires Photoshop et Adobe Premiere.

La quête continue!
benja
benjabox
Level 1
Level 1
 
Posts: 3
Joined: Wed Nov 10, 2010 8:45 am

Re: Pas de son

Postby dmonix66 on Sat Nov 13, 2010 1:58 am

ok benja par rapport a ta capture j'ai pense que tu etais sous gnome ubuntu et que tu auras beaucoup de mal a t'en sortir
bon finalement tu est sur Debian que j' ai desinstalle il y'a plus de 15 jours mais tu as alsamixer qui est un outils commun a beaucoup de linux
et avec, ta carte ça dois marche
1 est tu branche en analogique minijack 3.5 ou en digitale ou cable coaxial ???
dans alsamixer allume tous les canaux speaker,2,4,center,lfe+pcm si tu est en analogique pour le 7.1.
Retire le 3eme speaker en partant de la gauche si tu est en 5.1
si tu est en digital ce sont seulement les canaux sp/dif que tu dois actives + master
verifie aussi ton ampli que tu as chosi la bonnesource des fois ca arrive qu' on s'enbrouille
essaye la avec windows pour etre sur qu'elle fonctionne ce que tu as deja du faire
verifie qu'il existe un pilote linux chez soundblaster oui dans ce cas t"es tire d'affaire .NON ça sera tres dur
il y a des marques qui ne font aucuns efforts pour linux
un linux comme un windows peuvent voir ta carte mais pas communique avec s'ils n'ont pas le pilote adequat
sinon Debian c'est pas mal mais c'est pas la plus facile
au fait les canaux s'ouvre avec 'M' et surtout evite ''preference son'' ton salut est alsamixer
courage!!!
dmonix66
Level 1
Level 1
 
Posts: 4
Joined: Mon Nov 08, 2010 9:00 pm

Re: Pas de son

Postby benjabox on Sat Nov 13, 2010 11:13 am

Salut, merci pour les explications. Je vais voir ce que je peux faire.

dmonix66 wrote:bon finalement tu est sur Debian (...)

Bon en fait mea culpa, c'est moi qui brouille les pistes sans le vouloir,
mon OS c'est MINT mais j'ai cru comprendre que ce n'est qu'un Ubuntu modifié...
...et j'ai cru comprendre aussi qu'Ubuntu était une évolution de Debian,
voilà pourquoi j'ai voulu faire global. Autant pour moi, à partir de maintenant je dirai "Mint".

dmonix66 wrote:il y a des marques qui ne font aucuns efforts pour linux)

Tu parles, et en plus mon matériel est "vieux"! (et me donne entière satisfaction)

Je donnerai des nouvelles quand j'en aurai, histoire que notre conversation puisse servir à quelqu'un d'autre qui aurait le même problème.

---
PS :
he wrote:est tu branche en analogique minijack 3.5 ou en digitale ou cable coaxial ?

C'est plus simple que ça. J'utilise ma vieille carte son externe (achetée jadis pour un laptop) juste pour avoir les connecteurs à portée de main et pouvoir mettre ma tour sous la table. Je peux alors brancher/débrancher le casque et/ou le micro, et il y a une sortie analogique permanente (cinch vers des hauts-parleurs). La carte son, elle, est piquée en USB sur la tour.

_MG_3271.jpg
"Si tu vois c'que j'veux dire".
_MG_3271.jpg (62.55 KiB) Viewed 3890 times
benjabox
Level 1
Level 1
 
Posts: 3
Joined: Wed Nov 10, 2010 8:45 am

Re: Pas de son

Postby dmonix66 on Sat Nov 13, 2010 6:22 pm

salut benjab ca va grandement simplifie le probleme si t'es sur mint (debian=oubuntu=mint tout a fait vrai )
ok tu dois me precise si tu est sur gnome ou kde
ensuite ouvre une console "lspci' tu fait une capture du resultat ensuite lsusb idem tu post et apres on y verra plus
clair
ps; si tu connais la ref exacte de ton usb tu peux verifier aupres de sound blaster mais si ton truc a plus de dix ans
ils ont mis ca au archives ou meme a la poubelle
dmonix66
Level 1
Level 1
 
Posts: 4
Joined: Mon Nov 08, 2010 9:00 pm

( REGLE) Re: Pas de son

Postby jeantout on Sun Nov 14, 2010 3:42 pm

Bonsoir,
J'ai un peu tardé mais je n'étais pas at Home, mais le pb est réglé.
après avoir été dans Alsa ça ne marchait pas , mais il y avait une autre coche que je n'avais pas vu dans la config de l'option son

Merci à tous de votre aide.
jeantout
Level 1
Level 1
 
Posts: 11
Joined: Mon Nov 01, 2010 9:12 am

Linux Mint is funded by ads and donations.
 

Return to Français (French)

Who is online

Users browsing this forum: No registered users and 3 guests