Problème avec Grub ( Installé dans une clé USB )

French Forum

Problème avec Grub ( Installé dans une clé USB )

Postby mokhtar_one on Mon Aug 29, 2011 11:43 pm

Bonjours !
jai un problème avec ma clé USB :(
je voulais installer Xfce 10 sur ma clé USB , mais jai eu un problème avec Grub
J'ai installé Grub dans Sbd1 , et ça marche nickel sur un pc qui ne contient pas Grub , sauf que dans mon autre pc qui contient Linux mint 11 avec Grub ) refuse de détecter le Boot de ma Clé ( Xfce ) .
Merci :D
Cordialement
mokhtar_one
Level 1
Level 1
 
Posts: 27
Joined: Fri May 13, 2011 7:31 am

Linux Mint is funded by ads and donations.
 

Re: Problème avec Grub ( Installé dans une clé USB )

Postby eudyptes on Thu Sep 01, 2011 3:53 am

salut mokhtar_one

pour le grub, c'est pas ma tasse de thé : la manipulation du fstab et menu.lst je crois

mais si tu veux démarrer sur ta clé tu peux par exemple : changer l'ordre de démarrage dans ton bios en indiquant d'essayer l'usb en premier puis le cd puis le disque dur

++
Connaissez vous la communauté fr de mint?
http://www.linuxmint-fr.org/
Pour nous rejoindre sur le chat jabber :
jabber
User avatar
eudyptes
Level 2
Level 2
 
Posts: 64
Joined: Fri Aug 20, 2010 4:50 pm
Location: bordeaux

Re: Problème avec Grub ( Installé dans une clé USB )

Postby mokhtar_one on Thu Sep 01, 2011 10:38 am

merci eudyptes !
le choix de boot n'est pas un probleme , puisque jai deja essayer le truc :)
moi je veux juste que le Grub s'install dans ma clé Usb avec une configuration qui me permet d'excuter mon system Xfce sur n'importe quelle ordinateur voila ! 8)
mokhtar_one
Level 1
Level 1
 
Posts: 27
Joined: Fri May 13, 2011 7:31 am

Re: Problème avec Grub ( Installé dans une clé USB )

Postby eudyptes on Fri Sep 02, 2011 3:26 am

salut

Pour moi ce que tu demandes est impossible .. pourquoi? parce que lors de l'installation de ta clées usb avec le grub associé ; cette installation est liée à l'environnement où tu l'installes concrètement sur ce pc et pas un autre . Donc si tu installes un OS sur ta clées usb avec le grub associé : ceci ne sera valable que sur le pc où tu aura fait l'install.

bref pour y voir plus clair dans le fonctionnement du grub:
http://www.linuxmint-fr.org/forum/post- ... html#34483
(en espérant que cela ne vas pas t'embrouiller plus qu'autre chose)

bonne lecture

++
Connaissez vous la communauté fr de mint?
http://www.linuxmint-fr.org/
Pour nous rejoindre sur le chat jabber :
jabber
User avatar
eudyptes
Level 2
Level 2
 
Posts: 64
Joined: Fri Aug 20, 2010 4:50 pm
Location: bordeaux

Re: Problème avec Grub ( Installé dans une clé USB )

Postby mokhtar_one on Fri Sep 02, 2011 4:59 am

Je ne sais pas si c'est une coïncidence ou une découverte :lol: , mais il ya des mois que jais installé LXDE 10 sur ma clé USB et ça marché sur plusieurs ordi ( même ceux qui ne contienne pas Grub ) :roll:
mokhtar_one
Level 1
Level 1
 
Posts: 27
Joined: Fri May 13, 2011 7:31 am

Re: Problème avec Grub ( Installé dans une clé USB )

Postby eudyptes on Sun Sep 04, 2011 2:57 pm

salut

euh oui, j'ai pas compris tout de suite ton utilisation.

En fait ce que tu utilises c'est pas le grub pour le multiboot (l'intérêt du grub quand il y a plusieurs os sur une mm bécane) mais un disque (ici branché en usb) amovible pour accéder sur n'importe quel pc à ton "os portable". L'option qui permet ça se trouve dans le bios uniquement pour booter sur un support externe ... il est en mode persitant? tu utilises multisystem? ou unetbootin ou un autre pour l'install sur ta clées usb.

Pour revenir au pb initial (j'ai dérivé désolé) "J'ai installé Grub dans Sbd1 , et ça marche nickel sur un pc qui ne contient pas Grub , sauf que dans mon autre pc qui contient Linux mint 11 avec Grub ) refuse de détecter le Boot de ma Clé ( Xfce )"
Pour le premier pc où ça fonctionne il y a windows dessus uniquement ou linux? car si il y a linux mint par exemple :grub s'y trouve d'office mais pas visible car qu'un seul os : pas besoin de s'afficher. Pour forcer l'affichage du grub il faut rester appuyer sur la touche maj (flèche qui monte) au démarrage je crois.

Je pense tout simplement que certains bios n'arrivent pas à lire le grub au démarrage (si il s'agit du grub!) .... J'ai rencontré ce pb sur un vieux pc où un cd d'install ne voulait pas se lancer (pas lu) alors que sur un autre pc plus récent aucun problème. Voir peut être avec un autre logiciel d'installation sur ta clées...ou prendre (pour unetbootin par exemple) une version antérieure pour l'installation.

Après si c'est toujours pas ça ... j'ai droit à un joker? :mrgreen:

++
Connaissez vous la communauté fr de mint?
http://www.linuxmint-fr.org/
Pour nous rejoindre sur le chat jabber :
jabber
User avatar
eudyptes
Level 2
Level 2
 
Posts: 64
Joined: Fri Aug 20, 2010 4:50 pm
Location: bordeaux

Re: Problème avec Grub ( Installé dans une clé USB )

Postby mokhtar_one on Sun Sep 04, 2011 6:11 pm

Merci !
Je pense que c'est réglé , parce que j'ais ressayé le truc avec LXDE 11 et ça a marché comme sur le 10 :D , cependant j'aurez souhaité Xfce sur ma clé USB :?
Merci pour ton aide !
Problème Réglé !

Cordialement !
mokhtar_one
Level 1
Level 1
 
Posts: 27
Joined: Fri May 13, 2011 7:31 am

Linux Mint is funded by ads and donations.
 

Return to Français (French)

Who is online

Users browsing this forum: No registered users and 1 guest