Wlan Verbinndung besteht,trotzdem kein Internet

German Forum

Wlan Verbinndung besteht,trotzdem kein Internet

Postby timboo on Sat Aug 24, 2013 12:08 pm

Hi Leute!

ich habe mir ca vor einer Stunde Linux Mint 15 auf meinem Acer Aspire V3-771G installiert und soweit läuft alles gut. Das einzige was nicht funktionieren will ist die Wlan verbindung. Ich kann mit meinem Router eine Verbindung herstellen aber sobald ich im Firefox eine Seite öffnen will ist dies nicht möglich und er sagt nur "firefox kann den server nicht finden". Habe schon einige Forenbeiträge mit ähnlichen Problemen durchsucht aber komme alleine nicht weiter leider.

Ich hoffe jemand hier kann mir helfen :)!

Gruß
Tim
timboo
Level 1
Level 1
 
Posts: 6
Joined: Sat Aug 24, 2013 11:57 am

Linux Mint is funded by ads and donations.
 

Re: Wlan Verbinndung besteht,trotzdem kein Internet

Postby karlchen on Sun Aug 25, 2013 9:39 am

Hallo, Tim.

Was sagen denn die Terminalkommandos
Code: Select all
sudo lshw -C network
ifconfig
iwconfig
netstat -rn
ping -c 4 www.google.com

Wenn der WLAN Adapter eine Verbindung mit deinem Router aufbaut, sollte dieser ihm eine IP Adresse zuweisen und als Default Gateway ins Internet dienen. Die oben aufgelisteten Kommandos dienen dazu, festzustellen, ob das funktioniert.

Grüße
Karl
User avatar
karlchen
Level 10
Level 10
 
Posts: 3408
Joined: Sat Dec 31, 2011 7:21 am

Re: Wlan Verbinndung besteht,trotzdem kein Internet

Postby timboo on Sun Aug 25, 2013 11:45 am

Hallo Karl,

erstmal Danke für die Hilfe!

hier nun das Ergebnis:

tim@tim-Aspire-V3-771 ~ $ sudo lshw -C network
[sudo] password for tim:
*-network
description: Wireless interface
product: AR9462 Wireless Network Adapter
vendor: Atheros Communications Inc.
physical id: 0
bus info: pci@0000:0d:00.0
logical name: wlan0
version: 01
serial: 44:6d:57:53:ac:fb
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list rom ethernet physical wireless
configuration: broadcast=yes driver=ath9k driverversion=3.8.0-29-generic firmware=N/A ip=192.168.1.9 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
resources: irq:17 memory:d3500000-d357ffff memory:9fb00000-9fb0ffff
*-network
description: Ethernet interface
product: AR8151 v2.0 Gigabit Ethernet
vendor: Qualcomm Atheros
physical id: 0
bus info: pci@0000:0e:00.0
logical name: eth0
version: c0
serial: e8:40:f2:ab:ac:1e
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion=1.0.1.1-NAPI latency=0 link=no multicast=yes port=twisted pair
resources: irq:47 memory:d3400000-d343ffff ioport:2000(size=128)
tim@tim-Aspire-V3-771 ~ $ ifconfig
eth0 Link encap:Ethernet HWaddr e8:40:f2:ab:ac:1e
inet6 addr: fe80::ea40:f2ff:feab:ac1e/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:96406 errors:0 dropped:0 overruns:0 frame:0
TX packets:72097 errors:0 dropped:0 overruns:0 carrier:6
collisions:0 txqueuelen:1000
RX bytes:130726402 (130.7 MB) TX bytes:6546172 (6.5 MB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:1296 errors:0 dropped:0 overruns:0 frame:0
TX packets:1296 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:109800 (109.8 KB) TX bytes:109800 (109.8 KB)

wlan0 Link encap:Ethernet HWaddr 44:6d:57:53:ac:fb
inet addr:192.168.1.9 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::466d:57ff:fe53:acfb/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1456 errors:0 dropped:0 overruns:0 frame:0
TX packets:1739 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:195248 (195.2 KB) TX bytes:229504 (229.5 KB)

tim@tim-Aspire-V3-771 ~ $ iwconfig
eth0 no wireless extensions.

lo no wireless extensions.

wlan0 IEEE 802.11abgn ESSID:"o2-WLAN95"
Mode:Managed Frequency:2.412 GHz Access Point: 84:9C:A6:30:60:B7
Bit Rate=65 Mb/s Tx-Power=16 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=70/70 Signal level=-13 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

tim@tim-Aspire-V3-771 ~ $ netstat -rn
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 wlan0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 wlan0
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0
tim@tim-Aspire-V3-771 ~ $ ping -c 4 www.google.com
ping: unknown host www.google.com
tim@tim-Aspire-V3-771 ~ $


Gruß
Tim
timboo
Level 1
Level 1
 
Posts: 6
Joined: Sat Aug 24, 2013 11:57 am

Re: Wlan Verbinndung besteht,trotzdem kein Internet

Postby karlchen on Sun Aug 25, 2013 3:08 pm

Hallo, Tim.

Die WLAN Karte bekommt eine gültige IP zugewiesen. Das Problem scheint ausschließlich zu sein, dass keine Namensauflösung stattfindet. Deswegen scheitert dann der Befehl "ping -c 4 www.google.com".
Muß jetzt erst mal auf ein Mint System wechseln, um die Details des Wie und Wo zu überprüfen.
Aber das DNS Problem sollte sich lösen lassen, z.B. indem man als DNS Server die IP 8.8.8.8 hinzufügt. Das ist der DNS Dienst von Google. Der sollte stets verfügbar sein.

Grüße
Karl
User avatar
karlchen
Level 10
Level 10
 
Posts: 3408
Joined: Sat Dec 31, 2011 7:21 am

Re: Wlan Verbinndung besteht,trotzdem kein Internet

Postby timboo on Sun Aug 25, 2013 3:40 pm

Hallo Karl,

Vielen Dank das du dir die Mühe machst!

Ich habe jetzt mal versucht die IP vom DNS Dienst von google zu meiner bestehenden Wlan Verbindung hinzuzufügen. Denke auch das ich da nichts falsch gemacht habe aber der befehl "ping -c 4 www.google.com" bringt noch immer das gleiche Ergebnis. Ich habe mal ein wening nachgelesen im Forum und bin auf einen User gestoßen wo der Linux Kernel die Wlan Karte (noch) nicht unterstützt hat...er musste dann manuel treiber installieren. Das kann bei mir aber nicht der Fall sein oder?

Gruß
Tim
timboo
Level 1
Level 1
 
Posts: 6
Joined: Sat Aug 24, 2013 11:57 am

Re: Wlan Verbinndung besteht,trotzdem kein Internet

Postby karlchen on Sun Aug 25, 2013 5:19 pm

Hallo, Tim.

Soweit ich das sehen kann z.B. in der von dir gepostete Ausgabe des Befehls
Code: Select all
sudo lshw -C network
(zeige Hardware der Klasse Netzwerk) wird deine Netzwerkkarte erkannt, es wird ein passender Treiber geladen. Und das "link=yes" in derselben Ausgabe zeigt ja auch das, was du weißt: die Verbindung zum Router klappt.
Damit ist die Hardware- und Treiberseite erst einmal aus der Schußlinie, denn sonst käme keine Verbindung zum Router zustande.

Die Wlan Karte erhält auch vom Router eine IP Adresse zugewiesen. Das kann man im "sudo lshw -C network", als auch im "ifconfig" nachvollziehen: 192.168.1.9 zum Zeitpunkt der Ausführung beider Befehle.

Von oben nach unten kann ich in den Ausgaben aller Befehle keinen Fehler feststellen:
Code: Select all
sudo lshw -C network
ifconfig
iwconfig
netstat -rn
Bis hierhin sieht für mich formal alles aus wie auf meinem eigenen Rechner.
Erst beim Befehl
Code: Select all
ping -c 4 www.google.com
tritt ein Fehler auf. Server nicht gefunden. Heißt, es wird der Name http://www.google.com nicht übersetzt in die passende IP Adresse.
Dabei kann es sich nur um einen Einstellungsfehler auf deinem Mint System oder auf dem Router handeln.

So sieht das auf einem Gerät aus, auf dem Namensauflösung (DNS) funktioniert:
Code: Select all
$ ping -c 4 www.google.com
PING www.google.com (173.194.113.144) 56(84) bytes of data.
64 bytes from ham02s11-in-f16.1e100.net (173.194.113.144): icmp_req=1 ttl=58 time=16.5 ms
64 bytes from ham02s11-in-f16.1e100.net (173.194.113.144): icmp_req=2 ttl=58 time=16.6 ms
64 bytes from ham02s11-in-f16.1e100.net (173.194.113.144): icmp_req=3 ttl=58 time=15.0 ms
64 bytes from ham02s11-in-f16.1e100.net (173.194.113.144): icmp_req=4 ttl=58 time=15.9 ms

--- www.google.com ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3004ms
rtt min/avg/max/mdev = 15.092/16.046/16.629/0.621 ms

D.h. ich wette, wenn du von vorneherein die IP Adresse 173.194.113.144 anpingst, wird es auch auf deinem Mint System klappen:
Code: Select all
ping -c 4 173.194.113.144

Da es nicht praktikabel ist, die IP Adressen aller Internetseiten direkt anzugeben, müssen wir herausbekommen, warum DNS nicht funktioniert, und es zum Laufen bekommen. Danach klappt es auch mit dem Firefox.

Was steht in der Datei /var/run/resolvconf/resolv.conf?
In der Minimalausstattung muß folgendes drinstehen:
Code: Select all
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.0.1
search Domänenname_deines_Routers
Der gesamte Ausdruck Domänenname_deines_Routers muß ersetzt werden durch das, was dein Router dafür vorgibt. Da ich eine Fritz!Box nutze, liest man hier also search fritz.box.

Das funktioniert nun so:
Mint betreibt eine lokalen Prozess dnsmasq. Der wartet auf alle DNS-Anfragen, die auf deinem Mint Rechner gestellt werden, z.B. von ping oder auch Firefox. Kennt dnsmasq die Antwort schon von früher, gibt er die IP Adresse sofort als Antwort.
Kennt dnsmasq die Antwort nicht, dann reicht er die Anfrage an deinen Router weiter. Der sollte sie nun wiederum an den DNS Server deines Internet Providers weitergeben. Von dort kommt dann die IP Adresse den Weg rückwärts und wird an den anfragenden Prozess zurückgegeben.
Wenn nun dein Router DNS Anfragen nicht an deine Internet Provider weiterreicht oder dessen DNS Server nicht anworten, dann kommt es zum Fehler "Server nicht gefunden", obwohl man sicher sein kann, dass google.com existiert.


Was sind nun die nächsten Schritte?
Weiß nicht, ob das default-mäßig auf Mint 15 noch so ist, bei Mint 13 war es noch so:
Die Mint Macher hatten die Minimal-resolv.conf bereits um 2 weitere unabhängige DNS Server ergänzt. Diese werden dann befragt, wenn der vorrangig zu befragende DNS Server "streikt".
Was mußt du also nun tun?
Wenn die folgende Zeile nicht bereits am Ende der Datei /var/run/resolvconf/resolv.conf angezeigt wird:
Code: Select all
nameserver 8.8.8.8
dann diese Zeile hinzufügen.
Das geht aber nicht direkt, denn die Datei /var/run/resolvconf/resolv.conf wird bei jedem Neustart dynamisch neu erzeugt.
Darum folgendermaßen vorgehen:
  • Terminalfenster starten.
  • In den folgenden Ordner wechseln:
    Code: Select all
    cd /etc/resolvconf/resolv.conf.d
  • Nun mit root Rechten die Datei tail ergänzen:
    Code: Select all
    gksu gedit tail
    Wahrscheinlich ist die Datei leer. Wenn die Zeile noch nicht drinsteht, als erste Zeile an den Anfang setzen:
    Code: Select all
    nameserver 8.8.8.8
    Datei speichern. Terminalfenster schließen.
  • Es mag nicht wirklich notwendig sein, aber um ganz sicher zu gehen, den Rechner rebooten.
Wenn der Rechner wieder oben ist, Terminalfenster öffnen und nachschauen, ob das Problem schon umschifft ist:
Code: Select all
cat /var/run/resolvconf/resolv.conf
sollte nun 8.8.8.8 als DNS Server ausweisen.
Code: Select all
ping -c www.google.com
sollte nun funktionieren.

Nun warte ich mal gespannt, was das Ergebnis sein wird ...

Grüße,
Karl
User avatar
karlchen
Level 10
Level 10
 
Posts: 3408
Joined: Sat Dec 31, 2011 7:21 am

Re: Wlan Verbinndung besteht,trotzdem kein Internet

Postby timboo on Mon Aug 26, 2013 4:43 am

Hallo Karl,

hier der Inhalt der Datei var/run/resolvconf/resolv.conf

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1
search localdomain

# OpenDNS Fallback (configured by Linux Mint in /etc/resolvconf/resolv.conf.d/tail).
nameserver 208.67.222.222
nameserver 208.67.220.220

ist der Eintrag "search localdomain" korrekt? dort müsste doch dann wie von dir beschrieben mein router auftauchen oder?

Ich habe danach die Datei mit dem Eintrag "nameserver 8.8.8.8" wie von dir beschrieben über die Konsole erweitert...das Ergebnis im Terminal sah danach so aus:

tim@tim-Aspire-V3-771 ~ $ cat /var/run/resolvconf/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1

# OpenDNS Fallback (configured by Linux Mint in /etc/resolvconf/resolv.conf.d/tail).
nameserver 208.67.222.222
nameserver 208.67.220.220
nameserver 8.8.8.8
tim@tim-Aspire-V3-771 ~ $ ping -c www.google.com
ping: bad number of packets to transmit.
tim@tim-Aspire-V3-771 ~ $

Gruß
Tim
timboo
Level 1
Level 1
 
Posts: 6
Joined: Sat Aug 24, 2013 11:57 am

Re: Wlan Verbinndung besteht,trotzdem kein Internet

Postby karlchen on Mon Aug 26, 2013 9:03 am

Hallo, Tim.

Das Kommando lautet
Code: Select all
ping -c 4 www.google.com
Ohne die 4 bekommst du einen Syntaxfehler zurück. Heißt einfach, ping nicht ewig, sondern genau 4-mal. :wink:
Würde auch
Code: Select all
ping -c 4 8.8.8.8
versuchen, um festzustellen, ob deine Signale bis ins Internet rausgehen und die Antworten zurückkommen.

Tja, der neue Nameserver 8.8.8.8 steht jetzt am Ende der Datei resolv.conf. Würde daher nur benutzt, wenn die darüber stehenden Einträge nicht funktionieren.
Die beiden darüber sind OpenDNS. Wußte nicht, dass Mint das immer noch als "Reserve"-DNS direkt mitkonfiguriert.
Ist aber OK so. Wenn schon 2 im Grunde immer verfügbare DNS Server drinne stehen, dann ist der Zweck erfüllt, den ich mit 8.8.8.8 erreichen wollte.

Was den Eintrag "search <domänenname>" anbelangt:
Der Wert sollte im Grunde genommen von der Routerbox mitgegeben werden, wenn sie deinem Rechner die IP Adresse zuweist.
Wie der Wert bei deinem Router gesetzt wird und ob überhaupt, entzieht sich meiner Kenntnis. Ich weiß nur, dass unsere Fritz!Boxen alle "search fritz.box" eintragen. Ein Telekomrouter setzt was vergleichbares rein, nur mit Telekombezug.
Ich denke jedoch, dass der Eintrag für das Auflösen von Internet Adressen irrelavant ist, weil er nur für das eigene Heimnetz Gültigkeit hat.

Das Problem scheint zu sein, dass die Kette dnsmasq <=> Router <=> Internet Provider <=> O2 DNS Server an irgendeiner Stelle unterbrochen ist, so dass DNS Anfragen niemals zu einem DNS Server durchgereicht und entsprechend die Antworten nie zurückgegeben werden.

Was Schlaueres könnte ich jetzt erst wieder raten, wenn ich wieder unter Mint arbeite. Momentan unter Windows 7.

Grüße
Karl
User avatar
karlchen
Level 10
Level 10
 
Posts: 3408
Joined: Sat Dec 31, 2011 7:21 am

Re: Wlan Verbinndung besteht,trotzdem kein Internet

Postby karlchen on Mon Aug 26, 2013 10:07 am

Hallo, Tim.

Läuft bei dir dnsmasq überhaupt?
Code: Select all
ps axu | grep dnsmasq
Da müßte eine Zeile angezeigt werden, die ungefähr so aussieht:
$ ps axu | grep dnsmasq
nobody 1796 0.0 0.0 6884 1204 ? S 15:21 0:00 /usr/sbin/dnsmasq --no-resolv --keep-in-foreground --no-hosts --bind-interfaces --pid-file=/var/run/sendsigs.omit.d/network-manager.dnsmasq.pid --listen-address=127.0.0.1 --conf-file=/var/run/nm-dns-dnsmasq.conf --cache-size=0 --proxy-dnssec

Was steht in der Datei /var/run/nm-dns-dnsmasq.conf?
Code: Select all
cat /var/run/nm-dns-dnsmasq.conf
Da sollten jetzt die IP-Adressen der DNS Server auftauchen.
Was ist das Ergebnis von
Code: Select all
nslookup www.google.com

Wenn das Ergebnis ist "server can't find http://www.google.com", dann mal bitte ausprobieren
Code: Select all
nslookup www.google.com 8.8.8.8
Was ist nun das Ergebnis, da versucht wird, direkt den Google eigenen DNS Server direkt zu benutzen?

Grüße
Karl
User avatar
karlchen
Level 10
Level 10
 
Posts: 3408
Joined: Sat Dec 31, 2011 7:21 am

Re: Wlan Verbinndung besteht,trotzdem kein Internet

Postby timboo on Mon Aug 26, 2013 2:04 pm

Hi Karl,

ich muss echt sagen finde ich super das du dir so viel Zeit nimmst und alles so gut erklärst!

hier die Ausgabe zu dnsmasq:

tim@tim-Aspire-V3-771 ~ $ ps axu | grep dnsmasq
nobody 1510 0.0 0.0 34564 1532 ? S 10:20 0:00 /usr/sbin/dnsmasq --no-resolv --keep-in-foreground --no-hosts --bind-interfaces --pid-file=/var/run/NetworkManager/dnsmasq.pid --listen-address=127.0.1.1 --conf-file=/var/run/NetworkManager/dnsmasq.conf --cache-size=0 --proxy-dnssec --enable-dbus=org.freedesktop.NetworkManager.dnsmasq --conf-dir=/etc/NetworkManager/dnsmasq.d
tim 5836 0.0 0.0 15104 956 pts/1 S+ 19:46 0:00 grep --colour=auto dnsmasq

die Datei "/var/run/nm-dns-dnsmasq.conf" konnte ich nicht finden, hab nur eine die sich nur "dnsmasq.config" nennt und die ist komplett leer. Die beiden anderen Befehle führten zu folgendem Ergebnis:

tim@tim-Aspire-V3-771 ~ $ nslookup www.google.com
;; connection timed out; no servers could be reached

tim@tim-Aspire-V3-771 ~ $ nslookup www.google.com 8.8.8.8
;; connection timed out; no servers could be reached

Gruß
Tim
timboo
Level 1
Level 1
 
Posts: 6
Joined: Sat Aug 24, 2013 11:57 am

Re: Wlan Verbinndung besteht,trotzdem kein Internet

Postby karlchen on Mon Aug 26, 2013 2:43 pm

Hallo, Tim.

Tja, das ist das Problem mit der Flexibilität: man muß tatsächlich die Prozesszeile des dnsmasq auf den Bildschirm holen, um festzustellen, welche Konfigurationsdatei hinter dem --conf-file= angegeben ist.
Der unterschiedliche Pfad und der unterschiedliche Dateinamen hängen bestimmt damit zusammen, dass ich auf den meisten Systemen an Mint 13 festhalte, weil es eine Edition mit Langzeitsupport ist, dein Mint jedoch schon Mint 15 ist.
Das tut hier jedoch nicht wirklich was zur Sache. In der Konfigurationsdatei sollte auf Privatrechnern, die direkt an den Router angeschlossen sind, stehen: server=IP-Adresse_des_Routers, in deinem Fall: server=192.168.1.1

Jetzt ist immer noch die Frage nach der Ursache offen. Es gibt dabei im Grunde nur 2 Möglichkeiten:
  • der Router macht alles richtig und gibt alle benötigten Werte richtig an dein Mint 15, aber der Network Manager von Mint 15 verarbeitet sie nicht richtig.
    Da würde ich erwarten, dass es mehr Fehlerberichte gibt, in denen das WLAN nicht funktioniert, weil die DNS Auflösung scheitert.
  • oder der Router gibt nicht alle benötigten Werte an dein Mint 15. In dem Fall muß man sich die Konfiguration des Routers anschauen.
    Evtl. kann auch folgendes Detail die Frage nach Konfig-Fehler auf dem Router fast schon klären:
    Wenn es einen anderen (Windows) Rechner gibt, der sich per WLAN mit dem Router verbindet und auf dem man problemslos im Internet surfen kann, dann dürften die Routereinstellungen tendentiell eher in Ordnung sein.
    Es war z.B. hier nicht notwendig, irgendwas am Router zu verstellen, weil sowohl Windows Rechner drüber laufen, als auch Linux Rechner. Die wollen und bekommen alle haargenau dasgleiche vom Router geliefert.

Was ergibt denn der eine von den beiden ping-Befehlen:
Code: Select all
ping -c 4  8.8.8.8
(Den anderen kann man sich wegen der fehlenden Namensauflösung erst mal schenken.) => Möchte wissen, ob Mint 15 über den Router überhaupt rauskommt ins Internet.

Ach ja:
Wie war das denn beim Installieren vom Mint 15 Live System (Boot DVD oder USB Boot Stick)? Das Setup-Programm möchte doch zwischendurch und gegen Ende ebenfalls gerne nach Hause telefonieren und sich Sprachdateien und den ersten Schwung Updates holen. Hat das mit dem Live System geklappt?

Grüße
Karl
User avatar
karlchen
Level 10
Level 10
 
Posts: 3408
Joined: Sat Dec 31, 2011 7:21 am

Re: Wlan Verbinndung besteht,trotzdem kein Internet

Postby timboo on Mon Aug 26, 2013 3:45 pm

Hi Karl,

ja ich war auch am Anfang unsicher ob ich mir Mint 15 oder doch eine ältere Version installieren sollte,ich weiß garnicht mehr warum ich mich für 15 entschieden habe...

das Ergebnis des Befehls sieht so aus:

tim@tim-Aspire-V3-771 ~ $ ping -c 4 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.

--- 8.8.8.8 ping statistics ---
4 packets transmitted, 0 received, 100% packet loss, time 3024ms

wie ich das sehe geht er wohl schon ins Netz rein oder?

als ich Mint über Live CD installiert habe hatte ich eine Verbindung über Kabel hergestellt da ich davon ausging das Wlan nicht funktionieren würde weil ich dies auf einem anderm Notebook schon einmal mit Ubuntu hatte. Die Verbindung über Kabel funktioniert auch weiterhin ohne Probleme. Es ist wirklich nur das Wlan was Probleme macht.

Gruß
Tim
timboo
Level 1
Level 1
 
Posts: 6
Joined: Sat Aug 24, 2013 11:57 am

Re: Wlan Verbinndung besteht,trotzdem kein Internet

Postby karlchen on Mon Aug 26, 2013 6:54 pm

Hallo, Tim.

Tjä, darauf dass das Gerät gar nicht durchgelassen wird ins Internet, hätte man früher kommen sollen ... :oops:
Kabelgebundene Verbindung geht. Namensauflösung kein Problem. Alles paletti. :)
WLAN Verbindung bekommt IP, darf aber gar nicht raus. :cry:

Eine Möglichkeit wäre, dass auf dem Router speziell fürs WLAN etwas deaktiviert worden ist. Das kann man nur am Router selbst prüfen.
Ohne den Router zu kennen und Zugriff auf den Router zu haben - was ich gar nicht soll und will - kann ich da erst einmal wenig zu sagen.

Andere Möglichkeit ist, nur die Einstellungen der speziellen WLAN Verbindung auf dem Mint System sind - vielleicht durch manuelle Eingriffe - so verschlimmbessert worden, dass sie jetzt nicht mehr stimmen?

Da die Verbindung bereits besteht, aber nicht richtig funktioniert, würde ich wie folgt vorgehen:
  • Zuerst die vorhandene Verbindungseinstellungen entfernen und zwar so:
    • Netzwerkicon links von der Datumsanzeige im Systray anklicken.
    • Unterster Punkt ist Netzwerkeinstellungen. Den anklicken.
    • Im Netzwerk-Fenster auf Drahtlos klicken.
    • In der rechten Hälfte des Fensters sollte schon die bestehende WLan Verbindung ausgewählt sein.
    • Button [Netzwerk vergessen] anklicken und bestätigen.
    • Damit sollte die WLAN Verbindung erst einmal weg sein.
  • Nun die WLAN Verbindung zum eigenen Router neu wieder einrichten und zwar so:
    • Netzwerkicon links von der Datumsanzeige im Systray anklicken.
    • In der Liste der erkannten Funknetzwerke das Gewünschte, im vorliegenden Fall also das eigene (o2-WLAN95), anklicken.
    • Nach einer Weile erscheint die Aufforderung den WPA2 Schlüssel des Funknetzwerks einzugeben.
      Also den Schlüssel für den WLAN Zugriff genau so eingeben, wie im Router hinterlegt.
    • Wieder nach einer Weile sollte die Verbindung zu o2-WLAN95 stehen.
    • Das sollte es schon gewesen sein.
Und wenn die Ursache für das berichtete Verbindungsproblem nicht doch im Router zu finden ist, dann sollten jetzt beide Befehle zum Erfolg führen:
Code: Select all
ping -c 4    www.linuxmint.com
ping -c 4 213.175.215.218
Auch die Abfrage
Code: Select all
nslookup www.linuxmint.com
sollte funktionieren und eine IP-Adresse zurückgeben.

Und wenn es jetzt doch alles wieder nicht klappt mit dem WLAN, würde ich entweder sofort die WLAN Einstellungen des Routers kontrollieren oder eine Bekannten bitten, vorbeizukommen und sich mal mit seinem Notebook per WLAN mit deinem Router zu verbinden und zu schauen, ob Surfen im Internet funktioniert.

Wenn der WLAN-Name nicht täuscht, könnte es hilfreiche Informationen zum DSL Router vielleicht hier geben: DSL-Router einrichten

Grüße,
Karl
User avatar
karlchen
Level 10
Level 10
 
Posts: 3408
Joined: Sat Dec 31, 2011 7:21 am

Linux Mint is funded by ads and donations.
 

Return to Deutsch (German)

Who is online

Users browsing this forum: No registered users and 5 guests