Anzeigefenster - Inhalt flackert

German Forum

Anzeigefenster - Inhalt flackert

Postby alf17 on Sat Aug 02, 2008 7:23 am

Hallo,
auf dem Laptop HP Compac nc6000 mit ATI-Grafikkarte + von EnvyNG installiertem 3D-Treiber stellt sich folgendes Problem dar: Im Anzeigefenster von vermutlich 3D-orientierten Anwendungen (z.B. Celestia) stellt sich ein Flackern ein, so das die Darstellung nicht zu gebrauchen ist. Immer so wie an-aus-an-aus...... Ein ähnliches Problem hatte ich bei der Betrachtung von von *.mpeg in vlc, das aber nach dem "Haken-Setzen" in den Optionen unter Video-Einstellungen bei "X11" komplett verschwunden ist und jetzt spitzenmäßig klappt. Kann man den Anwendungen wie Celestia auch irgendwo sagen: bitte nutze X11 - so das dann alles flackerfrei funktioniert?

Viele Grüße Alf
alf17
Level 1
Level 1
 
Posts: 9
Joined: Sat May 31, 2008 2:56 pm

Linux Mint is funded by ads and donations.
 

Re: Anzeigefenster - Inhalt flackert

Postby chrisbee on Sat Aug 02, 2008 8:05 am

Dabei handelt es sich um ein bekanntes Problem in Verbindung mit dem original ATI Treiber und einem 3D beschleunigten Desktop. Der Haken "nutze X11" bei der Videoausgabe impliziert gleichzeitig "nutze nicht die 3D Auflösung, die mir der ATI-Treiber gibt".
Eine direkte Lösung für dieses Problem wird es so lange nicht geben, bis der gerade in Enwicklung befindliche OpenSource-Treiber noch nicht offiziell in die Quellen von Xorg integriert ist.
Es gibt zwei temporäre Lösungen, die du einmal probieren könntest:
1. schalte compiz ab, und starte das Spiel noch einmal (... unter "Einstellung -> Erscheinungsbild" die "visual effects" auf none stellen)
2. Mit der Tastenkombination "Alt + F2" das Programm "gksu gedit /etc/X11/xorg.conf" ausführen.
- Dort nach der Zeile 'Driver "fglrx"' suchen und dann die Zeile 'Option "TexturedVideo" "off"' darunterschreiben, so daß der Block danach so (oder so ähnlich) aussieht:
Code: Select all
Section "Device"
   Identifiert     "Bereits von LinuxMint eingefügt... Nicht ändern"
   Driver           "fglrx"
   Option          "TexturedVideo" "off"
[...]
EndSection

Der X-Server muss danach mit der Tastenkombination <STRG> + <ALT> + <Backspace> oder durch einen kompletten reboot neu gestartet werden, damit die Änderung aktiv wird.

Ich wünsche dir viel Erfolg, und hoffen wir, das eine der beiden (oder beide) Lösungen klappen. :D

cheers

Chris
I was born wet, naked and hungry. Then things got worse...
chrisbee
Level 1
Level 1
 
Posts: 18
Joined: Sun Jul 27, 2008 2:56 pm
Location: Germany, near Wiesbaden

Re: Anzeigefenster - Inhalt flackert

Postby alf17 on Sat Aug 02, 2008 3:38 pm

Danke für die schnelle Hilfe -> ich werd's testen. Gerade bin ich dabei, auf allen Rechnern zu Hause das Linux-Mint einzurichten. Sowohl bei dem anderen Laptop (Tochter) als auch auf dem normalen Rechner (beide mit NVIDIA-Grafikkarte) lief das nämlich problemlos. Bisher hatten wir dort überall Suse 10.3 drauf - nun geht's halt "hellgrüner" weiter. :D
Gruß Alf
alf17
Level 1
Level 1
 
Posts: 9
Joined: Sat May 31, 2008 2:56 pm

Re: Anzeigefenster - Inhalt flackert

Postby alf17 on Tue Aug 05, 2008 11:08 pm

Hallo,
leider brachte das editieren der xorg.conf keinen Erfolg. Das Astronomie-Programm "Celestia" flackert nach wie vor wie ein Lämmerschwanz. Also werde ich wohl auf einen anderen Treiber angewiesen sein - warten müssen, da es ("Celestia") ohne 3D-Unterstützung seine Weltraumansichten vermutlich nicht darstellen will. Um dieses -Vermutlich- in ein -Sicher- umzuwandeln: Wie kann das Mint beim Start zum Verzicht auf den ATI-Treiber gebracht werden, ohne das ich den deinstallieren muß, halt als temporäre Zwischenlösung? Dazu muß ich doch sicherlich nur in der xorg.conf was editieren -oder?

Viele Grüße Alf
alf17
Level 1
Level 1
 
Posts: 9
Joined: Sat May 31, 2008 2:56 pm

Re: Anzeigefenster - Inhalt flackert

Postby chrisbee on Wed Aug 06, 2008 6:28 am

Darauf zu warten, das AMD (<= der neue Eigentümer von ATi) den OpenSource-Treiber fertigstellt, und gleichzeitig in xorg integriert, könnte eine langwierige Sache werden.
Hast du denn beide Vorschläge von mir ausprobiert?

Ich würde vor Abschaltung des bschleunigten Treibers erst noch folgendes Probieren:

Am Ende der Datei /etc/X11/xorg.conf folgendes hinzufügen, und dann einmal den Rechner neu starten:
Code: Select all
Section "Extensions"
        Option  "Composite" "Disable"
EndSection


Sollte dieses nicht klappen, dann einmal den Block:
Code: Select all
Section "Device"
        Identifier      "Configured Video Device"
        Driver          "fglrx"
EndSection


so modifizieren, das er hinterher so aussieht:
Code: Select all
Section "Device"
        Identifier      "Configured Video Device"
        Driver          "radeon"
EndSection


Danach einmal den Rechner neu starten.

Bitte niemals vergessen, vor irgendwelchen Modifikationen, eine Sicherheitskopie von der xorg.conf zu machen

Code: Select all
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
I was born wet, naked and hungry. Then things got worse...
chrisbee
Level 1
Level 1
 
Posts: 18
Joined: Sun Jul 27, 2008 2:56 pm
Location: Germany, near Wiesbaden


Return to German

Who is online

Users browsing this forum: No registered users and 5 guests