Kein Sound unter Mint 15

German Forum

Kein Sound unter Mint 15

Postby Bugs2rl on Sun Jan 12, 2014 2:35 pm

Problem: Lautstärkeregler führte die Soundkarte nicht auf
PulseAudio Mixer_1.png
Lautstärkeregler vorher und nach Reboot
Hilfreiches Wiki zu diesem Thema:
http://wiki.ubuntuusers.de/Soundkarten_konfigurieren.

Lösung:
Soundkarte wie in dem Wiki beschrieben
durch die Konsoleneingabe 'hwinfo --sound' finden lassen;
Aktivierung durch 'sudo modprobe' in Verbindung mit dem dadurch gefundenen Modulnamen
wie in der hwinfo-Ergebniszeile 'Driver Activation Cmd' aufgeführt,
erzeugt dadurch den für den Sound wichtigen
hier vorher nicht automatisch vorhandenen Ordner /proc/asound
und füllt ihn mit den nötigen Inhalten,
wodurch der Lautstärkeregler funktioniert:
Soundcard gefunden.png
Lautstärkeregler nach 'sudo modprobe [Modulname]'
Eigentliches Problem:
Nach Reboot verschwindet das /asound-Verzeichnis aus dem /proc-Ordner wieder,
sodass wie oben beschrieben erneut manuell aktiviert werden muss.
Frage:
In welches Startscript empfielt sich die Eintragung
der (beiden) oben erwähnten Eingabezeile(n)?
------------------------------
Benutztes Betriebssystem: Mint 15 XFCE Olivia,
unter Mint 13 trat das Problem nicht auf.
Last edited by Bugs2rl on Mon Jan 13, 2014 6:46 am, edited 1 time in total.
User avatar
Bugs2rl
Level 1
Level 1
 
Posts: 4
Joined: Thu Jan 09, 2014 6:37 pm
Location: Heidelberg/Germany

Linux Mint is funded by ads and donations.
 

Re: Kein Sound

Postby seeley on Sun Jan 12, 2014 4:51 pm

Hi!
Man kann mit dem Programm "alsamixer" konfigurieren - das ist klar - und angeblich die Konfiguration abspeichern;
dies habe ich vor Monaten in irgend einem engl. Forum (nicht diesem) gelesen.
seeley @ Linux multiboot
Maya MATE Cinnamon , Petra KDE
Quickly get help
Anleitung: wie schnelle Hilfe erhalten
User avatar
seeley
Level 6
Level 6
 
Posts: 1297
Joined: Sun Mar 07, 2010 7:20 am

Re: Kein Sound

Postby Bugs2rl on Mon Jan 13, 2014 8:58 am

seeley wrote:Hi! Man kann mit dem Programm "alsamixer" konfigurieren - das ist klar - und angeblich die Konfiguration abspeichern;
dies habe ich vor Monaten in irgend einem engl. Forum (nicht diesem) gelesen.

Ich habe meinen Post inzwischen etwas erweitert, siehe dort.

Der Alsamixer scheint die durch modprobe bewirkte Soundaktivierung nicht dauerhaft abzuspeichern.
Ich habe mir nun damit beholfen, dass ich die beiden in meinem Post erwähnten Zeilen
in die /etc/rc.local-Startdatei eingetragen habe:

Code: Select all
# Anfang Soundkartenerkennung und -Aktivierung
echo "----------------------"
echo "Hwinfo-Soundkartenerkennung:"
hwinfo --sound
echo "----------------------"
echo "Modprobe-Soundkartenaktivierung:"
# In der folgenden Zeile anstatt '[Modulname]' direkt nach 'modprobe'
# die individuell von 'hwinfo --sound' gefundene Bezeichnung einsetzen
modprobe [Modulname]
echo "done."
echo "----------------------"
#   Ende Soundkartenerkennung und -Aktivierung

Ist wahrscheinlich nicht die beste Lösung, aber funktioniert zufriedenstellend,
die Soundkarte wird nun bei jedem Reboot automatisch neu initialisiert!
User avatar
Bugs2rl
Level 1
Level 1
 
Posts: 4
Joined: Thu Jan 09, 2014 6:37 pm
Location: Heidelberg/Germany

Re: Kein Sound unter Mint 15

Postby seeley on Tue Jan 21, 2014 8:26 am

Heute gefunden:
http://www.linuxquestions.org/questions/linux-newbie-8/how-to-alter-mic-settings-838506/
Im letzten Beitrag von onebuck wird das Speichern erwähnt (nicht von mir überprüft):
Code: Select all
alsactl store
seeley @ Linux multiboot
Maya MATE Cinnamon , Petra KDE
Quickly get help
Anleitung: wie schnelle Hilfe erhalten
User avatar
seeley
Level 6
Level 6
 
Posts: 1297
Joined: Sun Mar 07, 2010 7:20 am


Return to German

Who is online

Users browsing this forum: No registered users and 4 guests