Boot flag notwendig?

German Forum

Boot flag notwendig?

Postby seeley on Mon Jan 24, 2011 9:20 am

Hi!
Im Moment ist es mir zu anstrengend, im engl. Teil zu posten und um hier, im dt. Teil, etwas Leben hinein zu bringen:
Ausgangspunkt ist der Beitrag von shibby: "LMDE wont boot after install": http://forums.linuxmint.com/viewtopic.php?f=46&t=64699&p=372998#p372998
Es ging darum, daß LMDE (als einziges Betriebsystem) auf einer SSD-Platte nicht bootete.
Es wure eine Lösung gefunden, die mir völlig unklar ist: Setzen einer Markierung (root-Partition) , nämlich "boot", mit GParted > Partition > Markierungen bearbeiten.
Warum ich mich wundere? Ich habe 14 der ersten 15 Distributionen der Hitliste von http://distrowatch.com/ installiert und getestet (und weitere);
ab der 2. Installation immer mit GParted vorpartioniert und niemals ein boot flag gesetzt - und hatte nie ernste Probleme (nur mit Grub wg. Bugs).
Das ist eine seltsame Geschichte - ich vermute, daß es an SSD liegt - dafür gibt es Gründe:
Ich habe zuletzt immer Tripelbootsysteme installiert mit Mint, openSUSE / Fedora (verschiedene Desktops), so daß richtig getestet werden konnte.
Mint wurde (wg. GRUB"2") zuerst installiert (GRUB"2" -> MBR), dann Linux2 (Grub legacy-> root-Partition).
Merkwürdig: Fedora setzte bei einem von 4 Computern (altes Modell) ein boot flag in der rootFedora.
Ich habe es gelöscht und konnte danach ohne Probleme booten!
Bildschirmfotos von GP:
ScreenshotF14.png
ScreenshotF14.png (45.68 KiB) Viewed 2671 times

Noch eine interessante Sache: Das openSUSE Installationsprogramm (das beste!) läßt ein Setzen dieser Markierung zu (sonst nirgends gesehen).
Ich habe beide Optionen getestet (nat. durch installationen) und keinen Unterschied festgestellt.

Wieso mußte dann bei LMDE ein boot flag gesetzt werden??

Als Praktiker habe ich nun 5 x LMDE auf 3 Geräten installiert, immer vorpartitioniert mit GP, nie ein boot flag gesetzt, 3x keinen Bootloader installiert, trotzdem konnte ich in allen Fällen ohne Probleme LMDE booten (es war auch immer Mint mit GRUB"2" im MBR installiert).
Dies, um die Behauptung zu widerlegen, GRUB"2" würde während der Installation ein boot flag setzen - nie festgestellt!

ALSO: Hat jemand LMDE auf SSD statt hd instaliiert?

seeley
seeley @ Linux multiboot
Maya MATE Cinnamon , Petra KDE
Quickly get help
Anleitung: wie schnelle Hilfe erhalten
User avatar
seeley
Level 6
Level 6
 
Posts: 1297
Joined: Sun Mar 07, 2010 7:20 am

Linux Mint is funded by ads and donations.
 

Re: Boot flag notwendig?

Postby wayne128 on Mon Jan 24, 2011 10:30 am

Hi Seeley
I used google translate to read briefly
Understand your question is : Why need to set Boot Flag for LMDE partition?

I learned Boot flag applied to Windows only. Windows needs to set the partition active before its installer write boot code onto the partition, or else it will not boot, that is the reason people got problem installing windows on logical partition, windows cannot set logical partition active.. There are other ways around but out of this context.

On many ( too many) of my multi boot, I do not set boot flag on Linux OS, whether it used Lilo, Grub legacy or Grub2. I followed two other guru teachers, who multi boot more than 100 OS in one computer, they taught me about boot flag.
Anyway that was what I learned and experience. Others might have deeper knowledge than mine.
wayne128
Level 9
Level 9
 
Posts: 2832
Joined: Tue Jul 13, 2010 12:15 am

Re: Boot flag notwendig?

Postby seeley on Mon Jan 24, 2011 10:52 am

Hi wayne!
Thank you!
If you have time, you should read: http://forums.linuxmint.com/viewtopic.php?f=46&t=64699&p=372998#p372998
Later on, I there will add a posting or open a new thread in En.
I neither believe, that - normally - you have to set a boot flag in GParted to make a partition bootable nor that GRUB"2" sets a flag during installation - as stated in that thread.
(BTW: the openSUSE installer enables to set a boot flag and the Fedora installer was setting this flag on an old computer, but I could boot after having deleted the flag.)
Therefore I don't understand why it was necessary to set this flag to boot LMDE.
Maybe older computers and newer ones [SSD] need it?
(BTW: as you mentioned PCLinuxOS: GRUB"2" - until 1.97 - did not create a correct entry concerning PCL in the grub.cfg; without editing it, PCL could not start on my multiboot [max. operating systems was 7]!)
seeley
seeley @ Linux multiboot
Maya MATE Cinnamon , Petra KDE
Quickly get help
Anleitung: wie schnelle Hilfe erhalten
User avatar
seeley
Level 6
Level 6
 
Posts: 1297
Joined: Sun Mar 07, 2010 7:20 am

Re: Boot flag notwendig?

Postby shibby on Mon Jan 24, 2011 4:22 pm

Ich möchte auch noch was loswerden.
Als ich versucht habe, LMDE auf meine SSD zu installieren, war ich ja nicht in der Lage, das Betriebsystem nach Abschluss zu booten.
Da ich auch schon an meiner SSD gezweifelt habe, versuchte ich nacher dasselbe mit einer normalen HDD. Dabei passierte genau dasselbe, wie mit der SSD.
Desswegen kann das Problem nicht an der Festplatte liegen.

Was mich aber brennend interessiert, bin ich der einzige, welcher das "boot-frag" manuell setzten musste?
Bei meinem HP Mini 5103 war dies jedenfalls notwendig, um Linux Mint Debian installieren zu können. Als ich Mint 10 oder Ubuntu 10.10 einzeln auf die Festplatte installierte, ging alles problemlos über die Bühne...

Jedenfalls bin ich froh über die Hilfe hier im Forum und mein LMDE läuft nun wie geschmiert :wink:

shibby
User avatar
shibby
Level 1
Level 1
 
Posts: 13
Joined: Sat Jan 22, 2011 3:03 pm
Location: Switzerland

Re: Boot flag notwendig?

Postby seeley on Tue Jan 25, 2011 2:35 pm

Hi!
shibby wrote:Da ich auch schon an meiner SSD gezweifelt habe, versuchte ich nacher dasselbe mit einer normalen HDD. Dabei passierte genau dasselbe, wie mit der SSD

Also muß wahrscheinlich eine neue Theorie her.
Wie wär's mit: liegt am BIOS?
seeley
seeley @ Linux multiboot
Maya MATE Cinnamon , Petra KDE
Quickly get help
Anleitung: wie schnelle Hilfe erhalten
User avatar
seeley
Level 6
Level 6
 
Posts: 1297
Joined: Sun Mar 07, 2010 7:20 am

Re: Boot flag notwendig?

Postby casey972oo on Tue May 17, 2011 1:57 pm

Na klar liegt das am BIOS ! ..;
casey972oo
Level 4
Level 4
 
Posts: 347
Joined: Tue Mar 22, 2011 6:26 pm


Return to German

Who is online

Users browsing this forum: No registered users and 2 guests