Beim Ausschalten: "Eine Anwendung läuft noch: Unbekannt"

German Forum

Beim Ausschalten: "Eine Anwendung läuft noch: Unbekannt"

Postby teilnehmer on Mon Aug 08, 2011 4:31 am

Hallo!

Seit geraumer Zeit habe ich beim Ausschalten öfter mal ein Pop-Up mit der Information:

Eine Anwendung läuft noch:
Unbekannt
Keine Antwort


Wie bekomme ich am besten und ohne trial und error heraus, welche das ist? Hier meine laufenden Prozesse:
ps -A
Code: Select all
  PID TTY          TIME CMD
    1 ?        00:00:01 init
    2 ?        00:00:00 kthreadd
    3 ?        00:00:00 ksoftirqd/0
    4 ?        00:00:04 migration/0
    5 ?        00:00:00 watchdog/0
    6 ?        00:00:00 migration/1
    7 ?        00:00:00 ksoftirqd/1
    8 ?        00:00:00 watchdog/1
    9 ?        00:00:04 events/0
   10 ?        00:00:00 events/1
   11 ?        00:00:00 cpuset
   12 ?        00:00:00 khelper
   13 ?        00:00:00 netns
   14 ?        00:00:00 async/mgr
   15 ?        00:00:00 pm
   17 ?        00:00:00 sync_supers
   18 ?        00:00:00 bdi-default
   19 ?        00:00:00 kintegrityd/0
   20 ?        00:00:00 kintegrityd/1
   21 ?        00:00:01 kblockd/0
   22 ?        00:00:00 kblockd/1
   23 ?        00:00:00 kacpid
   24 ?        00:00:00 kacpi_notify
   25 ?        00:00:00 kacpi_hotplug
   26 ?        00:00:00 ata_aux
   27 ?        00:00:00 ata_sff/0
   28 ?        00:00:00 ata_sff/1
   29 ?        00:00:00 khubd
   30 ?        00:00:00 kseriod
   31 ?        00:00:00 kmmcd
   32 ?        00:00:00 khungtaskd
   33 ?        00:00:00 kswapd0
   34 ?        00:00:00 ksmd
   35 ?        00:00:00 aio/0
   36 ?        00:00:00 aio/1
   37 ?        00:00:00 ecryptfs-kthrea
   38 ?        00:00:00 crypto/0
   39 ?        00:00:00 crypto/1
   45 ?        00:00:00 kstriped
   46 ?        00:00:00 kmpathd/0
   47 ?        00:00:00 kmpathd/1
   48 ?        00:00:00 kmpath_handlerd
   49 ?        00:00:00 ksnapd
   50 ?        00:00:00 kondemand/0
   51 ?        00:00:00 kondemand/1
   52 ?        00:00:00 kconservative/0
   53 ?        00:00:00 kconservative/1
  244 ?        00:00:00 scsi_eh_0
  245 ?        00:00:00 scsi_eh_1
  246 ?        00:00:03 scsi_eh_2
  247 ?        00:00:00 scsi_eh_3
  248 ?        00:00:00 scsi_eh_4
  249 ?        00:00:00 scsi_eh_5
  273 ?        00:00:00 usbhid_resumer
  357 ?        00:00:00 jbd2/sda1-8
  358 ?        00:00:00 ext4-dio-unwrit
  359 ?        00:00:00 ext4-dio-unwrit
  400 ?        00:00:00 flush-8:0
  428 ?        00:00:00 upstart-udev-br
  431 ?        00:00:00 udevd
  557 ?        00:00:00 udevd
  558 ?        00:00:00 udevd
  680 ?        00:00:00 kpsmoused
  745 ?        00:00:00 cfg80211
  831 ?        00:00:00 hd-audio0
  832 ?        00:00:00 jbd2/sda3-8
  833 ?        00:00:14 phy0
  852 ?        00:00:00 ext4-dio-unwrit
  853 ?        00:00:00 ext4-dio-unwrit
  896 ?        00:00:00 rsyslogd
  914 ?        00:00:05 dbus-daemon
  922 ?        00:00:00 avahi-daemon
  924 ?        00:00:05 NetworkManager
  927 ?        00:00:00 avahi-daemon
  932 ?        00:00:00 modem-manager
  942 ?        00:00:00 wpa_supplicant
  959 ?        00:00:00 gdm-binary
  974 ?        00:00:00 console-kit-dae
 1049 ?        00:00:00 cupsd
 1052 ?        00:00:00 gdm-simple-slav
 1067 tty7     00:04:36 Xorg
 1342 ?        00:00:00 dbus-launch
 1363 tty4     00:00:00 getty
 1369 tty5     00:00:00 getty
 1377 tty2     00:00:00 getty
 1379 tty3     00:00:00 getty
 1383 tty6     00:00:00 getty
 1387 ?        00:00:00 acpid
 1392 ?        00:00:00 cron
 1393 ?        00:00:00 atd
 1424 ?        00:00:00 winbindd
 1428 ?        00:00:00 winbindd
 1540 ?        00:00:00 gdm-session-wor
 1549 ?        00:00:00 upowerd
 1565 ?        00:00:00 rtkit-daemon
 1576 ?        00:00:02 polkitd
 1602 tty1     00:00:00 getty
 1684 ?        00:00:00 gnome-keyring-d
 1703 ?        00:00:03 gnome-session
 1733 ?        00:00:00 ssh-agent
 1736 ?        00:00:00 dbus-launch
 1737 ?        00:00:00 dbus-daemon
 1742 ?        00:00:08 gconfd-2
 1748 ?        00:00:00 gnome-power-man
 1751 ?        00:00:08 gnome-settings-
 1755 ?        00:00:00 gvfsd
 1761 ?        00:00:00 gvfs-fuse-daemo
 1768 ?        00:00:05 nm-applet
 1769 ?        00:00:00 mintupdate-laun
 1771 ?        00:02:00 compiz
 1775 ?        00:00:00 polkit-gnome-au
 1776 ?        00:00:00 pulseaudio
 1777 ?        00:00:00 bluetooth-apple
 1778 ?        00:00:02 gnome-panel
 1783 ?        00:00:00 sh
 1784 ?        00:00:06 mintUpdate
 1809 ?        00:00:00 gconf-helper
 1836 ?        00:00:00 bonobo-activati
 1841 ?        00:00:00 gvfsd-trash
 1845 ?        00:00:00 gvfs-gdu-volume
 1855 ?        00:00:02 udisks-daemon
 1860 ?        00:00:04 udisks-daemon
 1871 ?        00:00:14 mintmenu
 1881 ?        00:00:00 notification-ar
 1884 ?        00:00:00 gvfs-gphoto2-vo
 1886 ?        00:00:01 gvfs-afc-volume
 1892 ?        00:00:01 clock-applet
 1893 ?        00:00:00 indicator-apple
 1922 ?        00:00:00 gvfsd-metadata
 1927 ?        00:00:00 dhclient
 1931 ?        00:00:00 indicator-sound
 1934 ?        00:00:04 gnome-screensav
 1937 ?        00:00:00 indicator-appli
 1985 ?        00:00:02 notify-osd
 1992 ?        00:00:06 gtk-window-deco
 2021 ?        00:00:00 gvfsd-burn
 2109 ?        00:00:00 applet.py
 3162 ?        00:03:26 gnome-system-mo <defunct>
 3164 ?        00:00:04 nautilus
 3186 ?        00:00:01 wnck-applet
 3223 ?        00:00:02 gnome-terminal
 3226 ?        00:00:00 gnome-pty-helpe
 3227 pts/0    00:00:00 bash
 3268 pts/0    00:00:00 ps


Viele Grüße,

Jan
User avatar
teilnehmer
Level 2
Level 2
 
Posts: 81
Joined: Sat May 14, 2011 4:19 am
Location: Germany

Linux Mint is funded by ads and donations.
 

Re: Beim Ausschalten: "Eine Anwendung läuft noch: Unbekannt"

Postby Gerd50 on Mon Aug 08, 2011 12:47 pm

Moin Jan,

hast du in /var/log/syslog und messages nachgesehen, ob du da Hinweise findest?
I believe in everything, except humans.

LM9, Debian Testing Xfce, Debian Sid Xfce - CPU/Amd64 2,6Ghz, Graphics/Nvidia 9600 GT, Sound/SB Audigy4 emu10K1
User avatar
Gerd50
Level 5
Level 5
 
Posts: 738
Joined: Wed Jul 22, 2009 3:42 pm
Location: Fishtown, Germany

Re: Beim Ausschalten: "Eine Anwendung läuft noch: Unbekannt"

Postby teilnehmer on Tue Aug 09, 2011 10:19 am

Hallo Gerd,

hab gerade wieder die Meldung bekommen, finde mit dmesg leider nichts interessantes. In /var/log/syslog könnte was sein, um 16:17 hab ich den Rechner auszumachen versucht:

Code: Select all
Aug  9 16:17:01 butler CRON[2099]: (root) CMD (   cd / && run-parts --report /etc/cron.hourly)
Aug  9 16:17:25 butler gnome-session[1651]: CRITICAL: gsm_client_peek_id: assertion `GSM_IS_CLIENT (client)' failed
Aug  9 16:17:25 butler gnome-session[1651]: WARNING: Client '(null)' failed to reply before timeout
Aug  9 16:17:25 butler gnome-session[1651]: CRITICAL: gsm_client_peek_app_id: assertion `GSM_IS_CLIENT (client)' failed
Aug  9 16:17:25 butler gnome-session[1651]: CRITICAL: gsm_client_get_app_name: assertion `GSM_IS_CLIENT (client)' failed
Aug  9 16:17:25 butler gnome-session[1651]: CRITICAL: gsm_client_peek_id: assertion `GSM_IS_CLIENT (client)' failed


Hilft das schon weiter? Gnome-Session kann ich ja schlecht killen, würd ich denken...
User avatar
teilnehmer
Level 2
Level 2
 
Posts: 81
Joined: Sat May 14, 2011 4:19 am
Location: Germany

Re: Beim Ausschalten: "Eine Anwendung läuft noch: Unbekannt"

Postby Gerd50 on Tue Aug 09, 2011 12:14 pm

Hallo Jan,

soweit ich weiß kann man jeden Prozess killen, bevor der Rechner runter fährt. Auf die nächste Sitzung hat das keine
Auswirkungen. Die Frage ist, ob das dann zum Dauerzustand wird mit killen müssen. Ich würde versuchen, gnome-session
einmal vollständig zu entfernen und neu installieren. Um zu sehen ob der Fehler dann immer noch auftritt.
I believe in everything, except humans.

LM9, Debian Testing Xfce, Debian Sid Xfce - CPU/Amd64 2,6Ghz, Graphics/Nvidia 9600 GT, Sound/SB Audigy4 emu10K1
User avatar
Gerd50
Level 5
Level 5
 
Posts: 738
Joined: Wed Jul 22, 2009 3:42 pm
Location: Fishtown, Germany

Re: Beim Ausschalten: "Eine Anwendung läuft noch: Unbekannt"

Postby teilnehmer on Wed Aug 10, 2011 4:05 am

Alles klar,

dank dir! Probier ich mal aus und beobachte erstmal weiter. Melde mich dann die Tage nochmal.
Beste Grüße,

Jan
User avatar
teilnehmer
Level 2
Level 2
 
Posts: 81
Joined: Sat May 14, 2011 4:19 am
Location: Germany

Re: Beim Ausschalten: "Eine Anwendung läuft noch: Unbekannt"

Postby thx1138 on Wed Aug 10, 2011 7:51 pm

Was für ein Mint benutzt du?
User avatar
thx1138
Level 4
Level 4
 
Posts: 322
Joined: Thu Apr 30, 2009 8:42 pm
Location: Germany/NRW

Re: Beim Ausschalten: "Eine Anwendung läuft noch: Unbekannt"

Postby teilnehmer on Thu Aug 11, 2011 3:25 am

Guten Tag!

@thx1138 - Mint 10, Kernel 2.6.35-22-generic.

@Gerd - Hat leider nicht geholfen. Ich habe mit apt-get remove und apt-get install gearbeitet. Ist das schon komplett deinstalliert, oder hätte ich noch irgendwas purgen müssen? Sowas hab ich schonmal gelesen, aber noch nie benutzt... Jedenfalls habe ich immer, wenn ich den Rechner nicht runterfahren kann, die beschriebene Meldung im syslog.
Verrückterweise weiß Google NICHTS zum Suchstring >>gnome-session "gsm is client"<<. Das hatte ich auch noch nie...

EDIT: Ich kann den Bug an anderer Stelle reproduzieren, indem ich gnome-session manuell beenden will. Dann kommt auch das beschriebene Popup (allerdings nicht die Meldung im syslog... vielleicht, weil ich noch in der gleichen Session bin?).
Sehe ich das richtig, dass sich gnome-session über einen Client namens "null" aufregt?, also einen namenlosen Prozess?
User avatar
teilnehmer
Level 2
Level 2
 
Posts: 81
Joined: Sat May 14, 2011 4:19 am
Location: Germany

Re: Beim Ausschalten: "Eine Anwendung läuft noch: Unbekannt"

Postby Gerd50 on Thu Aug 11, 2011 4:38 am

Moin Jan,

ich denke purgen wäre besser gewesen und in den verborgenen Dateien gibt es eine config Datei .gnome-session, die auch
weg sollte, bevor du gs neu installierst.

Versuch das nochmal mit:

Code: Select all
sudo apt-get purge gnome-session gnome-session-bin gnome-session-common && sudo apt-get install --reinstall gnome-session gnome-session-bin gnome-session-common

Was das mit dem Client '(null)' auf sich hat, weiß ich nicht.
I believe in everything, except humans.

LM9, Debian Testing Xfce, Debian Sid Xfce - CPU/Amd64 2,6Ghz, Graphics/Nvidia 9600 GT, Sound/SB Audigy4 emu10K1
User avatar
Gerd50
Level 5
Level 5
 
Posts: 738
Joined: Wed Jul 22, 2009 3:42 pm
Location: Fishtown, Germany

Re: Beim Ausschalten: "Eine Anwendung läuft noch: Unbekannt"

Postby teilnehmer on Sat Aug 13, 2011 10:47 am

Hi Gerd,

ah, alles klar, so benutzt man also die Option purge :) Danke!
Bevor ich fortfahre, frage ich lieber nochmal nach:
Code: Select all
Die folgenden Pakete werden ENTFERNT:
  gdm* gdm-guest-session* gnome-session* gnome-session-bin*
  gnome-session-common*

Echt gdm* ? Ich hab Schiss, den gnome-display-manager zu deinstallieren... klingt zu wichtig. Kann ich das tatsächlich gefahrlos tun?

Die Datei .gnome-session habe ich übrigens nicht. Ich habe einen Ordner namens .gnome2, den habe ich mal umbenannt. Vielleicht ein Versionsunterschied?
User avatar
teilnehmer
Level 2
Level 2
 
Posts: 81
Joined: Sat May 14, 2011 4:19 am
Location: Germany

Re: Beim Ausschalten: "Eine Anwendung läuft noch: Unbekannt"

Postby Gerd50 on Sat Aug 13, 2011 12:27 pm

Hallo Jan,

da bin ich jetzt unsicher. gnome-session-bin, gdm und gdm-guest-session sind abhängig voneinander und ich wäre auch
vorsichtig mit purgen.

Versuche es doch mal nur mit gnome-session, was offenbar zickt, also

Code: Select all
sudo apt-get purge gnome-session && sudo apt-get install --reinstall gnome-session

Die Datei .gnome-session befindet sich in den verborgenen Dateien im Ordner .config.
.gnome2 hat mit der Sache nichts zu tun, den kannst du wieder zurück benennen.
I believe in everything, except humans.

LM9, Debian Testing Xfce, Debian Sid Xfce - CPU/Amd64 2,6Ghz, Graphics/Nvidia 9600 GT, Sound/SB Audigy4 emu10K1
User avatar
Gerd50
Level 5
Level 5
 
Posts: 738
Joined: Wed Jul 22, 2009 3:42 pm
Location: Fishtown, Germany

Linux Mint is funded by ads and donations.
 

Return to German

Who is online

Users browsing this forum: No registered users and 2 guests