Linux Mint + Android SDK

German Forum

Linux Mint + Android SDK

Postby Bastian on Sat Jan 07, 2012 10:49 pm

Hallo,

ich versuche gerade Eclipse und das Android SDK auf Linux zum laufen zu bekommen.
Leider erhalten ich den folgenden Fehler:

Code: Select all
[2012-01-08 03:16:38 - adb] Failed to get the adb version: Cannot run program "/home/bastian/android-sdk-linux/platform-tools/adb": java.io.IOException: error=2, Datei oder Verzeichnis nicht gefunden


Das Android SDK ist jedoch da, aber ich kann es per Bash auch nicht ausführen:

Code: Select all
bastian-laptop platform-tools # ls -lisa
insgesamt 20416
9306998     4 drwxrwxrwx  4 bastian bastian     4096 2012-01-08 00:56 .
6947851     4 drwxr-x--- 12 bastian bastian     4096 2012-01-08 00:56 ..
9307026   804 -rwxrwxrwx  1 bastian bastian   811728 2012-01-08 00:56 aapt
9307040   164 -rwxrwxrwx  1 bastian bastian   159620 2012-01-08 00:56 adb
9307047   172 -rwxrwxrwx  1 bastian bastian   164312 2012-01-08 00:56 aidl
9307031   372 -rwxrwxrwx  1 bastian bastian   368701 2012-01-08 00:56 dexdump
9307045    12 -rwxrwxrwx  1 bastian bastian     2603 2012-01-08 00:56 dx
9307019    64 -rwxrwxrwx  1 bastian bastian    55776 2012-01-08 00:56 fastboot
9307035     4 drwxrwxrwx  2 bastian bastian     4096 2012-01-08 00:56 lib
9307043 18420 -rwxrwxrwx  1 bastian bastian 18850844 2012-01-08 00:56 llvm-rs-cc
9307027   380 -rwxrwxrwx  1 bastian bastian   377618 2012-01-08 00:56 NOTICE.txt
9306999     4 drwxrwxrwx  4 bastian bastian     4096 2012-01-08 00:56 renderscript
9307011    12 -rwxrwxrwx  1 bastian bastian      199 2012-01-08 00:56 source.properties
bastian-laptop platform-tools # ./adb
bash: ./adb: Datei oder Verzeichnis nicht gefunden


Also die Datei ist da und im korrekten Ordner, hat auch 777 Rechte aber kann nicht ausgeführt werden?
Würde mich freuen wenn mir hier jemand die Augen öffnen könnte.
Vielen Dank im Voraus.

MFG Bastian
Bastian
Level 1
Level 1
 
Posts: 2
Joined: Sat Jan 07, 2012 10:43 pm

Linux Mint is funded by ads and donations.
 

Re: Linux Mint + Android SDK

Postby Bastian on Sat Jan 07, 2012 11:08 pm

Ok, schon selber gefunden, man sollte natürlich 32-bit Programme ausführen können.

Code: Select all
sudo apt-get install ia32-libs
Bastian
Level 1
Level 1
 
Posts: 2
Joined: Sat Jan 07, 2012 10:43 pm


Return to German

Who is online

Users browsing this forum: No registered users and 7 guests