Problema installazione OS

Italian Forum

Problema installazione OS

Postby idkfa on Fri Feb 17, 2012 11:33 am

Note preliminari:

    Ho un Hard-Disk fisico da 250Gb così partizionato:
      sda1 da 230Gb con installato Windows 7 (ntfs)
      sda2 da 22Gb con installato Ubuntu (ext4)
      sda3 da 8Gb (swap)
      sda4 da 250Gb nessun OS (ntfs)
    Il problema si verifica sia con installazione da DVD live, sia con boot tramite UNetbootin (sia che UNetbootin venga lanciato da Windows, sia che venga lanciato da Ubuntu.
    Per accedere a Windows devo passare dal grub di Ubuntu.


Il problema:
Avviata la live di Lisa faccio doppio click sul desktop sull'icona per installare il sistema operativo e sia che gli dica di installare sopra Ubuntu, sia che decida di creare le partizioni da solo, quando avvio l'installazione vera e propria si verifica un errore e mi dice che mi sarà data la possibilità di riportare il bug in una finestra che dovrebbe essere visualizzata ma che non compare; più specificatamente questa finestra di dialogo si presenta poco dopo che viene visualizzata la schermata di selezione del fuso orario (e credo che non dipenda da ciò quanto piuttosto dal fatto che la scelta del fuso, nome utente etc., sono preferenze che l'installer mi fa scegliere mentre svolge il lavoro di installazione vero e proprio, o durante il partizionamento vero e proprio).
A questo punto mi è impossibile installare (riprovando compare sempre la finestra di dialogo) e sono costretto a riavviare.
Al riavvio del sistema il grub è sparito ed al suo posto c'è una schermata DOS nella quale mi dice qualcosa che non ricordo riguardante il grub, sono certo che Voi che ne capite qualcosa la conosciate praticamente a memoria. Viene menzionato il "grub rescue" e l'ultima linea credo che sia.
Code: Select all
grub > _
Essendo totalmente incompetente non sono capace di ripristinare il grub e devo reinstallare Ubuntu; fatto ciò riesco ad accedere a windows e tutti i miei files nelle partizioni sda1&4 sono intatti.


Inolte quando faccio click su Avanti, per uscire dalla schermata di confugurazione delle partizioni, mi esce questa finestra di dialogo (scusate ma nel forum non c'è la funzione spoiler :P ).
Image
Al che devo seguire questa guida per poter installare.

Se dovessero essere di aiuto questi sono i dati del mio hardware:

HD è un Hitachi 500Gb SATA2
Motherboard è una Asus P5KC
CPU è un Intel Quad Core Duo Q6600

Help please! :)
Last edited by idkfa on Fri Feb 17, 2012 3:39 pm, edited 1 time in total.
idkfa
Level 1
Level 1
 
Posts: 3
Joined: Fri Feb 17, 2012 10:57 am

Linux Mint is funded by ads and donations.
 

Re: Problema installazione OS

Postby HughT on Fri Feb 17, 2012 3:10 pm

Try to repair Grub from liveCD -
1) Mount Ubuntu partition
Code: Select all
sudo mount /dev/sda2 /mnt

2) Install Grub on sda master boot record in sda
Code: Select all
sudo grub-install --root-directory=/mnt /dev/sda

3) Re-boot to Ubuntu and
Code: Select all
sudo update-grub
Please Edit your post title and add [SOLVED] once your question is resolved.
HughT
Level 5
Level 5
 
Posts: 628
Joined: Thu Oct 20, 2011 1:54 pm
Location: England

Re: Problema installazione OS

Postby idkfa on Fri Feb 17, 2012 3:37 pm

Thank you for the answer HughT, I will find this informations helpful in case I'll step in this problem again, but my problem is to install Mint 12 actually. Shamefully, I've to admit I rushed posting the thread and I forgot to add few but important informations such as that I can't burn another version (out of DVDs), and I forgot to remark how my grub is restored thanks to the reinstallation of Ubuntu.
I wish to get rid of Ubuntu, and to start a fresh installation of Mint.

The main problem is that I'm unable to install Mint 12 (64bit) on my PC. Once it starts to create the partitions, or as it finishes to do it... I don't know when, just as the installer changes view to the time-zone selection screen and it starts the concrete part of the installation it crashes in few seconds, saying that there was an unknown error and that I'll be prompted with a window where I'll have the chance to submit a bug record if I wish, but it doesn't displays any window when I shut the installator and on reboot the grub results dead. :?

Other informations I forgot to add are:

My HD is a Hitachi 500Gb SATA2
My motherboard is an Asus P5KC
My CPU is an Intel Quad Core Duo Q6600

I don't know if they could be of any help but I wrote it just in case.
idkfa
Level 1
Level 1
 
Posts: 3
Joined: Fri Feb 17, 2012 10:57 am

Re: Problema installazione OS

Postby HughT on Fri Feb 17, 2012 4:18 pm

Hi idkfa - glad your English is very good! I think the problem is the disk - see recent post from an experienced user viewtopic.php?f=46&t=94719
I guess when you get more disks you could try the 32bit version.
Did you get Ubuntu working again?
Please Edit your post title and add [SOLVED] once your question is resolved.
HughT
Level 5
Level 5
 
Posts: 628
Joined: Thu Oct 20, 2011 1:54 pm
Location: England

Re: Problema installazione OS

Postby idkfa on Fri Feb 17, 2012 5:12 pm

Thank you, but I think my english isn't decent enough already. :mrgreen:
Anyway I'll keep an eye there, and make a post as well; and yes: ubuntu runs fine (I just -hate- Unity, and I prefer the look of Mint, also I can't have compiz-fusion &extra run properly on Ubuntu). I'll try with a 32-bit installer on the external hard disk.
idkfa
Level 1
Level 1
 
Posts: 3
Joined: Fri Feb 17, 2012 10:57 am


Return to Italiano (Italian)

Who is online

Users browsing this forum: Google Adsense [Bot] and 4 guests