Dualboot met Windows7 werkt niet

Dutch Forum

Moderator: xenopeek

Dualboot met Windows7 werkt niet

Postby Tool_Max on Tue Feb 21, 2012 6:51 am

Hallo,
Een paar dagen geleden heb ik Linux Mint geïnstalleerd naast Windows7 nadat ik dit een tijdje getest had via de live-dvd.
Omdat ik niet alles kon uitproberen via de dvd heb ik het dan geïnstalleerd naast Windows. Nu krijg ik bij het opstarten een
multibootscherm van grub waar ik Linux mint en Windows7 kan kiezen om op te starten, maar als ik Windows7 kies dan kom
ik telkens terug in het multibootscherm. Ik geraak alleen nog maar in Linux mint en heb al alles geprobeerd om toch maar
in Windows7 te geraken. Ik heb dit forum al volledig afgezocht en van alles uitgeprobeerd en heb ook al via de Windows-forums
geprobeerd om de mbr te herstellen, maar niks werkt. Omdat ik nog andere problemen heb met mint die ik niet opgelost krijg zou
ik graag terug met Windows werken, maar dit lukt mij niet. Is er iemand die mij zou kunnen helpen hiermee?

Ik heb een tijdje geleden nog een hele poos gewerkt met Ubuntu 10.4 en heb daarmee nooit problemen gehad. Nu met mint geraak
ik op geen enkele manier op mijn Qnap-NAS en krijg ik de dualboot met windows 7 niet in orde. Ik heb voor beide problemen alle forums
al afgeschuimd, maar vind nergens een oplossing die werkt.

Alvast bedankt voor de hulp.
Tool_Max
Level 1
Level 1
 
Posts: 6
Joined: Tue Feb 21, 2012 6:31 am

Linux Mint is funded by ads and donations.
 

Re: Dualboot met Windows7 werkt niet

Postby HughT on Thu Feb 23, 2012 4:01 pm

Ik heb dit forum al volledig afgezocht en van alles uitgeprobeerd en van alles uitgeprobeerd
What have you tried?
Have you tried this from a live CD?
Code: Select all
sudo mount /dev/sda? /mnt
replace ? with the appropriate partition for Mint

Code: Select all
sudo grub-install --root-directory=/mnt /dev/sda
note - there's a gap between =/mnt and /dev, and no partition number after sda

re-boot into Mint then
Code: Select all
sudo update-grub


hope this helps
Please Edit your post title and add [SOLVED] once your question is resolved.
HughT
Level 5
Level 5
 
Posts: 628
Joined: Thu Oct 20, 2011 1:54 pm
Location: England

Re: Dualboot met Windows7 werkt niet

Postby xenopeek on Thu Feb 23, 2012 5:04 pm

Volg deze link en download het boot info script: http://sourceforge.net/projects/bootinfoscript/

Na downloaden, open het .zip bestand en pak het .sh bestand uit. Open vervolgens een terminal op de directory waar je het bestand hebt uitgepakt. Start het script vervolgens en geef je wachtwoord zodat het kan draaien:
Code: Select all
sudo bash boot_info_script.sh

Het zal snel klaar zijn. Daarna heb je een bestand RESULTS.txt. Kan je deze op http://pastebin.com zetten en de link hier delen? Dan kunnen we je partities en boot configuratie onderzoeken op problemen.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14889
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Dualboot met Windows7 werkt niet

Postby Tool_Max on Fri Feb 24, 2012 10:18 am

Hallo,
Bedankt voor het antwoord.

Op onderstaande link staat het resultaat van mijn boot info:
http://pastebin.com/n0m7cLkG

Ondertussen ben ik nog bezig geweest met het proberen oplossen van mijn probleem, maar het gaat van kwaad naar erger. De verbinding met de mappen op mijn Qnap-nas heb ik in orde gekregen,
maar alleen via Samba terwijl ik het eigenlijk via NFS wou doen. Het opstartprobleem met windows7 krijg ik op geen enkele manier in orde, niet via linux en ook niet via de recovery van windows7.
Volgens de logfile zou de mbr op sdb1 moeten staan, maar dit is een kleine ntfs-partitie "door systeem gereserveerd". De windows-installatie zelf staat op de partitie sdb2. Via gparted heb ik de bootflag
al veranderd van sdb1 naar sdb2, maar dit veranderd niets. In het grub-opstartscherm staat dan bij windows7 loader wel de verwijzing naar sdb2 ipv sdb1, maar opstarten gaat nog niet en hij komt telkens
in het grub-opstartscherm terug.

Ondertussen heb ik nog een ander probleem bijgekregen: ik kan linux mint niet meer uitschakelen of herstarten! Wanneer ik dat doe dan krijg ik een zwart scherm waar hij alle stappen laat zien en blijft hij
hangen op de regel "Stopping Bluetooth [ok]". Daarna duurt het een tijdje en verschijnen er om de x-tijd steeds dezelfde foutmeldingen opnieuw. De info-tekst van deze 2 problemen zijn :
    Info:task Xorg:1249 blocked for more than 120 seconds
    Info:task S20sendings:2575 blocked for more than 120 seconds
Ik kan de pc nu dus alleen nog maar uitzetten met de knop. Wat eigenaardig is,is dat sinds ik dat probleem heb er in het opstartscherm een selectie bijgekomen is en die noemt "Previous Linux Versions".
De versie die hierin staat is 3.0.0-12 generic en die in het hoofdscherm is 3.0.0-16. Wanneer ik dan opstart in 3.0.0-12 dan kan ik wel de pc normaal uitschakelen of herstarten vanuit Linux Mint.
Sinds wanneer die optie voor vorige versies erbij staat kan ik niet zeggen want dat was me nog niet opgevallen totdat ik die afsluitproblemen gisteren heb gekregen. Ik weet niet wanneer hij die nieuwere
versie erop gezet heeft. Ik heb gezien dat de versie op de live-dvd ook 3.0.0-12 is en dat is die wat ik geïnstalleerd heb. Ik heb daarna wel alle updates die beschikbaar waren geïnstalleerd, maar ik weet niet
of die er toen al tussen stond. Dit alles staat er nu al bijna een week zo op en die afsluitproblemen zijn gisteren begonnen.

Voor mij is dit allemaal redelijk nieuw, want ik kan mijn weg wel vinden in windows maar veel ervaring met linux heb ik (nog) niet. Ik heb Ubuntu verschillende keren getest en een tijdje met 10.04 naast windows
gewerkt, maar geraakte er niet echt gewend aan. Maar ik wil met linux verder gaan en daarom wil ik het nu proberen met Mint. Ik vindt het wel spijtig dat ik deze problemen heb, maar van de andere kant is dit
de beste manier om het te leren.

Alvast heel hard bedankt voor de hulp!
Tool_Max
Level 1
Level 1
 
Posts: 6
Joined: Tue Feb 21, 2012 6:31 am

Re: Dualboot met Windows7 werkt niet

Postby Tool_Max on Fri Feb 24, 2012 10:21 am

HughT wrote:
Ik heb dit forum al volledig afgezocht en van alles uitgeprobeerd en van alles uitgeprobeerd
What have you tried?
Have you tried this from a live CD?
Code: Select all
sudo mount /dev/sda? /mnt
replace ? with the appropriate partition for Mint

Code: Select all
sudo grub-install --root-directory=/mnt /dev/sda
note - there's a gap between =/mnt and /dev, and no partition number after sda

re-boot into Mint then
Code: Select all
sudo update-grub


hope this helps


Thanks for the advice, but I have tried it all and nothing helps.
Tool_Max
Level 1
Level 1
 
Posts: 6
Joined: Tue Feb 21, 2012 6:31 am

Re: Dualboot met Windows7 werkt niet

Postby xenopeek on Fri Feb 24, 2012 12:38 pm

Probleem is denk ik dat Grub2 geinstalleerd is op je ntfs partitie /dev/sdb1. Dat lijkt mij de Windows boot partitie, daar zou geen Grub2 op moeten staan volgens mij.
sdb1: __________________________________________________________________________

File system: ntfs
Boot sector type: Grub2 (v1.99)
Boot sector info: Grub2 (v1.99) is installed in the boot sector of sdb1
and looks at sector 39496288 of the same hard drive
for core.img. core.img is at this location and looks
for on this drive. No errors found in the Boot
Parameter Block.

Vergelijkbaar probleem in dit topic; viewtopic.php?f=90&t=95062

Voor wat betreft het probleem met shutdown, het kan zijn dat de 3.0.0-16 kernel niet goed samenwerkt met jouw hardware, en de 3.0.0-12 kernel wel. Ik zou verwachten dat dit met de ACPI te maken heeft.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14889
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Dualboot met Windows7 werkt niet

Postby Tool_Max on Fri Feb 24, 2012 3:12 pm

Hallo,

ik heb juist het topic dat je vermeld eens doorgenomen, en ik was toevallig al zover geraakt zoals daar beschreven staat. Ik had ondertussen de boot-repair
geprobeerd en had ook de windows fixboot oplossing al gevonden en geprobeerd, maar beiden zonder resultaat. Met boot-repair geraakt ik vast doordat ik
in een terminal-venster de bestaande grub moet verwijderen met het commando
Code: Select all
sudo apt-get purge -y --force-yes grub-common

Dit lukt volledig, maar als ik dan verder wil gaan met boot-repair dan krijg ik de melding dat grub niet verwijderd is en dat ik het opnieuw moet proberen.
Ik heb dat verschillende keren opnieuw geprobeerd, maar volgens het terminal-venster is er geen grub meer te vinden en in boot-repair blijft hij zeggen
dat grub niet verwijderd is. Kan het zijn dat hij die 2de grub op mijn windows-partitie ziet staan en hoe moet ik die eventueel verwijderen?

Bij de herstelprocedure in windows recovery krijg ik bij de opdracht bootrec /fixboot de melding "kan geen element vinden". Hier zit ik dus ook vast.

Hoe die grub op de windows partitie terecht gekomen is kan ik ook niet verklaren. Ik heb Mint geïnstalleerd op een partitie waarop ervoor Ubuntu heeft gestaan.
Deze heb ik eerst volledig leeg gemaakt en daarna heb ik daar Mint op geïnstalleerd. Die partities staan wel op dezelfde fysieke harde schijf, kan dat een probleem zijn?

Ivm het afsluit- en herstartprobleem, zou dit aan mijn videokaart kunnen liggen? Ik heb een ATI-videokaart en toen ik Mint geïnstalleerd had kreeg ik dadelijk een update
voor mijn drivers van mijn videokaart om te installeren. Toen dat gedaan was en ik herstart had, had ik niks dan problemen met de weergave van Mint. Beelden bleven hangen,
er verschenen rare tekens en blokjes, alles liep door mekaar, enz... Ik heb die update toen ongedaan gemaakt en toen werkte alles terug zoals het moest. Ik heb op de site van
AMD/ATI de recentste drivers voor Linux willen afhalen, maar die link wil niet werken. Dus daar kan ik verder ook niks meer proberen vrees ik.

Ik zou dit graag in orde krijgen, dus ik hoop dat jullie me nog wat verder kunnen/willen helpen. Ik zal ook het andere topic volgen om te zien of daar een oplossing uit komt.

Heel fel bedankt voor de hulp.
Tool_Max
Level 1
Level 1
 
Posts: 6
Joined: Tue Feb 21, 2012 6:31 am

Re: Dualboot met Windows7 werkt niet

Postby Tool_Max on Sat Feb 25, 2012 12:40 pm

Voor mijn oplossing voor het probleem dat Windows7 niet meer start, zie mijn post in volgend topic:
http://forums.linuxmint.com/viewtopic.php?f=90&t=95062

Een oplossing voor mijn Linux Mint heb ik niet, krijg die grub op geen enkele manier hersteld.
Tool_Max
Level 1
Level 1
 
Posts: 6
Joined: Tue Feb 21, 2012 6:31 am

Re: Dualboot met Windows7 werkt niet

Postby AlbertP on Thu Mar 15, 2012 2:52 pm

Je had Grub op /dev/sdb1 geïnstalleerd, in plaats van de MBR van je harde schijf (/dev/sdb of /dev/sda - afhankelijk van welke schijf je BIOS opstart)
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6517
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Linux Mint is funded by ads and donations.
 

Return to Nederlands (Dutch)

Who is online

Users browsing this forum: No registered users and 1 guest