Sonido con cortes

Spanish Forum

Moderator: vrkalak

Sonido con cortes

Postby Sanva on Wed Jul 15, 2009 11:44 am

Hola.

Os escribo porque estoy teniendo problemas algo raritos con en audio en Linux Mint 7. Resulta que si pongo el Sonbird a reproducir música de vez en cuando algunas partes de la canción se atropellan, como si estuviese reproduciendo un CD rayado o algo por el estilo. Y no creo que sea cosa del Songbird, ya que he probado con el botón Probar de las Preferencias de sonido y sí, suena el típico pitido uniforme y constante, pero si lo dejo un rato de vez en cuando suenan sonidos bastante desagradables (me dan bastante grima). He probado con autodetectar, ALSA y Pulse Audio y todos hacen lo mismo...

Supongo que relacionado con esto, cuando tengo el emesene (un programa de mensajería para la red MSN) en un estado distinto a no disponible en lugar de producirse un sonidillo indicándome que se ha conectado algún contacto se produce un sonido parecido a que alguien arrugue algún tipo de material que no logro describir... realmente me da muchísima grima, es muy molesto.

Supongo que ambos problemas estarán relacionados con la tarjeta de sonido, pero es que cuando utilizaba Linux Mint 6 nunca tuve ningún problema de este tipo :? .

Por cierto, y por si sirve de algo, el sistema es un Intel Core 2 Duo (2.0 GHz) con 2GB DDR2 con dos monitores (en forma de escritorio extendido) y esta es la información relativa a mi tarjeta de sonido:

description: Audio device
product: 82801H (ICH8 Family) HD Audio Controller
vendor: Intel Corporation
physical id: 1b
bus info: pci@0000:00:1b.0
version: 03
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: driver=HDA Intel latency=0 module=snd_hda_intel


Saludos y gracias por leerme.
Sanva
Level 1
Level 1
 
Posts: 46
Joined: Fri Aug 15, 2008 4:31 am

Linux Mint is funded by ads and donations.
 

Re: Sonido con cortes

Postby MarGot333 on Fri Jul 17, 2009 8:16 am

A mí me pasaba con el Rhytmbox que la música se oía mal, como con un ruido de fondo, se lo solucione bajando un poquito (hasta que dejara de hacer el ruido) la parte de PCM y Front en el control de volumen... no sé si eso te servirá de algo :roll:

Suerte!
Hay un pasado que se fue para siempre, pero hay un futuro que todavía es nuestro
User avatar
MarGot333
Level 1
Level 1
 
Posts: 5
Joined: Wed Jul 15, 2009 5:04 pm

Re: Sonido con cortes

Postby Sanva on Tue Jul 21, 2009 5:47 am

Lo he probado y no parece que tenga nada que ver... realmente creo que lo mío debe ser algún problema con los buffers, pues parece que el sonido se atropella, pero no se cómo comprobar si es de eso ni como solucionarlo...

De todas formas gracias por tu contestación.
Sanva
Level 1
Level 1
 
Posts: 46
Joined: Fri Aug 15, 2008 4:31 am

Re: Sonido con cortes

Postby mercurio2054 on Thu Aug 06, 2009 10:24 pm

otra vez, otro post mas que no ayudo :P... pero te recomiendo que vayas tambien a algun foro de ubuntu. es casi lo mismo, mientras tanto vere si busco en internet tu problema.
mercurio2054
Level 1
Level 1
 
Posts: 14
Joined: Wed Aug 05, 2009 7:53 pm

Re: Sonido con cortes

Postby myspacecommassergio on Tue Dec 29, 2009 7:44 pm

Brother, deseo que prubes algo

Mi Laptop(Notebook) es un HP tiene las bocinas integrada hace poco estaba jugando un video juego online y un tipo grito por microfono y me revento una de las bocinas :shock:

Despues de esto tuve ese mismo problema, cuando le puse unas bocinas externales a mi ordenador por medio del headphone jack, el problema se resolvio. Por mucho tiempo pensaba que era el software del equipo pero resulto ser la bocina reventada. No entiendo porque pero cunado una bocina se revento el otro hacia buyas de "click" y no reproducia el audio bien tal y como dijiste tu sonaba como un disco rayado. Pensaba que no podia ser la bocina(porque una me sirvia) pero probe con articulares, despues con otras bocinas externales, y *FUACATA* problema resuelto :wink:

Trata otras bocinas aver. Tal vez sea el hardware y no el software. No soy un tecnico de linux pero por la mayor parte esto fue la solucion a mi problema.
:lol:
Prueba con bocinas externales a ver si se te quita el skipping ese que tiene. Tal vez eso solucione tu problema si no pues no tengo ni idea de lo que pueda ser. :(

Juega con las preferencias de audio a ver si eso te resuelve mejor(si utilizando el headphone jack con articulares/alta voces no te resuelve).

Que tengas un buen dia y ojala que resuelvas este dilema pronto... si encontraste otra solucion que no fue la antes mencionada recuerda poner aqui en el forro como solucionaste tu problema para los demas que estan en tu pocision tambien puedan resolver. Espero que esto te haya ayudado :!:
:D :D :D :D :D 8) :D :D :D :D :D
User avatar
myspacecommassergio
Level 3
Level 3
 
Posts: 135
Joined: Sun Dec 13, 2009 8:02 am

Re: Sonido con cortes

Postby Sanva on Wed Dec 30, 2009 6:00 am

Gracias por tu respuesta, pero no creo que tenga nada que ver.

Volví a instalar el sistema y ahora funciona perfectamente (alguna que otra vez se atropella, pero es muy raro... solo ocurre si el sistema está muy muy cargado).

Yo creo que debió ser algún problema de configuración de los buffers de audio o algo así...

De nuevo gracias por tu sugerencia.
Sanva
Level 1
Level 1
 
Posts: 46
Joined: Fri Aug 15, 2008 4:31 am

Re: Sonido con cortes

Postby myspacecommassergio on Fri Jan 01, 2010 1:18 am

Que rarro men... sera un driver?
User avatar
myspacecommassergio
Level 3
Level 3
 
Posts: 135
Joined: Sun Dec 13, 2009 8:02 am

Re: Sonido con cortes

Postby Sanva on Fri Jan 01, 2010 1:01 pm

No creo, ya te digo que creo que sería de algún error de configuración (quizá algo quedó mal configurado en alguna actualización o algo así).
Sanva
Level 1
Level 1
 
Posts: 46
Joined: Fri Aug 15, 2008 4:31 am

Re: Sonido con cortes

Postby myspacecommassergio on Sun Jan 03, 2010 5:52 am

creo que sería de algún error de configuración (quizá algo quedó mal configurado en alguna actualización o algo así).


Lo unico que me puedo imaginar es que sea que el volumen este demasiado alto o muy bajo pero dudo que eso sea el problema... que sera chico esta rarro este post porque no puedo pensar en ningun arreglo para esto. Ni idea tengo yo de lo que pueda ser :? :/
User avatar
myspacecommassergio
Level 3
Level 3
 
Posts: 135
Joined: Sun Dec 13, 2009 8:02 am

Quiza necesites asignar mayor prioridad a tu reproductor

Postby KDE-Spirit on Sun Mar 14, 2010 2:10 am

A mi me pasa que el sonido cada vez que uso el reproductor al usar una aplicacion que exprima la cpu se entrecorta sobre todo cuando utilizo un programa que use internet como firefox, o instalo un programa, lo que yo hago es asignar una alta prioridad de procesador para el reproductor de audio, esto se logra usando el comando nice, podrias probar lanzando el programa desde la terminal como te indico aquí (si no sabes que son las prioridades y el comando nice busca en google, hay mucha info sobre el tema):

sudo nice --19 amarok (en lugar de amarok pon el nombre de la aplicacion que quieres usar, por ejemplo songbird),

Con esto se iniciará el programa con una prioridad nice de -19 que es lo mas bestia, yo diría que es un tanto brutal darle tanta prioridad al programa, con esto ya no suena entrecortado con tanta frecuencia, aunque no se eliminan todos los cortes, si que disminuyen bastante.

Prueba con esto, si te funciona, entonces te puedo ayudar para que el programa se inicie automaticamente con una mayor prioridad sin necesidad de recurrir a la terminal cada vez que abras el programa.

Hasta la próxima :twisted:
KDE-Spirit
Level 1
Level 1
 
Posts: 7
Joined: Sun Mar 14, 2010 1:40 am

Linux Mint is funded by ads and donations.
 

Return to Español (Spanish)

Who is online

Users browsing this forum: No registered users and 2 guests