(Solucionado) Problema con microfono en chat

Spanish Forum

Moderator: vrkalak

(Solucionado) Problema con microfono en chat

Postby fcmsoft on Fri Feb 25, 2011 11:05 am

Hola!

Les cuento que hace un tiempo que uso Mint, y estoy muy contenta porque me ha solucionado muchos problemas con mi trabajo.
Pero tengo un problema que debo solucionar urgente y ya he probado de todo... y no sale, así que necesito de su ayuda. Gracias de antemano.

La cuestión es que tengo una notebook, Hp Pavillion dv6700, y el Mint me tomo todos los drivers bien. El problema en cuestión es con el micrófono, que anda con la grabadora de sonidos, pero no anda en ningún programa de chat, ni siquiera con el google talk desde la pagina de Gmail. Tampoco con el Pidgin que es el q uso para chatear, y necesito poder hablar con mis clientes...

¿Alguna idea de qué puede ser?

Gracias!
Last edited by fcmsoft on Mon Mar 21, 2011 7:51 pm, edited 1 time in total.
fcmsoft
Level 1
Level 1
 
Posts: 4
Joined: Fri Feb 25, 2011 10:57 am

Linux Mint is funded by ads and donations.
 

Re: Problema con microfono en chat

Postby Sebakon on Sat Feb 26, 2011 8:28 pm

Hola de nuevo!!
como les repito, yo tenia el mismo problema, asi que aqui les dejo la solución en 3 sencillos pasos:

1) Abran una Terminal y pongan lo siguiente:
Code: Select all
sudo gedit /etc/modprobe.d/sound.conf


2) les va abrir un documento, al final de este agreguen esto:
Code: Select all
options snd-hda-intel model=ideapad

y guarden.
si el documento no existe (no había nada dentro) guardenlo de todas maneras.

3) Reinicien y listo!!! :D :D :D :D

con esto ya les debería funcionar el microfono y los auriculares (les apuesto que tambien tenian el problema de que cuando ponian auriculares, no les funcionaban)

Ahora pueden Disfrutar su Linux Mint 10 al maximo!
Linux User # 528913
User avatar
Sebakon
Level 1
Level 1
 
Posts: 14
Joined: Wed Jan 12, 2011 4:37 pm

Re: Problema con microfono en chat

Postby fcmsoft on Mon Mar 07, 2011 7:53 pm

Gracias por contestar

Pero sigo sin poder resolver mi problema aunque seguí los pasos que indicas. Lo que pasa es que a mi me anda el sonido perfecto. El único problema que tengo es cuando quiero conversar por el chat, recibo bien el audio, pero la otra persona no me escucha a mi, como si no anduviese el micrófono. Pero el micrófono anda porque probé de grabar audio y lo hizo bien... ya no se que puede ser.

A nadie mas le paso algo así?

Puede influir que tengo Linux Mint 9? Tendré que actualizar el kernel o algo así?

Gracias
fcmsoft
Level 1
Level 1
 
Posts: 4
Joined: Fri Feb 25, 2011 10:57 am

Re: Problema con microfono en chat

Postby Sebakon on Sat Mar 12, 2011 10:42 pm

OK!
Aqui vamos con la revancha!
si no les funciona esto, ya no podre seguir ayudandoles! les aviso, esto sera muy, muy, muy,muy largooooo!
Nota: ahora, como decimos en mi pais, ahi que entrar a picar! y asi se hace!!!

1º Quitar todo rastro de Pulseaudio:
Renombramos el archivo "alsa.conf" en /usr/share/alsa con el comando:
Code: Select all
sudo cp /usr/share/alsa/alsa.conf /usr/share/alsa/alsa.conf.bak


Añadimos los repositorios "gnome-media/applets/settings-daemon" para cambiar el control de sonido de Pulse por el de "gstreamer-based" (Esto es lo ideal para usuarios que quieren OSS4 en GNOME) con:
Code: Select all
sudo apt-add-repository ppa:dtl131/ppa


Actualizamos el sistema con los siguientes comandos:
Code: Select all
sudo apt-get update
sudo apt-get dist-upgrade


Instalamos los siguientes paquetes de alsa con el siguiente comando:
Code: Select all
sudo apt-get install esound esound-clients esound-common alsa-base alsa-tools alsa-utils alsa-oss linux-sound-base python-alsaaudio gnome-media libsdl1.2debian-alsa


Desinstalamos los siguientes paquetes de pulseaudio con el siguiente comando:
Code: Select all
sudo apt-get purge libcanberra-pulse pulseaudio pulseaudio-esound-compat pulseaudio-module-bluetooth pulseaudio-module-gconf pulseaudio-module-udev pulseaudio-module-x11 gstreamer0.10-pulseaudio pulseaudio-utils pavucontrol


2º Reinstalar Alsa

Para reinstalar Alsa y dejarlo como el primer día ejecutamos el siguiente comando:
Code: Select all
sudo aptitude --purge reinstall linux-sound-base alsa-base alsa-utils linux-image-`uname -r` linux-ubuntu-modules-`uname -r` libasound2


3º Reiniciar
Ya tenemos Alsa como gestor del sonido y sin resto alguno de Pulseaudio.
Nota: si no aparece el icono del sonido en el panel superior, hacemos clic derecho sobre él, pulsamos "añadir al panel", seleccionamos "control de volumen" y pulsamos añadir.
Fuente: http://ubuntu-guia.blogspot.com/2010/11/quitar-pulseaudio-reinstalar-alsa.html

Al reiniciar vean si tienen estos paquetes instalados en Synaptic:
Code: Select all
alsaplayer-jack
libjack0
libavc1394-0
libiec61883-0
libfreebob0


ahora tendremos que hacer esto:
Code: Select all
sudo gedit /etc/modprobe.d/alsa-base.conf

y poner al final esto:
Code: Select all
options snd-hda-intel model=ideapad


Reiniciar otra vez (la ultima) y listo!
Nota 1: ahora que tienen alsa prueben esto; en el icono de sonido, aprieten boton derecho y pongan Abrir el control de volumen o Preferencias de sonido. notaran que la ventana es diferente. Ahora vayan a preferencias, y marquen la casilla que dice digital, y desmarquen la que dice capturar. ahora prueben en Skype!

Nota 2: Por favor, esta es una petición personal, cuando acaben de hacer esto, por favor comenten este post lo más rapido que puedan, para uno saber si les funciono o no, porque en lo personal yo siempre despues de poner un post, lo veo al otro dia, y al otro dia. si yo no veo respuestas significa que les sirvio entonces no me meto mas al foro por lo mismo, asi que si les sirvio plizzz, contesten luego.

Gracias por hacer nuestra comunidad más grande.

un abrazo.
Sebakon
Linux User # 528913
User avatar
Sebakon
Level 1
Level 1
 
Posts: 14
Joined: Wed Jan 12, 2011 4:37 pm

Re: Problema con microfono en chat

Postby fcmsoft on Sun Mar 13, 2011 2:47 am

Gracias!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Sos un genio!!!!!!!!!!!!

Seguí tus pasos y realmente me funcionó!!!!! Me solucionaste un problema, muchisimas gracias!!!!

A modo de conclusión: Cuando instalé Linux Mint me tomó todos los drivers bien, pero no podía chatear con audio, o sea, no me escuchaban en las videoconferencias o charlas con audio, yo escuchaba pero no me escuchaban a mi...

Ahora, gracias a la ayuda de Sebakon pude hacerlo funcionar.

gracias, y espero q le sirva a alguien más.
fcmsoft
Level 1
Level 1
 
Posts: 4
Joined: Fri Feb 25, 2011 10:57 am

Re: Problema con microfono en chat

Postby Sebakon on Sun Mar 13, 2011 8:36 pm

Si te sirvio, te recomiendo que edites el encabezado de este post, y entre parentesis antes del titulo le pones solucionado, por si acaso alguien le pasa lo mismo vera que aqui ahi una solucion y no una duda.

saludos.
Linux User # 528913
User avatar
Sebakon
Level 1
Level 1
 
Posts: 14
Joined: Wed Jan 12, 2011 4:37 pm

Re: (Solucionado) Problema con microfono en chat

Postby killerdog on Mon May 02, 2011 3:44 pm

Hola soy nuevo en Linux, Tengo una Toshiba satellite c645 sp4020M y linux mint 10 64bit fué la unica distro de las que probé que reconocio todo ecepto el audio a la primera y estuve mas de de una semana intentando hacer funcionar el audio hasta que encontre este hilo y funciono a la primera.

Muchisimas gracias ahora ya puedo empezar a preparar la maquina para trabajar de verdad me resolviiste un problemos estuve a punto de devolver la computadora.
killerdog
Level 1
Level 1
 
Posts: 1
Joined: Mon May 02, 2011 3:37 pm

Linux Mint is funded by ads and donations.
 

Return to Spanish

Who is online

Users browsing this forum: No registered users and 5 guests