Auricular-microfono no funciona

Spanish Forum

Moderator: vrkalak

Auricular-microfono no funciona

Postby autogestion on Sun Mar 06, 2011 6:24 pm

Hola,

Un amigo tiene LinuxMint 10 instalado en un portátil emachines E520 y quiere usar un conjunto de auriculares-microfono Huanjia HJ-820M.V pero no le funciona porque ni tan siquiera los detecta. Hemos probado esto viewtopic.php?f=68&t=66868&p=388302&hilit=auriculares#p388302 pero no ha funcionado.

¡Saludos!
autogestion
Level 1
Level 1
 
Posts: 6
Joined: Tue Oct 12, 2010 10:18 am

Linux Mint is funded by ads and donations.
 

Re: Auricular-microfono no funciona

Postby Sebakon on Sat Mar 12, 2011 10:51 pm

OK!
Aqui vamos con la revancha!
si no les funciona esto, ya no podre seguir ayudandoles! les aviso, esto sera muy, muy, muy,muy largooooo!
Nota: ahora, como decimos en mi pais, ahi que entrar a picar! y asi se hace!!!

1º Quitar todo rastro de Pulseaudio:
Renombramos el archivo "alsa.conf" en /usr/share/alsa con el comando:
Code: Select all
sudo cp /usr/share/alsa/alsa.conf /usr/share/alsa/alsa.conf.bak


Añadimos los repositorios "gnome-media/applets/settings-daemon" para cambiar el control de sonido de Pulse por el de "gstreamer-based" (Esto es lo ideal para usuarios que quieren OSS4 en GNOME) con:
Code: Select all
sudo apt-add-repository ppa:dtl131/ppa


Actualizamos el sistema con los siguientes comandos:
Code: Select all
sudo apt-get update
sudo apt-get dist-upgrade


Instalamos los siguientes paquetes de alsa con el siguiente comando:
Code: Select all
sudo apt-get install esound esound-clients esound-common alsa-base alsa-tools alsa-utils alsa-oss linux-sound-base python-alsaaudio gnome-media libsdl1.2debian-alsa


Desinstalamos los siguientes paquetes de pulseaudio con el siguiente comando:
Code: Select all
sudo apt-get purge libcanberra-pulse pulseaudio pulseaudio-esound-compat pulseaudio-module-bluetooth pulseaudio-module-gconf pulseaudio-module-udev pulseaudio-module-x11 gstreamer0.10-pulseaudio pulseaudio-utils pavucontrol


2º Reinstalar Alsa

Para reinstalar Alsa y dejarlo como el primer día ejecutamos el siguiente comando:
Code: Select all
sudo aptitude --purge reinstall linux-sound-base alsa-base alsa-utils linux-image-`uname -r` linux-ubuntu-modules-`uname -r` libasound2


3º Reiniciar
Ya tenemos Alsa como gestor del sonido y sin resto alguno de Pulseaudio.
Nota: si no aparece el icono del sonido en el panel superior, hacemos clic derecho sobre él, pulsamos "añadir al panel", seleccionamos "control de volumen" y pulsamos añadir.
Fuente: http://ubuntu-guia.blogspot.com/2010/11/quitar-pulseaudio-reinstalar-alsa.html

Al reiniciar vean si tienen estos paquetes instalados en Synaptic:
Code: Select all
alsaplayer-jack
libjack0
libavc1394-0
libiec61883-0
libfreebob0


ahora tendremos que hacer esto:
Code: Select all
sudo gedit /etc/modprobe.d/alsa-base.conf

y poner al final esto:
Code: Select all
options snd-hda-intel model=ideapad


Reiniciar otra vez (la ultima) y listo!
Nota 1: ahora que tienen alsa prueben esto; en el icono de sonido, aprieten boton derecho y pongan Abrir el control de volumen o Preferencias de sonido. notaran que la ventana es diferente. Ahora vayan a preferencias, y marquen la casilla que dice digital, y desmarquen la que dice capturar. ahora prueben en Skype!

Nota 2: Por favor, esta es una petición personal, cuando acaben de hacer esto, por favor comenten este post lo más rapido que puedan, para uno saber si les funciono o no, porque en lo personal yo siempre despues de poner un post, lo veo al otro dia, y al otro dia. si yo no veo respuestas significa que les sirvio entonces no me meto mas al foro por lo mismo, asi que si les sirvio plizzz, contesten luego.

Gracias por hacer nuestra comunidad más grande.

un abrazo.
Sebakon
Linux User # 528913
User avatar
Sebakon
Level 1
Level 1
 
Posts: 14
Joined: Wed Jan 12, 2011 4:37 pm

Re: Auricular-microfono no funciona

Postby masmadera on Thu May 17, 2012 8:23 am

:D
Hola , buen dia!!

Solo decirte que me registrado solamente para darte las gracias y decirte que a mi si me ha servido..
...llevaba ya intentandolo por unos cuantos sitios y maneras pero con tu post va.
(no se escucha muy fino y se corta a veces), webcam 046d:0819 : Va en Skype 2.2.0.35 beta y linuxMint 12 LXDE)
Un saludo y gracias
masmadera
Level 1
Level 1
 
Posts: 1
Joined: Wed May 16, 2012 6:44 am

Re: Auricular-microfono no funciona

Postby osmag on Thu Aug 16, 2012 6:33 am

Todo funciona a maravilla. Solo dos cosas:

1- la libreria libfreebob0 no esta en ningun repocitori que se pueda cargar automaticamente con apt-get o synaptic. la descargué como paquete deb y la instalé, pero no se si era indispensable.

2- el control de sonido estandard, ese que esta en el panel de cinnamon, ha desaparecido. seria comodo tenerlo. pero si funciona asi, esta biren. buscaré el modo de sustituirla.

gracias.

o
osmag
Level 1
Level 1
 
Posts: 1
Joined: Thu Aug 16, 2012 6:27 am


Return to Español (Spanish)

Who is online

Users browsing this forum: No registered users and 3 guests