prioblemas con dependencias incumplidas (solucionado)

Spanish Forum

Moderator: vrkalak

prioblemas con dependencias incumplidas (solucionado)

Postby Lexodus on Sun May 01, 2011 6:22 pm

bueno es que he querido instalar tuxkart pero primero me manda un error
puse sudo apt-get install supertuxkart

y manda este:

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Tal vez quiera ejecutar 'apt-get -f install' para corregirlo:
Los siguientes paquetes tienen dependencias incumplidas:
finch : Depende: pidgin-data (>= 1:2.7.11) pero 1:2.7.3-1ubuntu3.2 va a ser instalado
pidgin : Depende: pidgin-data (>= 1:2.7.11) pero 1:2.7.3-1ubuntu3.2 va a ser instalado
supertuxkart : Depende: supertuxkart-data (= 0.7.1b-1~getdeb1) pero no va a instalarse
E: Dependencias incumplidas. Intente 'apt-get -f install' sin paquetes (o especifique una solución).

le he dado sudo apt-get install -f

lo cual manda este otro mensaje:

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Corrigiendo dependencias... Listo
El paquete indicado a continuación se instaló de forma automática y ya no es necesarios.
libtextcat-data-utf8
Utilice «apt-get autoremove» para eliminarlos.
Se instalarán los siguientes paquetes extras:
pidgin-data
Se actualizarán los siguientes paquetes:
pidgin-data
1 actualizados, 0 se instalarán, 0 para eliminar y 14 no actualizados.
2 no instalados del todo o eliminados.
Se necesita descargar 0B/8604kB de archivos.
Se utilizarán 24.2MB de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]? s
(Leyendo la base de datos ... 00%
171811 ficheros y directorios instalados actualmente.)
Preparando para reemplazar pidgin-data 1:2.7.3-1ubuntu3.2 (usando .../pidgin-data_1%3a2.7.11-1~lffl~maverick~ppa_all.deb) ...
Desempaquetando el reemplazo de pidgin-data ...
dpkg: error al procesar /var/cache/apt/archives/pidgin-data_1%3a2.7.11-1~lffl~maverick~ppa_all.deb (--unpack):
intentando sobreescribir `/usr/share/pixmaps/pidgin/protocols/16/facebook.png', que está también en el paquete pidgin-facebookchat 1.67.1-1
dpkg-deb: el subproceso copiado fue terminado por la señal (Tubería rota)
Procesando disparadores para hicolor-icon-theme ...
Se encontraron errores al procesar:
/var/cache/apt/archives/pidgin-data_1%3a2.7.11-1~lffl~maverick~ppa_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

busque algun problema similar intente lo que decia ahi con:

sudo rm /var/cache/apt/archives/pidgin-data_1%3a2.7.11-1~lffl~maverick~ppa_all.deb

y al poner sudo apt-get -f install

me manda de nuevo

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Corrigiendo dependencias... Listo
El paquete indicado a continuación se instaló de forma automática y ya no es necesarios.
libtextcat-data-utf8
Utilice «apt-get autoremove» para eliminarlos.
Se instalarán los siguientes paquetes extras:
pidgin-data
Se actualizarán los siguientes paquetes:
pidgin-data
1 actualizados, 0 se instalarán, 0 para eliminar y 14 no actualizados.
2 no instalados del todo o eliminados.
Necesito descargar 8604kB de archivos.
Se utilizarán 24.2MB de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]? s
Des:1 http://ppa.launchpad.net/ferramroberto/pidgin/ubuntu/ maverick/main pidgin-data all 1:2.7.11-1~lffl~maverick~ppa [8604kB]
Descargados 8604kB en 1min. 12seg. (119kB/s)
(Leyendo la base de datos ... 00%
171811 ficheros y directorios instalados actualmente.)
Preparando para reemplazar pidgin-data 1:2.7.3-1ubuntu3.2 (usando .../pidgin-data_1%3a2.7.11-1~lffl~maverick~ppa_all.deb) ...
Desempaquetando el reemplazo de pidgin-data ...
dpkg: error al procesar /var/cache/apt/archives/pidgin-data_1%3a2.7.11-1~lffl~maverick~ppa_all.deb (--unpack):
intentando sobreescribir `/usr/share/pixmaps/pidgin/protocols/16/facebook.png', que está también en el paquete pidgin-facebookchat 1.67.1-1
dpkg-deb: el subproceso copiado fue terminado por la señal (Tubería rota)
Procesando disparadores para hicolor-icon-theme ...
Se encontraron errores al procesar:
/var/cache/apt/archives/pidgin-data_1%3a2.7.11-1~lffl~maverick~ppa_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

bien si alguien tiene idea de aque se deba de antemano gracias pro su ayuda solo que esta ocacion no pude solucionar el problema buscando

Last edited by Lexodus on Mon May 02, 2011 3:35 am, edited 1 time in total.
Lexodus
Level 1
Level 1
 
Posts: 3
Joined: Tue Feb 01, 2011 6:25 pm

Linux Mint is funded by ads and donations.
 

Re: prioblemas con dependencias incumplidas

Postby linmint777 on Sun May 01, 2011 9:48 pm

No das un dato imprtante para ayudarte, pero voy a suponer:

1.- Si tienes LMDE:

Des:1 http://ppa.launchpad.net/ferramroberto/pidgin/ubuntu/ maverick/main pidgin-data all 1:2.7.11-1~lffl~maverick~ppa [8604kB]


el problema es de dependencias, ya que estas mezclando repositorios ppa para ubuntu, lo cual es totalmente erroneo, debido a que Debian no es compatible con Ubuntu.

2.- Si tienes Mint basada en Ubuntu:
Yo siempre recomiendo no instalar repositorios PPA, ya que son personales, no oficiales y mantenidos por gente que no pertenecen al equipo de desarrolladores de Ubuntu, y por lo tanto son mas riesgosos para tu sistema y a veces no los actualizan como es debido.
en su lugar, si quieres tener lo ultimo de la paqueteria, aconsejo 3 cosas:
1.- buscar e instalar el paquete mas actualizado en .deb. (de preferencia de la pagina oficial)
2.-descargar y compilar desde el tarball (fuentes).
3.- usar una distro con paqueteria mas actualizada:
Gentoo o Arch.
Linux Mint #1 Distro.
http://mintyubuntu.blogspot.com
User avatar
linmint777
Level 5
Level 5
 
Posts: 648
Joined: Thu Nov 26, 2009 11:00 am

Re: prioblemas con dependencias incumplidas

Postby Lexodus on Sun May 01, 2011 9:54 pm

Bueno estoy en Mint 10 con gnome el basado en ubuntu y bueno si he tenido ganas de probar otras distros pero aun estoy familiarizandome con linux, pensaba en debian pero veo que no esta en al srecomendacions que me das y Arch dicen que esta un tanto complicada al inicio para alguien que inicia, pero con probar no pierdo nada. bueno gracias pro la respuesta y este problema buscando vi que no soy el unico que lo tiene.

Bueno buscando logre quitar ese ppa que era el que me causaba problemas gracias por ayudarme a darme cuenta donde estaba el problema, pues para arreglarlo fue sencillo primero en /etc/apt/sources.list desmarque el repositorio y lo borro, aunke me daba problemas de /var/lib/dpkg/info borre todos los archivos de pidgin y en la terminal

sudo aptitude --purge remove pidgin-ppa

y con eso elimine todo rastro de lo que me causaba problemas
Lexodus
Level 1
Level 1
 
Posts: 3
Joined: Tue Feb 01, 2011 6:25 pm

Re: prioblemas con dependencias incumplidas (solucionado)

Postby linmint777 on Mon May 02, 2011 5:13 pm

pensaba en debian pero veo que no esta en al srecomendacions que me das


porque sus paquetes (testing) son menos actuales que los de Ubuntu y derivadas y creo que tu quieres tener las versiones mas actualizadas (los ppa para eso se crearon, para instalar el software mas actual que el que viene en los repositorios)

Arch dicen que esta un tanto complicada al inicio para alguien que inicia
}

Si.
Linux Mint #1 Distro.
http://mintyubuntu.blogspot.com
User avatar
linmint777
Level 5
Level 5
 
Posts: 648
Joined: Thu Nov 26, 2009 11:00 am

Re: prioblemas con dependencias incumplidas (solucionado)

Postby burjans on Tue May 03, 2011 2:38 am

Bueno estoy en Mint 10 con gnome el basado en ubuntu y bueno si he tenido ganas de probar otras distros pero aun estoy familiarizándome con linux, pensaba en debian pero veo que no esta en las recomendaciones


Bueno, no se por que pero creo que LMDE es una muy buena opción, ya que es un Debian pero mas liviano para los que como yo queremos aprender, anímate y verás.

Por otra parte, dices que usas Linux Mint 10 y estabas agregando un PPA de Maverick que es Ubuntu 9.10, por lo que si no estoy equivocado deberías usar la rama de Ubuntu Lucid .... no ? :idea:

Por favor que alguien me corrija si estoy equivocado :!:
Debian Testing Xfce running on Pentium 4 / 512 MB - RAM
User avatar
burjans
Level 2
Level 2
 
Posts: 79
Joined: Fri Sep 10, 2010 2:22 pm

Re: prioblemas con dependencias incumplidas (solucionado)

Postby Exar on Tue May 03, 2011 5:19 am

burjans wrote:
Bueno estoy en Mint 10 con gnome el basado en ubuntu y bueno si he tenido ganas de probar otras distros pero aun estoy familiarizándome con linux, pensaba en debian pero veo que no esta en las recomendaciones

Por otra parte, dices que usas Linux Mint 10 y estabas agregando un PPA de Maverick que es Ubuntu 9.10, por lo que si no estoy equivocado deberías usar la rama de Ubuntu Lucid .... no ? :idea:

Por favor que alguien me corrija si estoy equivocado :!:


Ciertamente, debería de agregar las PPA correspondientes a su versión.

Saludos
User avatar
Exar
Level 1
Level 1
 
Posts: 18
Joined: Mon Apr 25, 2011 6:30 am

Re: prioblemas con dependencias incumplidas (solucionado)

Postby linmint777 on Tue May 03, 2011 12:52 pm

Por favor que alguien me corrija si estoy equivocado


Si y No.

No estas equivocado porque efectivamente se debe instalar la version de los PPA correspondiente a la distro.
sigue leyendo para que te enteres porque Si estas equivocado.......

Ciertamente, debería de agregar las PPA correspondientes a su versión.

Por otra parte, dices que usas Linux Mint 10 y estabas agregando un PPA de Maverick que es Ubuntu 9.10, por lo que si no estoy equivocado deberías usar la rama de Ubuntu Lucid .... no ?


El chico que abrio el tema Si agrego el PPA correspondiente a linux mint 10 (maverick):

Des:1 http://ppa.launchpad.net/ferramroberto/pidgin/ubuntu/ maverick/main pidgin-data all 1:2.7.11-1~lffl~maverick~ppa [8604kB]

Asi que ese no era el problema, el problema era este:
Yo siempre recomiendo no instalar repositorios PPA, ya que son personales, no oficiales y mantenidos por gente que no pertenecen al equipo de desarrolladores de Ubuntu, y por lo tanto son mas riesgosos para tu sistema y a veces no los actualizan como es debido.
Linux Mint #1 Distro.
http://mintyubuntu.blogspot.com
User avatar
linmint777
Level 5
Level 5
 
Posts: 648
Joined: Thu Nov 26, 2009 11:00 am

Re: prioblemas con dependencias incumplidas (solucionado)

Postby Exar on Tue May 03, 2011 12:57 pm

linmint777 wrote:
Asi que ese no era el problema, el problema era este:
Yo siempre recomiendo no instalar repositorios PPA, ya que son personales, no oficiales y mantenidos por gente que no pertenecen al equipo de desarrolladores de Ubuntu, y por lo tanto son mas riesgosos para tu sistema y a veces no los actualizan como es debido.


Pues yo tengo pidgin en Julia por ese PPA y no he tenido ningun problema (ni con ningun otro PPA)...

Un saludo
Last edited by Exar on Tue May 03, 2011 12:59 pm, edited 1 time in total.
User avatar
Exar
Level 1
Level 1
 
Posts: 18
Joined: Mon Apr 25, 2011 6:30 am

Re: prioblemas con dependencias incumplidas (solucionado)

Postby burjans on Tue May 03, 2011 12:58 pm

linmint777

el PPA correspondiente a linux mint 10 (maverick):


Entonces por lo que comentas Linux Mint 9 es LTS y no Linux Mint 10 ... ahora si me he quedado frito, pensaba que Linux Mint 10 tenía como base Ubuntu 10.04. :?

No obstante, no te calientes, yo uso Linux Mint Debian Edition :wink:

salu2
Last edited by burjans on Tue May 03, 2011 1:33 pm, edited 3 times in total.
Debian Testing Xfce running on Pentium 4 / 512 MB - RAM
User avatar
burjans
Level 2
Level 2
 
Posts: 79
Joined: Fri Sep 10, 2010 2:22 pm

Re: prioblemas con dependencias incumplidas (solucionado)

Postby linmint777 on Tue May 03, 2011 1:11 pm

No obstante, no te calientes, yo uso Linux Mint Debian Edition :wink:


tambien yo.

Pues yo tengo pidgin en Julia por ese PPA y no he tenido ningun problema (ni con ningun otro PPA)...


Aunque sea la misma distro (julia) cada pc (hardware) y S.O. (configuracion postinstalacion y paqueteria, librerias ,etc.) son diferentes, a ti te puede funcionar algo que a otro no.

saludos.
Linux Mint #1 Distro.
http://mintyubuntu.blogspot.com
User avatar
linmint777
Level 5
Level 5
 
Posts: 648
Joined: Thu Nov 26, 2009 11:00 am

Re: prioblemas con dependencias incumplidas (solucionado)

Postby Exar on Tue May 03, 2011 1:12 pm

linmint777 wrote:Aunque sea la misma distro (julia) cada pc (hardware) y S.O. (configuracion postinstalacion y paqueteria, librerias ,etc.) son diferentes, a ti te puede funcionar algo que a otro no.

saludos.


Ciertamente.

Sólo por curiosidad, ¿que versión de pidgin teneis actualmente en LMDE?

Saludos
User avatar
Exar
Level 1
Level 1
 
Posts: 18
Joined: Mon Apr 25, 2011 6:30 am

Re: prioblemas con dependencias incumplidas (solucionado)

Postby linmint777 on Tue May 03, 2011 1:24 pm

la version 2.7.11
Linux Mint #1 Distro.
http://mintyubuntu.blogspot.com
User avatar
linmint777
Level 5
Level 5
 
Posts: 648
Joined: Thu Nov 26, 2009 11:00 am

Re: prioblemas con dependencias incumplidas (solucionado)

Postby Exar on Tue May 03, 2011 1:32 pm

linmint777 wrote:la version 2.7.11


Que es la última versión disponible, si no me equivoco.
Gracias por la información ;)
User avatar
Exar
Level 1
Level 1
 
Posts: 18
Joined: Mon Apr 25, 2011 6:30 am

Linux Mint is funded by ads and donations.
 

Return to Español (Spanish)

Who is online

Users browsing this forum: No registered users and 3 guests