Problema - Actualizar Java plugin (Firefox)

Spanish Forum

Moderator: vrkalak

Problema - Actualizar Java plugin (Firefox)

Postby espinaca on Sat Jan 21, 2012 6:19 am

Hola!!!
Uso Firefox y cuando voy a revisar si tengo los Plugins actualizados me encuentro con que el de Java no lo está.
Me dice que está en estado vulnerable y lo debo actualizar.
La versión que me indica Firefox que tengo es esta: Java (TM) Plug-in 1.6.0-26. Pero cuando voy al gestor de paquetes Synaptic me marca que tengo instalada esta: Java(TM) Plug-in, Java SE 6.
Si hago un update && upgrade no me lo actualiza.
¿Qué podria hacer para actualizarlo?
Intente descargar el nuevo Plugin de la web oficial de Java. Sigo sus instrucciones pero no lo logro instalar, ya sea por una cosa o por la otra. No se crear un enlace simbólico, no se en que carpeta instalar el Plugin... :?
Agradeceria que alguien me de una mano :D
espinaca
Level 1
Level 1
 
Posts: 29
Joined: Wed Jan 04, 2012 5:42 pm

Linux Mint is funded by ads and donations.
 

Re: Problema - Actualizar Java plugin (Firefox)

Postby xenopeek on Sat Jan 21, 2012 7:46 am

Cambiar a openjdk-6-jre y icedtea-plugin. Oracle (anteriormente SUN) se ha retirado la licencia para distribuir sus productos Java. Y OpenJDK 7 es la referencia de la aplicación Java 7. Oracle Java se basa en que a partir de ahora.

También puede añadir un PPA para Sun Java 6, que es más reciente.
Code: Select all
sudo add-apt-repository ppa:ferramroberto/java
sudo apt-get update
sudo apt-get install sun-java6-jdk sun-java6-plugin
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15262
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Problema - Actualizar Java plugin (Firefox)

Postby espinaca on Sat Jan 21, 2012 8:23 am

Ya instalé el Open JDK Java. Pero ahora tengo dos dudas...
Todavia sigo teniendo el Java común. ¿Deberia quitarlo y quedarme solo con el OpenJDK? ¿O Java es necesario para algo?
Consultando el gestor de paquetes Synaptic me indica que los Java que tengo instalados son estos: sun-java6-bin (non-free), sun-java6-jre (non-free), java-common, además de librerias y otras dependencias...
¿Es seguro quitar Java? ¿O deberia conservarlo?
Y la otra duda es que si voy a Firefox>Compĺementos>Plugins no me aparece ningun Plugin asociado a OpenJDK ni a Icedtea, ¿Esto es normal o deberia indicarme algo? ¿Cómo saber si tengo el Plugin de OpenJDK para Firefox bien instalado?

Gracias y disculpas si son demasiadas preguntas :oops:
espinaca
Level 1
Level 1
 
Posts: 29
Joined: Wed Jan 04, 2012 5:42 pm

Re: Problema - Actualizar Java plugin (Firefox)

Postby xenopeek on Sat Jan 21, 2012 8:39 am

Se puede quitar el viejo java. Pero no hace daño estar en el sistema así.
Code: Select all
sudo apt-get --purge autoremove sun-java6-jre

Establecer el valor predeterminado de Java:
Code: Select all
sudo update-alternatives --config java

Comprueba tus plugins aquí, se puede ver que Java se utiliza? No estoy usando el plugin de Java en la actualidad...
https://www.mozilla.org/es-ES/plugincheck/
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15262
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Problema - Actualizar Java plugin (Firefox)

Postby espinaca on Sat Jan 21, 2012 9:10 am

Quite el viejo Java.
Cuando ejecuto este comando:
Code: Select all
sudo update-alternatives --config java


Me sale esto:
Code: Select all
Sólo hay una alternativa en el grupo de enlaces java: /usr/lib/jvm/java-6-openjdk/jre/bin/java
Nada que configurar.


¿Hay algo mal?
Ahh y el Plugin, como decia antes, no aparece en Firefox. Solo me indica que tengo el Shockwave Flash.

Saludos
espinaca
Level 1
Level 1
 
Posts: 29
Joined: Wed Jan 04, 2012 5:42 pm

Re: Problema - Actualizar Java plugin (Firefox)

Postby xenopeek on Sat Jan 21, 2012 1:09 pm

La respuesta update-alternatives está bien. Se confirma que sólo tiene un Java instalado.

Compruebe Java: http://browserspy.dk/java.php
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15262
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Problema - Actualizar Java plugin (Firefox)

Postby espinaca on Mon Jan 23, 2012 10:28 am

Hola
Copio lo que me aparece en la tabla:

Java enabled No or unable to detect...
Java supported No or unable to detect...
Java version No or unable to detect...
Java using object and applet tag Java isn't installed or doesn't work

El plugin que me indica instalar para ver el contenido es este: Java Runtime Environment 1.6 u29
¿Deberia instalarlo? ¿Es la versión actualizada que me hacia falta?

Gracias de antemano.
espinaca
Level 1
Level 1
 
Posts: 29
Joined: Wed Jan 04, 2012 5:42 pm

Re: Problema - Actualizar Java plugin (Firefox)

Postby espinaca on Wed Jan 25, 2012 10:19 pm

Hola deberia instalar el plugin??
porque tal parece que el plugin de icedteal no me lo reconoce....
agradeceria tu ayuda vincent
espinaca
Level 1
Level 1
 
Posts: 29
Joined: Wed Jan 04, 2012 5:42 pm

Re: Problema - Actualizar Java plugin (Firefox)

Postby espinaca on Wed Feb 01, 2012 12:37 am

Perdoón si parezco pesado, pero me gustaria saber como instalar el plugin en su verión mas actualizada, que creo es la 1.6 u30
Cuando me dirijo a este enlace que me dejo vincent http://browserspy.dk/java.php esta me sugiere instalar el plugin de java 1.6 u29, ¿Deberia instalarlo? pregunto porque no me quiero hacer ningun lio :)
Gracias
espinaca
Level 1
Level 1
 
Posts: 29
Joined: Wed Jan 04, 2012 5:42 pm

Re: Problema - Actualizar Java plugin (Firefox)

Postby JaRG1 on Sun Feb 19, 2012 8:06 pm

Yo quisiera saber como quitar java y usar openJDK :mrgreen:
JaRG1
Level 1
Level 1
 
Posts: 1
Joined: Sun Feb 19, 2012 4:36 pm

Re: Problema - Actualizar Java plugin (Firefox)

Postby espinaca on Mon Feb 20, 2012 2:27 pm

JaRG1 wrote:Yo quisiera saber como quitar java y usar openJDK :mrgreen:


Para remover Java (Estaba puesto mas arriba):

Code: Select all
sudo apt-get --purge autoremove sun-java6-jre


Y para instalar Open jdk lo buscas en el gestor de software o de paquetes synaptic ;)
espinaca
Level 1
Level 1
 
Posts: 29
Joined: Wed Jan 04, 2012 5:42 pm

Linux Mint is funded by ads and donations.
 

Return to Español (Spanish)

Who is online

Users browsing this forum: No registered users and 5 guests