Sun Java LMDE Xfce4:lle?[RATKAISTU]

Finnish Forum

Sun Java LMDE Xfce4:lle?[RATKAISTU]

Postby savis21 on Sat Aug 18, 2012 8:48 am

Moi! Nyt ei ole enää saatavissa sun-java6-plugin pakettia Debian Mintille.. Mistäs sais toimivan Sun Javan asennettua, jotta saa Sampopankin toimimaan taas?
Last edited by savis21 on Thu Aug 23, 2012 9:46 am, edited 1 time in total.
savis21
Level 1
Level 1
 
Posts: 15
Joined: Sat Feb 25, 2012 10:03 am

Linux Mint is funded by ads and donations.
 

Re: Sun Java LMDE Xfce4:lle?

Postby oobetimer on Sun Aug 19, 2012 11:38 am

Sun Java on nykyyään Oracle Java. Sampo Pankki ei toimi kunnolla uusimalla Javalla millään käyttöjärjestelmällä, joten asenna hyvin toimiva Java 6.

1. Poista kaikki IcedTea alkuiset paketit Synaptic paketinhallinnassa

2. Lataa Oracle Java (self extracting) sen omalta nettisivulta
http://www.java.com/en/download/manual_v6.jsp

3. Tee hakemisto /usr/local/java
sudo mkdir -p /usr/local/java

4. Kopioi ladattu jre-6u33-linux-i586.bin tiedosto hakemistoon /usr/local/java ja siirry samaan hakemistoon.
Esimerkki:
sudo cp /home/ubuntu/Lataukset/jre-6u33-linux-i586.bin /usr/local/java
cd /usr/local/java

5. Anna tiedostolle suoritusoikeus
sudo chmod a+x jre-6u33-linux-i586.bin

6. Asenna Java
sudo ./jre-6u33-linux-i586.bin

7. Tee linkki Firefoxille
sudo ln -s /usr/local/java/jre1.6.0_33/lib/i386/libnpjp2.so /usr/lib/mozilla/plugins

8. Avaa Firefoxissa tyhjä välilehti ja kirjoita siihen about:plugins

Jos Java näkyy plugineissa, niin sitten vaikka Danske Pankkiin asioille ..

Ohje on tehty 32-bittisellä Ubuntu 10.04:llä, joten 64-bittiselle täytyy muokata linkit niiden
oikeisiin polkuihin.


http://forum.ubuntu-fi.org/index.php?topic=42417.0

Voit tietenkin asentaa myös Java 7:n, mutta sen toiminta on paljon epävarmempaa kuin Java 6:n .. :wink:
User avatar
oobetimer
Level 7
Level 7
 
Posts: 1889
Joined: Tue Jun 01, 2010 12:53 pm
Location: Finland / above the Arctic Circle

Re: Sun Java LMDE Xfce4:lle?

Postby HaMi on Tue Aug 21, 2012 9:05 am

Itsellä Oracle Java 7 Update 6 pelittää moitteetta Mint 13/Firefox 14-yhdistelmässä, ja päivittyy automaattisesti.
Vain Chrome herjaa 7-Javaa vanhentuneeksi, kun elää kai vielä 6-versiossa. Senkin herjat voi kuitata pois.

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java7-installer
don't think too much about nothing and everything
User avatar
HaMi
Level 2
Level 2
 
Posts: 93
Joined: Fri Sep 03, 2010 12:18 pm
Location: Finland

Re: Sun Java LMDE Xfce4:lle?

Postby savis21 on Thu Aug 23, 2012 9:45 am

Kiitos, tämä homma ratkesi! Asensin Java6:n, kun Sampopankki tuntuu toimivan sillä paremmin.
savis21
Level 1
Level 1
 
Posts: 15
Joined: Sat Feb 25, 2012 10:03 am

Aito SUN JAVA, HELPOSTI, OpenJDK:n tilalle, ohjeet tässä

Postby MaxHC on Tue Apr 29, 2014 3:01 am

Jotkut sovellukset, kuten esimerkiksi Danske Bankin vanha Java-pohjainen verkkopankki ei toiminut OpenJDK:lla, joten tilallle piti saada aito Sun Java. Tämä on helppo tapa; mitään vanhaa ei tarvitse ensin poistaa itse. Asennus tekee sen itsestään puolestasi. Testattu toimestani Mint 14, 15 ja 16 XFCE:ssä ja toimivaksi todettu. Toiminee Ubuntuissa variantteineen ja Minteissä yleisesti.

VAIHE 1 - REPOSITORYN LISÄÄMINEN

Laita tämä /etc/apt/sources.list -tiedostoon:
Code: Select all
deb http://www.duinsoft.nl/pkg debs all


Kaksi tapaa tehdä se, joko:
A) Settings -> Software Sources
B) terminaalissa
Code: Select all
sudo gedit /etc/apt/sources.list


VAIHE 2 - ASENNUS

Mene terminaaliin ja anna seuraavat komennot:
Code: Select all
sudo apt-key adv --keyserver keys.gnupg.net --recv-keys 5CB26B26
sudo apt-get update
sudo apt-get install update-sun-jre


VAIHE 3 - TESTAA, ETTÄ KAIKKI SUJUI KUTEN PITÄÄ

SULJE FIREFOX, JA KÄYNNISTÄ SE UUDESTAAN!

Mene tänne ja ylläty:
http://www.java.com/en/download/installed.jsp



Lähde: http://www.duinsoft.nl/packages.php?t=en
Attachments
SunJavaAsennettuna.png
Lopputulos!
MaxHC
Level 1
Level 1
 
Posts: 4
Joined: Mon Apr 28, 2014 11:57 pm

Re: Sun Java LMDE Xfce4:lle?[RATKAISTU]

Postby HaMi on Mon May 19, 2014 4:32 am

Menneen talven lumia.
DanskeBank lopetti Oracle Javan käyttämisen sivustollaan. Se on flash-pohjainen kuten muillakin pankeilla.
Joten OpenJDK on OK.
don't think too much about nothing and everything
User avatar
HaMi
Level 2
Level 2
 
Posts: 93
Joined: Fri Sep 03, 2010 12:18 pm
Location: Finland


Return to Suomi (Finnish)

Who is online

Users browsing this forum: No registered users and 2 guests