[SOLVED]mintMenu delay/does not open with first launch click

Questions about applications and software
Forum rules
Before you post please read this

[SOLVED]mintMenu delay/does not open with first launch click

Postby teseglet on Sat Feb 04, 2012 12:59 pm

When I launch Linux Mint with the Cinnamon desktop and click the mintMenu icon for the very first time (whether it is immediately after starting Linux Mint or 5 - 10 minutes later), the menu icon hover background remains for about 3 seconds and disappears and the mintMenu box does not open. After the background hover color disappears, I click the menu icon again and mintMenu works perfectly then and for the rest of the session. This issue is every time I start Linux Mint. Mutiple clicks of the menu icon at startup does not help either.... just still have to wait 3-4 seconds before 1 of the clicks takes.

Has anyone else experienced this issue? I have an older GeForce 6200 video card.

It may be Gnome 3 related, because when I am in Gnome Shell at start-up and click the Activities button or swipe the upper left corner, I experience a similar result trying to access the whateveryoumightcallit app icon screen.

I'm not sure if this is video card related, slower processor related, or if there is a hack to correct. Any help would be appreciated as it is annoying as one of the first experiences at startup.
Last edited by teseglet on Sun Feb 05, 2012 2:00 pm, edited 2 times in total.
teseglet
Level 1
Level 1
 
Posts: 8
Joined: Sat Oct 10, 2009 10:25 am

Linux Mint is funded by ads and donations.
 

Re: mintMenu delay/does not open with first launch click

Postby mank_in on Sat Feb 04, 2012 1:38 pm

I think vga driver problem , if you are using proprietary driver , update to latest NVIDIA drivers. If already the latest , try using nouveau driver.
Check your vga driver with :
Code: Select all
inxi -Gx
Image
Sorry for my bad English , I am Indonesian.
User avatar
mank_in
Level 6
Level 6
 
Posts: 1346
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: mintMenu delay/does not open with first launch click

Postby teseglet on Sat Feb 04, 2012 1:44 pm

Here is what I have:

$ inxi -Gx
Graphics: Card-1: nVidia NV44A [GeForce 6200] bus-ID: 00:0a.0
Card-2: VIA CN700/P4M800 Pro/P4M800 CE/VN800 [S3 UniChrome Pro] bus-ID: 01:00.0
X.Org 1.10.4 drivers nvidia unloaded: fbdev,vesa,nouveau Resolution 1280x1024@50.0hz
GLX Renderer GeForce 6200/PCI/SSE2 GLX Version 2.1.2 NVIDIA 280.13 Direct Rendering Yes
teseglet
Level 1
Level 1
 
Posts: 8
Joined: Sat Oct 10, 2009 10:25 am

Re: mintMenu delay/does not open with first launch click

Postby mank_in on Sat Feb 04, 2012 2:18 pm

Disable On board VGA ( VIA ) in BIOS.

If you are want to used latest driver ( 290.10 ) , you can add ppa:ubuntu-x-swat/x-updates

Code: Select all
sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update


run update manager. If update manager didn't find nvidia 290, run synaptic , search nvidia 290.10 and install it, you maybe need remove nvidia 280.13 .
Restart . and check with inxi -Gx again.
Image
Sorry for my bad English , I am Indonesian.
User avatar
mank_in
Level 6
Level 6
 
Posts: 1346
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: mintMenu delay/does not open with first launch click

Postby teseglet on Sat Feb 04, 2012 5:22 pm

I updated to latest driver, but do not know how to disable on board VGA. The result is the issue still exists

$ inxi -Gx
Graphics: Card-1: nVidia NV44A [GeForce 6200] bus-ID: 00:0a.0
Card-2: VIA CN700/P4M800 Pro/P4M800 CE/VN800 [S3 UniChrome Pro] bus-ID: 01:00.0
X.Org 1.10.4 drivers nvidia unloaded: fbdev,vesa,nouveau Resolution 1280x1024@50.0hz
GLX Renderer GeForce 6200/PCI/SSE2 GLX Version 2.1.2 NVIDIA 290.10 Direct Rendering Yes
teseglet
Level 1
Level 1
 
Posts: 8
Joined: Sat Oct 10, 2009 10:25 am

Re: mintMenu delay/does not open with first launch click

Postby mank_in on Sat Feb 04, 2012 10:26 pm

Disable onboard VGA in BIOS depend your BIOS/Mainboard manufacture. Check manual of your mainboard.
Did you see performance improved or better color correction by latest drivers :?:
Image
Sorry for my bad English , I am Indonesian.
User avatar
mank_in
Level 6
Level 6
 
Posts: 1346
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: mintMenu delay/does not open with first launch click

Postby teseglet on Sun Feb 05, 2012 11:23 am

First, relative to improved performance and colors... I suppose, but nothing shockingly different. I suppose things might look a bit more rich, but now too late to remember how things were before, same goes for performance.

I figured out how to get to my BIOS... here were the only lines that referenced VGA:

Assign IRQ for VGA <enabled>
PCI/VGA Palette Snoop <disabled>
VGA share memory size <64M>

So still not sure how to disable on board VGA.
teseglet
Level 1
Level 1
 
Posts: 8
Joined: Sat Oct 10, 2009 10:25 am

Re: mintMenu delay/does not open with first launch click

Postby mank_in on Sun Feb 05, 2012 11:54 am

To onboard VGA change VGA share memory size to 0 MB.

is better or not before installing NVIDIA driver ( at first install ) :?:
If you don't remember , launch LIVE CD again and see the different. Live cd /first install using Nouveau (open source )driver.
If better you can try uninstall /deactivated NVIDIA driver from "additional driver"
You need restart after deactivate NVIDIA driver.

check your driver after that with inxi -Gx . It something like :

drivers nouveau unloaded: fbdev,vesa,nvidia
GLX Renderer Gallium 3D at NV44A Direct Rendering Yes

In my experience ( not much :lol: ) : nouveau has better compatibility , NVIDIA has better performance
Image
Sorry for my bad English , I am Indonesian.
User avatar
mank_in
Level 6
Level 6
 
Posts: 1346
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

[SOLVED]Re: mintMenu delay/does not open with first launch c

Postby teseglet on Sun Feb 05, 2012 1:58 pm

So I removed the Proprietary Nvidia Driver and switched to Nouveau... it did not fix mintMenu issue and noticed graphics effects slightly more jerky.

Then I went back to the BIOS and when I clicked <64M> for VGA Share Memory Size, it gave me a multiple choice selection and I was able to choose <disabled>.

This fixed the problem with mintMenu... but graphics were still a bit jerky so went back to the Proprietary Nvidia driver. Now my (old) system is perfect, so thanks for the guidance. In fact I think my system is better now than ever (in the 4 or so years I've owned this economy system) now that those 64MB of VGA memory have been freed back to my system.

:D
teseglet
Level 1
Level 1
 
Posts: 8
Joined: Sat Oct 10, 2009 10:25 am

Re: [SOLVED]mintMenu delay/does not open with first launch c

Postby mank_in on Sun Feb 05, 2012 2:11 pm

Glad could be helping :D
You are lucky you can have an option to disable onboard graphic in BIOS. A lot of another Mint user didn't have this option on Hybrid Graphic Notebook.
Image
Sorry for my bad English , I am Indonesian.
User avatar
mank_in
Level 6
Level 6
 
Posts: 1346
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: bishop3337, TheDynamicHamza21 and 12 guests