[SOLVED]Unable change window theme

Questions about applications and software
Forum rules
Before you post please read this

[SOLVED]Unable change window theme

Postby Liatodua on Wed Feb 08, 2012 12:15 am

I am using Mint-Lisa

I try to change look of open windows through Menu>Other>Advanced Settings>Theme>Window theme

But whatewer theme I choose the window looks the same
sc.png
sc.png (54.65 KiB) Viewed 2679 times


How to change the look of the window?
Last edited by Liatodua on Sun Feb 12, 2012 11:44 am, edited 1 time in total.
Liatodua
Level 1
Level 1
 
Posts: 11
Joined: Wed Dec 28, 2011 2:53 am

Linux Mint is funded by ads and donations.
 

Re: Unable change window theme

Postby richyrich on Wed Feb 08, 2012 10:04 am

... :(
Last edited by richyrich on Wed Feb 08, 2012 10:36 am, edited 1 time in total.
User avatar
richyrich
Level 13
Level 13
 
Posts: 4635
Joined: Mon May 04, 2009 8:31 pm

Re: Unable change window theme

Postby proxima_centauri on Wed Feb 08, 2012 10:16 am

Change the window theme, then press Alt+F2, type "r", without the quotes, and hit enter. This will reload gnome-shell with the updated window theme.
User avatar
proxima_centauri
Level 11
Level 11
 
Posts: 3968
Joined: Tue Dec 25, 2007 3:24 pm
Location: NB, Canada

Re: Unable change window theme

Postby Liatodua on Sat Feb 11, 2012 10:29 am

Alt+f2 did not do anything.

But I entered r in terminal. The reply was:

The program 'r' is currently not installed. You can install it by typing:
sudo apt-get install littler

So I did that and there was a long process of installation. And when it finished, I typed r and pressed enter. Nothing happened. Will now reboot and try again
Last edited by Liatodua on Sat Feb 11, 2012 10:59 am, edited 1 time in total.
Liatodua
Level 1
Level 1
 
Posts: 11
Joined: Wed Dec 28, 2011 2:53 am

Re: Unable change window theme

Postby Liatodua on Sat Feb 11, 2012 10:31 am

Oops, it does not allow to close the terminal - it says there is a process runing and closing the terminal will kill that.

Ok, I'll wait...
Liatodua
Level 1
Level 1
 
Posts: 11
Joined: Wed Dec 28, 2011 2:53 am

Re: Unable change window theme

Postby dagon on Sat Feb 11, 2012 11:14 am

Liatodua wrote:Alt+f2 did not do anything.

But I entered r in terminal. The reply was:

The program 'r' is currently not installed. You can install it by typing:
sudo apt-get install littler

So a did that and there was a long process of installation. And when it finished, I typed r and pressed enter. Nothing happened. Will now reboot and try again


I seldom use "Alt + F2" and the Run Application function but if you type "r" on the command line you are trying to invoke "litler", which is some scripting frontend for GNUR... And if you try to run a command/program that you don't have installed but that is in the repository, then Linux is going to ask you if you want to install it.
Since "littler" is used with R, which is a programming library, it will install that too so that explains the long installation process.
Whenever you install a program and there is a need for other software to be installed the computer will ask you if it is OK to install this other program, so it pays off to watch out for these
R or littler has nothing to do with themes of any kind... :wink: Since "littler" is used with R, which is a programming library, it will install that too so that explains the long installation process.

This is what it looks like when I try it:
$ r
The program 'r' is currently not installed. You can install it by typing:
sudo apt-get install littler
oskar@dagon-5741G ~ $ sudo apt-get install littler
[sudo] password for oskar:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
dpatch gfortran gfortran-4.4 libblas-dev libblas3gf libbz2-dev libgfortran3
liblapack-dev liblapack3gf libpcre3-dev libpcrecpp0 libreadline-dev
libreadline6-dev patchutils r-base-core r-base-dev r-cran-boot r-cran-class
r-cran-cluster r-cran-codetools r-cran-foreign r-cran-kernsmooth
r-cran-lattice r-cran-mass r-cran-matrix r-cran-mgcv r-cran-nlme r-cran-nnet
r-cran-rpart r-cran-spatial r-cran-survival r-doc-html r-recommended tcl8.5
tk8.5
Suggested packages:
curl gfortran-multilib gfortran-doc gfortran-4.4-multilib gfortran-4.4-doc
libgfortran3-dbg r-cran-getopt ess r-doc-info r-doc-pdf r-mathlib
r-base-html cdbs tclreadline
The following NEW packages will be installed:
dpatch gfortran gfortran-4.4 libblas-dev libblas3gf libbz2-dev libgfortran3
liblapack-dev liblapack3gf libpcre3-dev libpcrecpp0 libreadline-dev
libreadline6-dev littler patchutils r-base-core r-base-dev r-cran-boot
r-cran-class r-cran-cluster r-cran-codetools r-cran-foreign
r-cran-kernsmooth r-cran-lattice r-cran-mass r-cran-matrix r-cran-mgcv
r-cran-nlme r-cran-nnet r-cran-rpart r-cran-spatial r-cran-survival
r-doc-html r-recommended tcl8.5 tk8.5
0 upgraded, 36 newly installed, 0 to remove and 5 not upgraded.
Need to get 43.4MB of archives.
After this operation, 97.4MB of additional disk space will be used.
Do you want to continue [Y/n]?

You can safely uninstall it again but you should pay attention when you get a question like that because sometimes you will come across a piece of software that depends on another desktop environment than the one you've got installed and that could pull down even more software.

Liatodua wrote:Oops, it does not allow to close the terminal - it says there is a process runing and closing the terminal will kill that.

Ok, I'll wait...

Just close it!
Image
User avatar
dagon
Level 7
Level 7
 
Posts: 1690
Joined: Mon Dec 06, 2010 4:33 am
Location: Kungälv, Sweden

Re: Unable change window theme

Postby bimsebasse on Sat Feb 11, 2012 11:55 am

You need to change both "window theme" and "gtk theme" for a full window theme change, The window in you screenshot looks like it should because "gtk theme" is set to adwaita and only "window theme" is set to Crux.

Window theme = metacity theme, visually only the window buttons (minimize, max, close) will change
gtk theme = main window styling, this is the one that changes the whole window (except window buttons/metacity related styling)

See 4a in this guide
Thank you for this thread. That’s all I can say. You most definitely have made this forum into something special. You clearly know what you are doing, you’ve covered so many bases. Thanks!
User avatar
bimsebasse
Level 7
Level 7
 
Posts: 1709
Joined: Fri Nov 11, 2011 10:21 am
Location: Scandinavia

Re: Unable change window theme

Postby proxima_centauri on Sat Feb 11, 2012 12:40 pm

Running "r" in terminal is not the same as running it with Alt+F2. When you run "r" with Alt+F2, it restarts gnome-shell. Sorry for the confusion, you cannot run the same command in terminal.

To fix the Alt+F2 behaviour, go to Keyboard Settings in System Settings. Go to Shortcuts -> System, and add Alt+F2 to "Show the run command prompt".
User avatar
proxima_centauri
Level 11
Level 11
 
Posts: 3968
Joined: Tue Dec 25, 2007 3:24 pm
Location: NB, Canada

Re: Unable change window theme

Postby Liatodua on Sun Feb 12, 2012 10:12 am

dagon wrote:Just close it!

I closed it eventually. Nothing happened, anyway. I guess I installed the wrong thing? Should I uninstall it?
Liatodua
Level 1
Level 1
 
Posts: 11
Joined: Wed Dec 28, 2011 2:53 am

Re: Unable change window theme

Postby Liatodua on Sun Feb 12, 2012 10:21 am

bimsebasse wrote:You need to change both "window theme" and "gtk theme" for a full window theme change, The window in you screenshot looks like it should because "gtk theme" is set to adwaita and only "window theme" is set to Crux.

Window theme = metacity theme, visually only the window buttons (minimize, max, close) will change
gtk theme = main window styling, this is the one that changes the whole window (except window buttons/metacity related styling)

See 4a in this guide

Going through those instructions carefully. Will report back
Liatodua
Level 1
Level 1
 
Posts: 11
Joined: Wed Dec 28, 2011 2:53 am

Re: Unable change window theme

Postby Liatodua on Sun Feb 12, 2012 10:33 am

proxima_centauri wrote:Running "r" in terminal is not the same as running it with Alt+F2. When you run "r" with Alt+F2, it restarts gnome-shell. Sorry for the confusion, you cannot run the same command in terminal.

To fix the Alt+F2 behaviour, go to Keyboard Settings in System Settings. Go to Shortcuts -> System, and add Alt+F2 to "Show the run command prompt".

Thanks a lot! It appeared to be disabled so I activated it and am now able to do this 'r' trick.
Liatodua
Level 1
Level 1
 
Posts: 11
Joined: Wed Dec 28, 2011 2:53 am

Re: Unable change window theme

Postby Liatodua on Sun Feb 12, 2012 11:44 am

Ok, thanks to all the advices. I managed to change the look if the window. Here is what I did (if somebody has the same problem):

Menu>System tools>System settings>Keyboard>Shortcuts>System>Launch the run command prompt
there was no shortcut indicated for this launcher so I inserted Alt+F2 (you have to click the row and then press those keys you want to act as a shortcut)

Then:
Menu>Other>Advanced settings>Theme
And there you play with changing the GTK+theme and windows theme. To see the result of each combination you have to press Alt+F2 and the small window will appear. You have to enter r there and press enter key. The desktop will reload with a new window style/theme/whatever.

I managed to select the one which suits my taste:
sc2.png
sc2.png (54.25 KiB) Viewed 2561 times

Not quite happy with the pink color of the last activated item but it is useful feature and other themes do not seem to have it. At least I know how to get rid of it if I get tired of it.

thanks everybody!
Liatodua
Level 1
Level 1
 
Posts: 11
Joined: Wed Dec 28, 2011 2:53 am

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 17 guests