Remastersys giving errors after using dist option

Make a liveCD/DVD out of your installed LinuxMint (Ubuntu/Debian) system

Remastersys giving errors after using dist option

Postby BlahBlah_X on Wed Nov 07, 2007 12:10 am

I remastered an ubuntu gutsy install using remastersys dist as root (no errors during actual process)

However, when I boot the produced .iso file, I get to the GDM screen (the custom one i chose) and on the top the text shows up: user sam will login in 30 seconds. Why would it do that? I used the dist option, so why would the system try to log me in as the user i had on the build machine?

When the timer runs out and it tries to log me in, I get the error message: Your home directory is listed as /home/sam but it does not appear to exist. Do you want to log in with the / (root) directory as your home directory? It is unlikely anything will work unless you use a failsafe session. If I click yes, my session won't actually start.

If I ignore the timed login request and login as "mint" with no password (the user i specified in the /etc/remastersys.conf file), I don't get that same error message but I get an unthemed, uncustomized desktop (not the one I customized it to be) yet all the programs are in the menu.

So two questions:

1) Why is this business with my old username happening? How do I fix it?

2) How do I get it so the user mint has the right theme, wallpaper, and panel? Do I need to place certain folders in /etc/skel?
User avatar
BlahBlah_X
Level 4
Level 4
 
Posts: 283
Joined: Thu Apr 05, 2007 5:27 pm
Location: Walrus Teeth

Linux Mint is funded by ads and donations.
 

Re: Remastersys giving errors after using dist option

Postby Fragadelic on Sun Nov 11, 2007 8:34 pm

BlahBlah_X wrote:I remastered an ubuntu gutsy install using remastersys dist as root (no errors during actual process)

However, when I boot the produced .iso file, I get to the GDM screen (the custom one i chose) and on the top the text shows up: user sam will login in 30 seconds. Why would it do that? I used the dist option, so why would the system try to log me in as the user i had on the build machine?

When the timer runs out and it tries to log me in, I get the error message: Your home directory is listed as /home/sam but it does not appear to exist. Do you want to log in with the / (root) directory as your home directory? It is unlikely anything will work unless you use a failsafe session. If I click yes, my session won't actually start.

If I ignore the timed login request and login as "mint" with no password (the user i specified in the /etc/remastersys.conf file), I don't get that same error message but I get an unthemed, uncustomized desktop (not the one I customized it to be) yet all the programs are in the menu.

So two questions:

1) Why is this business with my old username happening? How do I fix it?

2) How do I get it so the user mint has the right theme, wallpaper, and panel? Do I need to place certain folders in /etc/skel?


Just posting the answer here as it was resolved on the Remastersys forum.

The issue was caused by some leftover autologin information for gdm.

If you are planning to run the dist option, please ensure that you do not have autologin any user setup or any other settings with the login manager.
User avatar
Fragadelic
Level 4
Level 4
 
Posts: 469
Joined: Wed Nov 15, 2006 11:05 am
Location: Canada

Re: Remastersys giving errors after using dist option

Postby Mr. Potter on Wed Jan 16, 2008 9:31 pm

OK, so how did you fix it? Reinstall?
Mr. Potter
 

Re: Remastersys giving errors after using dist option

Postby Fragadelic on Wed Jan 16, 2008 9:53 pm

Try restoring all the defaults to gdm first. That should take care of it.

The other consideration is that you need to make sure the livecd username is not the same as a username already on the system.
User avatar
Fragadelic
Level 4
Level 4
 
Posts: 469
Joined: Wed Nov 15, 2006 11:05 am
Location: Canada


Return to Remastersys

Who is online

Users browsing this forum: No registered users and 1 guest