Latest Version on new Repo Dist Install Errors

Make a liveCD/DVD out of your installed LinuxMint (Ubuntu/Debian) system

Latest Version on new Repo Dist Install Errors

Postby gilf on Mon Feb 11, 2008 12:47 pm


First, thanks for a great program!

Unfortunately, I'm having problems as follows:

1.) added new repository and upgraded Remastersys to latest version. It has a GUI now! Also doesn't seem to ask for the original install CD during processing (which the earlier console version of remastersys did). Is that normal?

2.) did a remastersys dist. Was careful not to run anything else until completion. No other open windows. No virtual drives. No mounted shared folders.

3.) burned DVD at slowest speed DAO. Had burner verify disk. OK. Also checked disk MD5 against the one in the remastersys folder. OK.

4.) tested liveCD session -- seemed to work okay, no problem with sudo requiring a password (a problem in the past version of remastersys I used) ran programs OK. All previously installed programs seemed to be present.

5.) went to install to HD. A simple install to a single Ext3 partition on the main hard drive. Swap partition present. Installation completed with no errors.

6.) rebooted to HD.

7.) presented with a login screen. No combination of usernames and passwords would work. Tried "custom" with blank password, custom with custom, root with blank, blank with blank, etc.

8.) tried my normal username "steve", with my normal password. This seemed to work, however, received error message:
Yourhome directory is listed as '/home/steve' but it does not appear to exist. Do you want to log in with the / (root) directory as your home directory? It is unlikely anything will work unless you use a failsafe session.

selecting yes:

Users $HOME/.dmrc file is being ignored. This prevents the default session and language from being saved. File should be owned by user and ahve 644 permissions. Users $HOME directory must be owned by user and not be writable by others.


hit OK:

Your session only lasted less than 10 seconds. (snip)

there was a twistie for view details -xsession errors , hit that and:

(process 5521): Gtk- WARNING ** ; This process is currently running setuid or setgid. This is not a supported use of GTK+. You must create a helper program instead. For further details see:

Refusing to initialize GTK+

/etc/gdm/Xsession: Beginning session setup.....
Can't create dir /home/steve/Desktop
(snip. similar lines for Templates, Public, Documents, etc.)
(x-session-manager:5518): libgnomevfs-WARNING ** Unable to create ~/.gnome2 directory: no such file or directory

Clicking OK brings me back to the login screen, and we start all over again.

Any help would be appreciated.

Linux Mint is funded by ads and donations.

Re: Latest Version on new Repo Dist Install Errors

Postby gilf on Tue Feb 12, 2008 12:25 am

This question is now being worked on at the remastersys/klikit forum here:

Return to Remastersys

Who is online

Users browsing this forum: No registered users and 1 guest