Aeroplane mode stuck to On, Wireless will not work.

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Aeroplane mode stuck to On, Wireless will not work.

Postby big_pete123 on Wed May 09, 2012 7:33 pm

Everytime I try to turn wireless on, it just either doesn't move, or it moves for a second and moves straight back. I noticed that no matter what I do, Aeroplane mode is always set to on, And when I switch it off, I open the network settings and it's straight back to on again.

I have a dell mini 1018 model, and There are no wifi switches etc, except for the function 1 button which the wireless button on the f1 key doesn't work. So I'd be confident in saying it's not that function button.
big_pete123
Level 1
Level 1
 
Posts: 2
Joined: Wed May 09, 2012 7:29 pm

Linux Mint is funded by ads and donations.
 

Re: Aeroplane mode stuck to On, Wireless will not work.

Postby dagon on Wed May 09, 2012 8:05 pm

Image
User avatar
dagon
Level 7
Level 7
 
Posts: 1690
Joined: Mon Dec 06, 2010 4:33 am
Location: Kungälv, Sweden

Re: Aeroplane mode stuck to On, Wireless will not work.

Postby big_pete123 on Thu May 10, 2012 7:28 am

That didn't help sorry :( Any other ideas?

Thanks for the welcome to the forums.

When I type sudpo rfkill list it comes up with

1: dell-wifi: Wireless LAN
Soft Blocked: yes
Hard Blocked: yes
2: dell-bluetooth: Bluetooth
Soft blocked: yes
Hard Blocked: no
3: phy0: Wireless LAN
Soft Blocked: no
Hard Blocked: Yes

I don't know if that helps at all.

Any help is appreciated.
big_pete123
Level 1
Level 1
 
Posts: 2
Joined: Wed May 09, 2012 7:29 pm

Re: Aeroplane mode stuck to On, Wireless will not work.

Postby jlickliter83 on Mon Jun 04, 2012 9:41 pm

I am totally new to the whole Linux experience. I have an HP DV9000 notebook that I just installed Mint 13 on. The wifi is driving me crazy....... I beleive that "airplane mode" is what is stopping me from turning wifi on but I cannot turn it off by clicking the switch. THERE MUST BE ANOTHER WAY! :evil:
jlickliter83
Level 1
Level 1
 
Posts: 2
Joined: Mon Jun 04, 2012 9:36 pm

Re: Aeroplane mode stuck to On, Wireless will not work.

Postby dfaw on Tue Jun 05, 2012 7:12 pm

I had the same problem today with my sony vaio running Mint 13.
rfkill list revealed
0: sony-wifi: Wireless LAN
Soft blocked: yes
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: yes
Hard blocked: yes

I solved it by using
rfkill unblock all

I hope this helps
dfaw
Level 1
Level 1
 
Posts: 1
Joined: Tue Jun 05, 2012 7:02 pm

Re: Aeroplane mode stuck to On, Wireless will not work.

Postby DisplacedMic on Wed Aug 15, 2012 12:58 pm

Having the same problem.

everything was working fine until today - no wifi. wireless card appears to be off because airplane mode is on. i can turn it off, but it comes right back on as soon as i close the window. rebooting is no help.

rfkill list yields the following:

0: ideapad_wlan: Wireless LAN
Soft blocked: no
Hard blocked: yes

1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes

rfkill unblock all doesn't do anything.

any ideas?
DisplacedMic
Level 1
Level 1
 
Posts: 2
Joined: Sun Aug 15, 2010 1:32 pm

Re: Aeroplane mode stuck to On, Wireless will not work.

Postby znerom on Wed Aug 15, 2012 11:37 pm

I ran into this problem recently on my Toshiba Laptop and discovered that the problem was I had used the keyboard shortcut to disable wireless and that hitting the keyboard shortcut again (it's a toggle) fixed the problem.
znerom
Level 1
Level 1
 
Posts: 8
Joined: Thu Aug 02, 2012 10:38 pm

Re: Aeroplane mode stuck to On, Wireless will not work.

Postby youknowyouloveit on Tue Aug 28, 2012 6:17 am

dfaw wrote:I solved it by using
rfkill unblock all

I hope this helps


Worked like a charm on my Vaio, thanks for the tip dfaw :D
youknowyouloveit
Level 1
Level 1
 
Posts: 1
Joined: Tue Aug 28, 2012 6:13 am
Location: London, UK

Re: Aeroplane mode stuck to On, Wireless will not work.

Postby danburgess67 on Mon Apr 15, 2013 11:42 am

I had the same problem on my Sony Vaio and "rfkill unblock all" did the job for me. Thanks everybody!
danburgess67
Level 1
Level 1
 
Posts: 2
Joined: Mon Apr 15, 2013 11:40 am

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot] and 31 guests