[SOLVED] Default user / username at login window

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

[SOLVED] Default user / username at login window

Postby undoIT on Fri May 18, 2012 2:37 am

Just finished installing Linux Mint 13 Cinnamon on my Macbook Air. Loving it so far :D

One minor annoyance is that I have to enter my username and password everytime I login to the desktop. How can I set the login window so that my username is automatically selected and all I have to do is enter my password?

I've looked through the expected settings, couldn't find anything, and I also tried hacking the lightdm.conf with (gksu gedit /etc/lightdm/lightdm.conf) :

Code: Select all
default-user=<myusername>


It is still requiring that I type my username at login.
Last edited by undoIT on Sat May 19, 2012 3:55 am, edited 1 time in total.
User avatar
undoIT
Level 1
Level 1
 
Posts: 22
Joined: Sat Sep 19, 2009 6:00 pm

Linux Mint is funded by ads and donations.
 

Re: Default user / username at login window

Postby sunewbie on Fri May 18, 2012 4:05 am

Did not try Mint 13 RC

However, it is available in as a check box in users and groups.

search for it in the cinnamon menu and you should be able to find it. Currently I am not on LM, on XP.
Linux Beginners Search Engine | more details | Google CSE Page
Acceptance = Relief, Resistance = Stress | Strength become Habit, Habit becomes Weakness
Be not a traitor in your thoughts. Do everything that is necessary in Proper time.
User avatar
sunewbie
Level 5
Level 5
 
Posts: 510
Joined: Sun Sep 04, 2011 12:55 pm
Location: Mumbai, India

Re: Default user / username at login window

Postby esteban1uy on Fri May 18, 2012 4:41 am

Sorry, I only speak Spanish
User avatar
esteban1uy
Level 5
Level 5
 
Posts: 734
Joined: Sat Nov 12, 2011 6:20 am

Re: Default user / username at login window

Postby undoIT on Fri May 18, 2012 4:04 pm



Actually, that isn't ideal because I still have to click on the user before entering password. The LDM login theme was much more attractive in Linux Mint 12. Perhaps this is just a place holder for LM13 until the new theme is finished for final release. I sure hope so, the current login window is not very newb friendly in terms of first impressions.
User avatar
undoIT
Level 1
Level 1
 
Posts: 22
Joined: Sat Sep 19, 2009 6:00 pm

Re: Default user / username at login window

Postby undoIT on Fri May 18, 2012 4:09 pm

Actually, it looks like LightDM isn't even installed. What is Linux Mint 13 useing for login window?
User avatar
undoIT
Level 1
Level 1
 
Posts: 22
Joined: Sat Sep 19, 2009 6:00 pm

Re: Default user / username at login window

Postby esteban1uy on Fri May 18, 2012 4:21 pm

MDM, a fork of old GDM.
Sorry, I only speak Spanish
User avatar
esteban1uy
Level 5
Level 5
 
Posts: 734
Joined: Sat Nov 12, 2011 6:20 am

Re: Default user / username at login window

Postby undoIT on Sat May 19, 2012 2:06 am

esteban1uy wrote:MDM, a fork of old GDM.


Strange choice. Is it possible to switch to LDM?
User avatar
undoIT
Level 1
Level 1
 
Posts: 22
Joined: Sat Sep 19, 2009 6:00 pm

Re: Default user / username at login window

Postby undoIT on Sat May 19, 2012 3:53 am

Code: Select all
sudo apt-get install lightdm unity-greeter lightdm-gtk-greeter
sudo dpkg-reconfigure lightdm

Hit Enter to Ok and then select lightdm.

Next:

Code: Select all
gksudo gedit /etc/lightdm/lightdm.conf/


add the following and save:

Code: Select all
[SeatDefaults]
user-session=cinnamon
greeter-session=unity-greeter


(you can also set the greeter to lightdm-gtk-greeter)

Reboot. Aaaaaaah. Relief!

The next step is not required, but if you are feeling naughty...

Code: Select all
sudo apt-get remove mdm mint-mdm-themes


This will remove mdm.
Last edited by undoIT on Thu May 31, 2012 1:31 pm, edited 4 times in total.
User avatar
undoIT
Level 1
Level 1
 
Posts: 22
Joined: Sat Sep 19, 2009 6:00 pm

Re: Default user / username at login window

Postby BopNiblets on Sat May 19, 2012 8:39 pm

undoIT wrote:
Code: Select all
sudo apt-get install lightdm
sudo dpkg-reconfigure lightdm

Hit Enter to Ok and then select lightdm. Reboot. Aaaaaaah. Relief!

Argh, this gives the purpley Ubuntu login, is the old Mint login theme on gnome-look somewhere, does anyone have it handy?
User avatar
BopNiblets
Level 2
Level 2
 
Posts: 83
Joined: Thu May 07, 2009 6:48 pm
Location: I'm in Mint Country!

Re: Default user / username at login window

Postby undoIT on Sat May 19, 2012 8:57 pm

BopNiblets wrote:Argh, this gives the purpley Ubuntu login, is the old Mint login theme on gnome-look somewhere, does anyone have it handy?


If you choose one of the default wallpapers, the purpley thing appears very briefly and then changes to the wallpaper. There is a way you can hack the default wallpaper list so that your custom wallpaper is included (as I remember, LDM reverts back to purpley thing in Ubuntu if you set a custom wallpaper). Hopefully, Mint releases an official LDM greeter.

I just found this and I'm going to give it a try.

http://mintnext.wordpress.com/2012/02/1 ... ackground/
User avatar
undoIT
Level 1
Level 1
 
Posts: 22
Joined: Sat Sep 19, 2009 6:00 pm

Re: Default user / username at login window

Postby esteban1uy on Sat May 19, 2012 9:27 pm

undoIT wrote:


Actually, that isn't ideal because I still have to click on the user before entering password. The LDM login theme was much more attractive in Linux Mint 12. Perhaps this is just a place holder for LM13 until the new theme is finished for final release. I sure hope so, the current login window is not very newb friendly in terms of first impressions.


Not really, just press your keyboard's up arrow key twice and the you're ready to type your password, nothing to click:
Image

If you prefer a "themed with face browser" login, just press Tab and then the up arrow key and type your password (no click also):
Image

By the way, there are lots of GDM themes that can be easily adapted to MDM:
Image
Sorry, I only speak Spanish
User avatar
esteban1uy
Level 5
Level 5
 
Posts: 734
Joined: Sat Nov 12, 2011 6:20 am

Re: Default user / username at login window

Postby Rüssel on Sun May 20, 2012 2:06 pm

undoIT wrote:
Code: Select all
sudo apt-get install lightdm
sudo dpkg-reconfigure lightdm

Hit Enter to Ok and then select lightdm. Reboot. Aaaaaaah. Relief!

If you are feeling naughty...

Code: Select all
sudo apt-get remove mdm mint-mdm-themes


I followed your instructions and wrote the first two lines in the terminal (not removing mdm), but the system fails to boot with lightdm. Instead the boot process interrupts with the following message:
"not starting mdm display manager; it is not the default display manager
saned disabled; edit /etc/default saned"

Now the system is completely unusable, and I dont know how to make lightdm running properly.

Please help!
Linux Mint Donor #2676
Rüssel
Level 1
Level 1
 
Posts: 19
Joined: Sun May 20, 2012 1:50 pm

Re: Default user / username at login window

Postby undoIT on Sun May 20, 2012 3:36 pm

Rüssel wrote:I followed your instructions and wrote the first two lines in the terminal (not removing mdm), but the system fails to boot with lightdm. Instead the boot process interrupts with the following message:
"not starting mdm display manager; it is not the default display manager
saned disabled; edit /etc/default saned"

Now the system is completely unusable, and I dont know how to make lightdm running properly.

Please help!


Did you make sure to hit Enter at the OK prompt and then select lightdm after running:

Code: Select all
sudo dpkg-reconfigure lightdm
User avatar
undoIT
Level 1
Level 1
 
Posts: 22
Joined: Sat Sep 19, 2009 6:00 pm

Re: Default user / username at login window

Postby undoIT on Sun May 20, 2012 3:39 pm

esteban1uy wrote:Not really, just press your keyboard's up arrow key twice and the you're ready to type your password, nothing to click:
Image

If you prefer a "themed with face browser" login, just press Tab and then the up arrow key and type your password (no click also):
Image

By the way, there are lots of GDM themes that can be easily adapted to MDM:
Image


These look very nice. But there are still two unnecessary keyboard clicks involved at the login window. I prefer username selected and cursor blinking in the password field, ready for action.
User avatar
undoIT
Level 1
Level 1
 
Posts: 22
Joined: Sat Sep 19, 2009 6:00 pm

Re: Default user / username at login window

Postby Rüssel on Sun May 20, 2012 4:41 pm

undoIT wrote:
Rüssel wrote:I followed your instructions and wrote the first two lines in the terminal (not removing mdm), but the system fails to boot with lightdm. Instead the boot process interrupts with the following message:
"not starting mdm display manager; it is not the default display manager
saned disabled; edit /etc/default saned"

Now the system is completely unusable, and I dont know how to make lightdm running properly.

Please help!


Did you make sure to hit Enter at the OK prompt and then select lightdm after running:

Code: Select all
sudo dpkg-reconfigure lightdm


Yes, I did hit enter at the OK prompt. Nonetheless the system doesnt boot. Now, I have to configure sth using the command line, I presume. But I have no idea what.
Please help, if possible
Linux Mint Donor #2676
Rüssel
Level 1
Level 1
 
Posts: 19
Joined: Sun May 20, 2012 1:50 pm

Re: [SOLVED] Default user / username at login window

Postby undoIT on Sun May 20, 2012 4:55 pm

After OK, there should be a list where you can select from mdm and lightdm. Did you change the selection to lightdm? If not, you could try booting into recovery mode and running sudo dpkg-reconfigure lightdm again from there.
User avatar
undoIT
Level 1
Level 1
 
Posts: 22
Joined: Sat Sep 19, 2009 6:00 pm

Re: [SOLVED] Default user / username at login window

Postby Rüssel on Sun May 20, 2012 5:46 pm

undoIT wrote:After OK, there should be a list where you can select from mdm and lightdm. Did you change the selection to lightdm? If not, you could try booting into recovery mode and running sudo dpkg-reconfigure lightdm again from there.


Yes, I did both. I ran sudo dpkg-reconfigure lightdm a second time form the recovery mode, and selected again lightdm, but no change. Still booting is impossible, no change.
Any more ideas?
Linux Mint Donor #2676
Rüssel
Level 1
Level 1
 
Posts: 19
Joined: Sun May 20, 2012 1:50 pm

Re: [SOLVED] Default user / username at login window

Postby undoIT on Sun May 20, 2012 6:08 pm

Rüssel wrote:Yes, I did both. I ran sudo dpkg-reconfigure lightdm a second time form the recovery mode, and selected again lightdm, but no change. Still booting is impossible, no change.
Any more ideas?


Based on the error message, it looks like the system is still trying to load mdm. It seems you followed all the steps I did to switch to lightdm. What is selected when you run dpkg-reconfigure before you change the selection? Is unity-greeter installed? Are you using the cinnamon version of Mint? Perhaps there is another depency that didn't get installed.
User avatar
undoIT
Level 1
Level 1
 
Posts: 22
Joined: Sat Sep 19, 2009 6:00 pm

Re: [SOLVED] Default user / username at login window

Postby Rüssel on Sun May 20, 2012 6:59 pm

undoIT wrote:
Rüssel wrote:Yes, I did both. I ran sudo dpkg-reconfigure lightdm a second time form the recovery mode, and selected again lightdm, but no change. Still booting is impossible, no change.
Any more ideas?


Based on the error message, it looks like the system is still trying to load mdm. It seems you followed all the steps I did to switch to lightdm. What is selected when you run dpkg-reconfigure before you change the selection? Is unity-greeter installed? Are you using the cinnamon version of Mint? Perhaps there is another depency that didn't get installed.


In the meantime I removed mdm using the third line of your original code. Yet the system still hangs on boot.

Now there is nothing more to select when running dpkg-reconfigure. I think it was lightdm selected before.

I'm not sure if unity-greeter is installed. How can I find out from the recovery shell? Should it be installed or should it not be installed?

I am using the Mate edition of LM 13 RC.

Thank you for helping!
Linux Mint Donor #2676
Rüssel
Level 1
Level 1
 
Posts: 19
Joined: Sun May 20, 2012 1:50 pm

Re: [SOLVED] Default user / username at login window

Postby undoIT on Sun May 20, 2012 7:14 pm

try running:

Code: Select all
sudo apt-get install lightdm liblightdm-gobject-1-0 unity-greeter
User avatar
undoIT
Level 1
Level 1
 
Posts: 22
Joined: Sat Sep 19, 2009 6:00 pm

Linux Mint is funded by ads and donations.
 
Next

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 23 guests