I'm voiceless!

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

I'm voiceless!

Postby wjwheels on Wed Mar 12, 2008 10:49 am

I recently installed Skype primarily to join a forum discussion I'm interested in. I can hear sounds fine, but cannot seem to get sound from my microphone. The test returns nothing no matter how I change the properties/preferences. I also cannot get a recording using "Sound Recorder". The microphone works fine in Windows applications.

Any help?
Quit your princess!
98% of the world doesn't care about your problems.
The other 2% are happy you have them.
User avatar
wjwheels
Level 1
Level 1
 
Posts: 38
Joined: Fri Feb 08, 2008 4:03 pm
Location: Paradise

Linux Mint is funded by ads and donations.
 

Re: I'm voiceless!

Postby Dwood on Wed Mar 12, 2008 6:50 pm

Sorry I can't help, but I was just about to make a post as I have exactly the same problem, sound but no voice in Skype.

I can hear the mic through the speakers but dont get anything from the test call.

I am using Cassandra xfce and Skype 2.0.

Has anyone got skype working?
Dwood
Level 2
Level 2
 
Posts: 55
Joined: Thu Jun 21, 2007 12:25 pm

Re: I'm voiceless!

Postby blendenzo on Wed Mar 12, 2008 7:11 pm

It's a little different with each sound card, but here's the basic steps to getting your microphone working (in Gnome):

Right-click the volume applet on the gnome-panel and select "Open Volume Control". If you see a "Recording" tab next to the "Playback" tab, click it and look for your microphone. Chances are that it's probably not listed, but if it is you just need to make sure that it's enabled and that the volume is up.

If your microphone is not listed, then it is hidden from the control list by default and you will need to unhide it. To do this, select "Preferences" from the "Edit" menu. You'll probably see that several of the audio devices in the list that pops up are not checked. Look for something about "Microphone" or "Capture" (on my system, I have a front and back microphone jack, so I have "Microphone" and "Front Mic", and I also have "Capture", "Capture 1", "Mic Boost", "Front Mic Boost", and two "Input Source" options which are important). As you select each audio device that was previously unselected, it's corresponding controls will be added to the Volume Control window.

Here's how it works on my system: "Microphone" and "Front Mic" are playback volume controls for the rear and front microphone jacks. This allows me to hear myself through the speakers, but it does not allow me to be heard by others over the internet. The "Mic Boost" and "Front Mic Boost" boxes add faders to the playback panel that allow me to increase the amplitude of the microphone signals (I'm not sure if this affects playback and recording or playback only). To be heard over the internet, I have to enable one of the "Capture" devices and it's corresponding "Input Source" option. Then "Capture" is added to the Recording tab and "Input Source" is added to a new tab called "Options". In Options, I set the input source to the microphone device I want to use, and in Recording I unmute the capture device and increase the volume.

Like I said, it's a bit different for each sound card. If I remember correctly, the microphone controls for the sound card on my old computer were in the OSS mixer controls, not the ALSA mixer, so I had to first choose "File >> Change Device" and select the OSS mixer from the list, then I could select "Edit >> Preferences" and add the correct controls.
blendenzo
Level 1
Level 1
 
Posts: 16
Joined: Tue Jul 17, 2007 2:16 pm

Re: I'm voiceless!

Postby wjwheels on Fri Mar 14, 2008 7:19 am

Thanks for the long detailed reply blendenzo. I tried about every combination possible yesterday, but still no sound. I found most of the sound options you described except "Mic Boost" & "Front Mic Boost". Maybe that's the problem. I have onboard sound on an Asus motherboard. I'll keep trying today.
Quit your princess!
98% of the world doesn't care about your problems.
The other 2% are happy you have them.
User avatar
wjwheels
Level 1
Level 1
 
Posts: 38
Joined: Fri Feb 08, 2008 4:03 pm
Location: Paradise

Re: I'm voiceless!

Postby MagnusB on Fri Mar 14, 2008 12:32 pm

Isn't Skype still beta in Linux? If so, you should expect a few hiccups..
Image
You're not drunk if you can lie on the floor without holding on.
--Dean Martin
MagnusB
Level 6
Level 6
 
Posts: 1255
Joined: Sun Nov 18, 2007 12:39 pm
Location: Norway

Re: I'm voiceless!

Postby Dwood on Mon Mar 17, 2008 9:38 pm

I have managed to get Skype working.

I installed the alsa-mixer gui from synaptic.

There were two white dots above the mic and mic boost sliders.
I clicked these to turn them red (i guess it sets it to record) and then my microphone worked in skype and I could hear myself using the skype test call.


I hope this works for you.
Dwood
Level 2
Level 2
 
Posts: 55
Joined: Thu Jun 21, 2007 12:25 pm

Re: I'm voiceless!

Postby wjwheels on Wed Mar 19, 2008 1:13 pm

Thanks for jumping in Drood. I basically gave up on it and uninstalled Skype. I wanted it ONLY for joining an on-line round-table discussion. I insteat installed it in Windoze for that purpose. I'm saving your response, however, and some time later I'll try it again in Linux Mint.
Quit your princess!
98% of the world doesn't care about your problems.
The other 2% are happy you have them.
User avatar
wjwheels
Level 1
Level 1
 
Posts: 38
Joined: Fri Feb 08, 2008 4:03 pm
Location: Paradise

Re: I'm voiceless!

Postby mint cat on Fri Apr 18, 2008 1:37 am

I have a usb headset with mic and gave up trying to make skype work. Well I ran into this thread and decided to give it another shot.
I think what did it for me was:
if you start skype and then right click on the icon in the task bar -> properties->headset options, my usb headset was not selected there, instead it was my onboard sound card or something like that.

Anyway, changed it and it started working :mrgreen:

I have been windowz free for 2 weeks now :lol:
mint cat
Level 1
Level 1
 
Posts: 3
Joined: Mon Apr 14, 2008 1:07 pm

Re: I'm voiceless!

Postby newW2 on Sat Apr 19, 2008 12:42 am

mint cat. First of all a big belated welcome to Linux Mint! And congratulations on your freedom! It only gets better from here on out. :D
User avatar
newW2
Level 6
Level 6
 
Posts: 1081
Joined: Fri Apr 06, 2007 10:24 am
Location: USA

Re: I'm voiceless!

Postby blendenzo on Sun Apr 20, 2008 12:10 am

mint cat wrote:I have been windowz free for 2 weeks now :lol:
Congrats, mint cat! I just celebrated my 1 year windoze free birthday, and I totally agree with newW2 that it just keeps getting better.

wjwheels, sad to hear you couldn't get it working. I have basically the opposite problem with my sound card... it works fine in Linux, but windows never recognized my front audio jacks (and I was using the manufacturer's latest driver from their website). I would have thought that there was something wrong with my frontside audio jacks if I wasn't using Linux. Weird.
blendenzo
Level 1
Level 1
 
Posts: 16
Joined: Tue Jul 17, 2007 2:16 pm

Re: I'm voiceless!

Postby Zwopper on Sun Apr 20, 2008 8:57 am

Keep on rockin' in the free world!
Image
My artwork at deviantART | My Tweet
CREA DIEM!
Lenovo E320 | 8GB | 512GB Samsung 840 PRO - SSD | Ubuntu 14.04
User avatar
Zwopper
Level 10
Level 10
 
Posts: 3101
Joined: Fri Nov 30, 2007 12:20 pm
Location: Deep in the Swedish woods

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Google Adsense [Bot], SandsOfArrakis and 28 guests