Intel 855 graphic card & openGL

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Intel 855 graphic card & openGL

Postby Caps18 on Sun Mar 30, 2008 2:18 am

I'm trying to run Google Earth, and it wants me to install openGL. Can I do this with the graphics card in my laptop? It is a Intel 855, and this site http://www.intellinuxgraphics.org/download.html seems to think I have the most up-to-date one already.
User avatar
Caps18
Level 1
Level 1
 
Posts: 43
Joined: Fri Mar 28, 2008 11:17 am

Linux Mint is funded by ads and donations.
 

Re: Intel 855 graphic card & openGL

Postby Slocker on Sun Mar 30, 2008 12:48 pm

Yes, hardware acceleration should be active by default. I have the same graphic card in my Dell Laptop and works out of the box for me. Test in the xorg.conf file which driver you're using. Because it exists two, the i810 and the intel one. I thought I remember 'intel' was newer, but still has some issues. Do:

Code: Select all
cat /etc/X11/xorg.conf | grep Driver

And it would show you a list of drivers used in the xorg.conf file. Check wether in one of the lines shows you 'i810' or 'intel'. If it shows you 'i810', I have had no problem with it, but if you still want to give a try to 'intel' follow these steps:

Code: Select all
sudo gedit /etc/X11/xorg.conf

find the

Code: Select all
Section "Device"
        (...)
        Driver      "i810"

And where you see 'i810' change it to 'intel' or change 'intel' to 'i810', the case you have. Save. Make sure quit all programs and press Ctrl + Alt + Backspace. The Desktop will restart, login again, try Google Earth. And see if you have now hardware acceleration.

Other issue might be that you don't have the 'glx' module loaded in the xorg.conf 'Module' section. In my case it's at the end of the xorg.conf file:

Code: Select all
Section "Module"
   Load      "glx"
EndSection
Alex Slocker
User avatar
Slocker
Level 2
Level 2
 
Posts: 73
Joined: Thu Nov 01, 2007 2:14 pm
Location: Madrid, Spain


Return to Newbie Questions

Who is online

Users browsing this forum: Hecubus and 25 guests