[x64] Wine??!! can't install to save my life

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

[x64] Wine??!! can't install to save my life

Postby linux4life on Thu Aug 23, 2012 6:29 pm

hello all!. I have been using Linux for a few years or so, but not with x64 this is my first dive into the world of 64 bit. I am having issues installing wine1.4 or 1.5 I have read that I am suposed to do
Code: Select all
sudo apt-get install wine-gecko1.5


the result of that is
Code: Select all
 annon@annon-alienware ~ $ sudo apt-get install wine-gecko1.5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
wine-gecko1.5 is already the newest version.
The following packages were automatically installed and are no longer required:
  libopenal1:i386 libkrb5-3:i386 libk5crypto3:i386 libpam-winbind
  libstdc++6:i386 libxfixes3:i386 update-notifier-common ttf-umefont
  libxcomposite1:i386 libldap-2.4-2:i386 libv4l-0:i386 liblcms1:i386
  gnome-exe-thumbnailer libroken18-heimdal:i386 libunistring0
  libunistring0:i386 libgphoto2-port0:i386 libdrm-nouveau2:i386 libwrap0:i386
  libjpeg-turbo8:i386 libjpeg8:i386 libdrm-radeon1:i386 libsane:i386
  libxxf86vm1:i386 libxcb-glx0:i386 libasn1-8-heimdal:i386 libxslt1.1:i386
  libgomp1:i386 libcapi20-3 libcapi20-3:i386 libx11-xcb1:i386 libgnutls26:i386
  libgssapi3-heimdal:i386 wine-mono0.0.4 libtasn1-3:i386 libfreetype6:i386
  libexpat1:i386 libv4lconvert0:i386 libavahi-common-data:i386 libjson0:i386
  libxcb1:i386 gettext libp11-kit0:i386 wine-gecko1.7 wine-gecko1.7:i386
  libdrm2:i386 libwind0-heimdal:i386 libxau6:i386 libcups2:i386 winetricks
  libosmesa6 libosmesa6:i386 libxinerama1:i386 libkrb5support0:i386
  libgif4:i386 libcroco3:i386 icoutils libice6:i386 libxdmcp6:i386
  libieee1284-3:i386 libgcrypt11:i386 libdrm-intel1:i386 libxml2:i386
  libkeyutils1:i386 libasound2:i386 libxpm4:i386 libflac8:i386
  libusb-0.1-4:i386 libxrender1:i386 libhcrypto4-heimdal:i386
  liborc-0.4-0:i386 libhx509-5-heimdal:i386 libvorbisenc2:i386
  libasyncns0:i386 libgettextpo0 libgettextpo0:i386 libgd2-xpm:i386
  libheimbase1-heimdal:i386 libtiff4:i386 libgstreamer-plugins-base0.10-0:i386
  libpciaccess0:i386 libavahi-client3:i386 ttf-unfonts-core libmpg123-0
  libmpg123-0:i386 libx11-6:i386 libsasl2-2:i386 libfontconfig1:i386
  ttf-mscorefonts-installer libsm6:i386 libpulse0:i386
  libheimntlm0-heimdal:i386 libxdamage1:i386 winbind libexif12:i386
  libgssapi-krb5-2:i386 libxi6:i386 libvorbis0a:i386 libgstreamer0.10-0:i386
  libxcursor1:i386 libxt6:i386 libxext6:i386 libsasl2-modules:i386
  libavahi-common3:i386 libxrandr2:i386 libsndfile1:i386 libsqlite3-0:i386
  libltdl7:i386 libtxc-dxtn0:i386 libkrb5-26-heimdal:i386 libssl1.0.0:i386
  libgpg-error0:i386 libgphoto2-2:i386 libogg0:i386
Use 'apt-get autoremove' to remove them.
 

well after looking at all the changes it wants to make, I got a bit nervous and declined the changes.
as I side note I do have the PPA for WINE in my sources.list file
if this peticular isssue has been addressed please forgive me, I know there are issues with WINE x64 but I think my issue is a bit different.

thanks very much!!
linux4life
Level 1
Level 1
 
Posts: 8
Joined: Thu Aug 23, 2012 6:20 pm

Linux Mint is funded by ads and donations.
 

Re: [x64] Wine??!! can't install to save my life

Postby Lord_Eager on Thu Aug 23, 2012 6:40 pm

The only issue with wine and 64 bit arch, is that to compile and patch a particular wine version, you need to build a chroot 32bit. For any other purpose it works just fine, and to run 32bit apps you can use the command WINEARCH=win32 .
To install wine you can type:
Code: Select all
sudo apt-get install wine

Wine-Gecko is automatically installed with the first run of wine together with the Mono package which are needed to run Internet Explorer and .NET frameworks.
To run windows 32bit and 64bit applications is suggested to use different wineprefixes for any application, for example for a 32bit one:
Code: Select all
env WINEPREFIX=$HOME/.APP-YOU-WANT WINEARCH=win32 wine /Path/to/the/application

It's preferrable to install the application in the preferred wineprefix and to run it from there with the custom configuration.
In this way you have no risk to mess up your wine directories and you can set the particular configurations for every application.
Lord_Eager
Level 3
Level 3
 
Posts: 184
Joined: Tue Jul 17, 2012 11:59 am

Re: [x64] Wine??!! can't install to save my life

Postby linux4life on Thu Aug 23, 2012 7:00 pm

I did
Code: Select all
Sudo apt-get install wine


and the output is

Code: Select all
annon@annon-alienware ~ $ sudo apt-get install wine
[sudo] password for annon:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine : Depends: wine1.5 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
   

to be honest I have never seen anything like this before.
linux4life
Level 1
Level 1
 
Posts: 8
Joined: Thu Aug 23, 2012 6:20 pm

Re: [x64] Wine??!! can't install to save my life

Postby zerozero on Thu Aug 23, 2012 7:12 pm

we need more information :)
Code: Select all
inxi -Sr
Code: Select all
apt-cache policy wine wine1.5
Code: Select all
sudo apt-get install wine1.5
zerozero
Level 16
Level 16
 
Posts: 6472
Joined: Tue Jul 07, 2009 2:29 pm

Re: [x64] Wine??!! can't install to save my life

Postby linux4life on Thu Aug 23, 2012 7:17 pm

of course thanks for the replys :)

Code: Select all
 annon@annon-alienware ~ $ inxi -sr
Sensors:   System Temperatures: cpu: 40.0C mobo: N/A gpu: 88C
           Fan Speeds (in rpm): cpu: N/A
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com/ maya main upstream import
           deb http://archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu/ precise-updates main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ precise-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ precise partner
           deb http://packages.medibuntu.org/ precise free non-free
           deb http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu precise main
           Active apt sources in file: /etc/apt/sources.list.d/playonlinux.list
           deb http://deb.playonlinux.com/ precise main
           Active apt sources in file: /etc/apt/sources.list.d/ubuntu-wine-ppa-precise.list
           deb-src http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu precise main
           Active apt sources in file: /etc/apt/sources.list.d/xorg-edgers-ppa-precise.list
           deb http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu precise main
           deb-src http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu precise main
 

Code: Select all
   annon@annon-alienware ~ $ apt-cache policy wine wine1.5
wine:
  Installed: (none)
  Candidate: 1.5.11-0ubuntu1
  Version table:
     1.5.11-0ubuntu1 0
        500 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ precise/main amd64 Packages
     1.4-0ubuntu4.1 0
        500 http://archive.ubuntu.com/ubuntu/ precise-updates/universe amd64 Packages
     1.4-0ubuntu4 0
        500 http://archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages
wine1.5:
  Installed: (none)
  Candidate: 1.5.11-0ubuntu1
  Version table:
     1.5.11-0ubuntu1 0
        500 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ precise/main amd64 Packages
         



Code: Select all
  annon@annon-alienware ~ $ sudo apt-get install wine1.5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine1.5 : Depends: wine1.5-i386 (= 1.5.11-0ubuntu1)
E: Unable to correct problems, you have held broken packages.
     
linux4life
Level 1
Level 1
 
Posts: 8
Joined: Thu Aug 23, 2012 6:20 pm

Re: [x64] Wine??!! can't install to save my life

Postby zerozero on Thu Aug 23, 2012 7:24 pm

try like this
Code: Select all
sudo apt-get install wine1.5 wine1.5-i386
zerozero
Level 16
Level 16
 
Posts: 6472
Joined: Tue Jul 07, 2009 2:29 pm

Re: [x64] Wine??!! can't install to save my life

Postby linux4life on Thu Aug 23, 2012 7:27 pm

Code: Select all
  sudo apt-get install wine1.5 wine1.5-i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine1.5-i386:i386 : Depends: libgl1-mesa-glx:i386 but it is not going to be installed or
                              libgl1:i386
                     Depends: libglu1-mesa:i386 but it is not going to be installed or
                              libglu1:i386
                     Recommends: gettext:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages. 


hmm this reminds me of RPM-hell but I can't quite figure out why.. :lol:
linux4life
Level 1
Level 1
 
Posts: 8
Joined: Thu Aug 23, 2012 6:20 pm

Re: [x64] Wine??!! can't install to save my life

Postby zerozero on Thu Aug 23, 2012 7:36 pm

let's go one step back (even to give me time to think :lol: ):
is the system updated?
Code: Select all
sudo apt-get update && sudo apt-get upgrade
zerozero
Level 16
Level 16
 
Posts: 6472
Joined: Tue Jul 07, 2009 2:29 pm

Re: [x64] Wine??!! can't install to save my life

Postby linux4life on Thu Aug 23, 2012 7:41 pm

I'm going to LMAO if the lack of updates were causing me issues. Update manager said it was all updated. Apt disagreed presenting me with almost 300 updates. will report back when updating is done. and Zero thanks for your help :D
linux4life
Level 1
Level 1
 
Posts: 8
Joined: Thu Aug 23, 2012 6:20 pm

Re: [x64] Wine??!! can't install to save my life

Postby linux4life on Thu Aug 23, 2012 9:18 pm

Code: Select all
 sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  hplip hplip-data libhpmud0 libsane-hpaio linux-headers-generic
  linux-image-generic printer-driver-hpcups printer-driver-hpijs
  virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11 vlc
  vlc-nox vlc-plugin-notify vlc-plugin-pulse xserver-xorg-core
  xserver-xorg-input-evdev xserver-xorg-input-mouse
  xserver-xorg-input-synaptics xserver-xorg-input-vmmouse
  xserver-xorg-input-wacom xserver-xorg-video-ati xserver-xorg-video-cirrus
  xserver-xorg-video-fbdev xserver-xorg-video-intel xserver-xorg-video-mach64
  xserver-xorg-video-mga xserver-xorg-video-neomagic
  xserver-xorg-video-nouveau xserver-xorg-video-openchrome
  xserver-xorg-video-qxl xserver-xorg-video-r128 xserver-xorg-video-radeon
  xserver-xorg-video-s3 xserver-xorg-video-savage
  xserver-xorg-video-siliconmotion xserver-xorg-video-sis
  xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident
  xserver-xorg-video-vesa xserver-xorg-video-vmware
0 upgraded, 0 newly installed, 0 to remove and 42 not upgraded.   


no good it still does

Code: Select all
    sudo apt-get install wine
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine : Depends: wine1.5 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
   
linux4life
Level 1
Level 1
 
Posts: 8
Joined: Thu Aug 23, 2012 6:20 pm

Re: [x64] Wine??!! can't install to save my life

Postby zerozero on Thu Aug 23, 2012 9:46 pm

this all "mess" [it's not only you] is caused by the multiarch switch :shock:
let's see if we can start untangling it
Code: Select all
sudo apt-get install ia32-libs

and then try to install wine or/and wine1.5
zerozero
Level 16
Level 16
 
Posts: 6472
Joined: Tue Jul 07, 2009 2:29 pm

Re: [x64] Wine??!! can't install to save my life

Postby linux4life on Thu Aug 23, 2012 9:52 pm

Code: Select all
 sudo apt-get install ia32-libs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ia32-libs : Depends: ia32-libs-multiarch
 


Code: Select all
  sudo apt-get install ia32-libs-multiarch
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ia32-libs-multiarch:i386 : Depends: libglapi-mesa:i386 but it is not going to be installed
                            Depends: libglu1-mesa:i386 but it is not going to be installed
                            Depends: libqt4-opengl:i386 but it is not going to be installed
                            Recommends: libgl1-mesa-glx:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
 
linux4life
Level 1
Level 1
 
Posts: 8
Joined: Thu Aug 23, 2012 6:20 pm


Re: [x64] Wine??!! can't install to save my life

Postby Lord_Eager on Fri Aug 24, 2012 4:33 am

I'm actually using wine on Ubuntu 12.04 x64 on my desktop without any major issue.
This looks like an Apt issue, try this:
Code: Select all
sudo apt-get remove --purge wine* playonlinux

Code: Select all
sudo apt-get autoremove

Code: Select all
sudo apt-get clean

Code: Select all
sudo apt-get update

Code: Select all
sudo apt-get install wine1.4
Lord_Eager
Level 3
Level 3
 
Posts: 184
Joined: Tue Jul 17, 2012 11:59 am

Re: [x64] Wine??!! can't install to save my life

Postby linux4life on Fri Aug 24, 2012 12:41 pm

I would like to thank everyone for there help with this issue. I have since droped x64 in favor of x86 + PAE. there is no longer any issue with wine and I can go back to playing CS:GO :D
I don't know if this should be marked as solved or just purged from the forums entirely? but thank you all for your help
linux4life
Level 1
Level 1
 
Posts: 8
Joined: Thu Aug 23, 2012 6:20 pm

Re: [x64] Wine??!! can't install to save my life

Postby zerozero on Fri Aug 24, 2012 8:08 pm

linux4life,
in a way i'm glad :) because you sorted the issue but it's not yet closed for me :lol: :wink: now i want to find out what's the problem here.
zerozero
Level 16
Level 16
 
Posts: 6472
Joined: Tue Jul 07, 2009 2:29 pm

Re: [x64] Wine??!! can't install to save my life

Postby zerozero on Fri Aug 24, 2012 9:34 pm

ok i can't reproduce that here :shock:
this is the system (is far from vanilla- i added xfce, bits of mate, who knows what else)
Code: Select all
zerozero@zerozero-Inspiron-1545 ~ $ inxi -Sr
System:    Host: zerozero-Inspiron-1545 Kernel: 3.2.0-29-generic x86_64 (64 bit)
           Desktop: KDE 4.8.4 Distro: Linux Mint 13 Maya
Repos:     Active apt sources in file: /etc/apt/sources.list.d/medibuntu.list
           deb http://packages.medibuntu.org/ precise free non-free
           Active apt sources in file: /etc/apt/sources.list.d/mint.list
           deb http://packages.linuxmint.com/ maya main upstream import backport
           deb-src http://packages.linuxmint.com/ maya main upstream import backport #Added by software-properties
           Active apt sources in file: /etc/apt/sources.list.d/ubuntu.list
           deb http://archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu/ precise-updates main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ precise-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ precise partner
           Active apt sources in file: /etc/apt/sources.list.d/xubuntu-dev-xfce-4_10-precise.list
           deb http://ppa.launchpad.net/xubuntu-dev/xfce-4.10/ubuntu precise main
           deb-src http://ppa.launchpad.net/xubuntu-dev/xfce-4.10/ubuntu precise main

updated
Code: Select all
zerozero@zerozero-Inspiron-1545 ~ $ apt update && apt upgrade
[sudo] password for zerozero:
Ign http://security.ubuntu.com precise-security InRelease
Ign http://archive.canonical.com precise InRelease                                           
Ign http://ppa.launchpad.net precise InRelease                                               
Ign http://archive.ubuntu.com precise InRelease                                             
Ign http://archive.ubuntu.com precise-updates InRelease                                     
Hit http://security.ubuntu.com precise-security Release.gpg                                 
Hit http://archive.canonical.com precise Release.gpg                                         
Hit http://ppa.launchpad.net precise Release.gpg                                             
Hit http://archive.ubuntu.com precise Release.gpg                                           
Hit http://archive.canonical.com precise Release                                             
Hit http://ppa.launchpad.net precise Release                                                 
Hit http://packages.medibuntu.org precise InRelease                                         
Get:1 http://archive.ubuntu.com precise-updates Release.gpg [198 B]                         
Hit http://archive.canonical.com precise/partner amd64 Packages                             
Hit http://ppa.launchpad.net precise/main Sources                                           
Hit http://archive.ubuntu.com precise Release                                               
Hit http://archive.canonical.com precise/partner i386 Packages                               
Ign http://archive.canonical.com precise/partner TranslationIndex                           
Hit http://ppa.launchpad.net precise/main amd64 Packages                                     
Hit http://ppa.launchpad.net precise/main i386 Packages                                       
Ign http://ppa.launchpad.net precise/main TranslationIndex                                   
Get:2 http://archive.ubuntu.com precise-updates Release [49.6 kB]                           
Hit http://packages.medibuntu.org precise/free amd64 Packages                               
Ign http://packages.linuxmint.com maya InRelease                                             
Hit http://packages.medibuntu.org precise/non-free amd64 Packages                           
Hit http://security.ubuntu.com precise-security Release                                     
Hit http://archive.ubuntu.com precise/main amd64 Packages                                   
Hit http://archive.ubuntu.com precise/restricted amd64 Packages                             
Hit http://archive.ubuntu.com precise/universe amd64 Packages                               
Hit http://archive.ubuntu.com precise/multiverse amd64 Packages                             
Hit http://archive.ubuntu.com precise/main i386 Packages                                     
Hit http://archive.ubuntu.com precise/restricted i386 Packages                               
Hit http://archive.ubuntu.com precise/universe i386 Packages                                 
Hit http://archive.ubuntu.com precise/multiverse i386 Packages                               
Hit http://archive.ubuntu.com precise/main TranslationIndex                                 
Hit http://archive.ubuntu.com precise/multiverse TranslationIndex                           
Get:3 http://packages.linuxmint.com maya Release.gpg [197 B]                                 
Hit http://security.ubuntu.com precise-security/main amd64 Packages                         
Hit http://packages.medibuntu.org precise/free i386 Packages                                 
Hit http://archive.ubuntu.com precise/restricted TranslationIndex                           
Hit http://archive.ubuntu.com precise/universe TranslationIndex                             
Get:4 http://archive.ubuntu.com precise-updates/main amd64 Packages [374 kB]                 
Hit http://security.ubuntu.com precise-security/restricted amd64 Packages                   
Hit http://security.ubuntu.com precise-security/universe amd64 Packages                     
Hit http://security.ubuntu.com precise-security/multiverse amd64 Packages                   
Hit http://security.ubuntu.com precise-security/main i386 Packages                           
Hit http://security.ubuntu.com precise-security/restricted i386 Packages                     
Hit http://security.ubuntu.com precise-security/universe i386 Packages                       
Hit http://security.ubuntu.com precise-security/multiverse i386 Packages                     
Hit http://security.ubuntu.com precise-security/main TranslationIndex                       
Hit http://security.ubuntu.com precise-security/multiverse TranslationIndex                 
Hit http://security.ubuntu.com precise-security/restricted TranslationIndex                 
Hit http://packages.medibuntu.org precise/non-free i386 Packages                             
Ign http://archive.canonical.com precise/partner Translation-en_GB                           
Hit http://security.ubuntu.com precise-security/universe TranslationIndex                   
Ign http://ppa.launchpad.net precise/main Translation-en_GB                                 
Get:5 http://packages.linuxmint.com maya Release [17.7 kB]                                   
Ign http://archive.canonical.com precise/partner Translation-en                             
Hit http://security.ubuntu.com precise-security/main Translation-en                         
Hit http://security.ubuntu.com precise-security/multiverse Translation-en                   
Ign http://ppa.launchpad.net precise/main Translation-en                                     
Ign http://packages.medibuntu.org precise/free TranslationIndex                             
Hit http://security.ubuntu.com precise-security/restricted Translation-en                   
Hit http://security.ubuntu.com precise-security/universe Translation-en                     
Ign http://packages.medibuntu.org precise/non-free TranslationIndex                         
Get:6 http://packages.linuxmint.com maya/main Sources [17.4 kB]                             
Get:7 http://archive.ubuntu.com precise-updates/restricted amd64 Packages [6,755 B]         
Get:8 http://archive.ubuntu.com precise-updates/universe amd64 Packages [126 kB]             
Get:9 http://archive.ubuntu.com precise-updates/multiverse amd64 Packages [8,677 B]         
Get:10 http://archive.ubuntu.com precise-updates/main i386 Packages [378 kB]                 
Get:11 http://packages.linuxmint.com maya/upstream Sources [6,099 B]                         
Get:12 http://packages.linuxmint.com maya/import Sources [22.9 kB]                           
Get:13 http://packages.linuxmint.com maya/backport Sources [20 B]                           
Get:14 http://packages.linuxmint.com maya/main amd64 Packages [18.0 kB]                     
Get:15 http://packages.linuxmint.com maya/upstream amd64 Packages [10.6 kB]                 
Get:16 http://packages.linuxmint.com maya/import amd64 Packages [41.3 kB]                   
Get:17 http://archive.ubuntu.com precise-updates/restricted i386 Packages [6,732 B]         
Get:18 http://packages.linuxmint.com maya/backport amd64 Packages [20 B]                     
Get:19 http://packages.linuxmint.com maya/main i386 Packages [18.0 kB]                       
Get:20 http://archive.ubuntu.com precise-updates/universe i386 Packages [127 kB]             
Get:21 http://archive.ubuntu.com precise-updates/multiverse i386 Packages [9,672 B]         
Hit http://archive.ubuntu.com precise-updates/main TranslationIndex                         
Hit http://archive.ubuntu.com precise-updates/multiverse TranslationIndex                   
Hit http://archive.ubuntu.com precise-updates/restricted TranslationIndex                   
Hit http://archive.ubuntu.com precise-updates/universe TranslationIndex                     
Hit http://archive.ubuntu.com precise/main Translation-en_GB                                 
Hit http://archive.ubuntu.com precise/main Translation-en                                   
Hit http://archive.ubuntu.com precise/multiverse Translation-en_GB                           
Hit http://archive.ubuntu.com precise/multiverse Translation-en                             
Hit http://archive.ubuntu.com precise/restricted Translation-en_GB                           
Hit http://archive.ubuntu.com precise/restricted Translation-en                             
Hit http://archive.ubuntu.com precise/universe Translation-en_GB                             
Hit http://archive.ubuntu.com precise/universe Translation-en                               
Hit http://archive.ubuntu.com precise-updates/main Translation-en_GB                         
Hit http://archive.ubuntu.com precise-updates/main Translation-en                           
Hit http://archive.ubuntu.com precise-updates/multiverse Translation-en_GB                   
Hit http://archive.ubuntu.com precise-updates/multiverse Translation-en                     
Hit http://archive.ubuntu.com precise-updates/restricted Translation-en_GB                   
Hit http://archive.ubuntu.com precise-updates/restricted Translation-en                     
Hit http://archive.ubuntu.com precise-updates/universe Translation-en_GB                     
Hit http://archive.ubuntu.com precise-updates/universe Translation-en                       
Get:22 http://packages.linuxmint.com maya/main i386 Packages [18.0 kB]           
Ign http://packages.medibuntu.org precise/free Translation-en_GB                           
Ign http://packages.medibuntu.org precise/free Translation-en                             
Ign http://packages.medibuntu.org precise/non-free Translation-en_GB
Ign http://packages.medibuntu.org precise/non-free Translation-en
Get:23 http://packages.linuxmint.com maya/upstream i386 Packages [10.6 kB]
Get:24 http://packages.linuxmint.com maya/import i386 Packages [41.6 kB]
Get:25 http://packages.linuxmint.com maya/backport i386 Packages [20 B]
Ign http://packages.linuxmint.com maya/backport TranslationIndex
Ign http://packages.linuxmint.com maya/import TranslationIndex
Ign http://packages.linuxmint.com maya/main TranslationIndex
Ign http://packages.linuxmint.com maya/upstream TranslationIndex
Ign http://packages.linuxmint.com maya/backport Translation-en_GB
Ign http://packages.linuxmint.com maya/backport Translation-en
Ign http://packages.linuxmint.com maya/import Translation-en_GB
Ign http://packages.linuxmint.com maya/import Translation-en
Ign http://packages.linuxmint.com maya/main Translation-en_GB
Ign http://packages.linuxmint.com maya/main Translation-en
Ign http://packages.linuxmint.com maya/upstream Translation-en_GB
Ign http://packages.linuxmint.com maya/upstream Translation-en
Fetched 1,291 kB in 5s (217 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

dry-run to install wine1.4 (default in the repos)
Code: Select all
zerozero@zerozero-Inspiron-1545 ~ $ sudo apt-get -s install wine
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  binfmt-support fonts-droid fonts-horai-umefont fonts-unfonts-core gcc-4.6-base:i386
  libasn1-8-heimdal:i386 libasound2:i386 libavahi-client3:i386 libavahi-common-data:i386
  libavahi-common3:i386 libc6:i386 libcapi20-3 libcapi20-3:i386 libcomerr2:i386
  libcups2:i386 libdb5.1:i386 libdbus-1-3:i386 libdrm-intel1:i386 libdrm-nouveau1a:i386
  libdrm-radeon1:i386 libdrm2:i386 libexif12:i386 libexpat1:i386 libffi6:i386
  libfontconfig1:i386 libfreetype6:i386 libgcc1:i386 libgcrypt11:i386 libgd2-xpm:i386
  libgettextpo0 libgif4:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libglapi-mesa:i386
  libglib2.0-0:i386 libglu1-mesa:i386 libgnutls26:i386 libgpg-error0:i386 libgphoto2-2:i386
  libgphoto2-port0:i386 libgpm2:i386 libgssapi-krb5-2:i386 libgssapi3-heimdal:i386
  libgstreamer-plugins-base0.10-0:i386 libgstreamer0.10-0:i386 libhcrypto4-heimdal:i386
  libheimbase1-heimdal:i386 libheimntlm0-heimdal:i386 libhx509-5-heimdal:i386 libice6:i386
  libieee1284-3:i386 libjpeg-turbo8:i386 libjpeg8:i386 libk5crypto3:i386 libkeyutils1:i386
  libkrb5-26-heimdal:i386 libkrb5-3:i386 libkrb5support0:i386 liblcms1:i386
  libldap-2.4-2:i386 libllvm3.0:i386 libltdl7:i386 libmpg123-0 libmpg123-0:i386
  libncurses5:i386 libodbc1 libopenal1:i386 liborc-0.4-0:i386 libp11-kit0:i386
  libpam-winbind libpciaccess0:i386 libpcre3:i386 libpng12-0:i386 libroken18-heimdal:i386
  libsane:i386 libsasl2-2:i386 libsasl2-modules:i386 libselinux1:i386 libsm6:i386
  libsqlite3-0:i386 libssl1.0.0:i386 libstdc++6:i386 libtasn1-3:i386 libtiff4:i386
  libtinfo5:i386 libunistring0 libusb-0.1-4:i386 libuuid1:i386 libv4l-0:i386
  libv4lconvert0:i386 libwind0-heimdal:i386 libx11-6:i386 libx11-xcb1:i386 libxau6:i386
  libxcb-glx0:i386 libxcb1:i386 libxcomposite1:i386 libxcursor1:i386 libxdamage1:i386
  libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxi6:i386 libxinerama1:i386 libxml2:i386
  libxpm4:i386 libxrandr2:i386 libxrender1:i386 libxslt1.1:i386 libxt6:i386 libxxf86vm1:i386
  ttf-droid ttf-mscorefonts-installer ttf-umefont ttf-unfonts-core unixodbc winbind
  wine-gecko1.4 wine-gecko1.4:i386 wine1.4 wine1.4-amd64 wine1.4-common wine1.4-i386:i386
  winetricks zlib1g:i386
Suggested packages:
  libasound2-plugins:i386 libasound2-python:i386 glibc-doc:i386 locales:i386
  cups-common:i386 rng-tools:i386 libgd-tools:i386 libglide3:i386 gnutls-bin:i386
  gphoto2:i386 gtkam:i386 gpm:i386 krb5-doc:i386 krb5-user:i386 libvisual-0.4-plugins:i386
  gstreamer-codec-install:i386 gnome-codec-install:i386 gstreamer0.10-tools:i386
  gstreamer0.10-plugins-base:i386 liblcms-utils:i386 libmyodbc odbc-postgresql tdsodbc
  unixodbc-bin hpoj:i386 hplip:i386 libsane-extras:i386 sane-utils:i386
  libsasl2-modules-otp:i386 libsasl2-modules-ldap:i386 libsasl2-modules-sql:i386
  libsasl2-modules-gssapi-mit:i386 libsasl2-modules-gssapi-heimdal:i386 dosbox
Recommended packages:
  xml-core:i386 gettext gettext:i386 unixodbc:i386
The following NEW packages will be installed
  binfmt-support fonts-droid fonts-horai-umefont fonts-unfonts-core gcc-4.6-base:i386
  libasn1-8-heimdal:i386 libasound2:i386 libavahi-client3:i386 libavahi-common-data:i386
  libavahi-common3:i386 libc6:i386 libcapi20-3 libcapi20-3:i386 libcomerr2:i386
  libcups2:i386 libdb5.1:i386 libdbus-1-3:i386 libdrm-intel1:i386 libdrm-nouveau1a:i386
  libdrm-radeon1:i386 libdrm2:i386 libexif12:i386 libexpat1:i386 libffi6:i386
  libfontconfig1:i386 libfreetype6:i386 libgcc1:i386 libgcrypt11:i386 libgd2-xpm:i386
  libgettextpo0 libgif4:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libglapi-mesa:i386
  libglib2.0-0:i386 libglu1-mesa:i386 libgnutls26:i386 libgpg-error0:i386 libgphoto2-2:i386
  libgphoto2-port0:i386 libgpm2:i386 libgssapi-krb5-2:i386 libgssapi3-heimdal:i386
  libgstreamer-plugins-base0.10-0:i386 libgstreamer0.10-0:i386 libhcrypto4-heimdal:i386
  libheimbase1-heimdal:i386 libheimntlm0-heimdal:i386 libhx509-5-heimdal:i386 libice6:i386
  libieee1284-3:i386 libjpeg-turbo8:i386 libjpeg8:i386 libk5crypto3:i386 libkeyutils1:i386
  libkrb5-26-heimdal:i386 libkrb5-3:i386 libkrb5support0:i386 liblcms1:i386
  libldap-2.4-2:i386 libllvm3.0:i386 libltdl7:i386 libmpg123-0 libmpg123-0:i386
  libncurses5:i386 libodbc1 libopenal1:i386 liborc-0.4-0:i386 libp11-kit0:i386
  libpam-winbind libpciaccess0:i386 libpcre3:i386 libpng12-0:i386 libroken18-heimdal:i386
  libsane:i386 libsasl2-2:i386 libsasl2-modules:i386 libselinux1:i386 libsm6:i386
  libsqlite3-0:i386 libssl1.0.0:i386 libstdc++6:i386 libtasn1-3:i386 libtiff4:i386
  libtinfo5:i386 libunistring0 libusb-0.1-4:i386 libuuid1:i386 libv4l-0:i386
  libv4lconvert0:i386 libwind0-heimdal:i386 libx11-6:i386 libx11-xcb1:i386 libxau6:i386
  libxcb-glx0:i386 libxcb1:i386 libxcomposite1:i386 libxcursor1:i386 libxdamage1:i386
  libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxi6:i386 libxinerama1:i386 libxml2:i386
  libxpm4:i386 libxrandr2:i386 libxrender1:i386 libxslt1.1:i386 libxt6:i386 libxxf86vm1:i386
  ttf-droid ttf-mscorefonts-installer ttf-umefont ttf-unfonts-core unixodbc winbind wine
  wine-gecko1.4 wine-gecko1.4:i386 wine1.4 wine1.4-amd64 wine1.4-common wine1.4-i386:i386
  winetricks zlib1g:i386
0 upgraded, 126 newly installed, 0 to remove and 0 not upgraded.
Inst gcc-4.6-base:i386 (4.6.3-1ubuntu5 Ubuntu:12.04/precise [i386])

adding ubuntu-wine ppa
Code: Select all
zerozero@zerozero-Inspiron-1545 ~ $ sudo add-apt-repository ppa:ubuntu-wine/ppa
You are about to add the following PPA to your system:
 Welcome to the Wine Team PPA.  Here you can get the latest available Wine betas for every supported version of Ubuntu.  This PPA is managed by Scott Ritchie and Maarten Lankhorst.
 More info: https://launchpad.net/~ubuntu-wine/+archive/ppa
Press [ENTER] to continue or ctrl-c to cancel adding it

Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.91nvOq1Tkg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp://keyserver.ubuntu.com:80/ --recv 883E8688397576B6C509DF495A9A06AEF9CB8DB0
gpg: requesting key F9CB8DB0 from hkp server keyserver.ubuntu.com
gpg: key F9CB8DB0: public key "Launchpad PPA for Ubuntu Wine Team" imported
gpg: no ultimately trusted keys found
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)

again update/upgrade
Code: Select all
zerozero@zerozero-Inspiron-1545 ~ $ apt update && apt upgrade
Ign http://security.ubuntu.com precise-security InRelease
Ign http://archive.canonical.com precise InRelease                                           
Hit http://security.ubuntu.com precise-security Release.gpg                                 
Hit http://archive.canonical.com precise Release.gpg                                         
Ign http://archive.ubuntu.com precise InRelease                                             
Ign http://archive.ubuntu.com precise-updates InRelease                                     
Hit http://security.ubuntu.com precise-security Release                                     
Hit http://archive.canonical.com precise Release                                             
Ign http://ppa.launchpad.net precise InRelease                                               
Hit http://packages.medibuntu.org precise InRelease                                         
Ign http://ppa.launchpad.net precise InRelease                                               
Hit http://archive.ubuntu.com precise Release.gpg                                           
Hit http://security.ubuntu.com precise-security/main amd64 Packages                         
Hit http://archive.canonical.com precise/partner amd64 Packages                             
Get:1 http://ppa.launchpad.net precise Release.gpg [316 B]                                   
Get:2 http://archive.ubuntu.com precise-updates Release.gpg [198 B]                         
Hit http://security.ubuntu.com precise-security/restricted amd64 Packages                   
Hit http://security.ubuntu.com precise-security/universe amd64 Packages                     
Hit http://security.ubuntu.com precise-security/multiverse amd64 Packages                   
Hit http://security.ubuntu.com precise-security/main i386 Packages                           
Hit http://security.ubuntu.com precise-security/restricted i386 Packages                     
Hit http://archive.canonical.com precise/partner i386 Packages                               
Ign http://archive.canonical.com precise/partner TranslationIndex                           
Hit http://ppa.launchpad.net precise Release.gpg                                             
Hit http://archive.ubuntu.com precise Release                                               
Hit http://security.ubuntu.com precise-security/universe i386 Packages                       
Hit http://security.ubuntu.com precise-security/multiverse i386 Packages                     
Hit http://security.ubuntu.com precise-security/main TranslationIndex                       
Hit http://security.ubuntu.com precise-security/multiverse TranslationIndex                 
Hit http://security.ubuntu.com precise-security/restricted TranslationIndex                 
Hit http://packages.medibuntu.org precise/free amd64 Packages                               
Get:3 http://ppa.launchpad.net precise Release [11.9 kB]                                     
Get:4 http://archive.ubuntu.com precise-updates Release [49.6 kB]                           
Hit http://security.ubuntu.com precise-security/universe TranslationIndex                   
Ign http://packages.linuxmint.com maya InRelease                                             
Hit http://security.ubuntu.com precise-security/main Translation-en                         
Hit http://security.ubuntu.com precise-security/multiverse Translation-en                   
Hit http://packages.medibuntu.org precise/non-free amd64 Packages                           
Hit http://ppa.launchpad.net precise Release                                                 
Hit http://security.ubuntu.com precise-security/restricted Translation-en                   
Get:5 http://ppa.launchpad.net precise/main Sources [2,952 B]                               
Get:6 http://ppa.launchpad.net precise/main amd64 Packages [4,167 B]                         
Hit http://security.ubuntu.com precise-security/universe Translation-en                     
Hit http://packages.medibuntu.org precise/free i386 Packages                                 
Get:7 http://packages.linuxmint.com maya Release.gpg [197 B]                                 
Get:8 http://ppa.launchpad.net precise/main i386 Packages [4,158 B]                         
Ign http://ppa.launchpad.net precise/main TranslationIndex                                   
Hit http://ppa.launchpad.net precise/main Sources                                           
Hit http://ppa.launchpad.net precise/main amd64 Packages                                     
Hit http://ppa.launchpad.net precise/main i386 Packages                                     
Ign http://ppa.launchpad.net precise/main TranslationIndex                                   
Hit http://archive.ubuntu.com precise/main amd64 Packages                                   
Hit http://archive.ubuntu.com precise/restricted amd64 Packages                             
Hit http://archive.ubuntu.com precise/universe amd64 Packages                               
Hit http://archive.ubuntu.com precise/multiverse amd64 Packages                             
Hit http://archive.ubuntu.com precise/main i386 Packages                                     
Hit http://archive.ubuntu.com precise/restricted i386 Packages                               
Hit http://archive.ubuntu.com precise/universe i386 Packages                                 
Hit http://archive.ubuntu.com precise/multiverse i386 Packages                               
Hit http://archive.ubuntu.com precise/main TranslationIndex                                 
Hit http://archive.ubuntu.com precise/multiverse TranslationIndex                           
Hit http://packages.medibuntu.org precise/non-free i386 Packages                             
Hit http://archive.ubuntu.com precise/restricted TranslationIndex                           
Hit http://archive.ubuntu.com precise/universe TranslationIndex                             
Get:9 http://archive.ubuntu.com precise-updates/main amd64 Packages [374 kB]                 
Ign http://archive.canonical.com precise/partner Translation-en_GB                           
Ign http://archive.canonical.com precise/partner Translation-en                             
Get:10 http://packages.linuxmint.com maya Release [17.7 kB]                                 
Ign http://packages.medibuntu.org precise/free TranslationIndex                             
Ign http://packages.medibuntu.org precise/non-free TranslationIndex                         
Ign http://ppa.launchpad.net precise/main Translation-en_GB                               
Ign http://ppa.launchpad.net precise/main Translation-en                                 
Ign http://ppa.launchpad.net precise/main Translation-en_GB                               
Ign http://ppa.launchpad.net precise/main Translation-en                                     
Get:11 http://packages.linuxmint.com maya/main Sources [17.4 kB]                             
Get:12 http://packages.linuxmint.com maya/upstream Sources [6,099 B]                         
Get:13 http://packages.linuxmint.com maya/import Sources [22.9 kB]                           
Get:14 http://archive.ubuntu.com precise-updates/restricted amd64 Packages [6,755 B]         
Get:15 http://archive.ubuntu.com precise-updates/universe amd64 Packages [126 kB]           
Get:16 http://packages.linuxmint.com maya/backport Sources [20 B]                           
Get:17 http://packages.linuxmint.com maya/main amd64 Packages [18.0 kB]                     
Get:18 http://packages.linuxmint.com maya/upstream amd64 Packages [10.6 kB]                 
Get:19 http://archive.ubuntu.com precise-updates/multiverse amd64 Packages [8,677 B]         
Get:20 http://archive.ubuntu.com precise-updates/main i386 Packages [378 kB]                 
Get:21 http://packages.linuxmint.com maya/import amd64 Packages [41.3 kB]                   
Get:22 http://packages.linuxmint.com maya/backport amd64 Packages [20 B]                     
Get:23 http://packages.linuxmint.com maya/main i386 Packages [18.0 kB]                       
Get:24 http://packages.linuxmint.com maya/upstream i386 Packages [10.6 kB]                   
Ign http://packages.medibuntu.org precise/free Translation-en_GB                             
Get:25 http://packages.linuxmint.com maya/import i386 Packages [41.6 kB]                     
Ign http://packages.medibuntu.org precise/free Translation-en                               
Get:26 http://packages.linuxmint.com maya/backport i386 Packages [20 B]                     
Ign http://packages.linuxmint.com maya/backport TranslationIndex                             
Ign http://packages.linuxmint.com maya/import TranslationIndex                           
Get:27 http://archive.ubuntu.com precise-updates/restricted i386 Packages [6,732 B]         
Get:28 http://archive.ubuntu.com precise-updates/universe i386 Packages [127 kB]             
Ign http://packages.linuxmint.com maya/main TranslationIndex                                 
Get:29 http://archive.ubuntu.com precise-updates/multiverse i386 Packages [9,672 B]         
Hit http://archive.ubuntu.com precise-updates/main TranslationIndex                         
Hit http://archive.ubuntu.com precise-updates/multiverse TranslationIndex                   
Hit http://archive.ubuntu.com precise-updates/restricted TranslationIndex                   
Hit http://archive.ubuntu.com precise-updates/universe TranslationIndex                     
Hit http://archive.ubuntu.com precise/main Translation-en_GB                                 
Hit http://archive.ubuntu.com precise/main Translation-en                                   
Hit http://archive.ubuntu.com precise/multiverse Translation-en_GB                           
Hit http://archive.ubuntu.com precise/multiverse Translation-en                             
Hit http://archive.ubuntu.com precise/restricted Translation-en_GB                           
Hit http://archive.ubuntu.com precise/restricted Translation-en                             
Hit http://archive.ubuntu.com precise/universe Translation-en_GB                             
Hit http://archive.ubuntu.com precise/universe Translation-en                               
Hit http://archive.ubuntu.com precise-updates/main Translation-en_GB                         
Hit http://archive.ubuntu.com precise-updates/main Translation-en                           
Hit http://archive.ubuntu.com precise-updates/multiverse Translation-en_GB                   
Hit http://archive.ubuntu.com precise-updates/multiverse Translation-en                     
Hit http://archive.ubuntu.com precise-updates/restricted Translation-en_GB                   
Hit http://archive.ubuntu.com precise-updates/restricted Translation-en                     
Hit http://archive.ubuntu.com precise-updates/universe Translation-en_GB                     
Hit http://archive.ubuntu.com precise-updates/universe Translation-en                       
Ign http://packages.linuxmint.com maya/upstream TranslationIndex                             
Ign http://packages.medibuntu.org precise/non-free Translation-en_GB             
Ign http://packages.medibuntu.org precise/non-free Translation-en
Ign http://packages.linuxmint.com maya/backport Translation-en_GB
Ign http://packages.linuxmint.com maya/backport Translation-en
Ign http://packages.linuxmint.com maya/import Translation-en_GB
Ign http://packages.linuxmint.com maya/import Translation-en
Ign http://packages.linuxmint.com maya/main Translation-en_GB
Ign http://packages.linuxmint.com maya/main Translation-en
Ign http://packages.linuxmint.com maya/upstream Translation-en_GB
Ign http://packages.linuxmint.com maya/upstream Translation-en
Fetched 1,314 kB in 5s (244 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

install wine1.5 from the ppa (dry-run)
Code: Select all
zerozero@zerozero-Inspiron-1545 ~ $ sudo apt-get -s install wine
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  binfmt-support fonts-droid fonts-horai-umefont fonts-unfonts-core gcc-4.6-base:i386
  libasn1-8-heimdal:i386 libasound2:i386 libasyncns0:i386 libavahi-client3:i386
  libavahi-common-data:i386 libavahi-common3:i386 libc6:i386 libcapi20-3 libcapi20-3:i386
  libcomerr2:i386 libcups2:i386 libdb5.1:i386 libdbus-1-3:i386 libdrm-intel1:i386
  libdrm-nouveau1a:i386 libdrm-radeon1:i386 libdrm2:i386 libexif12:i386 libexpat1:i386
  libffi6:i386 libflac8:i386 libfontconfig1:i386 libfreetype6:i386 libgcc1:i386
  libgcrypt11:i386 libgd2-xpm:i386 libgettextpo0 libgif4:i386 libgl1-mesa-dri:i386
  libgl1-mesa-glx:i386 libglapi-mesa:i386 libglib2.0-0:i386 libglu1-mesa:i386
  libgnutls26:i386 libgpg-error0:i386 libgphoto2-2:i386 libgphoto2-port0:i386 libgpm2:i386
  libgssapi-krb5-2:i386 libgssapi3-heimdal:i386 libgstreamer-plugins-base0.10-0:i386
  libgstreamer0.10-0:i386 libhcrypto4-heimdal:i386 libheimbase1-heimdal:i386
  libheimntlm0-heimdal:i386 libhx509-5-heimdal:i386 libice6:i386 libieee1284-3:i386
  libjpeg-turbo8:i386 libjpeg8:i386 libjson0:i386 libk5crypto3:i386 libkeyutils1:i386
  libkrb5-26-heimdal:i386 libkrb5-3:i386 libkrb5support0:i386 liblcms1:i386
  libldap-2.4-2:i386 libllvm3.0:i386 libltdl7:i386 libmpg123-0 libmpg123-0:i386
  libncurses5:i386 libodbc1 libogg0:i386 libopenal1:i386 liborc-0.4-0:i386 libosmesa6
  libosmesa6:i386 libp11-kit0:i386 libpam-winbind libpciaccess0:i386 libpcre3:i386
  libpng12-0:i386 libpulse0:i386 libroken18-heimdal:i386 libsane:i386 libsasl2-2:i386
  libsasl2-modules:i386 libselinux1:i386 libsm6:i386 libsndfile1:i386 libsqlite3-0:i386
  libssl1.0.0:i386 libstdc++6:i386 libtasn1-3:i386 libtiff4:i386 libtinfo5:i386
  libunistring0 libusb-0.1-4:i386 libuuid1:i386 libv4l-0:i386 libv4lconvert0:i386
  libvorbis0a:i386 libvorbisenc2:i386 libwind0-heimdal:i386 libwrap0:i386 libx11-6:i386
  libx11-xcb1:i386 libxau6:i386 libxcb-glx0:i386 libxcb1:i386 libxcomposite1:i386
  libxcursor1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxi6:i386
  libxinerama1:i386 libxml2:i386 libxpm4:i386 libxrandr2:i386 libxrender1:i386
  libxslt1.1:i386 libxt6:i386 libxxf86vm1:i386 ttf-droid ttf-mscorefonts-installer
  ttf-umefont ttf-unfonts-core unixodbc winbind wine-gecko1.7 wine-gecko1.7:i386
  wine-mono0.0.4 wine1.5 wine1.5-amd64 wine1.5-i386:i386 winetricks zlib1g:i386
Suggested packages:
  libasound2-plugins:i386 libasound2-python:i386 glibc-doc:i386 locales:i386
  cups-common:i386 rng-tools:i386 libgd-tools:i386 libglide3:i386 gnutls-bin:i386
  gphoto2:i386 gtkam:i386 gpm:i386 krb5-doc:i386 krb5-user:i386 libvisual-0.4-plugins:i386
  gstreamer-codec-install:i386 gnome-codec-install:i386 gstreamer0.10-tools:i386
  gstreamer0.10-plugins-base:i386 liblcms-utils:i386 libmyodbc odbc-postgresql tdsodbc
  unixodbc-bin hpoj:i386 hplip:i386 libsane-extras:i386 sane-utils:i386
  libsasl2-modules-otp:i386 libsasl2-modules-ldap:i386 libsasl2-modules-sql:i386
  libsasl2-modules-gssapi-mit:i386 libsasl2-modules-gssapi-heimdal:i386 dosbox:any
Recommended packages:
  xml-core:i386 gettext gettext:i386 unixodbc:i386 wine-mono0.0.4:i386
The following NEW packages will be installed
  binfmt-support fonts-droid fonts-horai-umefont fonts-unfonts-core gcc-4.6-base:i386
  libasn1-8-heimdal:i386 libasound2:i386 libasyncns0:i386 libavahi-client3:i386
  libavahi-common-data:i386 libavahi-common3:i386 libc6:i386 libcapi20-3 libcapi20-3:i386
  libcomerr2:i386 libcups2:i386 libdb5.1:i386 libdbus-1-3:i386 libdrm-intel1:i386
  libdrm-nouveau1a:i386 libdrm-radeon1:i386 libdrm2:i386 libexif12:i386 libexpat1:i386
  libffi6:i386 libflac8:i386 libfontconfig1:i386 libfreetype6:i386 libgcc1:i386
  libgcrypt11:i386 libgd2-xpm:i386 libgettextpo0 libgif4:i386 libgl1-mesa-dri:i386
  libgl1-mesa-glx:i386 libglapi-mesa:i386 libglib2.0-0:i386 libglu1-mesa:i386
  libgnutls26:i386 libgpg-error0:i386 libgphoto2-2:i386 libgphoto2-port0:i386 libgpm2:i386
  libgssapi-krb5-2:i386 libgssapi3-heimdal:i386 libgstreamer-plugins-base0.10-0:i386
  libgstreamer0.10-0:i386 libhcrypto4-heimdal:i386 libheimbase1-heimdal:i386
  libheimntlm0-heimdal:i386 libhx509-5-heimdal:i386 libice6:i386 libieee1284-3:i386
  libjpeg-turbo8:i386 libjpeg8:i386 libjson0:i386 libk5crypto3:i386 libkeyutils1:i386
  libkrb5-26-heimdal:i386 libkrb5-3:i386 libkrb5support0:i386 liblcms1:i386
  libldap-2.4-2:i386 libllvm3.0:i386 libltdl7:i386 libmpg123-0 libmpg123-0:i386
  libncurses5:i386 libodbc1 libogg0:i386 libopenal1:i386 liborc-0.4-0:i386 libosmesa6
  libosmesa6:i386 libp11-kit0:i386 libpam-winbind libpciaccess0:i386 libpcre3:i386
  libpng12-0:i386 libpulse0:i386 libroken18-heimdal:i386 libsane:i386 libsasl2-2:i386
  libsasl2-modules:i386 libselinux1:i386 libsm6:i386 libsndfile1:i386 libsqlite3-0:i386
  libssl1.0.0:i386 libstdc++6:i386 libtasn1-3:i386 libtiff4:i386 libtinfo5:i386
  libunistring0 libusb-0.1-4:i386 libuuid1:i386 libv4l-0:i386 libv4lconvert0:i386
  libvorbis0a:i386 libvorbisenc2:i386 libwind0-heimdal:i386 libwrap0:i386 libx11-6:i386
  libx11-xcb1:i386 libxau6:i386 libxcb-glx0:i386 libxcb1:i386 libxcomposite1:i386
  libxcursor1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxi6:i386
  libxinerama1:i386 libxml2:i386 libxpm4:i386 libxrandr2:i386 libxrender1:i386
  libxslt1.1:i386 libxt6:i386 libxxf86vm1:i386 ttf-droid ttf-mscorefonts-installer
  ttf-umefont ttf-unfonts-core unixodbc winbind wine wine-gecko1.7 wine-gecko1.7:i386
  wine-mono0.0.4 wine1.5 wine1.5-amd64 wine1.5-i386:i386 winetricks zlib1g:i386
0 upgraded, 137 newly installed, 0 to remove and 0 not upgraded.

works and without any error :shock:
something i forgot yesterday- is multiarch enabled?
Code: Select all
zerozero@zerozero-Inspiron-1545 ~ $ dpkg --print-foreign-architectures
i386
zerozero
Level 16
Level 16
 
Posts: 6472
Joined: Tue Jul 07, 2009 2:29 pm

Re: [x64] Wine??!! can't install to save my life

Postby zerozero on Fri Aug 24, 2012 10:12 pm

on the other hand if you have the repo version installed and add the ppa, you have to tell apt to install wine explicitly otherwise it wont update to 1.5
Code: Select all
zerozero@zerozero-Inspiron-1545 ~ $ apt dist-upgrade
[sudo] password for zerozero:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed
  libasound2-plugins:i386 libasyncns0:i386 libcroco3:i386 libflac8:i386 libgettextpo0:i386 libgomp1:i386 libjack-jackd2-0:i386 libjson0:i386 libogg0:i386 libosmesa6 libosmesa6:i386
  libpulse0:i386 libsamplerate0:i386 libsndfile1:i386 libspeexdsp1:i386 libunistring0:i386 libvorbis0a:i386 libvorbisenc2:i386 libwrap0:i386 wine-gecko1.7 wine-gecko1.7:i386 wine-mono0.0.4
The following packages have been kept back:
  wine
The following packages will be upgraded:
  wine1.4 wine1.4-amd64 wine1.4-common wine1.4-i386:i386 winetricks
5 upgraded, 22 newly installed, 0 to remove and 1 not upgraded.
Need to get 127 MB of archives.
After this operation, 110 MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Get:1 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ precise/main wine-gecko1.7 amd64 1.7-0ubuntu1~ppa1~precise1 [17.4 MB]
Get:2 http://archive.ubuntu.com/ubuntu/ precise/main libasyncns0 i386 0.8-4 [12.9 kB]     
Get:3 http://archive.ubuntu.com/ubuntu/ precise/main libcroco3 i386 0.6.5-1 [99.7 kB]     
Get:4 http://archive.ubuntu.com/ubuntu/ precise/main libogg0 i386 1.2.2~dfsg-1ubuntu1 [17.6 kB]
Get:5 http://archive.ubuntu.com/ubuntu/ precise/main libflac8 i386 1.2.1-6 [142 kB]
Get:6 http://archive.ubuntu.com/ubuntu/ precise/main libgomp1 i386 4.6.3-1ubuntu5 [28.3 kB]
Get:7 http://archive.ubuntu.com/ubuntu/ precise/main libunistring0 i386 0.9.3-5 [432 kB]
Get:8 http://archive.ubuntu.com/ubuntu/ precise/main libgettextpo0 i386 0.18.1.1-5ubuntu3 [118 kB]
Get:9 http://archive.ubuntu.com/ubuntu/ precise/main libsamplerate0 i386 0.1.8-4 [1,341 kB]
Get:10 http://archive.ubuntu.com/ubuntu/ precise/main libjack-jackd2-0 i386 1.9.8~dfsg.1-1ubuntu1 [170 kB]                                                                                     
Get:11 http://archive.ubuntu.com/ubuntu/ precise/main libjson0 i386 0.9-1ubuntu1 [16.7 kB]                                                                                                     
Get:12 http://archive.ubuntu.com/ubuntu/ precise/main libvorbis0a i386 1.3.2-1ubuntu3 [99.4 kB]                                                                                               
Get:13 http://archive.ubuntu.com/ubuntu/ precise/main libvorbisenc2 i386 1.3.2-1ubuntu3 [116 kB]                                                                                               
Get:14 http://archive.ubuntu.com/ubuntu/ precise/main libsndfile1 i386 1.0.25-4 [180 kB]                                                                                                       
Get:15 http://archive.ubuntu.com/ubuntu/ precise/main libwrap0 i386 7.6.q-21 [49.7 kB]                                                                                                         
Get:16 http://archive.ubuntu.com/ubuntu/ precise-updates/main libpulse0 i386 1:1.1-0ubuntu15.1 [278 kB]                                                                                       
Get:17 http://archive.ubuntu.com/ubuntu/ precise/main libspeexdsp1 i386 1.2~rc1-3ubuntu2 [90.8 kB]                                                                                             
Get:18 http://archive.ubuntu.com/ubuntu/ precise-updates/main libosmesa6 amd64 8.0.3+8.0.2-0ubuntu3.2 [1,155 kB]                                                                               
Get:19 http://archive.ubuntu.com/ubuntu/ precise-updates/main libosmesa6 i386 8.0.3+8.0.2-0ubuntu3.2 [1,144 kB]                                                                               
Get:20 http://archive.ubuntu.com/ubuntu/ precise/main libasound2-plugins i386 1.0.25-1ubuntu1 [69.0 kB]                                                                                       
Get:21 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ precise/main wine-gecko1.7 i386 1.7-0ubuntu1~ppa1~precise1 [16.9 MB]                                                                   
Get:22 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ precise/main wine-mono0.0.4 all 0.0.4-0ubuntu1~ppa1 [44.0 MB]                                                                         
Get:23 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ precise/main wine1.4-i386 i386 1.4.1-0ubuntu1~precise1~ppa3 [20.0 MB]                                                                 
Get:24 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ precise/main wine1.4-common all 1.4.1-0ubuntu1~precise1~ppa3 [970 B]                                                                   
Get:25 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ precise/main wine1.4 amd64 1.4.1-0ubuntu1~precise1~ppa3 [1,125 kB]                                                                     
Get:26 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ precise/main wine1.4-amd64 amd64 1.4.1-0ubuntu1~precise1~ppa3 [21.6 MB]                                                                 
Get:27 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ precise/main winetricks amd64 0.0+20120819~precise1~ppa1 [149 kB]                                                                       
Fetched 127 MB in 5min 3s (418 kB/s)                                                                                                                                                           
Preconfiguring packages ...
Selecting previously unselected package libasyncns0:i386.
(Reading database ... 257612 files and directories currently installed.)
Unpacking libasyncns0:i386 (from .../libasyncns0_0.8-4_i386.deb) ...
Selecting previously unselected package libcroco3:i386.
Unpacking libcroco3:i386 (from .../libcroco3_0.6.5-1_i386.deb) ...
Selecting previously unselected package libogg0:i386.
Unpacking libogg0:i386 (from .../libogg0_1.2.2~dfsg-1ubuntu1_i386.deb) ...
Selecting previously unselected package libflac8:i386.
Unpacking libflac8:i386 (from .../libflac8_1.2.1-6_i386.deb) ...
Selecting previously unselected package libgomp1:i386.
Unpacking libgomp1:i386 (from .../libgomp1_4.6.3-1ubuntu5_i386.deb) ...
Selecting previously unselected package libunistring0:i386.
Unpacking libunistring0:i386 (from .../libunistring0_0.9.3-5_i386.deb) ...
Selecting previously unselected package libgettextpo0:i386.
Unpacking libgettextpo0:i386 (from .../libgettextpo0_0.18.1.1-5ubuntu3_i386.deb) ...
Selecting previously unselected package libsamplerate0:i386.
Unpacking libsamplerate0:i386 (from .../libsamplerate0_0.1.8-4_i386.deb) ...
Selecting previously unselected package libjack-jackd2-0:i386.
Unpacking libjack-jackd2-0:i386 (from .../libjack-jackd2-0_1.9.8~dfsg.1-1ubuntu1_i386.deb) ...
Selecting previously unselected package libjson0:i386.
Unpacking libjson0:i386 (from .../libjson0_0.9-1ubuntu1_i386.deb) ...
Selecting previously unselected package libvorbis0a:i386.
Unpacking libvorbis0a:i386 (from .../libvorbis0a_1.3.2-1ubuntu3_i386.deb) ...
Selecting previously unselected package libvorbisenc2:i386.
Unpacking libvorbisenc2:i386 (from .../libvorbisenc2_1.3.2-1ubuntu3_i386.deb) ...
Selecting previously unselected package libsndfile1:i386.
Unpacking libsndfile1:i386 (from .../libsndfile1_1.0.25-4_i386.deb) ...
Selecting previously unselected package libwrap0:i386.
Unpacking libwrap0:i386 (from .../libwrap0_7.6.q-21_i386.deb) ...
Selecting previously unselected package libpulse0:i386.
Unpacking libpulse0:i386 (from .../libpulse0_1%3a1.1-0ubuntu15.1_i386.deb) ...
Selecting previously unselected package libspeexdsp1:i386.
Unpacking libspeexdsp1:i386 (from .../libspeexdsp1_1.2~rc1-3ubuntu2_i386.deb) ...
Selecting previously unselected package wine-gecko1.7.
Unpacking wine-gecko1.7 (from .../wine-gecko1.7_1.7-0ubuntu1~ppa1~precise1_amd64.deb) ...
Selecting previously unselected package wine-gecko1.7:i386.
Unpacking wine-gecko1.7:i386 (from .../wine-gecko1.7_1.7-0ubuntu1~ppa1~precise1_i386.deb) ...
Selecting previously unselected package wine-mono0.0.4.
Unpacking wine-mono0.0.4 (from .../wine-mono0.0.4_0.0.4-0ubuntu1~ppa1_all.deb) ...
Preparing to replace wine1.4-i386:i386 1.4-0ubuntu4.1 (using .../wine1.4-i386_1.4.1-0ubuntu1~precise1~ppa3_i386.deb) ...
Unpacking replacement wine1.4-i386:i386 ...
Preparing to replace wine1.4-common 1.4-0ubuntu4.1 (using .../wine1.4-common_1.4.1-0ubuntu1~precise1~ppa3_all.deb) ...
Unpacking replacement wine1.4-common ...
Preparing to replace wine1.4 1.4-0ubuntu4.1 (using .../wine1.4_1.4.1-0ubuntu1~precise1~ppa3_amd64.deb) ...
Unpacking replacement wine1.4 ...
Preparing to replace wine1.4-amd64 1.4-0ubuntu4.1 (using .../wine1.4-amd64_1.4.1-0ubuntu1~precise1~ppa3_amd64.deb) ...
Unpacking replacement wine1.4-amd64 ...
Preparing to replace winetricks 0.0+20120308 (using .../winetricks_0.0+20120819~precise1~ppa1_amd64.deb) ...
Unpacking replacement winetricks ...
Selecting previously unselected package libosmesa6.
Unpacking libosmesa6 (from .../libosmesa6_8.0.3+8.0.2-0ubuntu3.2_amd64.deb) ...
Selecting previously unselected package libosmesa6:i386.
Unpacking libosmesa6:i386 (from .../libosmesa6_8.0.3+8.0.2-0ubuntu3.2_i386.deb) ...
Selecting previously unselected package libasound2-plugins:i386.
Unpacking libasound2-plugins:i386 (from .../libasound2-plugins_1.0.25-1ubuntu1_i386.deb) ...
Processing triggers for man-db ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for desktop-file-utils ...
Setting up libasyncns0:i386 (0.8-4) ...
Setting up libcroco3:i386 (0.6.5-1) ...
Setting up libogg0:i386 (1.2.2~dfsg-1ubuntu1) ...
Setting up libflac8:i386 (1.2.1-6) ...
Setting up libgomp1:i386 (4.6.3-1ubuntu5) ...
Setting up libunistring0:i386 (0.9.3-5) ...
Setting up libgettextpo0:i386 (0.18.1.1-5ubuntu3) ...
Setting up libsamplerate0:i386 (0.1.8-4) ...
Setting up libjack-jackd2-0:i386 (1.9.8~dfsg.1-1ubuntu1) ...
Setting up libjson0:i386 (0.9-1ubuntu1) ...
Setting up libvorbis0a:i386 (1.3.2-1ubuntu3) ...
Setting up libvorbisenc2:i386 (1.3.2-1ubuntu3) ...
Setting up libsndfile1:i386 (1.0.25-4) ...
Setting up libwrap0:i386 (7.6.q-21) ...
Setting up libpulse0:i386 (1:1.1-0ubuntu15.1) ...
Setting up libspeexdsp1:i386 (1.2~rc1-3ubuntu2) ...
Setting up wine-gecko1.7 (1.7-0ubuntu1~ppa1~precise1) ...
Setting up wine-gecko1.7:i386 (1.7-0ubuntu1~ppa1~precise1) ...
Setting up wine-mono0.0.4 (0.0.4-0ubuntu1~ppa1) ...
Setting up winetricks (0.0+20120819~precise1~ppa1) ...
Setting up libosmesa6 (8.0.3+8.0.2-0ubuntu3.2) ...
Setting up libosmesa6:i386 (8.0.3+8.0.2-0ubuntu3.2) ...
Setting up libasound2-plugins:i386 (1.0.25-1ubuntu1) ...
Setting up wine1.4-common (1.4.1-0ubuntu1~precise1~ppa3) ...
Setting up wine1.4-amd64 (1.4.1-0ubuntu1~precise1~ppa3) ...
Setting up wine1.4-i386:i386 (1.4.1-0ubuntu1~precise1~ppa3) ...
Setting up wine1.4 (1.4.1-0ubuntu1~precise1~ppa3) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place


Code: Select all
zerozero@zerozero-Inspiron-1545 ~ $ apt install wine
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libunistring0:i386 libgomp1:i386 libcroco3:i386 libgettextpo0:i386
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  wine1.5 wine1.5-amd64 wine1.5-i386:i386
Suggested packages:
  dosbox:any
Recommended packages:
  gettext gettext:i386
The following packages will be REMOVED
  wine1.4 wine1.4-amd64 wine1.4-common wine1.4-i386:i386
The following NEW packages will be installed
  wine1.5 wine1.5-amd64 wine1.5-i386:i386
The following packages will be upgraded:
  wine
1 upgraded, 3 newly installed, 4 to remove and 0 not upgraded.
Need to get 44.3 MB of archives.
After this operation, 7,730 kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Get:1 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ precise/main wine amd64 1.5.11-0ubuntu1 [922 B]
Get:2 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ precise/main wine1.5-amd64 amd64 1.5.11-0ubuntu1 [22.4 MB]
Get:3 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ precise/main wine1.5 amd64 1.5.11-0ubuntu1 [1,139 kB]                                                                                   
Get:4 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ precise/main wine1.5-i386 i386 1.5.11-0ubuntu1 [20.7 MB]                                                                               
Fetched 44.3 MB in 1min 57s (377 kB/s)                                                                                                                                                         
(Reading database ... 257702 files and directories currently installed.)
Preparing to replace wine 1.4-0ubuntu4.1 (using .../wine_1.5.11-0ubuntu1_amd64.deb) ...
Unpacking replacement wine ...
(Reading database ... 257701 files and directories currently installed.)
Removing wine1.4 ...
Removing wine1.4-amd64 ...
dpkg: wine1.4-common: dependency problems, but removing anyway as you requested:
 wine1.4-i386:i386 depends on wine1.4-common (= 1.4.1-0ubuntu1~precise1~ppa3).
Removing wine1.4-common ...
Processing triggers for desktop-file-utils ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for man-db ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Selecting previously unselected package wine1.5-amd64.
(Reading database ... 256519 files and directories currently installed.)
Unpacking wine1.5-amd64 (from .../wine1.5-amd64_1.5.11-0ubuntu1_amd64.deb) ...
Selecting previously unselected package wine1.5.
Unpacking wine1.5 (from .../wine1.5_1.5.11-0ubuntu1_amd64.deb) ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for desktop-file-utils ...
Processing triggers for man-db ...
(Reading database ... 257737 files and directories currently installed.)
Removing wine1.4-i386:i386 ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Selecting previously unselected package wine1.5-i386:i386.
(Reading database ... 256594 files and directories currently installed.)
Unpacking wine1.5-i386:i386 (from .../wine1.5-i386_1.5.11-0ubuntu1_i386.deb) ...
Setting up wine1.5-amd64 (1.5.11-0ubuntu1) ...
Setting up wine1.5 (1.5.11-0ubuntu1) ...
Setting up wine1.5-i386:i386 (1.5.11-0ubuntu1) ...
Setting up wine (1.5.11-0ubuntu1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
zerozero@zerozero-Inspiron-1545 ~ $
zerozero
Level 16
Level 16
 
Posts: 6472
Joined: Tue Jul 07, 2009 2:29 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Hank2, Kugelsicher, WharfRat, Wilbur-Klick and 42 guests