Silly Question- which version do I have..?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Silly Question- which version do I have..?

Postby LOVEANDA45 on Fri Apr 11, 2008 10:39 am

I installed this awhile ago after trying a million different distros, this was the only keeper:) Love it. I just was wondering which edition I am using. Im drawing a blank on the name.

when I check system monitor, it says

Ubuntu
Release 7.04 (feisty)

though terminal it says:
sara@Linux:~$ uname -a && cat /etc/*release
Linux Linux 2.6.20-16-generic #2 SMP Tue Feb 12 05:41:34 UTC 2008 i686 GNU/Linux
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=7.04
DISTRIB_CODENAME=feisty
DISTRIB_DESCRIPTION="Ubuntu 7.04"


Is there some way I can tell the actual edition of mint? I was wondering if there was any upgrades to my current version, but I can't really tell if I don't know my current edition:)

I was also wondering if there is any easy way to upgrade to Gimp 2.4. When I try installing through Terminal, it says I have the current version, but I am running 2.2. When I check the synaptic package manager, I don't see 2.4 available either.

Any feedback for a Mint newbie would be much appreciated!
LOVEANDA45
Level 1
Level 1
 
Posts: 8
Joined: Fri Apr 11, 2008 10:28 am

Linux Mint is funded by ads and donations.
 

Re: Silly Question- which version do I have..?

Postby LOVEANDA45 on Fri Apr 11, 2008 11:16 am

browsing around a bit through the forums, I discovered:

Cassandra/Celena (Feisty) <---so I think I just found the answer. I seem to recall the name Cassandra now.

also, from what I can tell updates are based on repositories, so the repository for Cassandra probably doesn't have the Gimp 2.4 update available.

Is it a hassel to upgrade from Cassandra to Daryna? I feel foolish asking. I know Windows like the back of my hand (unfortunately) but when it comes to linux Im all like, duh.
Is there a way to upgrade without losing information? Usually I do a clean install when Im changing OS's, but I have alot of info on my current computer I don't really feel like relocating to my back up drive right now. Im only mildly ambitious.

I will keep poking around the forums and try to answer my own question, but if anyone wants to clue me in-please, feel free!

thanks!
LOVEANDA45
Level 1
Level 1
 
Posts: 8
Joined: Fri Apr 11, 2008 10:28 am

Re: Silly Question- which version do I have..?

Postby solar1951 on Fri Apr 11, 2008 11:40 am

Upgrades are not really to much of a hassle but it really depends on whether you have a separate /home partition with your personal files and settings for firefox amongst others.
Gimp 2.4.5 is available as a series of .deb files from Getdeb
http://www.getdeb.net/search.php?keywords=gimp

It probably wont install in Cassandra/Celena/Ubuntu 7.04 due to version issues with dependancies.
solar1951
Level 4
Level 4
 
Posts: 259
Joined: Wed Oct 03, 2007 4:14 am
Location: France

Re: Silly Question- which version do I have..?

Postby eagle on Fri Apr 11, 2008 12:30 pm

As solar1951 says, upgrading should not be much of a problem if your /home folder is on another partition. If is isn't on another partition, there's a nice howto for moving your /home folder to a new partition on the wiki: http://www.linuxmint.com/wiki/index.php/Move_home_to_its_own_partition The only thing I would add is that when/if you decide to try and move your /home folder, make sure that you have automatic network browsing turned off. I didn't think about that when I tried moving my /home folder, and it tried to move everything on my network (which is in the Network folder in /home). Needless to say, the partition got full before it could copy everything! :P I'm actually running on Daryna Xfce right now, but if I remember correctly, you turn off automatic network browsing in mintDesktop, and then reboot. You can then turn it back on after your move.

About the Gimp, there seems to be no easy way to get a 2.4 version on a Feisty system. The .deb that solar1951 posted the link to is for Gutsy, so as he points out, you will run into dependency problems. I did a bit of googling, and there were many people asking how to get 2.4 on Feisty, but there were few answers. The best thing I could find was a tutorial on the Ubuntu community site: https://help.ubuntu.com/community/GIMP2.4-on-Feisty It is rather long and complicated, and there is the risk of messing up other programs that depend on the files you would have to update for the Gimp.

Hope this helps out! :)
User avatar
eagle
Level 1
Level 1
 
Posts: 31
Joined: Fri Jul 06, 2007 12:22 am

Re: Silly Question- which version do I have..?

Postby LOVEANDA45 on Fri Apr 11, 2008 1:31 pm

Thank you both!

I decided to just back up my files (around time to do that anyway!) and do a fresh install. I hope it goes smoothly- Ihavn't run into any notable issues with Mint yet, so I am feeling confident that it will.

I'll be back when I'm done my upgrade!

:)
LOVEANDA45
Level 1
Level 1
 
Posts: 8
Joined: Fri Apr 11, 2008 10:28 am


Return to Newbie Questions

Who is online

Users browsing this forum: austin.texas, buytick, Google Adsense [Bot], Linny and 31 guests