Mint 13 won't connect to wifi? [SOLVED]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Mint 13 won't connect to wifi? [SOLVED]

Postby mastermind16X on Thu Oct 18, 2012 10:26 am

Hi, I have recently installed Linux Mint 13 alongside Windows, and every time I boot it I need to input his code into the terminal:
sudo modprobe -r iwlagn
sudo modprobe iwlagn bt_coex_active=0

This will fix the wifi, but only temporarily. I have to re-enter the code every time I reboot my machine. I have an ASUS u56e Notebook PC. I have Linux Mint 13 MATE interface, 64 bit. My PC is also 64 bit, so there are no problems there. Is there any way to permanently fix the wifi, or do I need to type this every time I boot Mint? Or should I just install Mint 12 and use that rather than 13?
Last edited by mastermind16X on Sat May 04, 2013 9:08 pm, edited 1 time in total.
"When you are courting a nice girl an hour seems like a second. When you sit on a red-hot cinder a second seems like an hour. That's relativity."
-Albert Einstein
mastermind16X
Level 1
Level 1
 
Posts: 36
Joined: Wed Oct 17, 2012 8:01 pm

Linux Mint is funded by ads and donations.
 

Re: Mint 13 won't connect to wifi?

Postby xenopeek on Thu Oct 18, 2012 10:33 am

See the tips here on how to make that permanent: http://askubuntu.com/questions/104651/h ... 585#114585

If you need any help with that, please share. On Linux Mint 13 MATE, replace "gedit" in the commands with "pluma". Or on KDE replace "gksu gedit" with "kdesu kate".
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14985
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Mint 13 won't connect to wifi?

Postby mastermind16X on Thu Oct 18, 2012 11:37 am

I put the codes in and used pluma rather than gedit, but it didn't work. I still have to put in the code into the terminal at boot.
"When you are courting a nice girl an hour seems like a second. When you sit on a red-hot cinder a second seems like an hour. That's relativity."
-Albert Einstein
mastermind16X
Level 1
Level 1
 
Posts: 36
Joined: Wed Oct 17, 2012 8:01 pm

Re: Mint 13 won't connect to wifi?

Postby AlbertP on Thu Oct 18, 2012 12:03 pm

You can put the commands in /etc/rc.local, without sudo, then they are executed automatically when booting.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6519
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Mint 13 won't connect to wifi?

Postby mastermind16X on Thu Oct 18, 2012 9:24 pm

Sorry for being paranoid, but could you type out exactly what I need to type into the terminal so I don't mess something up? I'm very new to Linux and haven't figured most of it out just yet.
"When you are courting a nice girl an hour seems like a second. When you sit on a red-hot cinder a second seems like an hour. That's relativity."
-Albert Einstein
mastermind16X
Level 1
Level 1
 
Posts: 36
Joined: Wed Oct 17, 2012 8:01 pm

Re: Mint 13 won't connect to wifi?

Postby xenopeek on Fri Oct 19, 2012 6:34 am

To edit the file suggested by AlbertP, type:
Code: Select all
gksudo pluma /etc/rc.local

In Pluma add the two commands you had to enter upon each boot, but without the sudo prefix. Add them just before the final line with "exit 0" on it. So for example like so (added lines in red):
/etc/rc.local wrote:#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

modprobe -r iwlagn
modprobe iwlagn bt_coex_active=0

exit 0
Last edited by xenopeek on Fri Oct 19, 2012 6:53 am, edited 1 time in total.
Reason: Removed errant sudo as per AlbertP's observation
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14985
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Mint 13 won't connect to wifi?

Postby AlbertP on Fri Oct 19, 2012 6:48 am

Since /etc/rc.local is executed as root, you can remove "sudo" when putting commands in there. I'm not sure if sudo will actually work there, at least if it's removed the commands should run fine.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6519
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Mint 13 won't connect to wifi?

Postby xenopeek on Fri Oct 19, 2012 6:54 am

Dôh... Thanks for catching that one AlbertP, you are entirely correct!
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14985
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Mint 13 won't connect to wifi?

Postby mastermind16X on Fri Oct 19, 2012 10:23 am

Alright, it's working now, thanks! I read somewhere that this lowers the internet connection speed, is this true, or will I never run into this problem? The Mint forum is slower, but none of the other websites I've been to have been noticeably slowed.
"When you are courting a nice girl an hour seems like a second. When you sit on a red-hot cinder a second seems like an hour. That's relativity."
-Albert Einstein
mastermind16X
Level 1
Level 1
 
Posts: 36
Joined: Wed Oct 17, 2012 8:01 pm

Re: Mint 13 won't connect to wifi?

Postby xenopeek on Fri Oct 19, 2012 10:39 am

On the link I shared it is suggesting that your solution might cause a speed drop, and IIRC it has a solution for that also. I'd test with something like www.speedtest.net what your speed is, and compare it to from another operating system?
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14985
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Mint 13 won't connect to wifi?

Postby mastermind16X on Fri Oct 19, 2012 11:07 am

My internet speed is considerably slower on Mint 13 than on Windows 7. Is it possible that this is because I have Mint installed alongside Windows, or is this incorrect thinking? Also, is there anything different that I'd need to do since I'm running Mint instead of Ubuntu, or is it the same for both OS's?
"When you are courting a nice girl an hour seems like a second. When you sit on a red-hot cinder a second seems like an hour. That's relativity."
-Albert Einstein
mastermind16X
Level 1
Level 1
 
Posts: 36
Joined: Wed Oct 17, 2012 8:01 pm

Re: Mint 13 won't connect to wifi?

Postby mastermind16X on Fri Oct 19, 2012 11:18 am

I did what the site told me to do, and it solved nothing. It just disconnected me from the wifi and gave me the same problem I had before I edited the pluma file, though this problem was only temporary. The internet speed is still slow, any other ideas as to what I should do?
"When you are courting a nice girl an hour seems like a second. When you sit on a red-hot cinder a second seems like an hour. That's relativity."
-Albert Einstein
mastermind16X
Level 1
Level 1
 
Posts: 36
Joined: Wed Oct 17, 2012 8:01 pm

Re: Mint 13 won't connect to wifi?

Postby jaderiver on Sat Oct 20, 2012 1:22 pm

mastermind 16X...

I have the same computer system as yours and my MINT 13 wifi now works like lightning. (Even dialup works really fast now, as far as dialup goes.) My computer is outfitted with iwlwifi, not iwlagn. (To check what you have, use terminal command, "lsmod." )

So, here is the wifi script which worked for me. In terminal:
rmmod iwlwifi

Then,
modprobe iwlwifi bt_coex_active=0

To make this script permanent, in terminal:
sudo pluma /etc/modprobe.d/iwlwifi.conf

Then add line:
options iwlwifi bt_coex_active=0

Save changes. Can't remember if I needed to reboot.
Here is another article, which is long and technical, and shows the process of how one team solved this issue; I found interesting:

http://bugzilla.intellinuxwireless.org/ ... gi?id=2325

Good luck w/ getting up to speed.
jaderiver :P
ASUS U56E 64-bit Mint 13 MATE Maya w/Petra backported - dualboot WIN 7
Zoom #3095 dialup USB modem
jaderiver
Level 2
Level 2
 
Posts: 79
Joined: Wed Jun 27, 2012 1:43 pm
Location: Oregon Coast

Re: Mint 13 won't connect to wifi?

Postby AlbertP on Sun Oct 21, 2012 7:20 am

The iwlwifi or iwlagn name of the driver for Intel wireless, depends on the Mint version that you are using. I'm now on Mint 12 where iwlagn does not exist but iwlwifi does. On other Mint versions it may be iwlagn instead.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6519
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Mint 13 won't connect to wifi?

Postby jaderiver on Sun Oct 21, 2012 11:29 am

AlbertP...

Thank you very much for clarifying how versions of drivers are determined. I just typed in terminal, inxi -N, to see the following:

Network: Card-1: Atheros AR8151 v2.0 Gigabit Ethernet driver: atl1c
Card-2: Intel Centrino Wireless-N + WiMAX 6150 driver: iwlwifi

So, now I am to understand that card types/models are physical constants within computer hardware, whereas driver versions are determined by the OS being used. Please correct me if I am wrong.

jaderiver
ASUS U56E 64-bit Mint 13 MATE Maya w/Petra backported - dualboot WIN 7
Zoom #3095 dialup USB modem
jaderiver
Level 2
Level 2
 
Posts: 79
Joined: Wed Jun 27, 2012 1:43 pm
Location: Oregon Coast

Re: Mint 13 won't connect to wifi?

Postby AlbertP on Sun Oct 21, 2012 12:58 pm

That's correct. The driver is the OS component that makes you able to use the hardware.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6519
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Mint 13 won't connect to wifi?

Postby mastermind16X on Mon Oct 22, 2012 10:20 am

When I typed rmmod iwlwifi I got an error message: ERROR: Removing 'iwlwifi': Operation not permitted

I went on ahead and did the other stuff, the ping speed increased a bit, but the download and upload speeds were drastically lowered, even from Mint 13 before. I am on a public network, so this may be a factor, but I don't think the codes did anything.

I also can't connect to my home network. The router is a Belkin N600 router, and it will try to connect for a while, then ask me for the password. I put in the password, it tries to connect, fails, and asks me for the password again. Did I just mess up and use the wrong password, or is this another Mint 13 problem? Is the fix I applied before not applicable to my home router?
"When you are courting a nice girl an hour seems like a second. When you sit on a red-hot cinder a second seems like an hour. That's relativity."
-Albert Einstein
mastermind16X
Level 1
Level 1
 
Posts: 36
Joined: Wed Oct 17, 2012 8:01 pm

Re: Mint 13 won't connect to wifi?

Postby xenopeek on Mon Oct 22, 2012 10:52 am

The command should probably be run as superuser. So do:
Code: Select all
sudo rmmod iwlwifi

instead.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14985
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Mint 13 won't connect to wifi?

Postby mastermind16X on Mon Oct 22, 2012 11:12 am

I applied the fix, but my internet is just as slow as it was before. Am I doing something wrong?
"When you are courting a nice girl an hour seems like a second. When you sit on a red-hot cinder a second seems like an hour. That's relativity."
-Albert Einstein
mastermind16X
Level 1
Level 1
 
Posts: 36
Joined: Wed Oct 17, 2012 8:01 pm

Re: Mint 13 won't connect to wifi?

Postby remoulder on Mon Oct 22, 2012 11:51 am

Vincent Vermeulen wrote:sudo rmmod iwlwifi

Hesitant to get involved here as there are already too many hands, however @mastermind16X you may be getting a little confused as to which replies apply to you. You are running the iwlagn driver, so Vincent's command should have been
Code: Select all
sudo rmmod iwlagn
if it was meant for you, but as there is no need for you to remove the driver it may have been intended at @jaderiver.

@mastermind16X going back to your original post, if you have entered the options iwlagn bt_coex_active=0 in a /etc/modprobe.d/iwl.conf file, all you should need to do is reload the driver with
Code: Select all
sudo modprobe -r iwlagn
sudo modprobe iwlagn

If you have modified /etc/rc.local you will need to reboot.
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Linux Mint is funded by ads and donations.
 
Next

Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], Yahoo [Bot] and 26 guests