Dual screen set up attempt gone wrong.

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Dual screen set up attempt gone wrong.

Postby mocap on Tue Apr 22, 2008 7:24 pm

I have a radeon x1950pro gfx, dual head, dual monitor display. Trying to set up extended desktop on my second monitor, but every time I try to follow the instructions (blindly I must add...) to use xorg (not even sure what it is) with theATI big desktop (? ?) and then started again trying mergedFB... it doesnt work or I am doing it wrong (sadly, probably the latter), and I am not left with the 1280 x 1024 clones I started with, I am left with two 800x600 clones. Ack. I did try to back the xorg config file before I started, but I think I mucked that up too. I have run the thing to put the back up in place to put it back the way it should be before I started mucking with it.. I think.... can't be sure... but I am left with an annoying display.

Anyway, my xorg.conf :
Code: Select all
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "gb"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"        "/dev/input/mice"
        Option          "Protocol"      "ImPS/2"
        Option          "ZAxisMapping"  "4 5"
        Option          "Emulate3Buttons"       "true"
EndSection

Section "InputDevice"
        Driver          "wacom"
        Identifier      "stylus"
         Option          "Device"        "/dev/input/wacom"
        Option          "Type"  "stylus"
        Option          "ForceDevice"   "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
        Driver          "wacom"
        Identifier      "eraser"
        Option          "Device"        "/dev/input/wacom"
        Option          "Type"  "eraser"
        Option          "ForceDevice"   "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
        Driver          "wacom"
        Identifier      "cursor"
        Option          "Device"        "/dev/input/wacom"
        Option          "Type"  "cursor"
        Option          "ForceDevice"   "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
       Identifier      "Generic Video Card"
        Driver          "fglrx"
        Busid           "PCI:4:0:0"
EndSection

Section "Monitor"
        Identifier      "ASUS VW193S"
        Option          "DPMS"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "Generic Video Card"
        Monitor         "ASUS VW193S"
        Defaultdepth    24
        SubSection "Display"
                Modes   "1280x1024"
#       "1440x1440"     "1440x900"      "1280x1280"     "1280x1024"     "1280x960"      "1152x864"      "1024x768"      "832x624"       "800x600"       "72$
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
  screen "Default Screen"
        Inputdevice     "Generic Keyboard"
        Inputdevice     "Configured Mouse"

        # Uncomment if you have a wacom tablet
        #       InputDevice     "stylus"        "SendCoreEvents"
        #       InputDevice     "cursor"        "SendCoreEvents"
        #       InputDevice     "eraser"        "SendCoreEvents"
EndSection
Section "Module"
        Load            "glx"
EndSection
Section "Extensions"
        Option          "Composite"     "0"
EndSection




I am sorry if this is a little dumb, this is my first real attempt at a linux install, rather than just to muck about on, and fist attempt at a dual montior display. I hope I have given enough information!

*edit* Uhm didn't acutally put in what I wanted to acheive. A 1280x1024 on one screen, 1440x900 on second screen, or atleast a useable resolution! *edit*

Sorry if I waffled!

J
User avatar
mocap
Level 1
Level 1
 
Posts: 1
Joined: Tue Apr 22, 2008 5:49 pm
Location: West Yorks, UK

Linux Mint is funded by ads and donations.
 

Re: Dual screen set up attempt gone wrong.

Postby Husse on Wed Apr 23, 2008 5:48 am

ATI.....
Anyway this is an xorg.conf for just one monitor - not a trace of dual monitors
I think you can fix it after reading this
viewtopic.php?f=59&t=10729&hilit=dual+monitors+ati
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden


Return to Newbie Questions

Who is online

Users browsing this forum: karlchen, NewBconvert and 33 guests