CD or DVD autoplay doesn't work in Mint 13 Maya

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

CD or DVD autoplay doesn't work in Mint 13 Maya

Postby xntryk1 on Sun Dec 09, 2012 6:39 pm

Whenever I insert a CD or DVD, it spins for a little while, but doesn't open any program. I can only start it manually, by opening the program (say, VLC), finding the DVD in the drive and starting it. That can't possibly be the only way to do it. How do I fix this? Help! Thanks!


Lenovo IBM ThinkPad T60 laptop
120 GB hard drive
CPU: Intel Core Duo T2400 (1.83GHz)
Bus speed: 667MHz
Memory: 3GB of DDR2 667MHz SDRAM (2 DIMMs)
CD-RW/DVD-ROM combo drive (in Ultrabay Slim)
Graphics: ATI Mobility Radeon X1400 graphics adapter (integrated)
Display: 14.1" TFT with SXGA+ (1400x1050) resolution
Communications: 802.11a/b/g via Intel PRO/Wireless 3945AGB
Modem: 56K Modem
USB Port: 3
xntryk1
Level 1
Level 1
 
Posts: 19
Joined: Sun Nov 04, 2012 10:58 am

Linux Mint is funded by ads and donations.
 

Re: CD or DVD autoplay doesn't work in Mint 13 Maya

Postby caribriz on Sun Dec 09, 2012 10:27 pm

Do CDs and DVDs play ok in VLC if you start them manually?
That is, your sound and video is working? If so -

These settings (kind of***) work for me in Mint 13 mate using VLC - no guarantees it will work for you.

Menu > Control Center > Preferred Applications > Multimedia
Multimedia Player > choose VLC
Video Player > choose VLC

Menu > Control Center > File Management > Media tab
Media Handling .....
CD Audio: Open VLC media player
DVD Video: Open VLC media player
At bottom of window, uncheck both:
"Never prompt or start programs on media insertion"
"Browse media when inserted"

With these settings:

When I inserted a DVD - VLC opened and started playing - seemed ok.
***When I inserted a CD, VLC opened and it started, but "jerkily" played for a few seconds, and then played track 10 - it didn't start at the beginning of the disk.
This happened for me with a couple of CDs - and on two different installs of Mint 13 mate - so will have to look further into it.

Let me know if it is the same for you ...

caribriz
Image
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 17 Cinnamon)
caribriz
Level 5
Level 5
 
Posts: 900
Joined: Mon Nov 28, 2011 7:43 am

Re: CD or DVD autoplay doesn't work in Mint 13 Maya

Postby xntryk1 on Mon Dec 10, 2012 7:48 pm

Yes, sound and video work fine when I start something up manually.

OK, I did all of that and had EXACTLY the same results. Store-bought DVD movies started up just fine in VLC. And a store-bought audio CD started up, gave a couple scratching sounds and then proceeded to play Track 10!

Two things, when I inserted a home-recorded DVD movie (versus the store-bought kind), VLC still would NOT start up automatically. However, I CAN play those kinds of DVDs just fine by starting them up manually in VLC. They (still) just won't autoplay for some reason.

Also, when I inserted a blank CD, the burning utility Brasero did not automatically open, nor was I given any option to start it. An icon for the blank CD is just displayed on the desktop. However, when I open Brasero manually, it recognizes the blank CD in the drive and seems ready for the burning task. Any ideas on how to make THAT start automatically?

Is is just me or is it strange that these kinds of seemingly intuitive actions aren't already built into Mint? Maybe I'm just too used to Windows and not having to worry about such things.

Anyway, thanks for all of your help, so far. At least we're making SOME progress. :-)
xntryk1
Level 1
Level 1
 
Posts: 19
Joined: Sun Nov 04, 2012 10:58 am

Re: CD or DVD autoplay doesn't work in Mint 13 Maya

Postby caribriz on Tue Dec 11, 2012 8:34 am

I've been searching the internet and experimenting with this, but haven't been able to find any solutions.
I saw only two brief mentions of the "starting at Track 10" problem - and no fixes provided.

As you saw in the original thread, Mint 13 xfce VLC will autoplay cds/dvds -
http://forums.linuxmint.com/viewtopic.php?f=57&t=115736

I've reproduced this with LM13 xfce, and also the failure with LM13 mate with 2 different installs of each version.
Both xfce and mate are using the exact same version of VLC (2.0.3).

These are just my observations:
The difference between the two versions seems to be the options available for handling Removable Media, choosing Preferred Applications, and also the ability to specify a command for VLC in xfce - these options are different for the two versions. Some options are not available in mate and I don't know how to (or if you can) - manually configure them. In mate, some options are "greyed out". Mate doesn't have the same "Removable Drives and Media" section to configure.
The nearest thing it has are the options in Preferred Applications and File Management preferences.

In Mint 13 xfce you can choose these options and insert a command for VLC:
Image

In mate, these are the Preferred Applications options and the command area is greyed out.
Under "Multimedia player" and "Video player" you can't choose "Custom" or set a command either:
Image

Mint 13 mate File Management preferences:
Image

There is also a difference in the way VLC in xfce and mate reads the track numbers during autoplay -
Mint 13 xfce reads tracks in sequence:
Image

Mint 13 mate - reads tracks out of order:
Image

Yet, if you start it manually in mate the tracks play in the proper sequence. :?

I haven't tried it, but probably there are similar reasons to the above for the autostart failure with a blank cd in Brasero (in mate).
Yet, again, it will work ok when you start it manually.

These problems really don't bother me too much - I usually start playing cds/dvds and burning manually anyway.
But if it is a deal breaker for you, maybe you could check out LM13 xfce, but you will find it very different from mate in many ways.
The versions of LM13 - Cinnamon, mate, xfce and KDE all have their different ways of doing things and their own "quirks".
(I think that LM13 Cinnamon is similar to mate with autoplay but I'm not sure how LM13 KDE handles it.)

As I said, this is just what I've experienced messing around with this - I haven't any clue how to fix this in mate.
I'm hoping someone else will have some suggestions to fix this weird problem.

caribriz
Image
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 17 Cinnamon)
caribriz
Level 5
Level 5
 
Posts: 900
Joined: Mon Nov 28, 2011 7:43 am

Re: CD or DVD autoplay doesn't work in Mint 13 Maya

Postby xntryk1 on Tue Dec 11, 2012 1:21 pm

No, it's not a deal-breaker for me, personally. I don't mind (too much) having to use work-arounds to make things work - as long as they end up working! I was just hoping to make this computer as glitch-free as possible, because I'm wanting to sell it. I suppose I could make it clear that the Mint installation (which I've since upgraded to 14) will require the usual TLC that any Linux operating system seems to need. And then, maybe only someone who's similarly OK with playing with work-arounds will buy it.

It's just strange to me that only two or three of us seem to be the ONLY ones who have this concern about autoplay. You'd think there would be LOTS of threads about it and lots of suggestions for solutions. I know it's not THAT big of a deal, but still, it's something that SHOULD work.

Anyway, thanks again for all of your efforts. I'll be perusing them carefully in hopes that they might lead me to maybe think of a solution. If I come up with anything, I'll definitely come back here and make a report.
xntryk1
Level 1
Level 1
 
Posts: 19
Joined: Sun Nov 04, 2012 10:58 am

Re: CD or DVD autoplay doesn't work in Mint 13 Maya

Postby caribriz on Tue Dec 11, 2012 3:31 pm

You're right, of course, it should work in mate (and Cinnamon) just like it does in xfce. It is the same version of the software.
We might be missing something very simple, and it might be able to be "tweaked" directly in mate's Configuration Editor.
I did try to change mate's VLC command in this way, but it made no difference to being able to autoplay correctly or not.
(I noticed the greyed out command in mate is %s, and the usual command to launch VLC is /usr/bin/vlc %U).

One thing I forgot to mention with regards to the track order problem - it may be that the File Manager - Thunar in xfce and Caja in mate - has something to do with it.
Maybe Thunar reads the track order (files) is the correct way, ie. 1, 2, 3 or 01, 02, 03 etc. and Caja may somehow mistakenly read numbers on media
as 10 first then ... well whatever :lol: It's certainly very strange. I couldn't find a setting to change it in mate.
Then again, it also may not have anything to do with it. :wink: Just throwing it out there ... I'm just trying to see what the differences are between one version
of Mint that works with autoplay, and one that doesn't.

If you do find a solution or make some progress with this, please post back.

caribriz
Image
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 17 Cinnamon)
caribriz
Level 5
Level 5
 
Posts: 900
Joined: Mon Nov 28, 2011 7:43 am

Re: CD or DVD autoplay doesn't work in Mint 13 Maya

Postby caribriz on Sat Dec 15, 2012 5:44 pm

I think I found a solution (for Mint 13 mate) ...

You need to adjust 2 settings -
In the File Manager Preferences Media tab - CD Audio - add a custom command
In VLC's Preferences - Input and Codecs screen - change the default optical device
Save the Preferences

This is what I did:

Open vlc > Tools > Preferences
click Reset Preferences > ok
Again go to: vlc > Tools > Preferences > Input & Codecs > Optical drive > Default optical device ...
change from default (mine) /dev/dvd to /dev/sr0 (the choice may be different for your setup ?)
click Save

Open File Manager
Edit > Preferences > Media tab
Media Handling
CD Audio ... click down arrow - click "Open with other Application" (I missed this option before - I just didn't see that you could choose this!)
"Add Application" window opens - click down arrow next to "Use a custom command"
type in box
/usr/bin/vlc cdda:///dev/sr0
(again, this command may depend on your cd/dvd drive ?)
click Add

(In CD Audio preferences is now "Open vlc" (with no icon) instead of "Open VLC Media Player" with icon)
close

Inserted cd
It autoplayed from Track 1 in the correct order and also played without any "stutter" like it did previously.
Tried with the 2 cds I was experimenting with before - and it works on both of my Mint 13 mate installs.

Edit: It's puzzling that the command that works for me for Mint 13 xfce (/usr/bin/vlc cdda:///dev/cdrom) is different than the working command
for cds for Mint 13 mate (/usr/bin/vlc cdda:///dev/sr0)
As said before, the version of vlc is the same - 2.0.3 Twoflower :?

caribriz
Image
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 17 Cinnamon)
caribriz
Level 5
Level 5
 
Posts: 900
Joined: Mon Nov 28, 2011 7:43 am

Re: CD or DVD autoplay doesn't work in Mint 13 Maya

Postby xntryk1 on Sat Dec 15, 2012 6:27 pm

Thanks for the heads-up! Sure enough, that worked - excellent! Now, both store-bought CDs and DVDs autoplay like they're supposed to - AND start at the right place. Thank you SO much!

Now if only I could get it to recognize and autostart Brasero. Here's the error message I get when I insert a blank CD: "Unable to mount Blank CD-R Disc. Location is already mounted." That's in one small window.

Underneath it is another window that says: "You have just inserted a blank CD. Choose what application to launch. Select how to open "Blank CD-0R Disc" and whether to perform this action in the future for other media of type "Blank CD-R Disc."

But the drop-down menu is grayed-out and there's no way to select any application! Aaaaaccckk!
xntryk1
Level 1
Level 1
 
Posts: 19
Joined: Sun Nov 04, 2012 10:58 am

Re: CD or DVD autoplay doesn't work in Mint 13 Maya

Postby caribriz on Sat Dec 15, 2012 8:41 pm

Glad we could get at least autoplay of cds/dvds working :)

With regards to the blank cd problem -
like you I get this message on insertion of blank cd:
"You have just inserted a blank CD. Choose what application to launch.
Select how to open "Blank CD-R Disc" and whether to perform this action in the future for other media of type "Blank CD-R Disc."

but, I don't get the first message
"Unable to mount Blank CD-R Disc. Location is already mounted."

Don't know what to do about that. :(

But, just been looking around and found this:
https://bugs.launchpad.net/linuxmint/+bug/1016956

Add those two lines:
Code: Select all
x-content/blank-cd=brasero.desktop
x-content/blank-dvd=brasero.desktop

to ~/ .local/share/applications/mimeapps.list

After adding them:
File Manager > Edit > Preferences > Media tab > Other media > blank cd
now has other "Action" options -
Ask what to do
Do nothing
Open folder
Open Brasero Disc Burner
Open with other application

I chose "Open Brasero Disc Burner", closed box, then again inserted a blank cd.
Brasero opened up at the "New Data Disc Project" page.
There are now extra options to choose for blank DVDs as well.

You may have to fix the "Unable to mount Blank CD-R ...." problem first. :?:

caribriz
Image
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 17 Cinnamon)
caribriz
Level 5
Level 5
 
Posts: 900
Joined: Mon Nov 28, 2011 7:43 am

Re: CD or DVD autoplay doesn't work in Mint 13 Maya

Postby xntryk1 on Sat Dec 15, 2012 8:52 pm

You're too good to me - thanks! I'll get to work on that. The "unable to mount" thing only started after I messed with a couple other settings. Hopefully, I can remember what I did...
xntryk1
Level 1
Level 1
 
Posts: 19
Joined: Sun Nov 04, 2012 10:58 am

Re: CD or DVD autoplay doesn't work in Mint 13 Maya

Postby caribriz on Sat Dec 15, 2012 8:55 pm

Fingers crossed you can get it to work -

it seems that it is a common problem ...
https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/1069964

caribriz
Image
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 17 Cinnamon)
caribriz
Level 5
Level 5
 
Posts: 900
Joined: Mon Nov 28, 2011 7:43 am

Re: CD or DVD autoplay doesn't work in Mint 13 Maya

Postby xntryk1 on Sun Jan 06, 2013 4:37 pm

And 3 weeks later, I'm finally getting a chance to "get to work on that" and newbie me immediately runs into a(nother) brick wall. WHERE/HOW do I find/access "~/ .local/share/applications/mimeapps.list" in order to add those two lines? Help!

Sorry to (still) be such a pain... :-(
xntryk1
Level 1
Level 1
 
Posts: 19
Joined: Sun Nov 04, 2012 10:58 am

Re: CD or DVD autoplay doesn't work in Mint 13 Maya

Postby TheDynamicHamza21 on Sun Jan 06, 2013 6:35 pm

xntryk1 wrote:And 3 weeks later, I'm finally getting a chance to "get to work on that" and newbie me immediately runs into a(nother) brick wall. WHERE/HOW do I find/access "~/ .local/share/applications/mimeapps.list" in order to add those two lines? Help!

Sorry to (still) be such a pain... :-(


with Caja navigate to the file> right click> choose "open as Administrator" ,type in your password and it it will open with Pluma.
Linux Registered User: # 573034

www.domeshotsandfatlaces.com
User avatar
TheDynamicHamza21
Level 5
Level 5
 
Posts: 780
Joined: Thu Oct 04, 2012 7:24 pm
Location: California

Re: CD or DVD autoplay doesn't work in Mint 13 Maya

Postby xntryk1 on Sun Jan 06, 2013 6:42 pm

Thanks so much, but you're still way over my newbie head. What's "Caja" and how and where do I find IT? :-)
xntryk1
Level 1
Level 1
 
Posts: 19
Joined: Sun Nov 04, 2012 10:58 am

Re: CD or DVD autoplay doesn't work in Mint 13 Maya

Postby caribriz on Sun Jan 06, 2013 6:47 pm

xntryk1 wrote:WHERE/HOW do I find/access "~/ .local/share/applications/mimeapps.list" in order to add those two lines?

Open your /home folder
Click View > Show hidden files
Open the folders .local > share > applications ..... then open the file mimeapps.list
Add the two lines to the [Default Applications] section - (I just copied/pasted them after the line x-content/video-dvd=vlc.desktop)
Save the file.

Logout/login.

Then click Edit > Preferences > Media tab > Other media > blank cd
and choose the (now added option) "Open Brasero Disc Burner"

Note: I don't know how to get Brasero to open a different page other than "New Data Disc Project" when you insert a blank cd.

caribriz
Image
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 17 Cinnamon)
caribriz
Level 5
Level 5
 
Posts: 900
Joined: Mon Nov 28, 2011 7:43 am

Re: CD or DVD autoplay doesn't work in Mint 13 Maya

Postby xntryk1 on Sun Jan 06, 2013 6:59 pm

Yay! That did it! Now, when I insert a blank CD, Brasero starts automatically AND recognizes that there's a blank CD in the drive. Unfortunately, that little "unable to mount" message still shows up, but it doesn't seem to affect anything so I can live with that. Thanks again, caribriz! :-)
xntryk1
Level 1
Level 1
 
Posts: 19
Joined: Sun Nov 04, 2012 10:58 am

Re: CD or DVD autoplay doesn't work in Mint 13 Maya

Postby xntryk1 on Sun Jan 06, 2013 7:23 pm

Apparently, that "unable to mount" thing is a confirmed Ubuntu bug:
https://bugs.launchpad.net/ubuntu/+sour ... ug/1069964
Maybe somebody will have afix for it some day...
xntryk1
Level 1
Level 1
 
Posts: 19
Joined: Sun Nov 04, 2012 10:58 am

Re: CD or DVD autoplay doesn't work in Mint 13 Maya

Postby caribriz on Sun Jan 06, 2013 7:28 pm

No problem :)

xntryk1 wrote:What's "Caja" and how and where do I find IT?

Caja is just the name of the file manager used in mate - if you open your /home folder, click Help > About, you'll see what version of your file manager you're running.
(In other versions of Mint the file manager is different - in LM13 Cinnamon the default is Nautilus, in LM14 Cinnamon it is Nemo - and each file manager is different -
as you've seen above with xfce - which uses Thunar as default).

When working with the files in your own home folder (whatever the file manager), you shouldn't need to be Administrator to edit the file.
You would have to "right-click, and Open as Administrator" if you were editing a file in Filesystem (root).

Apparently, that "unable to mount" thing is a confirmed Ubuntu bug ... Maybe somebody will have afix for it some day...

Yes, let's hope :wink:

caribriz
Image
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 17 Cinnamon)
caribriz
Level 5
Level 5
 
Posts: 900
Joined: Mon Nov 28, 2011 7:43 am

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: figgy, mach50, Mute Ant and 38 guests