How NOT to mount NTFS partitions?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

How NOT to mount NTFS partitions?

Postby junior-s on Fri Jan 18, 2013 11:00 pm

Whenever I start Mint it mounts Windows' partitions. Is there any wahy NOT to mount it by default?
junior-s
Level 1
Level 1
 
Posts: 40
Joined: Mon Jan 14, 2013 8:57 pm

Linux Mint is funded by ads and donations.
 

Re: How NOT to mount NTFS partitions?

Postby TheDynamicHamza21 on Fri Jan 18, 2013 11:28 pm

junior-s wrote:Whenever I start Mint it mounts Windows' partitions. Is there any wahy NOT to mount it by default?


Are sure it's being mounted? Mint doesn't mount partitions unless an user allow it to? Showing a partition and mounting are two different things.
"I rock project yards and township youth
I make the people listen,boogie down and move"
Rakaa Iriscience - Triple Optics


www.domeshotsandfatlaces.com
User avatar
TheDynamicHamza21
Level 5
Level 5
 
Posts: 643
Joined: Thu Oct 04, 2012 7:24 pm

Re: How NOT to mount NTFS partitions?

Postby junior-s on Fri Jan 18, 2013 11:41 pm

Yes. Just noticed it shows it, but doesn't mount by default. Thing is you doesn't need root passwd to mount then (which is really a security threat for me). I read somewhere I can edit the /etc/fstab not to show/mount them when Mint boots up, but I couldn't find it anywhere.
junior-s
Level 1
Level 1
 
Posts: 40
Joined: Mon Jan 14, 2013 8:57 pm

Re: How NOT to mount NTFS partitions?

Postby TheDynamicHamza21 on Fri Jan 18, 2013 11:50 pm

junior-s wrote:Yes. Just noticed it shows it, but doesn't mount by default. Thing is you doesn't need root passwd to mount then (which is really a security threat for me). I read somewhere I can edit the /etc/fstab not to show/mount them when Mint boots up, but I couldn't find it anywhere.



search the web for "hide partitions [file manager name]"
"I rock project yards and township youth
I make the people listen,boogie down and move"
Rakaa Iriscience - Triple Optics


www.domeshotsandfatlaces.com
User avatar
TheDynamicHamza21
Level 5
Level 5
 
Posts: 643
Joined: Thu Oct 04, 2012 7:24 pm

Re: How NOT to mount NTFS partitions?

Postby junior-s on Fri Jan 18, 2013 11:57 pm

Untick the "Computer icon visible on the desktop", "Home icon visible on the desktop" and "Show mounted volumes on the desktop", then close the window.


'-'
junior-s
Level 1
Level 1
 
Posts: 40
Joined: Mon Jan 14, 2013 8:57 pm

Re: How NOT to mount NTFS partitions?

Postby TheDynamicHamza21 on Sat Jan 19, 2013 5:34 am

junior-s wrote:
Untick the "Computer icon visible on the desktop", "Home icon visible on the desktop" and "Show mounted volumes on the desktop", then close the window.


'-'



Drives,mounted and unmounted, are only show on the desktop using the live dvd. They are not shown on desktop when linux mint is installed but they are displayed in left hand panel of a file manger. Only usb connected devices (external hard drives/usb sticks/mp3 players,etc) are displayed on the desktop.
"I rock project yards and township youth
I make the people listen,boogie down and move"
Rakaa Iriscience - Triple Optics


www.domeshotsandfatlaces.com
User avatar
TheDynamicHamza21
Level 5
Level 5
 
Posts: 643
Joined: Thu Oct 04, 2012 7:24 pm

Re: How NOT to mount NTFS partitions?

Postby altair4 on Sat Jan 19, 2013 9:01 am

This is an example:

[1] Run the following command to find the correct UUID number for your ntfs partition:
Code: Select all
sudo blkid -c /dev/null

[2] Create a mount point for the ntfs partition - we aren't going to actually mount it - trust me :wink:
Code: Select all
sudo mkdir /mnt/WinC

[3] Add a line to /etc/fstab that looks like this - using the correct UUID from step [1] and the correct mount point from step [2]:
Code: Select all
UUID=200C11850C1156DE /mnt/WinC ntfs defaults,noauto 0 0

[4] Run the following command to test for syntax errors:
Code: Select all
sudo mount -a


The next time you boot into your system the WinC partition will not be mounted and it will not show up in Computer or in Nemo/Caja/ or whatever file manager you are using - that's what the "noauto" option does.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5517
Joined: Tue Feb 03, 2009 10:27 am

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: cajun46 and 34 guests