Cannot run Cinnamon, only Gnome

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

Cannot run Cinnamon, only Gnome

Postby VivoDePyre on Sun Jan 20, 2013 2:59 pm

I'll start with this: I'm green as hell. I had Lisa dualbooted on a laptop back when it hit, and everything was dandy. I had some issues, but they were common enough and nothing really required my to leave my depth.

Now I've built a new desktop and tossed Linux Mint 14 64bit Cinnamon edition alongside my Windows 7 64 bit. Something was screwed with the installation the first time, but I don't remember what. It went away the second time, so I didn't pay any mind. Well now that I have it installed successfully(ish), I boot into Linux Mint 14 from GRUB. Before hitting the log in screen, I see the linux mint logo but badly distorted with each subsequent horizontal scan line. The log in screen looks normal, so I don't question it too hard. Well whenever I try to boot into Cinnamon, it gives me a black screen with my computer name, the log in name, version number, etc. Then it briefly flashes to what looks like "Checking battery state..." or something, it moves too fast for me to see. Similarly on the prior screen. After flashing that quick "Checking ... state" message, it sends me back to the log in screen. Cinnamon 2D similarly does not work. Gnome, however, does. I went through and installed all of the pending updates, same problem persists.

I figured downloading drivers would help, maybe it was a display issue for Cinnamon. I went to the GeForce page and downloaded the driver for my card as Linux64. It gave me a .run file which gave me the message
Could not open the file /home/vivo/Downloads/NVI…A-Linux-x86_64-310.19.run using the Western (ISO-8859-15) character encoding.

So I have no clue what that is or even how to effectively search it. Taking bits in quotes didn't turn up any meaningful results for me, though not much is meaningful to me yet. So I look in the software sources -> additional drivers section like some other posts mentioned. Here's where my results start getting weird. "Using X.ORG X Server" is selected by default. If I select "Using NVIDIA binary Xorg driver, kernel module and VDPAU library..." it will pop back to X.Org after the progress bar quickly finishes. However, the Experimental NVIDIA binary Xorg driver actually progresses normal and installs. It sticks, I go to the log in screen, suddenly Cinnamon doesn't kick me out.

All well and good right? Wrong. It looks exactly like Gnome, I can't adjust themes in Cinnamon settings, I don't have the applets, etc. It's EXACTLY like what gnome was for me before. (I can post a screen shot if needed, but it's obviously not the default cinnamon). I have absolutely no idea where to go from here, because I don't even know what the problem is. I'm effectively drowning in a sea of "Nothing is working like it should".

Here's my potentially relevant specs. (roughly)

Intel® Core™ i3-3220 CPU @ 3.30GHz × 4
z77 MSI Military class motherboard
Geforce GTX 650 Ti
Connected directly from GPU to Monitor via DV-I (no idea why it would matter, but whatever)


Thank you for reading, all of your help/input is greatly appreciated.
VivoDePyre
Level 1
Level 1
 
Posts: 1
Joined: Sun Jan 20, 2013 2:08 pm

Linux Mint is funded by ads and donations.
 

Re: Cannot run Cinnamon, only Gnome

Postby passerby on Sun Jan 20, 2013 5:24 pm

Try:
-Removing everything nvidia.
Remove the attempted manual installation (sudo sh ./NVIDIA-blah-blah.run --uninstall)
Remove any drivers installed through other means (sudo purge nvidia*)
-Reboot.
Is the nouvea driver giving you a proper desktop now? If so:
-Install nvidia (whichever version you prefer. Since it worked before, I'd suggest installing nvidia experimental 310 through synaptic)
-Run sudo nvidia-xconfig (you may need to install this manually. I forget if it's packaged in with the main driver)
-Reboot again

I had this issue before because the leftover manual installation wasn't working and instead hindered the synaptic install.
The steps I took to rectify the issue were all over the place, so hopefully the above will do the trick for you.
Home PC: Xubuntu 14.04 x64, Nvidia GTX650, i7 3770K, 16GB RAM, Asus Xonar DX
Work PC: Mint 13 x64 XFCE, Nvidia GT620, i5 3470, 8GB RAM
Laptop: System76 Kudu Pro, Xubuntu 14.04 x64

My HTML5 login themes + screenshots
User avatar
passerby
Level 6
Level 6
 
Posts: 1375
Joined: Sun Dec 16, 2012 7:29 pm


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], bwsmith25, Mute Ant and 41 guests