[SOLVED] Unable to install Skype

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

[SOLVED] Unable to install Skype

Postby TrevelyanBlues on Wed Jan 23, 2013 2:17 pm

Hi guys,

Ok, so having just installed Mint 13 after a very long ordeal I'm now trying to get myself used to the new system.

My primary focus just now is getting Skype, everythin else I can wait for and figure out over time.

Simple question really...

How do I intsall it?

I've tried the installs on the Skype website but they all present a meesage that an older version is available and more compatible on the software channel. I checked the channel (or what I believe to be the channel) and tried a download on there. Every time I click install the bar at the bottom fills and nothing happens.
I've also tried the "sudo apt-get skype" etc to no avail, says it's unable to install...

Unable to fetch some archives- and then something about trying --fix-missing

I tried that with the end result of E: Abort install

Any advice?

Thanks everyone
Last edited by TrevelyanBlues on Wed Jan 23, 2013 7:40 pm, edited 1 time in total.
TrevelyanBlues
Level 1
Level 1
 
Posts: 13
Joined: Tue Jan 22, 2013 8:35 pm

Linux Mint is funded by ads and donations.
 

Re: Unable to install Skype

Postby xenopeek on Wed Jan 23, 2013 2:45 pm

Try the following two commands on the terminal (run them one at a time):
Code: Select all
apt update
apt install skype
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15449
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Unable to install Skype

Postby TrevelyanBlues on Wed Jan 23, 2013 5:00 pm

sorry i took so long, paying attention now!!!

it came up with this on the update

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

should i do as it says? or is something else afoot?
TrevelyanBlues
Level 1
Level 1
 
Posts: 13
Joined: Tue Jan 22, 2013 8:35 pm

Re: Unable to install Skype

Postby xenopeek on Wed Jan 23, 2013 5:39 pm

Yes, please do the command as it says. Any errors, share them here. It seems another package has not successfully completed installing, and hopefully this command will fix it.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15449
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Unable to install Skype

Postby TrevelyanBlues on Wed Jan 23, 2013 5:56 pm

i keep getting stuck with this when i try and install skype

Configuration file `/etc/grub.d/10_linux'
==> Modified (by you or by a script) since installation.
==> Package distributor has shipped an updated version.
What would you like to do about it ? Your options are:
Y or I : install the package maintainer's version
N or O : keep your currently-installed version
D : show the differences between the versions
Z : start a shell to examine the situation
The default action is to keep your current version.
*** 10_linux (Y/I/N/O/D/Z) [default=N] ?

the update stated Done
install created the above problem, which should i go for, if any?
TrevelyanBlues
Level 1
Level 1
 
Posts: 13
Joined: Tue Jan 22, 2013 8:35 pm

Re: Unable to install Skype

Postby xenopeek on Wed Jan 23, 2013 5:59 pm

Keep your current file is usually the right response for files in /etc. So either press enter on the prompt to do that, or press the 'D' key to show the differences between your current file and the newer one.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15449
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Unable to install Skype

Postby TrevelyanBlues on Wed Jan 23, 2013 6:03 pm

just pressed enter lol, tried the D before and i've no idea what happened xD
keep you posted, thanks for following this :)

ok, it stated a lot but it's said this at the end

Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Processing triggers for menu ...

it looks pretty normal to me, please correct me if otherwise

should i try apt install skype or something else?
TrevelyanBlues
Level 1
Level 1
 
Posts: 13
Joined: Tue Jan 22, 2013 8:35 pm

Re: Unable to install Skype

Postby xenopeek on Wed Jan 23, 2013 6:08 pm

Go ahead, try skype install.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15449
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Unable to install Skype

Postby TrevelyanBlues on Wed Jan 23, 2013 6:14 pm

did this maybe work...?

Reading package lists... Done
Building dependency tree
Reading state information... Done
skype is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 16 not upgraded.


sorry to keep this going but i feel with such progress i don't want to muck it up now!

where do i go from here? :)
TrevelyanBlues
Level 1
Level 1
 
Posts: 13
Joined: Tue Jan 22, 2013 8:35 pm

Re: Unable to install Skype

Postby xenopeek on Wed Jan 23, 2013 6:17 pm

Skype should be installed already? Check your Internet section in the menu.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15449
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Unable to install Skype

Postby TrevelyanBlues on Wed Jan 23, 2013 6:25 pm

awesome

ok so skype is now a go!
umm, hate to be cheeky but do you know how i can get video through this? only has phone calls, can i update without screwing up what we (mainly you) just did?
TrevelyanBlues
Level 1
Level 1
 
Posts: 13
Joined: Tue Jan 22, 2013 8:35 pm

Re: Unable to install Skype

Postby xenopeek on Wed Jan 23, 2013 6:45 pm

Might be a problem with your webcam support on Skype. That goes beyond what I'm familiar with, but perhaps here is something that may help: https://wiki.ubuntu.com/SkypeWebCams
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15449
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Unable to install Skype

Postby TrevelyanBlues on Wed Jan 23, 2013 7:39 pm

you have been incredible, thank you so much for your patience and persistence!
looked all over the internet to no avail and you've provided the answers i so desperately needed
can't thank you enough :D
TrevelyanBlues
Level 1
Level 1
 
Posts: 13
Joined: Tue Jan 22, 2013 8:35 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], Google Adsense [Bot], Mute Ant, RobHK, tgaddo, tooppy and 40 guests