Incompatability problems with Kernel 3.7.x

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Incompatability problems with Kernel 3.7.x

Postby cplguy on Wed Jan 23, 2013 11:41 pm

I upgraded the kernel to the 3.7 line from the 3.5 line, and when I did, I lost multiple monitor support, and native resolution support for the monitor that did work. After I dropped down to the command line, I was able to install the official Nvidia package, but upon restarting x server, the problem was worse. It only would display the desktop in 640x480. Since this was not acceptable to me, I reverted back to kernel 3.5.022-generic. Is there a way to have the 3.7.x kernel, and have my video card support native resolutions? My video card is a Geforce 465.
cplguy
Level 1
Level 1
 
Posts: 5
Joined: Wed Jan 23, 2013 11:35 pm

Linux Mint is funded by ads and donations.
 

Re: Incompatability problems with Kernel 3.7.x

Postby passerby on Thu Jan 24, 2013 12:14 am

Which version of the nvidia driver did you install?
Also, did you install 3.7 from source, via synaptic or by use of a .deb package?

As a relatively new kernel, older nvidia drivers don't work with it.
If you're on Mint (rather than LMDE) you may need to install the 310 experimental driver (after completely removing the current nvidia installation).
If you're on LMDE, you'll need packages from Sid.
Home PC: Xubuntu 14.04 x64, Nvidia GTX650, i7 3770K, 16GB RAM, Asus Xonar DX
Work PC: Mint 13 x64 XFCE, Nvidia GT620, i5 3470, 8GB RAM
Laptop: System76 Kudu Pro, Xubuntu 14.04 x64

My HTML5 login themes + screenshots
User avatar
passerby
Level 6
Level 6
 
Posts: 1373
Joined: Sun Dec 16, 2012 7:29 pm

Re: Incompatability problems with Kernel 3.7.x

Postby cplguy on Thu Jan 24, 2013 2:26 am

I installed Nvidia 310.32 x86_64 version directly downloaded from the Nvidia site. I installed 3.7 from synaptic, and I am running Linux Mint 14 KDE Edition.
cplguy
Level 1
Level 1
 
Posts: 5
Joined: Wed Jan 23, 2013 11:35 pm

Re: Incompatability problems with Kernel 3.7.x

Postby catweazel on Thu Jan 24, 2013 2:40 am

cplguy wrote:Is there a way to have the 3.7.x kernel, and have my video card support native resolutions?

Yes, compile it yourself from sources, with the appropriate options set. 3.7.x isn't in the repos and is completely unsupported.
Mint Testing Team & Mint Donor #3606
KDE 4.12.0, custom preemptive kernel 3.12.5,
Intel i7 4770K @ 4.7GHz, 16GB 2666MHz XMP,
4 Samsung 840 PRO 512GB SSDs in RAID0,
6TB HW RAID10, dual 24" Acer X243H,
Gigabyte nVidia GTX 680 Super Overclock
User avatar
catweazel
Level 7
Level 7
 
Posts: 1656
Joined: Fri Oct 12, 2012 9:44 pm

Re: Incompatability problems with Kernel 3.7.x

Postby passerby on Thu Jan 24, 2013 3:38 am

I recommend completely uninstalling the manually installed nvidia driver and using one from synaptic.
Probably nvidia-experimental-310, since you're keen on using 3.7.

In the directory with the .run file:
Code: Select all
sudo sh NVIDIA* --uninstall
sudo rm /etc/X11/xorg.conf
sudo apt-get install linux-source    //may be named differently, depending on where you got this kernel. Just make sure it's for 3.7
sudo apt-get install nvidia-experimental-310*
sudo nvidia-xconfig

Reboot and it should work fine. I think it would be a better idea to compile the kernel from source with the nvidia module, but this way is a quick & dirty solution.
Home PC: Xubuntu 14.04 x64, Nvidia GTX650, i7 3770K, 16GB RAM, Asus Xonar DX
Work PC: Mint 13 x64 XFCE, Nvidia GT620, i5 3470, 8GB RAM
Laptop: System76 Kudu Pro, Xubuntu 14.04 x64

My HTML5 login themes + screenshots
User avatar
passerby
Level 6
Level 6
 
Posts: 1373
Joined: Sun Dec 16, 2012 7:29 pm


Return to Newbie Questions

Who is online

Users browsing this forum: myedroid, nomko and 43 guests