Reading Package List .......... Error!

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Reading Package List .......... Error!

Postby dev-jam on Tue Jan 29, 2013 1:49 am

Hi,

I'm new to linux as I have changed as got sick of the bugs in windows so have converted to Linux now and it is so much faster and better. I can't believe I didn't do this sooner. I am having an issue updating the system though as I gettin the below error when trying to update.

apt update
Ign http://packages.linuxmint.com nadia InRelease
Ign http://security.ubuntu.com quantal-security InRelease
Ign http://archive.ubuntu.com quantal InRelease
Get:1 http://packages.linuxmint.com nadia Release.gpg [197 B]
Ign http://archive.canonical.com quantal InRelease
Hit http://security.ubuntu.com quantal-security Release.gpg
Get:2 http://packages.linuxmint.com nadia Release [17.6 kB]
Ign http://archive.ubuntu.com quantal-updates InRelease
Get:3 http://archive.canonical.com quantal Release.gpg [933 B]
Hit http://security.ubuntu.com quantal-security Release
Get:4 http://archive.ubuntu.com quantal Release.gpg [933 B]
Hit http://archive.canonical.com quantal Release
Hit http://security.ubuntu.com quantal-security/main i386 Packages
Ign http://archive.canonical.com quantal Release
Get:5 http://packages.linuxmint.com nadia/main i386 Packages [22.6 kB]
Hit http://security.ubuntu.com quantal-security/restricted i386 Packages
Hit http://archive.ubuntu.com quantal-updates Release.gpg
Ign http://archive.canonical.com quantal/partner i386 Packages/DiffIndex
Hit http://security.ubuntu.com quantal-security/universe i386 Packages
Hit http://archive.ubuntu.com quantal Release
Ign http://archive.ubuntu.com quantal Release
Get:6 http://packages.linuxmint.com nadia/upstream i386 Packages [11.3 kB]
Hit http://security.ubuntu.com quantal-security/multiverse i386 Packages
Hit http://archive.ubuntu.com quantal-updates Release
Get:7 http://packages.linuxmint.com nadia/import i386 Packages [44.0 kB]
Hit http://packages.medibuntu.org quantal InRelease
Ign http://archive.ubuntu.com quantal/main i386 Packages/DiffIndex
Hit http://security.ubuntu.com quantal-security/main Translation-en
Hit http://archive.canonical.com quantal/partner i386 Packages
Ign http://archive.ubuntu.com quantal/restricted i386 Packages/DiffIndex
Hit http://security.ubuntu.com quantal-security/multiverse Translation-en
Ign http://archive.ubuntu.com quantal/universe i386 Packages/DiffIndex
Hit http://packages.medibuntu.org quantal/free i386 Packages
Ign http://archive.ubuntu.com quantal/multiverse i386 Packages/DiffIndex
Hit http://security.ubuntu.com quantal-security/restricted Translation-en
Hit http://archive.ubuntu.com quantal/main Translation-en_AU
Hit http://packages.medibuntu.org quantal/non-free i386 Packages
Hit http://security.ubuntu.com quantal-security/universe Translation-en
Hit http://archive.ubuntu.com quantal/main Translation-en
Hit http://archive.ubuntu.com quantal/multiverse Translation-en_AU
Hit http://archive.ubuntu.com quantal/multiverse Translation-en
Ign http://archive.canonical.com quantal/partner Translation-en_AU
Hit http://archive.ubuntu.com quantal/restricted Translation-en_AU
Ign http://archive.canonical.com quantal/partner Translation-en
Hit http://archive.ubuntu.com quantal/restricted Translation-en
Hit http://archive.ubuntu.com quantal/universe Translation-en_AU
Hit http://archive.ubuntu.com quantal/universe Translation-en
Hit http://archive.ubuntu.com quantal-updates/main i386 Packages
Hit http://archive.ubuntu.com quantal-updates/restricted i386 Packages
Hit http://archive.ubuntu.com quantal-updates/universe i386 Packages
Ign http://security.ubuntu.com quantal-security/main Translation-en_AU
Hit http://archive.ubuntu.com quantal-updates/multiverse i386 Packages
Ign http://security.ubuntu.com quantal-security/multiverse Translation-en_AU
Ign http://security.ubuntu.com quantal-security/restricted Translation-en_AU
Hit http://archive.ubuntu.com quantal-updates/main Translation-en
Ign http://security.ubuntu.com quantal-security/universe Translation-en_AU
Hit http://archive.ubuntu.com quantal-updates/multiverse Translation-en
Ign http://packages.linuxmint.com nadia/import Translation-en_AU
Ign http://packages.linuxmint.com nadia/import Translation-en
Hit http://archive.ubuntu.com quantal-updates/restricted Translation-en
Ign http://packages.linuxmint.com nadia/main Translation-en_AU
Ign http://packages.linuxmint.com nadia/main Translation-en
Ign http://packages.linuxmint.com nadia/upstream Translation-en_AU
Hit http://archive.ubuntu.com quantal-updates/universe Translation-en
Ign http://packages.linuxmint.com nadia/upstream Translation-en
Hit http://archive.ubuntu.com quantal/main i386 Packages
Hit http://archive.ubuntu.com quantal/restricted i386 Packages
Hit http://archive.ubuntu.com quantal/universe i386 Packages
Hit http://archive.ubuntu.com quantal/multiverse i386 Packages
Ign http://packages.medibuntu.org quantal/free Translation-en_AU
Ign http://archive.ubuntu.com quantal-updates/main Translation-en_AU
Ign http://archive.ubuntu.com quantal-updates/multiverse Translation-en_AU
Ign http://packages.medibuntu.org quantal/free Translation-en
Ign http://archive.ubuntu.com quantal-updates/restricted Translation-en_AU
Ign http://packages.medibuntu.org quantal/non-free Translation-en_AU
Ign http://archive.ubuntu.com quantal-updates/universe Translation-en_AU
Ign http://packages.medibuntu.org quantal/non-free Translation-en
Fetched 97.6 kB in 18s (5,306 B/s)
Reading package lists... Error!
W: GPG error: http://archive.canonical.com quantal Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>
W: GPG error: http://archive.ubuntu.com quantal Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/packages.medibuntu.org_dists_quantal_free_i18n_Translation-en
E: The package lists or status file could not be parsed or opened.

Can some one please point me in the right direction to be able to fix this issue? :)

Thank you for your help.

Dev-jam
dev-jam
Level 1
Level 1
 
Posts: 1
Joined: Tue Jan 29, 2013 1:35 am

Linux Mint is funded by ads and donations.
 

Re: Reading Package List .......... Error!

Postby xenopeek on Tue Jan 29, 2013 3:32 am

For the badsig, you may try the following two commands from the terminal (one at a time). You can copy text to/from the terminal, see its Edit menu. You will be asked to provide your password; note that on the terminal you do not get any feedback as you type your password.
Code: Select all
sudo gpg --keyserver keyserver.ubuntu.com --recv-keys 40976EAF437D05B5
sudo gpg --export --armor 40976EAF437D05B5 | sudo apt-key add -

For the MergeList, do the following, to delete all package index files.
Code: Select all
sudo rm -fv /var/lib/apt/lists/*

That should solve both problems. Then run the following command to get all package index files anew. Any more errors, please share here.
Code: Select all
apt update
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14989
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Reading Package List .......... Error!

Postby aac74 on Tue Jan 29, 2013 9:13 am

I tried getting new keys but still get these invalid key errors ?

W: GPG error: http://www.mirrorservice.org nadia Release: The following signatures were invalid: BADSIG 3EE67F3D0FF405B2 Clement Lefebvre (Linux Mint Package Repository v1) <root@linuxmint.com>
W: GPG error: http://archive.ubuntu.com quantal Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>
W: GPG error: http://dl.google.com stable Release: The following signatures were invalid: BADSIG A040830F7FAC5991 Google, Inc. Linux Package Signing Key <linux-packages-keymaster@google.com>
aac74
Level 2
Level 2
 
Posts: 57
Joined: Sat Dec 08, 2012 2:29 pm

Re: Reading Package List .......... Error!

Postby passerby on Tue Jan 29, 2013 9:33 am

The error (and its solution) are detailed here: http://askubuntu.com/questions/89198/th ... re-invalid
Home PC: Xubuntu 14.04 x64, Nvidia GTX650, i7 3770K, 16GB RAM, Asus Xonar DX
Work PC: Mint 13 x64 XFCE, Nvidia GT620, i5 3470, 8GB RAM
Laptop: System76 Kudu Pro, Xubuntu 14.04 x64

My HTML5 login themes + screenshots
User avatar
passerby
Level 6
Level 6
 
Posts: 1375
Joined: Sun Dec 16, 2012 7:29 pm

Re: Reading Package List .......... Error!

Postby aac74 on Tue Jan 29, 2013 10:22 am

ok now I get one less error (after changing to main download server):

W: GPG error: http://archive.ubuntu.com quantal Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>
W: GPG error: http://dl.google.com stable Release: The following signatures were invalid: BADSIG A040830F7FAC5991 Google, Inc. Linux Package Signing Key <linux-packages-keymaster@google.com>

tried the above fix and tried getting new keys
aac74
Level 2
Level 2
 
Posts: 57
Joined: Sat Dec 08, 2012 2:29 pm

Re: Reading Package List .......... Error!

Postby xenopeek on Tue Jan 29, 2013 10:28 am

Try installing the package ubuntu-keyring.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14989
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Reading Package List .......... Error!

Postby aac74 on Tue Jan 29, 2013 11:38 am

reinstalled ubuntu-keyring but still the same.
aac74
Level 2
Level 2
 
Posts: 57
Joined: Sat Dec 08, 2012 2:29 pm

Re: Reading Package List .......... Error!

Postby aac74 on Tue Jan 29, 2013 2:31 pm

this worked for me:

sudo apt-get clean
cd /var/lib/apt
sudo mv lists lists.old
sudo mkdir -p lists/partial
sudo apt-get clean
sudo apt-get update
aac74
Level 2
Level 2
 
Posts: 57
Joined: Sat Dec 08, 2012 2:29 pm

Re: Reading Package List .......... Error!

Postby ptruchon on Mon Apr 08, 2013 11:50 am

Thanks aac74, this worked for me too.

Cheers!
ptruchon
Level 1
Level 1
 
Posts: 22
Joined: Sun Nov 20, 2011 10:25 pm

Re: Reading Package List .......... Error!

Postby nemarona on Sun Dec 15, 2013 6:24 pm

Since Medibuntu was discontinued, you can also get similar errors if it is still included in your sources.list: http://blog.linuxmint.com/?p=2469.
nemarona
Level 1
Level 1
 
Posts: 8
Joined: Tue Jan 18, 2011 10:08 am

Re: Reading Package List .......... Error!

Postby 0ne_Up on Mon Jan 06, 2014 1:26 pm

xenopeek wrote:
Code: Select all
sudo rm -fv /var/lib/apt/lists/*



I got a similar error as the OP when running apt-get update, running only the quoted command solved it for me. Thanks!
0ne_Up
Level 1
Level 1
 
Posts: 6
Joined: Tue Nov 12, 2013 4:30 am

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Google [Bot], Google Adsense [Bot] and 28 guests