Workspaces popping up , why?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Workspaces popping up , why?

Postby mikeeve on Wed Jan 30, 2013 2:45 am

New install of Mint 14, Cinnamon 64-bit in Virtual Box 4.2.6, Windows 7/64 host, 4-core AMD.

When I am at the desktop in the default workspace (1), a window pops up showing 2 windows labeled Workspace 1 and Workspace 2. This happens seemingly at random when I move the mouse around the desktop. Then I click on Workspace 1, but the slightest mouse motions throw me back to (what I think is) the workspace switcher.

Is this normal behaviour? Maybe a setting in Cinnamon needs to be changed (I turned of Workspace OSD in Settings, but doesn't help).

Might be a problem with Virtual Box. BTW, there is noticeable lag when typing this text.

I thought it might be my cordless mouse so switched to a corded mouse. Same problem.

I'll play around more with settings unless someone has a solution.
mikeeve
Level 1
Level 1
 
Posts: 12
Joined: Wed Jul 27, 2011 9:23 pm

Linux Mint is funded by ads and donations.
 

Re: Workspaces popping up , why?

Postby mikeeve on Wed Jan 30, 2013 2:53 am

I disabled HotCorner in Settings and looks like that fixed the problem, but I wasn't even coming near the corners when I was having the problem.
mikeeve
Level 1
Level 1
 
Posts: 12
Joined: Wed Jul 27, 2011 9:23 pm

Re: Workspaces popping up , why?

Postby passerby on Wed Jan 30, 2013 3:00 am

Your assumption was correct; it's a virtualbox problem. Cinnamon does that for me in vbox, but it works fine on actual installs.
Home PC: Xubuntu 14.04 x64, Nvidia GTX650, i7 3770K, 16GB RAM, Asus Xonar DX
Work PC: Mint 13 x64 XFCE, Nvidia GT620, i5 3470, 8GB RAM
Laptop: System76 Kudu Pro, Xubuntu 14.04 x64

My HTML5 login themes + screenshots
User avatar
passerby
Level 6
Level 6
 
Posts: 1375
Joined: Sun Dec 16, 2012 7:29 pm

Re: Workspaces popping up , why?

Postby mikeeve on Wed Jan 30, 2013 3:02 am

passerby wrote:Your assumption was correct; it's a virtualbox problem. Cinnamon does that for me in vbox, but it works fine on actual installs.


Thanks. Do you know if this is a problem with XFCE or other flavors?
mikeeve
Level 1
Level 1
 
Posts: 12
Joined: Wed Jul 27, 2011 9:23 pm

Re: Workspaces popping up , why?

Postby passerby on Wed Jan 30, 2013 3:45 am

I haven't experienced it with other DEs (apart from gnome shell).
Basically it keeps registering a mouseover event on the top left corner, hence why disabling the hot corner did the trick.
Home PC: Xubuntu 14.04 x64, Nvidia GTX650, i7 3770K, 16GB RAM, Asus Xonar DX
Work PC: Mint 13 x64 XFCE, Nvidia GT620, i5 3470, 8GB RAM
Laptop: System76 Kudu Pro, Xubuntu 14.04 x64

My HTML5 login themes + screenshots
User avatar
passerby
Level 6
Level 6
 
Posts: 1375
Joined: Sun Dec 16, 2012 7:29 pm

Re: Workspaces popping up , why?

Postby cmate4352 on Wed Jan 30, 2013 3:53 am

mikeeve wrote:New install of Mint 14, Cinnamon 64-bit in Virtual Box 4.2.6, Windows 7/64 host, 4-core AMD.

When I am at the desktop in the default workspace (1), a window pops up showing 2 windows labeled Workspace 1 and Workspace 2. This happens seemingly at random when I move the mouse around the desktop. Then I click on Workspace 1, but the slightest mouse motions throw me back to (what I think is) the workspace switcher.

Is this normal behaviour? Maybe a setting in Cinnamon needs to be changed (I turned of Workspace OSD in Settings, but doesn't help).

Might be a problem with Virtual Box. BTW, there is noticeable lag when typing this text.

I thought it might be my cordless mouse so switched to a corded mouse. Same problem.

I'll play around more with settings unless someone has a solution.

I've got the exact same problem running LM 14 64 KDE in VB Totally random.
Please post if you find a solution. I'll do the same
cmate4352
Level 1
Level 1
 
Posts: 4
Joined: Sun Jan 27, 2013 8:53 am

Re: Workspaces popping up , why?

Postby mikeeve on Thu Jan 31, 2013 3:40 am

cmate4352 wrote:I've got the exact same problem running LM 14 64 KDE in VB Totally random.
Please post if you find a solution. I'll do the same


Disabling HotCorners in Settings (see above) stopped the workspace switcher popping up. In VirtualBox, machine settings, I changed the video memory to max and enabled 3d acceleration. Seems to be running well with no known lag. Quite useable now, so I will continue using 14/Cinnamon in VB. Also, will install some engineering tools (Octave, PyLab) for an online course that starts in a couple of weeks. I also saw something about changing the Linux kernel's clock frequency from 1000Hz to 100Hz for guest machines to reduce load on the host maching, but I don't think I need that yet.
mikeeve
Level 1
Level 1
 
Posts: 12
Joined: Wed Jul 27, 2011 9:23 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 22 guests