Getting Openvpn to connect at startup

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

Getting Openvpn to connect at startup

Postby yuri21 on Thu Jan 31, 2013 9:30 pm

Getting Openvpn to connect at startup on Linux Mint 14 xfce(fresh install, less than 48 hours old):

I'm trying to get Openvpn to run at startup. "Connect automatically" is checked but no deal.

I've since tried this command but to no success. Yes, there're symlinks between /etc/init.d/openvpn and most of the /etc/rc#.d directories. Still, no connect!

Code: Select all
sudo update-rc.d openvpn enable 2345


Note: my VPN provider issues certs and keys and uh, not sure how much of a difference that'll make.

There're other walkarounds I've come across but they seem to be for other distros like Gentoo, very outdated info and so on. So, the commands/steps don't really work. :lol:


Edit: Oops, Edited title to make more sense. :)
yuri21
Level 2
Level 2
 
Posts: 68
Joined: Wed Jul 25, 2007 4:11 am

Linux Mint is funded by ads and donations.
 

Re: Getting Openvpn to connect at startup

Postby Tartufo on Wed Feb 06, 2013 1:30 pm

Depending on what DE you are using, you should have something from the main menu like "Services" or "Session startup" or something like that. Check there and see if the OpenVPN is enabled (it'll be a tick mark next to it). If not, then that would help I think.

The other alternative would be to check out some docs for Ubuntu or Debian on init run-levels, but be careful - there be dragons so proceed cautiously!! :-)
Tartufo
Level 1
Level 1
 
Posts: 17
Joined: Tue Feb 05, 2013 5:50 am

Re: Getting Openvpn to connect at startup

Postby yuri21 on Sat Feb 23, 2013 4:29 am

Well, Openvpn was already enabled and I could connect to the VPN manually. :)

In the end, I went through pages and different solutions and none of them really worked! Probably because some of them were for different distros, or things had changed enough and I didn't have enough knowledge to understand what I needed to change. I know, I forgot quite a bit of my Linux knowledge from years ago. :oops:

Until, I came across this solution which requires a shell script or something, that runs at startup and it works:
http://ubuntuforums.org/showpost.php?p= ... ostcount=2

I hope this works for others looking for a solution. :)

Now, still hoping I can find a way to get it to auto-reconnect if it drops. Sorry for not visiting the thread earlier but I was very busy and extremely tired as of late.
yuri21
Level 2
Level 2
 
Posts: 68
Joined: Wed Jul 25, 2007 4:11 am


Return to Newbie Questions

Who is online

Users browsing this forum: AlexxTM, gmilo2 and 27 guests